Błędy przechwytywalne aparatu bazy danych Microsoft Jet

Błędy przechwytywalne pochodzące z aparatu bazy danych Microsoft® Jet mogą wystąpić w trakcie działania aplikacji, zarówno w środowisku do tworzenia aplikacji, jak i w samodzielnym pliku wykonywalnym. Wykorzystując obiekt Error, można testować występowanie błędów oraz obsługiwać je.

Kod Komunikat

2420 Błąd składniowy w liczbie.

2421 Błąd składniowy w dacie.

2422 Błąd składniowy w ciągu znaków.

2423 Niepoprawne użycie ".", "!" lub "()".

2424 Nieznana nazwa.

2425 Nieznana nazwa funkcji.

2426 Funkcji nie można używać w wyrażeniach.

2427 Obiekt nie ma wartości.

2428 Nieprawidłowe argumenty funkcji.

2429 Operator In bez ().

2430 Operator Between bez And.

2431 Błąd składniowy (brak operatora).

2432 Błąd składniowy (przecinek).

2433 Błąd składniowy.

2434 Błąd składniowy (brak operatora).

2435 Zbędny ).

2436 Brak ), ] lub innego elementu.

2437 Niepoprawne użycie kresek pionowych.

2438 Błąd składniowy.

2439 Niewłaściwa liczba argumentów funkcji.

2440 Funkcja IIF bez ().

2442 Nieprawidłowe użycie nawiasów.

2443 Nieprawidłowe użycie operatora Is.

2445 Zbyt skomplikowane wyrażenie.

2446 Brak pamięci podczas obliczeń.

2447 Niepoprawne użycie ".", "!" lub "()".

2448 Nie można ustawić wartości.

3000 Błąd zarezerwowany <Element>; dla tego błędu nie ma komunikatu.

3001 Nieprawidłowy argument.

3002 Nie można rozpocząć sesji.

3003 Nie można rozpocząć transakcji; zbyt wiele zagnieżdżonych transakcji.

3005 <Nazwa bazy danych> jest niepoprawną nazwą bazy danych.

3006 Baza danych <nazwa> jest zablokowana w sposób wyłączny.

3007 Nie można otworzyć bibliotecznej bazy danych <nazwa>.

3008 Tabela <nazwa> jest już otwarta w sposób wyłączny przez innego użytkownika lub jest otwarta poprzez interfejs użytkownika i nie można nią manipulować programowo.

3009 Podczas otwierania już używanej tabeli <tabela> nastąpiła próba zablokowania jej, co nie jest możliwe w przypadku tabeli będącej już w użyciu. Poczekaj chwilę, a następnie powtórz operację.

3010 Tabela <nazwa> już istnieje.

3011 Aparat bazy danych Microsoft Jet nie może znaleźć obiektu <nazwa>. Upewnij się, że obiekt istnieje, a jego nazwa i nazwa ścieżki podane są prawidłowo.

3012 Obiekt <nazwa> już istnieje.

3013 Nie można zmienić nazwy instalowalnego pliku ISAM.

3014 Nie można otworzyć więcej tabel.

3015 Nie znaleziono indeksu.

3016 Pole nie mieści się w rekordzie.

3017 Rozmiar pola jest zbyt duży.

3018 Nie można znaleźć pola.

3019 Operacja niedopuszczalna bez bieżącego indeksu.

3020 Wywołanie metody Update lub CancelUpdate bez wywołania metody AddNew lub Edit.

3021 Brak bieżącego rekordu.

3022 Nie wprowadzono zmian w tabeli, gdyż doprowadziłoby to do powtórzenia wartości w indeksie, kluczu podstawowym lub relacji. Zmień dane w polach zawierających powtarzające się dane, usuń indeks lub zdefiniuj go tak, aby umożliwić powtarzanie się danych.

3023 Metoda AddNew lub Edit została już użyta.

3024 Nie można znaleźć pliku <nazwa>.

3025 Nie można otworzyć więcej plików.

3026 Brak wolnego obszaru na dysku.

3027 Nie można uaktualnić. Baza danych lub obiekt przeznaczony jest tylko do odczytu.

3028 Nie można uruchomić aplikacji. Plik informacyjny grupy roboczej nie istnieje lub został otwarty w trybie wyłączności przez innego użytkownika.

3029 Niewłaściwa nazwa konta lub niewłaściwe hasło.

3030 <Nazwa konta> nie jest poprawną nazwą konta.

3031 To nie jest właściwe hasło.

3032 Nie można wykonać operacji.

3033 Brak koniecznego zezwolenia na użycie obiektu <nazwa>. Zwróć się do administratora systemu lub osoby, która utworzyła ten obiekt, aby uzyskać właściwe zezwolenia.

3034 Próba zatwierdzenia lub wycofania transakcji bez uprzedniego wykonania rozpoczęcia transakcji.

3036 Osiągnięto maksymalny rozmiar bazy danych.

3037 Nie można otworzyć więcej tabel ani kwerend.

3039 Nie można utworzyć indeksu; zbyt wiele już zdefiniowanych indeksów.

3040 Błąd operacji dyskowej podczas czytania.

3041 Nie można otworzyć bazy danych utworzonej przez poprzednią wersję aplikacji.

3042 Wyczerpanie dojść do plików MS-DOS.

3043 Błąd dysku lub sieci.

3044 <Ścieżka> nie jest poprawną ścieżką. Sprawdź, czy nazwa ścieżki jest wprowadzona poprawnie oraz czy istnieje połączenie z serwerem, na którym jest przechowywany plik.

3045 Nie można użyć <nazwa>; plik jest już w użyciu.

3046 Nie można zapisać; strona aktualnie zablokowana przez innego użytkownika.

3047 Rekord jest zbyt duży.

3048 Nie można otworzyć więcej baz danych.

3049 Nie można otworzyć bazy danych <nazwa>. Aplikacja nie rozpoznaje tej bazy danych lub plik jest uszkodzony.

3050 Nie udało się zablokować pliku.

3051 Aparat bazy danych Microsoft Jet nie może otworzyć pliku <nazwa>. Plik jest już otwarty do wyłącznego użytku przez innego użytkownika lub potrzebne jest zezwolenie na oglądanie jego danych.

3052 Przekroczony licznik blokad współużytkowania plików. Zwiększ wartość wpisu rejestru MaxLocksPerFile.

3053 Zbyt wiele zadań klienta.

3054 Zbyt wiele pól typu Memo, OLE, lub obiekt Hyperlink.

3055 Nieprawidłowa nazwa pliku.

3056 Nie można naprawić tej bazy danych.

3057 Operacja nie jest dopuszczalna dla tabel połączonych.

3058 Indeks i klucz podstawowy nie mogą zawierać wartości Null.

3059 Operacja anulowana przez użytkownika.

3060 Zły typ danych dla parametru <parametr>.

3061 Za mało parametrów. Oczekiwano <liczba>.

3062 Powtarzający się wyjściowy alias <nazwa>.

3063 Powtarzające się przeznaczenie wyjścia <nazwa>.

3064 Nie można otworzyć kwerendy funkcjonalnej <nazwa>.

3065 Nie można wykonać kwerendy wybierającej.

3066 W kwerendzie musi być przynajmniej jedno pole przeznaczenia.

3067 Wejście kwerendy musi zawierać przynajmniej jedną tabelę lub kwerendę.

3068 Nieprawidłowy alias.

3069 Kwerenda funkcjonalna <nazwa> nie może być użyta jako źródło wierszy.

3070 Aparat bazy danych Microsoft Jet nie może rozpoznać <nazwa> jako poprawnej nazwy pola lub jako wyrażenia.

3071 Wyrażenie jest niepoprawnie napisane lub jest zbyt skomplikowane, aby mogło być obliczone. Na przykład, wyrażenie numeryczne zawiera zbyt wiele skomplikowanych elementów. Uprość wyrażenie, przypisując do zmiennych elementy wyrażenia.

3072 Wystąpił błąd niezgodności typów podczas tworzenia reguły poprawności dla tabeli lub ograniczenia CHECK dla kolumny.

3073 Operacja musi wykorzystywać kwerendę, którą można aktualizować.

3074 Nie można powtórzyć nazwy tabeli <nazwa> w klauzuli FROM.

3075 <Komunikat> w wyrażeniu kwerendy <wyrażenie>.

3076 <Nazwa> w wyrażeniu kryterium.

3077 <Komunikat> w wyrażeniu.

3078 Aparat bazy danych Microsoft Jet nie może znaleźć tabeli wejściowej lub kwerendy <nazwa>. Sprawdź, czy ona istnieje oraz czy nazwa jest poprawnie napisana.

3079 Podane odwołanie do pola <pole> może odnosić się do więcej niż jednej tabeli podanej na liście klauzuli FROM w instrukcji SQL.

3080 Tabela sprzężona <nazwa> nie podana na liście klauzuli FROM.

3081 Nie można sprząc więcej niż jednej tabeli o takiej samej nazwie <nazwa>.

3082 Operacja JOIN <operacja> odwołuje się do pola nie znajdującego się w jednej z podanych tabel.

3083 Nie można użyć wewnętrznej kwerendy raportu.

3084 Nie można wstawiać danych za pomocą kwerendy funkcjonalnej.

3085 Nie zdefiniowana funkcja <nazwa> w wyrażeniu.

3086 Nie można usunąć danych z podanych tabel.

3087 Zbyt wiele wyrażeń w klauzuli GROUP BY.

3088 Zbyt wiele wyrażeń w klauzuli ORDER BY.

3089 Zbyt wiele wyrażeń dla wyjścia predykatu DISTINCT.

3090 Tabela wynikowa nie może mieć więcej niż jedno pole typu Autonumer.

3091 Klauzula HAVING <nazwa> bez operacji grupowania lub agregacji.

3092 Nie można użyć klauzuli HAVING w instrukcji TRANSFORM.

3093 Klauzula ORDER BY <klauzula> koliduje z predykatem DISTINCT.

3094 Klauzula ORDER BY <klauzula> koliduje z klauzulą GROUP BY.

3095 Nie można umieścić funkcji agregującej w wyrażeniu <wyrażenie>.

3096 Nie można umieścić funkcji agregującej w klauzuli WHERE <klauzula>.

3097 Nie można umieścić funkcji agregującej w klauzuli ORDER BY <klauzula>.

3098 Nie można umieścić funkcji agregującej w klauzuli GROUP BY <klauzula>.

3099 Nie można umieścić funkcji agregującej w operacji JOIN <operacja>.

3100 Nie można przypisać wartości Null do pola <nazwa> w kluczu sprzężenia.

3101 Aparat bazy danych Microsoft Jet nie może znaleźć rekordu w tabeli <nazwa> o kluczu pasującym do pola (pól) <nazwa>.

3102 Odesłanie cykliczne spowodowane przez <odesłanie do kwerendy>.

3103 Odesłanie cykliczne spowodowane przez alias <nazwa> na liście SELECT definicji kwerendy.

3104 W kwerendzie krzyżowej nie można określić więcej niż raz stałego nagłówka kolumny <wartość>.

3105 Brak nazwy pola przeznaczenia w instrukcji SELECT INTO: <instrukcja>.

3106 Brak nazwy pola przeznaczenia w instrukcji UPDATE: <instrukcja>.

3107 Nie można dodać rekordu lub rekordów; brak zezwolenia na wstawianie do <nazwa>.

3108 Nie można poddać edycji rekordu lub rekordów; brak zezwolenia na uaktualnianie <nazwa>.

3109 Nie można usunąć rekordu lub rekordów; brak zezwolenia na usuwanie z <nazwa>.

3110 Nie można odczytać definicji; brak zezwolenia na czytanie definicji tabeli lub kwerendy <nazwa>.

3111 Nie można wykonać operacji tworzenia; brak zezwolenia na modyfikację projektu tabeli <nazwa>.

3112 Nie można odczytać rekordu lub rekordów; brak zezwolenia na czytanie z <nazwa>.

3113 Nie można uaktualnić <nazwa pola >; pole nie może być uaktualniane.

3114 Nie można na liście wyboru umieścić pól typu Memo, OLE, lub obiekt Hyperlink, jeśli wybierane są wartości unikatowe <instrukcja>.

3115 Nie można umieszczać pól typu Memo, OLE, lub obiekt Hyperlink w argumentach agregacji <instrukcja>.

3116 Nie można umieszczać pól typu Memo, OLE, lub obiekt Hyperlink w kryteriach <kryteria> funkcji agregacji.

3117 Nie można sortować według pól typu Memo, OLE, lub obiekt Hyperlink <klauzula>.

3118 Nie można dokonywać sprzężenia według pól typu Memo, OLE, lub obiekt Hyperlink <nazwa>.

3119 Nie można grupować według pól typu Memo, OLE, lub obiekt Hyperlink <klauzula>.

3120 Nie można grupować według pól wybranych przy użyciu '*' <nazwa tabeli>.

3121 Nie można grupować według pól wybranych przy użyciu '*'.

3122 Próba wykonania kwerendy, która nie zawiera podanego wyrażenia <nazwa> jako elementu funkcji agregującej.

3123 Nie można użyć '*' w kwerendzie krzyżowej.

3124 Wewnętrzna kwerenda raportu nie może być źródłem danych <nazwa>.

3125 <Nazwa> nie jest prawidłową nazwą. Upewnij się, że nie zawiera nieprawidłowych znaków lub znaków przestankowych oraz czy nazwa nie jest za długa.

3126 Niewłaściwe nawiasy w nazwie <nazwa>.

3127 Instrukcja INSERT INTO zawiera następującą nieznaną nazwę pola: <nazwa pola>. Sprawdź pisownię tej nazwy i powtórz operację.

3128 Określ tabelę zawierającą rekordy do usunięcia.

3129 Niewłaściwa instrukcja SQL; oczekiwano "DELETE", "INSERT", "PROCEDURE", "SELECT" lub "UPDATE".

3130 Błąd składniowy w instrukcji DELETE.

3131 Błąd składniowy w klauzuli FROM.

3132 Błąd składniowy w klauzuli GROUP BY.

3133 Błąd składniowy w klauzuli HAVING.

3134 Błąd składniowy w instrukcji INSERT INTO.

3135 Błąd składniowy w operacji JOIN.

3136 Klauzula LEVEL zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe znaki przestankowe.

3137 Brak średnika (;) na końcu instrukcji SQL.

3138 Błąd składniowy w klauzuli ORDER BY.

3139 Błąd składniowy w klauzuli PARAMETER.

3140 Błąd składniowy w klauzuli PROCEDURE.

3141 Instrukcja SELECT zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe znaki przestankowe.

3142 Po końcu instrukcji SQL znaleziono znaki.

3143 Błąd składniowy w instrukcji TRANSFORM.

3144 Błąd składniowy w instrukcji UPDATE.

3145 Błąd składniowy w klauzuli WHERE.

3146 Nieudane wywołanie ODBC.

3151 ODBC — Nie można nawiązać połączenia z <nazwa>.

3154 ODBC – Nie można znaleźć pliku DLL <nazwa>.

3155 ODBC — Nie powiodła się próba wstawienia do połączonej tabeli <tabela>.

3156 ODBC — Nie powiodła się próba usunięcia z połączonej tabeli <tabela>.

3157 ODBC — Nie powiodła się próba aktualizacji w połączonej tabeli <tabela>.

3158 Nie można zapisać rekordu; rekord jest blokowany przez innego użytkownika.

3159 Nieprawidłowa zakładka.

3160 Tabela nie jest otwarta.

3161 Nie można odszyfrować pliku.

3162 Usiłowano przypisać wartość Null zmiennej o typie danych innym niż Variant.

3163 Pole jest zbyt małe, aby pomieścić wprowadzane dane. Należy spróbować wstawić lub wkleić mniejszą ilość danych.

3164 Pole nie może zostać zaktualizowane.

3165 Nie można otworzyć pliku .inf.

3166 Nie można znaleźć pliku memo bazy danych Xbase.

3167 Rekord jest usunięty.

3168 Nieprawidłowy plik .inf.

3169 Aparat bazy danych Microsoft Jet nie może wykonać instrukcji SQL, gdyż zawiera ona pole o nieprawidłowym typie danych.

3170 Nie można odnaleźć instalowalnego pliku ISAM.

3171 Nie można znaleźć ścieżki sieciowej lub nazwy użytkownika.

3172 Nie można otworzyć pliku Paradox.net.

3173 Nie można otworzyć tabeli 'MSysAccounts' z pliku informacyjnego grupy roboczej.

3174 Nie można otworzyć tabeli 'MSysGroups' z pliku informacyjnego grupy roboczej.

3175 Data znajduje się poza zakresem lub jest w nieprawidłowym formacie.

3176 Nie można otworzyć pliku <nazwa>.

3177 Nieprawidłowa nazwa tabeli.

3179 Niespodziewanie napotkano koniec pliku.

3180 Nie można pisać do pliku <nazwa>.

3181 Nieprawidłowy zakres.

3182 Nieprawidłowy format pliku.

3183 Brak miejsca na dysku tymczasowym.

3184 Nie można wykonać kwerendy; nie można znaleźć połączonej tabeli.

3185 Wykonanie instrukcji SELECT INTO w odległej bazie danych prowadzi do utworzenia zbyt wielu pól.

3186 Nie można dokonać zapisu; strona aktualnie zablokowana przez użytkownika <nazwa> na maszynie <nazwa>.

3187 Nie można dokonać odczytu; strona aktualnie zablokowana przez użytkownika <nazwa> na komputerze <nazwa>.

3188 Nie można dokonać aktualizacji; dane aktualnie zablokowane przez inną sesję na tym komputerze.

3189 Użytkownik <nazwa> na komputerze <nazwa> zablokował na wyłączność tabelę <nazwa>.

3190 Zbyt wiele zdefiniowanych pól.

3191 Nie można zdefiniować pola więcej niż jeden raz.

3192 Nie można odnaleźć tabeli wynikowej <nazwa>.

3196 Baza danych <nazwa bazy danych> jest używana przez inną osobę lub proces. Powtórz operację, gdy baza danych będzie ponownie dostępna.

3197 Aparat bazy danych Microsoft Jet zatrzymał proces, ponieważ inny użytkownik próbuje jednocześnie zmienić te same dane..

3198 Nie można rozpocząć sesji. Zbyt wiele sesji jest już aktywnych.

3199 Nie można znaleźć wskazywanego obiektu.

3200 Nie można zmienić ani usunąć rekordu, ponieważ tabela <nazwa> zawiera rekordy z nim powiązane.

3201 Nie można dodać ani zmienić rekordu, ponieważ w tabeli <nazwa> musi istnieć powiązany z nim rekord.

3202 Nie można zapisać; strona aktualnie zablokowana przez innego użytkownika.

3203 Podkwerendy nie mogą być stosowane w wyrażeniu <wyrażenie>.

3204 Baza danych już istnieje.

3205 Zbyt wiele nagłówków kolumn krzyżowych <wartość>.

3206 Nie można tworzyć relacji pola z samym sobą.

3207 Operacja na tabeli bazy Paradox nie może być wykonana bez określenia klucza podstawowego.

3208 Niepoprawna wartość parametru Deleted klucza Xbase w Rejestrze Windows.

3210 Ciąg połączenia jest za długi.

3211 Aparat bazy danych nie może zablokować dostępu do tabeli <nazwa>, ponieważ jest ona aktualnie wykorzystywana przez innego użytkownika lub proces.

3212 Tabela <nazwa> nie może być zablokowana, ponieważ jest aktualnie używana przez użytkownika <nazwa> komputera <nazwa>.

3213 Niepoprawna wartość parametru Date klucza Xbase w Rejestrze Windows.

3214 Niepoprawna wartość parametru Mark klucza Xbase w Rejestrze Windows.

3216 Na miejscu podanego parametru <nazwa> powinna być podana nazwa tabeli.

3217 Na miejscu podanego parametru <nazwa> powinna być podana nazwa bazy danych.

3218 Aktualizacja nie jest możliwa z powodu blokady.

3219 Nieprawidłowa operacja.

3220 Niewłaściwa kolejność sortowania.

3222 Kwerenda nie może zawierać parametru typu Database.

3223 Nazwa <parametru> jest niewłaściwa, ponieważ jest zbyt długa lub zawiera znaki niedozwolone.

3227 Niepoprawna wartość parametru Century klucza Xbase w Rejestrze Windows.

3228 Wybrana kolejność sortowania nie jest obsługiwana przez system operacyjny.

3230 Nieaktualny plik blokad bazy Paradox.

3231 ODBC — Pole byłoby za długie; dane zostały obcięte.

3232 ODBC – Nie można utworzyć tabeli.

3234 ODBC — Przekroczony został limit czasu przeznaczony na wykonanie kwerendy zdalnej.

3235 ODBC — Typ danych nie obsługiwany przez serwer.

3238 ODBC — Dane spoza dozwolonego zakresu.

3239 Zbyt wielu aktywnych użytkowników.

3242 Niepoprawne odwołanie w instrukcji SELECT.

3243 Żadna z nazw importowanych pól nie jest zgodna z nazwą pola w tabeli dołączonej.

3244 Arkusz kalkulacyjny chroniony hasłem nie może być importowany.

3245 Nazwy pól z pierwszego wiersza importowanej tabeli nie mogą zostać rozdzielone.

3246 Podczas transakcji wystąpiła operacja, która nie jest obsługiwana.

3247 ODBC — Definicja połączonej tabeli została zmieniona.

3248 Nieprawidłowa wartość parametru NetworkAccess w Rejestrze Windows.

3249 Nieprawidłowa wartość parametru PageTimeout w Rejestrze Windows.

3250 Nie można zbudować klucza.

3251 Operacja nie jest obsługiwana dla tego typu obiektu.

3252 Nie można otworzyć formularza, którego kwerenda podstawowa zawiera funkcję zdefiniowaną przez użytkownika usiłującą ustawić lub pobrać właściwość RecordsetClone formularza.

3254 ODBC – Nie można zablokować wszystkich rekordów.

3256 Nie można znaleźć pliku indeksowego.

3257 Błąd składniowy w deklaracji WITH OWNERACCESS OPTION.

3258 Nie można wykonać instrukcji SQL ze względu na niejednoznaczne sprzężenia zewnętrzne. Aby wymusić wykonanie jednego ze sprzężeń w pierwszej kolejności, należy utworzyć osobną kwerendę wykonującą pierwsze sprzężenie i dołączyć ją do instrukcji SQL.

3259 Nieprawidłowy typ danych w polu.

3260 Nie można dokonać aktualizacji; strona aktualnie zablokowana przez użytkownika <nazwa> na komputerze <nazwa>.

3261 Użytkownik <nazwa> na maszynie <nazwa> zablokował na wyłączność tabelę <nazwa>.

3262 Nie można zablokować tabeli.

3263 Nieprawidłowy obiekt bazy danych.

3264 Pole nie jest zdefiniowane i nie można dołączyć obiektu TableDef lub Index.

3265 Nie znaleziono obiektu w tej kolekcji.

3266 Nie można dołączyć obiektu Field będącego już elementem kolekcji Fields.

3267 Właściwość można ustawić wyłącznie wtedy, gdy obiekt Field stanowi część kolekcji Fields obiektu Recordset.

3268 Nie można ustawić właściwości obiektu będącego już elementem kolekcji.

3269 Nie można dołączyć obiektu Index będącego już elementem kolekcji Indexes.

3270 Nie odnaleziono właściwości.

3271 Nieprawidłowa wartość właściwości.

3272 Obiekt nie jest kolekcją.

3273 Do tego obiektu nie można zastosować tej metody.

3274 Zewnętrzna tabela nie ma oczekiwanego formatu.

3275 Nieoczekiwany błąd <numer błędu> w sterowniku zewnętrznej bazy danych.

3276 Nieprawidłowe odwołanie do obiektu bazy danych.

3277 Indeks nie może zawierać więcej niż 10 pól.

3278 Aparat bazy danych Microsoft Jet nie został zainicjowany.

3279 Aparat bazy danych Microsoft Jet został już zainicjowany.

3280 Nie można usunąć pola będącego częścią indeksu lub niezbędnego dla systemu.

3281 Nie można usunąć tego indeksu lub tabeli. Jest to albo bieżący indeks, albo jest używany w relacji.

3282 Nie można wykonać tej operacji na tabeli zawierającej dane.

3283 Klucz podstawowy już istnieje.

3284 Indeks już istnieje.

3285 Nieprawidłowa definicja indeksu.

3286 Format pliku memo nie jest zgodny z podanym formatem zewnętrznej bazy danych.

3287 Nie można utworzyć indeksu dla tego pola.

3288 Indeks bazy danych Paradox nie jest indeksem podstawowym.

3289 Błąd składniowy w klauzuli CONSTRAINT.

3290 Błąd składniowy w poleceniu CREATE TABLE.

3291 Błąd składniowy w poleceniu CREATE INDEX.

3292 Błąd składniowy w definicji pola.

3293 Błąd składniowy w poleceniu ALTER TABLE.

3294 Błąd składniowy w poleceniu DROP INDEX.

3295 Błąd składniowy w poleceniu DROP TABLE lub DROP INDEX.

3296 Wyrażenia ze sprzężeniami nie są obsługiwane.

3297 Nie można importować tabeli lub kwerendy. Nie znaleziono rekordów lub wszystkie rekordy zawierają błędy.

3298 Istnieje wiele tabel o tej samej nazwie. Należy podać nazwę właściciela tabeli, posługując się formatem "właściciel.tabela".

3299 Błąd niezgodności specyfikacji ODBC <komunikat>. Zawiadom projektanta aplikacji o błędzie.

3300 Nie można utworzyć relacji.

3301 Nie można wykonać tej operacji, ponieważ własności występujące w tej wersji są niedostępne w bazach danych zapisanych w starszych formatach.

3302 Nie można zmieniać reguły w czasie używania reguł tej tabeli.

3303 Nie można usunąć tego pola. Wchodzi ono w skład jednej lub więcej relacji.

3304 Musisz wprowadzić identyfikator osobisty (PID) składający się z co najmniej 4 i nie więcej niż 20 znaków.

3305 Nieprawidłowy ciąg połączenia w kwerendzie przekazującej.

3306 Napisano podkwerendę, która może zwrócić więcej niż jedno pole, bez użycia zastrzeżonego słowa EXISTS w klauzuli FROM kwerendy głównej. Zmień instrukcję SELECT podkwerendy tak, aby wybierała tylko jedno pole.

3307 Liczby kolumn z dwóch wybranych tabel lub kwerend kwerendy składającej nie są zgodne.

3308 Nieprawidłowy argument TOP w kwerendzie SELECT.

3309 Wartość właściwości jest za duża.

3310 Ta właściwość nie jest obsługiwana dla zewnętrznych źródeł danych lub dla baz danych utworzonych za pomocą poprzedniej wersji aparatu Microsoft Jet.

3311 Określona właściwość już istnieje.

3312 Reguły poprawności i wartości domyślne nie mogą być umieszczone w tabelach systemowych lub tabelach połączonych.

3313 Nie można umieścić wyrażenia kontroli poprawności w tym polu.

3314 Pole <nazwa> nie może zawierać wartości Null, ponieważ właściwość Required tego pola została ustawiona na True. Wprowadź wartość w to pole.

3315 Pole <nazwa> nie może być ciągiem znaków o zerowej długości.

3316 <Tekst komunikatu reguły poprawności na poziomie tabeli>.

3317 Reguła poprawności <reguła> ustalona dla pola <nazwa> wprowadza ograniczenia na niektóre wartości. Wprowadź wartość akceptowaną przez wyrażenie określone dla tego pola.

3318 Wartości podane w klauzuli TOP są niedozwolone w kwerendach usuwających i raportach.

3319 Błąd składniowy w kwerendzie składającej.

3320 <Błąd> w wyrażeniu kontroli poprawności na poziomie tabeli.

3321 Brak określenia bazy danych w ciągu połączenia lub w klauzuli IN.

3322 Kwerenda krzyżowa zawiera jeden lub więcej nieprawidłowo ustalonych nagłówków kolumn.

3323 Nie można używać kwerendy jako źródła wierszy.

3324 Kwerenda jest kwerendą DDL i nie może być użyta jako źródło wierszy.

3325 Kwerenda przekazująca z właściwością ReturnsRecords ustawioną na wartość True nie zwróciła żadnego rekordu.

3326 Nie można zmieniać tego zestawu rekordów.

3327 Pole <nazwa> jest tworzone na podstawie wyrażenia i nie można go edytować.

3328 Tabela <nazwa> jest dostępna tylko do odczytu.

3329 Rekord w tabeli <nazwa> został usunięty przez innego użytkownika.

3330 Rekord w tabeli <nazwa> został zablokowany przez innego użytkownika.

3331 Aby wprowadzić zmiany, należy najpierw zapisać rekord.

3332 Nie można wprowadzić wartości do pustego pola po stronie ‘jeden’ sprzężenia zewnętrznego.

3333 Rekordy w tabeli <nazwa> nie miałyby rekordu po stronie ‘jeden’.

3334 Dostępne tylko w wersji 1.0.

3337 Nieprawidłowe ustawienie inicjujące opcji DataCodePage.

3340 Kwerenda <nazwa> jest uszkodzona.

3341 Bieżące pole musi być zgodne z kluczem sprzężenia <nazwa> w tabeli po stronie "jeden" związku jeden-do-wielu. Wprowadź rekord z żądaną wartością klucza do tabeli po stronie "jeden", a następnie wpisz żądany klucz sprzężenia do tabeli po stronie "tylko-wielu".

3342 Nieprawidłowa wartość obiektu Memo, OLE, lub Hyperlink w podkwerendzie <nazwa>.

3343 Nie rozpoznany format bazy danych <nazwa_pliku>.

3344 Aparat bazy danych nie rozpoznaje pola <nazwa> w wyrażeniu kontroli poprawności lub wartości domyślnej w tabeli <nazwa>.

3345 Nieznane lub nieprawidłowe odwołanie do pola <nazwa>.

3346 Liczba wartości kwerendy i pól docelowych nie są takie same.

3347 Nie można dodać rekordu (rekordów); w zestawie rekordów brak klucza podstawowego tabeli <nazwa>.

3348 Nie można dodać rekordu (rekordów); w zestawie rekordów brak klucza sprzężenia tabeli <nazwa>.

3349 Przepełnienie pola numerycznego.

3350 Obiekt nieprawidłowy dla operacji.

3351 Klauzula ORDER BY <wyrażenie> zawiera pola, które nie są wybierane przez kwerendę. Wyrażenie ORDER BY może zawierać tylko pola wybierane w pierwszej kwerendzie.

3352 Brak nazwy pola przeznaczenia w instrukcji INSERT INTO <instrukcja>.

3354 Ta podkwerenda może zwrócić co najwyżej jeden rekord.

3355 Błąd składniowy w wartości domyślnej.

3356 Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>. Spróbuj ponownie, gdy baza danych będzie już dostępna.

3357 Ta kwerenda nie jest prawidłowo zbudowaną kwerendą definiującą dane.

3358 Nie można otworzyć pliku informacyjnego grupy roboczej aparatu Microsoft Jet.

3359 Kwerenda przekazująca musi zawierać co najmniej jeden znak.

3360 Kwerenda jest zbyt złożona.

3361 W podkwerendzie operacje UNION są niedozwolone.

3362 Kwerenda aktualizująca/usuwająca pojedynczy wiersz wpłynęła na kilka wierszy połączonej tabeli. Unikatowy indeks zawiera powtarzające się wartości.

3363 Nie można dodać rekordu (rekordów); brak odpowiednich rekordów po stronie ‘jeden’.

3364 W klauzuli SELECT kwerendy składającej nie można używać pola <nazwa> typu Memo, OLE, lub obiekt Hyperlink.

3365 Wartość właściwości nie jest poprawna dla obiektów REMOTE.

3366 Nie można dołączyć relacji, dla której nie zdefiniowano pól.

3367 Nie można dołączyć obiektu. Obiekt o tej nazwie już istnieje w kolekcji.

3368 Relacja musi dotyczyć takiej samej liczby pól o takich samych typach danych.

3370 Nie można modyfikować projektu tabeli <nazwa>. Znajduje się ona w bazie danych przeznaczonej tylko do odczytu.

3371 Nie można znaleźć tabeli lub ograniczenia.

3372 Brak takiego indeksu <nazwa> w tabeli <nazwa>.

3373 Nie można utworzyć relacji. Wskazywana tabela <nazwa> nie ma klucza podstawowego.

3374 Podane pola nie są jednoznacznie indeksowane w tabeli <nazwa>.

3375 Tabela <nazwa> ma już indeks <nazwa>.

3376 Tabela <nazwa> nie istnieje.

3377 Brak relacji <nazwa> odnoszącej się do tabeli <nazwa>.

3378 W bieżącej bazie danych istnieje już relacja o podanej nazwie <nazwa>.

3379 Nie można utworzyć relacji do narzucenia integralności referencyjnej. Dane istniejące w tabeli <nazwa> naruszają reguły integralności referencyjnej w tabeli <nazwa>.

3380 Pole <nazwa> już istnieje w tabeli <nazwa>.

3381 Brak pola o podanej nazwie <nazwa> w tabeli <nazwa>.

3382 Rozmiar pola <nazwa> jest za duży.

3383 Nie można usunąć pola <nazwa>. Wchodzi ono w skład jednej lub więcej relacji.

3384 Nie można usunąć właściwości wbudowanej.

3385 Właściwości zdefiniowane przez użytkownika nie akceptują wartości Null.

3386 Przed zastosowaniem tej metody właściwość <nazwa> musi być ustawiona.

3388 Nieznana funkcja <nazwa> w wyrażeniu kontroli poprawności lub wartości domyślnej dla <nazwa>.

3389 Obsługa kwerendy niedostępna.

3390 Nazwa konta już istnieje.

3393 Nie można wykonać operacji sprzężenia, grupowania, sortowania lub indeksowanego wyboru. Poszukiwana lub sortowana wartość jest zbyt długa.

3394 Nie można zapisać właściwości; ponieważ jest to właściwość schematu.

3396 Nie można wykonać operacji kaskadowej. Ze względu na istnienie powiązanych rekordów w tabeli <nazwa> reguły integralności referencyjnej zostałyby naruszone.

3397 Nie można wykonać operacji kaskadowej. Tabela <nazwa> musi zawierać powiązany rekord.

3398 Nie można wykonać operacji kaskadowej. Dałaby ona w rezultacie wartość Null klucza tabeli <nazwa>.

3399 Nie można wykonać operacji kaskadowej. Rezultatem tej operacji byłby powtarzający się klucz w tabeli <nazwa>.

3400 Nie można wykonać operacji kaskadowej. Wynikiem operacji byłyby dwie aktualizacje pola <nazwa> z tabeli <nazwa>.

3401 Nie można wykonać operacji kaskadowej. W wyniku tej operacji pole <nazwa> przyjęłoby wartość Null, co nie jest dozwolone.

3402 Nie można wykonać operacji kaskadowej. Prowadziłoby to do przypisania polu <nazwa> wartości ciągu znaków o zerowej długości, co nie jest dozwolone.

3403 Nie można wykonać operacji kaskadowej: <tekst kontrolny>.

3404 Nie można wykonać operacji kaskadowej. Wprowadzona wartość jest zabroniona przez regułę poprawności <reguła> ustaloną dla <nazwa>.

3405 Błąd <objaśnienie błędu> w regule poprawności.

3406 Wyrażenie, które próbowano zastosować dla właściwości DefaultValue jest nieprawidłowe, ponieważ <komunikat błędu >. Do ustawienia tej właściwości należy użyć poprawnego wyrażenia.

3407 Tabela MSysConf serwera istnieje, ale ma nieprawidłowy format. Skontaktuj się z administratorem systemu.

3408 Zbyt wiele wywołanych sesji szybkiego wyszukiwania (FastFind).

3409 Nieprawidłowa definicja pola <nazwa> w definicji indeksu lub relacji.

3411 Nieprawidłowe dane wejściowe. Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ wprowadzona wartość jest za duża dla pola <nazwa>.

3412 Nie można wykonać aktualizacji kaskadowej w tabeli, ponieważ jest ona aktualnie używana przez innego użytkownika.

3413 Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ jest ona używana przez użytkownika <nazwa> na komputerze <nazwa>.

3414 Nie można wykonać operacji kaskadowej na tabeli <nazwa>, ponieważ jest ona aktualnie używana.

3415 Ciąg znaków o zerowej długości jest dopuszczalny tylko w polu typu Text lub Memo.

3416 <zarezerwowany alarm o błędzie>

3417 Nie można stosować kwerendy funkcjonalnej jako źródła wierszy.

3418 Nie można otworzyć <nazwa tabeli>. Inny użytkownik otworzył tabelę, wykorzystując inny plik sterowania siecią lub styl blokowania.

3419 Nie można otworzyć tabeli Paradox 4.x lub 5.x, ponieważ w Rejestrze Windows ParadoxNetStyle jest ustawiony na 3.x.

3420 Obiekt jest nieprawidłowy lub nie ma już wartości.

3421 Błąd konwersji typu danych.

3422 Nie można zmodyfikować struktury tabeli. Tabela jest otwarta przez innego użytkownika.

3423 Nie można używać ODBC do importowania, eksportowania lub dołączania do bazy danych tabeli z zewnętrznej bazy danych Microsoft Jet lub ISAM.

3424 Nie można utworzyć bazy danych, ponieważ ustawienia regionalne są nieprawidłowe.

3428 W bazie danych wystąpił problem. Usuń ten problem przez naprawę i kompaktowanie bazy danych.

3429 Niezgodna wersja instalowalnej bazy danych ISAM.

3430 Podczas ładowania instalowalnej bazy danych ISAM programu Microsoft Excel nie można było zainicjować obsługi OLE.

3431 To nie jest plik w formacie Microsoft Excel 5.0.

3432 Błąd otwarcia pliku w formacie Microsoft Excel 5.0.

3433 Nieprawidłowe ustawienie klucza Excel w sekcji Engines Rejestru Windows.

3434 Nie można rozszerzyć nazwanego zakresu.

3435 Nie można usunąć komórek arkusza kalkulacyjnego.

3436 Błąd podczas tworzenia pliku.

3437 Arkusz kalkulacyjny jest zapełniony.

3438 Format eksportowanych danych nie jest zgodny z formatem opisanym w pliku Schema.ini.

3439 Próbowano łączyć lub importować plik korespondencji seryjnej Microsoft Word. Pliki takie można eksportować, ale nie można ich łączyć ani importować.

3440 Próba importu lub łączenia pustego pliku tekstowego. Plik tekstowy, który można importować lub łączyć, musi zawierać dane.

3441 Separator pól specyfikacji pliku tekstowego odpowiada separatorowi dziesiętnemu lub ogranicznikowi tekstu.

3442 W specyfikacji <nazwa> pliku tekstowego opcja <nazwa> jest nieprawidłowa.

3443 Specyfikacja stałej szerokości <nazwa> nie zawiera szerokości kolumn.

3444 W specyfikacji <nazwa> ustalonej szerokości kolumna <kolumna> nie określa szerokości.

3445 Znaleziono niepoprawną wersję pliku DLL <nazwa>.

3446 Brakuje pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych). Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.

3447 Nieudana próba zainicjowania pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych) przy próbie użycia go. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.

3448 Nieudane wywołanie funkcji systemowej OLE. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.

3449 Nie znaleziono kodu kraju w ciągu połączenia dla połączonej tabeli.

3450 Błąd składniowy w kwerendzie. Niepełna klauzula kwerendy.

3451 Nieprawidłowe odwołanie w kwerendzie.

3452 Nie można dokonać zmiany projektu replikowanej bazy danych.

3453 Nie można ustanawiać ani aktualizować wymuszonych relacji pomiędzy tabelą replikowaną a tabelą lokalną.

3455 Baza danych nie może zostać przekształcona do postaci replikowalnej.

3456 Obiekt <nazwa> zawarty w kontenerze <nazwa> nie może zostać przekształcony do postaci replikowalnej.

3457 Nie można ustawić właściwości KeepLocal dla obiektu, który już został zreplikowany.

3458 Właściwość KeepLocal nie może być ustawiana dla całej bazy danych, a jedynie dla poszczególnych jej obiektów.

3459 Po wykonaniu na bazie danych operacji replikowania nie można już z tej bazy usunąć żadnych cech związanych z replikacją.

3460 Podjęta operacja jest w konflikcie z aktualną operacją wykonywaną na danym elemencie zestawu replik.

3461 Nastąpiła próba zmiany właściwości replikacji, która jest dostępna tylko do odczytu i nie może być zmieniana.

3462 Błąd podczas ładowania DLL.

3463 Nie można znaleźć .dll <nazwa>.

3464 Nieodpowiedni typ danych w wyrażeniu kryterium.

3465 Nastąpiła próba dostępu do dysku, z którego nie można czytać.

3468 Brak praw dostępu do folderu skrzynki <nazwa>. (Błąd 3468)

3469 Brak miejsca na dysku zawierającym folder skrzynki <nazwa>.

3470 Podczas dostępu do folderu skrzynki <nazwa> wystąpił błąd dysku.

3471 Wystąpił błąd podczas pisania do dziennika Synchronizatora.

3472 Wystąpiło przepełnienie dysku dla ścieżki <nazwa>.

3473 Podczas dostępu do pliku dziennika <nazwa> wystąpił błąd dysku.

3474 Plik dziennika <nazwa> nie może być otwarty do pisania.

3475 Podczas próby otwarcia pliku dziennika <nazwa> w trybie zakazu pisania (Deny Write) nastąpiło naruszenie zasad współużytkowania

3476 Nieprawidłowa ścieżka dla skrzynki <nazwa>.

3477 Adres skrzynki <nazwa> jest syntaktycznie niepoprawny.

3478 Replika nie jest repliką częściową.

3479 Replika częściowa nie może stać się wzorcem zestawu replik.

3480 Relacja <nazwa> w wyrażeniu definiującym filtr jest nieprawidłowa.

3481 Nazwa tabeli <nazwa> w wyrażeniu definiującym filtr jest nieprawidłowa.

3482 Wyrażenie definiujące filtr dla częściowej repliki jest nieprawidłowe.

3483 Hasło podane dla folderu skrzynki <nazwa> jest nieprawidłowe.

3484 Hasło użyte przez Synchronizator podczas pisania do docelowego folderu skrzynki jest nieprawidłowe.

3485 Obiekt nie może być replikowany, ponieważ baza danych nie jest bazą replikowaną.

3486 Nie można umieścić w tabeli drugiego pola typu Autonumer przeznaczonego na identyfikator repliki (ReplicaID).

3487 Baza danych poddawana replikacji nie może być przekształcona.

3488 Podana wartość nie jest równa identyfikatorowi repliki (ReplicaID) żadnego z elementów zestawu replik.

3489 Podany obiekt nie może być replikowany, ponieważ brak potrzebnych zasobów.

3490 Nie można utworzyć nowej repliki, ponieważ obiekt <nazwa> pojemnika <nazwa> nie może być replikowany.

3491 Aby mogła być replikowana, baza danych musi być otwarta w trybie wyłączności.

3492 Synchronizacja nie powiodła się, ponieważ nie można było wykonać zmiany projektu jednej z replik.

3493 Podany parametr Synchronizatora nie może być ustawiony w Rejestrze.

3494 Nie można odczytać z Rejestru wartości podanego parametru Synchronizatora.

3495 Brak zaplanowanych synchronizacji pomiędzy dwoma Synchronizatorami.

3496 Menedżer replikacji nie znalazł wartości ExchangeID w tabeli MSysExchangeLog.

3497 Nie można ustawić planu dla Synchronizatora.

3499 Nie można uzyskać informacji o pełnej ścieżce dla danego elementu zestawu replik.

3500 Nie można wyznaczyć dwóch Synchronizatorów do zarządzania tą samą repliką.

3502 Wzorzec lub replika nie są zarządzane przez Synchronizator.

3503 Żądany klucz nie ma przypisanej wartości w Rejestrze Synchronizatora.

3504 Identyfikator Synchronizatora jest niezgodny z identyfikatorem istniejącym w tabeli MSysTranspAddress.

3505 Próbowano usunąć lub uzyskać informacje na temat filtru częściowego, który nie istnieje w MSysFilters.

3506 Synchronizator nie może otworzyć dziennika Synchronizatora.

3507 Błąd podczas pisania do dziennika Synchronizatora.

3508 Brak aktywnego transportu dla Synchronizatora.

3509 Nie można znaleźć prawidłowego transportu dla danego Synchronizatora.

3510 Próba synchronizacji elementu zestawu replik, który jest aktualnie używany w innej synchronizacji.

3512 Wystąpił błąd podczas czytania folderu skrzynki.

3513 Wystąpił błąd podczas zapisu do folderu skrzynki.

3514 Synchronizator nie znalazł do wykonania żadnej (ani zaplanowanej, ani na żądanie) synchronizacji.

3515 Aparat bazy danych Microsoft Jet nie może odczytać wskazań zegara systemowego komputera.

3516 Docelowy Synchronizator nie został skonfigurowany do wykonywania synchronizacji pośredniej oraz docelowa replika jest niedostępna dla synchronizacji bezpośredniej.

3517 Synchronizator nie znalazł żadnych komunikatów do przetworzenia.

3518 Brak Synchronizatora w tabeli MSysTranspAddress.

3519 Błąd podczas wysyłania komunikatu.

3520 Nazwa lub identyfikator repliki nie są zgodne z aktualnie obsługiwanym elementem zestawu replik.

3521 Dwa elementy zestawu replik nie mogą zostać zsynchronizowane, ponieważ brak wspólnego punktu, od którego można by zacząć synchronizację.

3522 Synchronizator nie może znaleźć zapisu o danej synchronizacji w tabeli MSysExchangeLog.

3523 Synchronizator nie może znaleźć odpowiedniego numeru wersji w tabeli MSysSchChange.

3524 Historia zmian projektu w replice jest niezgodna z historią zmian we wzorcu.

3525 Synchronizator nie ma dostępu do bazy danych zawierającej komunikaty.

3526 Nazwa wybrana dla obiektu systemowego jest już używana przez inny obiekt.

3527 Synchronizator lub Menedżer replikacji nie mogą zlokalizować obiektu systemowego.

3528 Brak w pamięci wspólnej nowych danych do czytania dla Synchronizatora lub Menedżera replikacji.

3529 Synchronizator lub Menedżer replikacji znalazły w pamięci wspólnej nie odczytane dane. Istniejące dane zostaną zastąpione nowymi.

3530 Synchronizator już obsługuje jednego klienta.

3531 Przekroczony został limit czasu oczekiwania na zdarzenie.

3532 Synchronizator nie może zostać zainicjowany.

3533 Obiekt systemowy wciąż istnieje chociaż proces, który z niego korzystał, już został zakończony.

3534 Synchronizator nie znalazł zdarzenia systemowego, które mógłby przesłać do klienta.

3535 Klient zażądał, by Synchronizator zakończył działanie.

3536 Synchronizator otrzymał nieprawidłowy komunikat przeznaczony dla elementu zestawu replik, którym zarządza.

3537 Klient Synchronizatora nie jest już obecny i nie może zostać powiadomiony.

3538 Nie można zainicjować Synchronizatora z powodu zbyt wielu uruchomionych aplikacji.

3539 Nastąpił błąd systemowy lub zapełnił się plik wymiany.

3540 Plik wymiany przepełnił się lub jest uszkodzony.

3541 Synchronizator nie mógł zostać poprawnie zamknięty i jest wciąż aktywny.

3542 Proces został zatrzymany przy próbie zakończenia działania klienta Synchronizatora.

3543 Synchronizator nie jest zainstalowany.

3544 Synchronizator już jest aktywny

3545 Próba synchronizacji replik z dwóch różnych zestawów replik.

3546 Niepoprawny typ synchronizacji.

3547 Synchronizator nie może znaleźć we właściwym zestawie repliki potrzebnej do zakończenia synchronizacji.

3548 Wartości GUID są niezgodne ze sobą lub nie można odszukać żądanej wartości GUID.

3549 Podana nazwa pliku jest za długa.

3550 Brak indeksu dla kolumny GUID.

3551 Nie można usunąć podanego parametru Rejestru dla Synchronizatora.

3552 Rozmiar parametru Rejestru przekracza dopuszczalną wartość maksymalną.

3553 Nie można utworzyć wartości typu GUID.

3555 Wszystkie dopuszczalne nazwy replik są już w użyciu.

3556 Nieprawidłowa ścieżka folderu skrzynki docelowej.

3557 Nieprawidłowy adres folderu skrzynki docelowej.

3558 Błąd dyskowej operacji wejścia/wyjścia dla folderu skrzynki docelowej.

3559 Błąd operacji zapisu z powodu zapełnienia dysku docelowego.

3560 Oba synchronizowane ze sobą elementy zestawu replik mają ten sam identyfikator repliki (ReplicaID).

3561 Oba synchronizowane ze sobą elementy zestawu replik pełnią rolę wzorca.

3562 Brak uprawnień dostępu do folderu skrzynki docelowej.

3563 Błąd krytyczny przy próbie dostępu do lokalnego folderu skrzynki.

3564 Synchronizator nie może znaleźć źródłowego pliku komunikatów.

3565 Wystąpiło naruszenie zasad współużytkowania w folderze skrzynki źródłowej, gdyż baza danych z komunikatami jest otwarta w innej aplikacji.

3566 Błąd operacji wejścia/wyjścia w sieci.

3567 Komunikat w folderze skrzynki należy do niewłaściwego Synchronizatora.

3568 Synchronizator nie mógł usunąć pliku.

3569 Ten element zestawu replik został logicznie usunięty z tego zestawu i nie jest już dostępny.

3570 Filtry definiujące replikę częściową nie są z sobą zsynchronizowane.

3571 Próba zmiany wartości kolumny w replice częściowej naruszyła zasadę obowiązującą w replikach częściowych.

3572 Błąd dyskowej operacji wejścia/wyjścia przy próbie czytania lub pisania do katalogu TEMP.

3573 Katalog, w którym poszukiwano listy replik, nie jest katalogiem zarządzanym.

3574 Identyfikator (ReplicaID) tego elementu zestawu replik został zmieniony w efekcie procedury przeniesienia lub skopiowania.

3575 Dysk, na który próbowano pisać, jest pełen.

3576 Baza danych, którą próbowano otworzyć, jest używana przez inną aplikację.

3577 Nie można zmienić zawartości systemowej kolumny replikacji.

3578 Błąd przy replikacji bazy danych; nie można określić, czy baza danych jest otwarta w trybie wyłączności.

3579 Nie udało się utworzyć tabel systemu replikacji, potrzebnych do przekształcenia bazy danych w bazę replikowalną.

3580 Nie udało się dodać wierszy potrzebnych do przekształcenia bazy danych w bazę replikowalną.

3581 Nie można otworzyć systemowej tabeli replikacji <nazwa>, gdyż ta tabela jest aktualnie w użyciu.

3582 Nie można utworzyć nowej repliki, ponieważ obiekt <nazwa> w kontenerze <nazwa> nie może zostać obiektem replikowalnym.

3583 Obiektu <nazwa> zawartego w kontenerze <nazwa> nie można uczynić replikowalnym.

3584 Brak pamięci do wykonania operacji.

3585 Nie można dokonać replikacji tabeli; liczba kolumn przekroczyła dopuszczalną wartość maksymalną.

3586 Błąd składniowy w wyrażeniu filtru częściowego dla tabeli <nazwa>.

3587 We właściwości ReplicaFilter wystąpiło niepoprawne wyrażenie.

3588 Błąd przy obliczaniu wartości wyrażenia filtru częściowego.

3589 Wyrażenie filtru częściowego zawiera nieznaną funkcję.

3590 Narusza reguły dla replik częściowych.

3591 Nieprawidłowa ścieżka <nazwa> do pliku dziennika.

3592 Baza danych chroniona hasłem nie może być replikowana; dla replikowanej bazy danych nie można też ustawić hasła.

3593 Nie można zmienić atrybutu trybu aktualizacji danych dla zestawu replik.

3594 Nie można zmienić atrybutu trybu aktualizacji danych dla zestawu replik. Dopuszcza on zmiany tylko we wzorcu.

3595 Tabele systemowe repliki są niepewne i replika nie powinna być używana.

3600 Wyrażenia agregujące nie mogą korzystać z GUID.

3605 Synchronizacja z nie replikowaną bazą danych nie jest dopuszczalna. Baza danych <nazwa> nie jest repliką ani nie pełni roli wzorca.

3607 Właściwość replikacji, którą próbowano usunąć, jest przeznaczona tylko do odczytu i nie można jej usunąć.

3608 Długość rekordu zbyt duża dla indeksowanej tabeli bazy danych Paradox.

3609 Nie znaleziono unikatowego indeksu dla wskazywanego pola tablicy podstawowej.

3610 Ta sama tabela <tabela> wymieniona jako źródłowa i docelowa w kwerendzie tworzącej tabelę.

3611 Nie można wykonać instrukcji definicji danych na połączonych źródłach danych.

3612 W podkwerendzie nie można użyć wielopoziomowej klauzuli GROUP BY.

3613 Nie można utworzyć relacji pomiędzy połączonymi tabelami ODBC.

3614 GUID nie jest dozwolone w wyrażeniu kryterium metody Find.

3615 Niezgodność typów w wyrażeniu JOIN.

3616 Aktualizacja danych w połączonych tabelach nie jest obsługiwana przez tę wersję ISAM.

3617 Usuwanie danych z połączonej tabeli nie jest obsługiwane przez tę wersję ISAM.

3618 Podczas importu/eksportu nie można utworzyć tabeli wyjątków.

3619 Nie można dodać rekordów do tabeli wyjątków.

3620 Połączenie umożliwiające przeglądanie arkuszy Microsoft Excel zostało zerwane.

3621 Nie można zmienić hasła dla współużytkowanej otwartej bazy danych.

3622 W celu dostępu do tabeli serwera SQL posiadającej kolumnę IDENTITY należy w metodzie OpenRecordset użyć opcji dbSeeChanges.

3623 Brak dostępu do dowiązanego pliku DBF <nazwa_pliku> bazy FoxPro 3.0.

3624 Nie można odczytać rekordu - jest on obecnie zablokowany przez innego użytkownika.

3625 Specyfikacja pliku tekstowego <nazwa> nie istnieje. Nie można importować, eksportować ani ustanawiać łączy, używając tej specyfikacji.

3626 Operacja nieudana. Zbyt dużo indeksów dla tabeli <nazwa>. Usuń niektóre indeksy tabeli i spróbuj wykonać operację ponownie.

3627 Synchronizator nie może odnaleźć pliku wykonywalnego (mstran40.exe).

3628 Replika współpracująca nie jest zarządzana przez Synchronizator.

3629 Synchronizator <nazwa> wykorzystuje tę samą skrzynkę systemu plików <nazwa>.

3630 Synchronizator <nazwa> wykorzystuje tę samą skrzynkę systemu plików <nazwa>.

3631 Niepoprawna nazwa tabeli w filtrze.

3632 Transport internetowy nie jest udostępniony na zdalnym Synchronizatorze.

3633 Nie można załadować biblioteki DLL <nazwa>.

3634 Nie można utworzyć repliki, korzystając z repliki częściowej.

3635 Nie można utworzyć częściowej repliki systemowej bazy danych.

3636 Nie można wypełnić repliki lub zmienić filtru repliki, gdyż w replice występują konflikty lub błędy danych.

3637 Nie można użyć jako podkwerendy skrzyżowania kolumny, która nie jest stała.

3638 Bazy danych sterowanej źródłem nie można uczynić replikowalną.

3639 Nie można utworzyć repliki systemowej bazy danych.

3640 Bufor odczytu okazał się zbyt mały w stosunku do wielkości żądanych danych.

3641 Obiekt Recordset zawiera mniej rekordów niż zażądano.

3642 Operacja została anulowana.

3643 Jeden z rekordów obiektu Recordset został usunięty przez inny proces.

3645 Jeden z parametrów wiążących jest niepoprawny.

3646 Podana długość wiersza jest mniejsza niż suma długości kolumn.

3647 Żądana kolumna nie jest zwracana do obiektu Recordset.

3648 Nie można synchronizować repliki częściowej z inną repliką częściową.

3649 Strona kodowa specyficzna dla języka nie jest określona lub nie może zostać znaleziona.

3650 Sieć Internet jest zbyt wolna lub problem ma związek z instalatorem Menedżera replik na serwerze internetowym.

3651 Nieprawidłowy adres internetowy.

3652 Błąd logowania w Internecie.

3653 Internet nie jest skonfigurowany.

3656 Błąd podczas obliczania wartości wyrażenia częściowego.

3657 Błąd przy obliczaniu wartości wyrażenia filtru typu Boolean dla tabeli <nazwa>.

3658 W filtrze typu Boolean nie można użyć kolumny <nazwa> typu Binary.

3659 Relacja <nazwa> nie jest wymuszona. W częściowym wyrażeniu filtru relacja musi być wymuszona.

3660 Żądana wymiana nie powiodła się, ponieważ <opis>.

3661 Żądana wymiana nie powiodła się, ponieważ <opis>.

3663 Ta operacja wymaga innej biblioteki kursorów.

3664 Wywołanie asynchroniczne OpenConnection nie zostało ukończone; do czasu jego ukończenia nie można odwoływać się do zwracanego obiektu Connection.

3665 Nie można modyfikować systemowego obiektu replikacji <nazwa>.

3666 Nie można modyfikować systemowego obiektu replikacji<nazwa>.

3667 Wykonywanie tej operacji jest wstrzymywane przez inną operację.

3668 Nie można zrealizować tej operacji, ponieważ brak jest aktywnego połączenia.

3672 Nie można załadować pliku RDOCURS.DLL

3673 Ta tabela zawiera komórki o wartościach spoza zakresu zdefiniowanego w tym arkuszu.

3674 Nie można było znaleźć internetowego pliku dll (wininet.dll) lub nie było możliwe jego załadowanie.

3675 Nie powiodło się czytanie z dojścia internetowego. Ponów operację.

3676 Nie powiódł się zapis dla dojścia internetowego. Ponów operację.

3677 Nie powiodło się wykonanie żądania HTTP uruchomienia Synchronizatora internetowego na serwerze. Aby skonfigurować Synchronizatora internetowego na serwerze internetowym, należy użyć Menedżera replik.

3678 Nie powiodło się połączenie z usługą FTP pracującą na serwerze internetowym. Należy się upewnić, czy usługa FTP jest uruchomiona na serwerze, oraz czy obsługuje połączenia anonimowe.

3679 Nie powiodło się otwarcie pliku za pomocą usługi FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu.

3680 Nie powiodło się pobranie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu.

3681 Nie powiodło się umieszczenie pliku na serwerze przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do zapisu.

3682 Nie powiodło się usunięcie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu i zapisu.

3683 Synchronizator internetowy niespodziewanie zakończył pracę na serwerze. Aby poznać przyczynę powstania tego problemu, należy przejrzeć historię wymiany repliki współpracującej na serwerze internetowym.

3684 Nie ma odpowiedniej repliki do wymiany.

3685 Nieprawidłowy adres HTTP.

3686 Nieprawidłowa ścieżka lub nazwa replikacji.

3689 Błąd składniowy SQL - oczekiwano: Przywileje.

3700 Nieprawidłowa precyzja dla dziesiętnego typu danych.

3701 Nieprawidłowa skala dla dziesiętnego typu danych.

3702 Szerokość kolumny tekstu Unicode musi zajmować parzystą ilość bajtów.

3703 Operacja nie jest obsługiwana dla replikowalnych baz danych, które nie zostały skonwertowane do bieżącej wersji.

3704 Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>. Spróbuj ponownie, gdy baza danych będzie już dostępna.

3705 Nie można uczynić tabeli <nazwa> replikowalną – zbyt wiele kolumn.

3706 Nie można uczynić tabeli <nazwa> replikowalną – zbyt wiele indeksów.

3707 Opcje kaskadowe dla nowego odwołania pozostają w konflikcie z istniejącym odwołaniem <nazwa>.

3708 Błąd składniowy w instrukcji Transaction. Oczekiwano TRANSACTION, WORK, lub nic.

3709 Klucz poszukiwania nie został znaleziony w żadnym rekordzie.

3710 Nie można znaleźć folderu MAPI lub książki adresowej.

3711 Odzyskano replikowalne dane. Ten wiersz został odzyskany z uszkodzonej replikowalnej bazy danych. Sprawdź zawartość rekordu, popraw go i dodaj ponownie, lub usuń błędny rekord.

3713 Konflikt uaktualnienie/uaktualnienie. Inna replika także uaktualniła dany rekord. Ten rekord przegrał w konflikcie. Ponów próbę uaktualnienia lub usuń rekord powodujący konflikt.

3714 Zablokowana tabela. Ten rekord nie mógł zostać uwzględniony podczas synchronizacji z powodu zablokowania tabeli przez innego użytkownika. Prześlij ponownie rekord powodujący konflikt.

3715 Naruszenie klucza unikatowego. Ten rekord posiada taką samą wartość klucza jak inny rekord podczas gdy wartości unikatowe są jedynymi dozwolonymi. Zmień wartość klucza w rekordzie powodującym konflikt, lub kluczu wygrywającym konflikt i prześlij rekord ponownie, bądź go usuń.

3716 Naruszenie TLV. Ten rekord zawiera pole, którego wartość nie spełnia wymagań ograniczeń na poziomie tabeli. Uaktualizuj pole naruszające regułę poprawności i prześlij ponownie rekord powodujący konflikt, lub usuń ten rekord.

3717 Konflikt usunięcie/integralność referencyjna. Rekord zawierający klucz podstawowy został usunięty przez inną replikę, więc odwołujący się do niego rekord został odrzucony. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej, lub usuń rekord powodujący konflikt.

3718 Konflikt uaktualnienie/integralność referencyjna. Rekord zawierający klucz podstawowy został uaktualniony przez inną replikę, więc odwołujący się do niego rekord został odrzucony. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej i prześlij ponownie uaktualnienie, zmodyfikuj wartość klucza obcego w tym rekordzie aby odpowiadał poprawnej wartości klucza podstawowego i prześlij ponownie uaktualnienie, lub usuń rekord powodujący konflikt.

3719 Naruszenie klucza obcego wynikające z błędnego rekordu zawierającego klucz podstawowy, który to rekord uczestniczył w konflikcie replikacji. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej i prześlij ponownie uaktualnienie zmodyfikuj wartość klucza obcego w tym rekordzie aby odpowiadał poprawnej wartości klucza podstawowego i prześlij ponownie uaktualnienie, lub usuń rekord powodujący konflikt.

3720 Nie można zmienić nazwy pola <nazwa>. Jest ono częścią jednego lub więcej związków.

3721 Nieprawidłowa składnia SQL – oczekiwano nazwy dla słowa kluczowego CONSTRAINT.

3722 Nieprawidłowa składnia SQL - oczekiwano: DEFAULT.

3723 Nieprawidłowa składnia SQL - oczekiwano: COMPRESSION za WITH.

3724 Nieprawidłowa składnia SQL - oczekiwano: UPDATE lub DELETE.

3725 Nieprawidłowa składnia SQL - oczekiwano: CASCADE, SET NULL, lub NO ACTION.

3726 Nieprawidłowa składnia SQL - oczekiwano: NULL.

3727 Nieprawidłowa składnia SQL – dozwolona jest tylko jedna reguła uaktualniania i/lub jedna reguła usuwania.

3728 Nieprawidłowa składnia SQL - oczekiwano: AS.

3729 Nieprawidłowa składnia SQL - oczekiwano: SELECT.

3730 WIDOK (VIEW) nie może zawierać parametru.

3731 Liczba określonych aliasów musi być równa liczbie wyjściowych kolumn.

3732 Oczekiwano nazwy kwerendy po EXECUTE.

3733 Baza danych została wprowadzona przez nieznanego użytkownika w stan uniemożliwiający jej zablokowanie lub otwarcie.

3734 Baza danych została wprowadzona przez użytkownika <nazwa> komputera <nazwa> w stan uniemożliwiający jej zablokowanie lub otwarcie.

3736 Konflikt uaktualnienie/usunięcie. Uaktualniony rekord został usunięty w innej replice. Dodaj ponownie rekord powodujący konflikt lub usuń go.

3737 Nie można utworzyć repliki tego typu z podanej repliki źródłowej.

3738 Repliki lokalne lub anonimowe muszą być synchronizowane tylko poprzez wskazaną replikę globalną.

3740 Nie można dodać nowych kolumn do tabeli <nazwa>. Usuń zbędne kolumny i skompaktuj bazę danych.

3741 Nieprawidłowa replika do synchronizacji. Repliki lokalne lub anonimowe muszą synchronizować z wskazaną repliką globalną.

3742 Przekroczony został limit czasu oczekiwania na wykonanie funkcji internetowej.

3743 Replika nie została zsynchronizowana w czasie okresu przechowywania zmian danych.

3745 Długość połączonej nazwy serwera internetowego, nazwy HTTP i aliasu FTP nie powinna przekroczyć 252 znaków.

3746 Błąd składniowy w kwerendzie. Wartość parametru.

3747 Parametr nie posiada wartości domyślnej.

3748 Parametr <nazwa> nie posiada wartości domyślnej.

3749 Obiekt nie jest procedurą SQL.

3750 Obiekt <nazwa> nie jest procedurą SQL.

3751 Zażądano blokowania na poziomie rekordów, ale baza danych jest w trybie blokowania stron.

3752 Zażądano blokowania na poziomie stron, ale baza danych jest w trybie blokowania rekordów.

3753 Nie można utworzyć repliki z repliki aparatu Jet SQL.

3754 Nie można usunąć danych z repliki Prevent Deletes.

3755 Ograniczenie CHECK <nazwa> nie istnieje.

3756 Ograniczenie CHECK <nazwa> już istnieje.

3757 Biblioteki sortowania aparatu Jet nie mogą być poprawnie załadowane.

3758 Skalowanie wartości dziesiątkowych spowodowało obcięcie danych.

3759 Skalowanie wartości dziesiątkowych spowodowało obcięcie danych.

3760 Skalowanie wartości dziesiątkowych spowodowało przepełnienie danych.

3761 Precyzja pola dziesiątkowego jest zbyt mała aby zaakceptować podaną liczbę.

3762 Błędna składnia SQL – oczekiwano: ACTION.

3763 Schemat jednoczesnych zmian spowodował niepomyślne zakończenie operacji tworzenia repliki. Należy ponowić próbę.

3765 Błąd składniowy w ograniczeniu klauzuli CHECK.

3766 Jedynie proste kwerendy SELECT są dozwolone w widokach.

3767 Tabela <nazwa> nie mogła zostać przekształcona do postaci replikowalnej, ponieważ nie mogła zostać otwarta w trybie wyłączności.

3768 Szybkie wyszukiwanie (FastFind) nie może operować na odwołaniach niekolumnowych.

3769 Nie można zmienić nazw tabel powodujących konflikt.

3770 Definicja licznika w niepoprawnym zakresie.

3771 Repliki lokalne lub anonimowe nie mogą zostać przekształcone do postaci wzorca głównego.

3772 Bez uprawnień administratora, priorytet repliki musi zawierać się w przedziale 0 - <numer>.

3773 Nie można usunąć jednego lub więcej obiektów: <nazwa>.

3775 Nie można załadować pliku mechanizmu Jet SQL Server Reconciler - MSRPJT40.dll

3777 Niedozwolona operacja wykonana na replice serwera aparatu Jet SQL.

3778 Baza danych aparatu Jet jest nieprawidłowa lub nie istnieje dla tego zestawu replik SQL/Jet.

3779 Nie można zmienić właściwość śledzenia na poziomie kolumny (Column Level Tracking) dla obiektów replikowalnych.

3780 Nieprawidłowa składnia SQL – oczekiwano nazwy widoku.

3781 Nieprawidłowa składnia SQL – oczekiwano nazwy procedury.

3784 Baza danych jest już replikowalna.

3785 Nieprawidłowa składnia SQL - oczekiwano: Baza danych.

3786 Nieprawidłowa składnia SQL – oczekiwano przywileju bazy danych takiego jak CREATEDB lub CONNECT.

3787 Ta operacja nie jest dozwolona w podkwerendach.

3788 Nie można utworzyć indeksu dla tego folderu MAPI/książki adresowej.

3789 Niedozwolone ograniczenie na poziomie kolumny.

3798 Ograniczenia CHECK nie są dozwolone dla replikowalnych baz danych.

3799 Nie można znaleźć pola <nazwa>.

3800 <Nazwa> nie jest indeksem dla tej tabeli.

3801 Obiekt <nazwa> nie może zostać użyty w klauzuli ograniczenia CHECK.

3802 Błąd przy wyliczaniu ograniczenia <nazwa> CHECK. <Dodatkowa informacja.>

3803 DDL nie może zostać zakończone dla tej tabeli, ponieważ odwołuje się do niej ograniczenie <nazwa> dla tabeli <nazwa>.

3804 Nie ma klientów MAPI zainstalowanych na tym komputerze. Zainstaluj klienta MAPI, takiego jak program Outlook na tym komputerze.

3805 Ograniczenie CHECK dla tabeli <nazwa> nie zostanie przeniesione dla tej tabeli. Ograniczenia CHECK mogą być tworzone jedynie poprzez instrukcje DLL języka SQL.

3806 Nie można ustawić wielokrotnych atrybutów NULL, NOT NULL.

3807 Kwerenda <nazwa> zawiera niejednoznaczną nazwę kolumny, która pozostaje w konflikcie z nazwą powiązania (aliasem) <nazwa>. Określ w pełni nazwę kolumny lub zmień nazwę powiązania (alias).

3808 Należy użyć bazy danych w formacie wersji 4.x lub większej aby wykonać operację.


kwerenda funkcjonalna <definicja Jet>

kwerenda funkcjonalna

Kwerenda kopiująca lub zmieniająca dane. Do kwerend funkcjonalnych zaliczane są kwerendy dołączające, usuwające, tworzące tabele i aktualizujące. Kwerendy usuwające i aktualizujące zmieniają istniejące dane, a kwerendy dołączające i tworzące tabele kopiują istniejące dane. W języku SQL są one nazywane kwerendami typu DML i obejmują następujące słowa kluczowe: DELETE, INSERT i UPDATE. Microsoft® Jet obsługuje również słowo kluczowe SELECT INTO, które jest kwerendą wybierającą typu DDL. W przeciwieństwie do omawianych wcześniej kwerend, kwerendy wybierające zwracają rekordy. Kwerendą funkcjonalną może być także kwerenda przekazująca języka SQL.


Active Data Objects (ADO) <definicja Jet>

Active Data Objects (ADO)

Interfejs programowania umożliwiający uzyskiwanie dostępu do obiektów bazy danych i operowanie na nich.


funkcje agregujące <definicja Jet>

funkcje agregujące

Funkcje, które można wykorzystywać do obliczania wartości zbiorczych, takie jak Sum, Count, Avg i Var. W wyrażeniach i programach zarówno funkcje agregujące SQL (łącznie z czterema wyżej wymienionymi), jak i lokalne funkcje agregacji można wykorzystywać do tworzenia różnego typu statystyk.


alias <definicja Jet>

alias

Visual Basic: Zastępcza nazwa nadana procedurze zewnętrznej w celu uniknięcia konfliktu ze słowem kluczowym języka Visual Basic, zmienną publiczną, stałą lub nazwą niedozwoloną przez konwencje nazewnictwa stosowane w języku Visual Basic.

Język SQL (Structured Query Language): Zastępcza nazwa nadawana polu lub wyrażeniu w instrukcji SELECT (za pomocą klauzuli AS). Standard ANSI określa ją jako nazwę skorelowaną.


zestaw znaków ANSI <definicja Jet>

zestaw znaków ANSI

Zestaw 8-bitowych znaków wykorzystywany przez Microsoft® Windows®, obejmujący do 256 znaków (o kodach od 0 do 255), możliwych do wprowadzenia za pomocą klawiatury. Zestaw znaków ASCII jest podzbiorem zestawu znaków ANSI.


tryb ANSI SQL-92 <definicja Jet>

tryb ANSI SQL-92

Ten tryb udostępnia rozszerzoną składnię języka SQL o większej zgodności z wersją SQL-92 i wersją Microsoft® SQL Server™. Jest on dostępny wyłącznie przy zastosowaniu aparatu Microsoft OLE DB Provider for Jet i nie może być włączony przy korzystaniu z obiektów DAO. Większość nowych własności dostępna jest głównie w językach DDL. Zgodna ze standardem ANSI obsługa symboli wieloznacznych, takich jak znak procent (%) i znak podkreślenia, jest również elementem trybu ANSI SQL-92.


kwerenda dołączająca <definicja Jet>

kwerenda dołączająca

Kwerenda funkcjonalna dodająca rekordy na końcu istniejącej tabeli lub kwerendy. Kwerendy dołączające nie zwracają rekordów (wierszy). Składnia języka SQL zawiera słowo kluczowe INSERT.


argument <definicja Jet>

argument

Stała, zmienna lub wyrażenie przekazujące dodatkową informację do akcji, procedury lub metody. Do przekazania dodatkowych informacji wymaganych przez niektóre akcje można użyć w wyrażeniu argumentu z operandem.


tablica <definicja Jet>

tablica

Zmienna zawierająca skończoną liczbę elementów o wspólnej nazwie i typie danych. Każdy element tablicy jest identyfikowany unikatowym numerem indeksu. Zmiany dokonywane na jednym elemencie tablicy nie wpływają na inne elementy.


zestaw znaków ASCII <definicja Jet>

zestaw znaków ASCII

7-bitowy zestaw znaków amerykańskiego standardowego kodu do wymiany informacji (ASCII - American Standard Code for Information Interchange) wykorzystywany powszechnie do reprezentowania liter i symboli znajdujących się na standardowej klawiaturze amerykańskiej. Zestaw znaków ASCII pokrywa się z pierwszymi 128 znakami (kody od 0 do 127) zestawu znaków ANSI.


gwiazdka <definicja Jet>

gwiazdka

Znak (*) wykorzystywany jako symbol wieloznaczny w wyrażeniach LIKE języka SQL. Na przykład, wyrażenie LIKE "*ala*" zwróci rekordy zawierające ciąg "ala", po którym lub przed którym występuje zero lub więcej znaków.

Przy tworzeniu kwerend lub wprowadzaniu instrukcji SQL gwiazdkę można wykorzystać do uwzględnienia w wyniku wszystkich aktualnie istniejących pól w tabeli lub kwerendzie, będącej przedmiotem kwerendy. Na przykład, instrukcja SELECT * FROM MojaTabela zwróci wszystkie pola (kolumny) z tabeli.

W trakcie wykonywania kwerendy poprzez mechanizm Microsoft® OLE DB Provider for Jet, gwiazdka nie jest rozumiana jako symbol wieloznaczny. W tym wypadku jej rolę pełni znak procent (%). Zapisane wcześniej kwerendy nie będą podlegały tym ograniczeniom, ale wszystkie nowe kwerendy, które zostaną utworzone przez mechanizm Microsoft® OLE DB Provider for Jet będą wymagały zastosowania symboli wieloznacznych ANSI, tzn. znaku procent (%) i znaku podkreślenia (_), aby uzyskać zachowanie podobne do tego, które zwykle uzyskuje się przez użycie gwiazdki (*) i znaku zapytania (?). Mechanizm Microsoft® OLE DB Provider for Jet przetłumaczy gwiazdkę i znak zapytania jak zwykłe znaki literowe i zwracany zbiór wynikowy będzie inny niż ten, który otrzymuje się poprzez mechanizmy Microsoft® Access® UI lub obiekty DAO.


kwerenda asynchroniczna <definicja Jet>

kwerenda asynchroniczna

Typ kwerend SQL, które oddają sterowanie natychmiast, jeszcze przed wygenerowaniem wyników. Umożliwia to aplikacji kontynuowanie przetwarzania innych danych, podczas gdy realizowana jest kwerenda.


Autonumer - typ pola <definicja Jet>

Autonumer - typ pola

Pole typu dane, które automatycznie przechowuje unikatową wartość każdego rekordu w momencie dodania go do tabeli. Pole typu Autonumer zawsze korzysta z danych liczbowych zwiększonej precyzji (Long). Liczby generowane przez pole typu Autonumer nie mogą być modyfikowane bez specjalnego zezwolenia, które może być nadane tabeli za pomocą instrukcji Grant lub Revoke według składni SQL DDL. Pole Autonumer znane jest również jako pole typu Licznik lub Identyfikator. Obecna składnia SQL DDL dopuszcza zadawanie wartości początkowej i przyrostowej. Jest to różnica w stosunku do poprzednich wersji, dla których obie te wartości były równe 1.

Zobacz także

atrybut identyfikacji

wartość początkowa

przyrost


tabela bazowa <definicja Jet>

tabela bazowa

Tabela w bazie danych Microsoft® Jet. Tabela definiuje strukturę relacyjnej bazy danych i jest obiektem, w którym dane przechowywane są w rekordach i polach. Strukturę tabeli bazowej można zmieniać, korzystając z obiektów DAO lub instrukcji definicji danych języka SQL. Dane w tabeli bazowej można modyfikować za pomocą obiektów Recordset lub kwerend funkcjonalnych.


Big Integer - typ danych <definicja Jet>

Big Integer - typ danych

Typ danych przechowujący dokładną wartość numeryczną ze znakiem, o precyzji 19 cyfr (ze znakiem) lub 20 cyfr (bez znaku) i skali 0 (ze znakiem: -263 ≤ n ≤ 263-1; bez znaku: 0 ≤ n ≤ 264-1).


Binary - typ danych <definicja Jet>

Binary - typ danych

Typ danych przechowujący dane binarne o stałej długości. Maksymalna długość wynosi 255 bajtów.


zakładka <definicja Jet>

zakładka

Właściwość obiektu Recordset zawierająca ciąg binarny identyfikujący bieżący rekord. Jeżeli wartość właściwości Bookmark zostanie przypisana do zmiennej, a potem nastąpi przejście do innego rekordu, to poprzedni rekord można ponownie uczynić bieżącym przez nadanie właściwości Bookmark wartości przechowywanej w tej zmiennej.


wyrażenie typu Boolean <definicja Jet>

wyrażenie typu Boolean

Wyrażenie przyjmujące wartość True lub False.


Boolean - typ danych <definicja Jet>

Boolean - typ danych

Wartość True/False lub tak/nie. Wartości typu Boolean są w bazie danych Microsoft® Jet przechowywane zwykle jako pola bitowe (typu Bit), jednak niektóre bazy danych nie obsługują tego typu danych bezpośrednio.


Byte - typ danych <definicja Jet>

Byte - typ danych

Podstawowy typ danych służący do przechowywania małych dodatnich liczb całkowitych z zakresu od 0 do 255.


iloczyn kartezjański <definicja Jet>

iloczyn kartezjański

Wynik sprzężenia dwóch tabel (relacji) dający wszystkie możliwe uporządkowane kombinacje wierszy z pierwszej tabeli i wszystkich wierszy z drugiej tabeli.

Ogólnie, iloczyn kartezjański powstaje w wyniku wykonania instrukcji SELECT języka SQL, której klauzula FROM odnosi się do dwóch lub więcej tabel, ale w której nie zawarto klauzul WHERE ani JOIN wskazujących, w jaki sposób tabele mają być sprzężone.


kaskada <definicja Jet>

kaskada

Proces, w którym jedna akcja wyzwala kolejną akcję. Na przykład, gdy dla dwóch (lub więcej) tabel zdefiniowana jest relacja z aktualizacją kaskadową, zmiana wartości klucza podstawowego w tabeli podstawowej wyzwala automatycznie (kaskadowo) zmiany w tabeli obcej.

Obecnie dostępne również z poziomu SQL DLL.


usuwanie kaskadowe <definicja Jet>

usuwanie kaskadowe

Dla relacji wymuszających integralność referencyjną pomiędzy tabelami wprowadzono usuwanie kaskadowe, polegające na tym, że usunięcie rekordu w podstawowej tabeli powoduje automatyczne usunięcie wszystkich związanych z nim rekordów w obcej tabeli lub w wielu obcych tabelach.

Na przykład, jeśli przy włączonej opcji usuwania kaskadowego zostanie ustalona relacja pomiędzy podstawową tabelą Klienci a obcą tabelą Zamówienia, to w momencie usunięcia rekordu z tabeli Klienci, zostaną również usunięte wszystkie związane z nim rekordy w tabeli Zamówienia.

Obecnie dostępne również z poziomu SQL DLL.


aktualizacja kaskadowa <definicja Jet>

aktualizacja kaskadowa

Dla relacji wymuszających integralność referencyjną pomiędzy tabelami wprowadzono aktualizacje kaskadową, polegającą na tym, że zmiana klucza podstawowego danego rekordu podstawowej tabeli powoduje automatyczną zmianę wszystkich kluczy obcych w związanych z nim rekordach w tabeli obcej lub w wielu tabelach obcych.

Na przykład, jeśli przy włączonej opcji aktualizacji kaskadowej zostanie ustalona relacja pomiędzy podstawową tabelą Klienci a obcą tabelą Zamówienia, to w momencie zmiany klucza podstawowego dla rekordu z tablicy Klienci, zostaną również zmienione wszystkie zamówienia związane z tym klientem, znajdujące się w tabeli obcej Zamówienia.

Obecnie dostępne również z poziomu SQL DLL.


zerowanie kaskadowe <definicja Jet>

zerowanie kaskadowe

Dla zależności wymuszających integralność referencyjną pomiędzy tabelami wprowadzono zerowanie kaskadowe, polegające na tym, że usunięcie wiersza w podstawowej tablicy automatycznie uaktualnia z wartością NULL klucz obcy we wszystkich zależnych rekordach tabeli obcej lub tabel obcych.

Obecnie dostępne również z poziomu SQL DLL.

Na przykład, jeśli przy włączonej opcji zerowania kaskadowego zostanie ustalona relacja pomiędzy podstawową tabelą Klienci a obcą tabelą Zamówienia, to w momencie usunięcia rekordu z tablicy Klienci, wszystkim zamówieniom w obcej tabeli, związanym z usuniętym klientem, zostanie przypisana wartość NULL.


uwzględnianie wielkości liter <definicja Jet>

uwzględnianie wielkości liter

Rozróżnianie małych i wielkich liter. Wyszukiwanie z uwzględnianiem wielkości liter spowoduje odnalezienie wyłącznie tekstu, w którym wielkość liter jest zgodna ze wzorcem. W takim wyszukiwaniu ciągi "CiągZerowy" i "ciągzerowy" traktowane są jako różne. Operacje w bazie danych Microsoft® Jet nie uwzględniają wielkości liter. Jednak niektóre systemy zarządzania bazami danych mają możliwości rozróżniania małych i wielkich liter.


Char - typ danych <definicja Jet>

Char - typ danych

Typ danych przechowujący ciąg znaków o stałej długości. Długość jest ustalona przez właściwość Size.


CHECK - ograniczenie <definicja Jet>

CHECK - ograniczenie

Koncepcja pochodząca z języka ANSI SQL-92, która umożliwia tworzenie reguł biznesowych, które obejmują całą tabelę lub wiele tabel. Przykładem może być tworzenie tabeli Klienci i tabeli Zamówienia. Tabela Zamówienia mogłaby mieć ograniczenie CHECK, które uniemożliwiałoby przekroczenie w zamówieniu limitu zdefiniowanego dla klienta w tabeli Klienci.


klasa <definicja Jet>

klasa

Formalna definicja obiektu. Klasa jest szablonem, na podstawie którego w czasie wykonywania programu tworzona jest instancja obiektu. Klasa definiuje właściwości obiektu oraz metody wykorzystywane do sterowania zachowaniem się obiektu.


biblioteka kursorów grupowych klienta <definicja Jet>

biblioteka kursorów grupowych klienta

Biblioteka dostarczająca kursory po stronie klienta dla aplikacji baz danych korzystających z mechanizmów ODBCDirect. Biblioteka ta obsługuje wszystkie cztery typy kursorów (kluczowe, statyczne, dynamiczne i progresywne) oraz dostarcza wiele innych funkcji, łącznie z możliwością odbierania przydzielonych połączeń i realizacją optymistycznych aktualizacji.


indeks klastrowy <definicja Jet>

indeks klastrowy

Fizyczna kolejność wierszy jest taka sama, jak kolejność indeksów odnoszących się do tych wierszy.


kolekcja <definicja Jet>

kolekcja

Obiekt zawierający zestaw powiązanych ze sobą obiektów. Pozycja obiektu w kolekcji nie jest stała, może zmienić się przy każdej zmianie dokonywanej w kolekcji.


kolizja <definicja Jet>

kolizja

Konflikt występujący w trakcie aktualizacji grupowej.

Kolizja występuje wówczas, gdy klient odczytuje dane z serwera, następnie próbuje zmienić je operacją aktualizacji grupowej, lecz zanim ta aktualizacja zostanie rzeczywiście zrealizowana, inny klient zmienia dane na serwerze. W tej sytuacji pierwszy klient próbuje zmienić na serwerze dane, których w istocie nie zna.


kolumna <definicja Jet>

kolumna

Wizualna reprezentacja pola w siatce. Kolumna definiuje typ danych, rozmiar i inne atrybuty jednego pola w wierszu (rekordzie) danych. Wszystkie kolumny potraktowane jako jeden zestaw definiują wiersz (rekord) bazy danych. Pojedyncza kolumna zawiera dane jednego typu i o tym samym znaczeniu w obrębie całej tabeli. Oznacza to, że definicja kolumny jest stała dla kolejnych wierszy.


śledzenie na poziomie kolumn <definicja Jet>

śledzenie na poziomie kolumn

Śledzenie na poziomie kolumn jest mechanizmem, w którym każda kolumna w wierszu uczestniczy oddzielnie w określaniu i rozwiązywaniu konfliktów. Jeśli co najmniej jedna replika modyfikuje ten sam wiersz, a każda modyfikuje unikatową kolumnę, nie występuje konflikt i wszystkie zmiany zostaną scalone.


zatwierdzenie <definicja Jet>

zatwierdzenie

Zaakceptowanie nie zapisanych jeszcze wyników transakcji. W trakcie przetwarzania transakcji, rozpoczętych przy użyciu obiektów DAO i ADO lub instrukcji języka SQL, żadna z tych transakcji nie jest zapisywana do bazy danych do chwili, aż nie zostanie ona zatwierdzona.


kwerenda złożona <definicja Jet>

kwerenda złożona

Kwerenda składająca się z co najmniej jednej kwerendy funkcjonalnej (czyli takiej, która kopiuje lub zmienia dane) i co najmniej jednej kwerendy wybierającej (czyli takiej, która zwraca zestaw rekordów typu Recordset, nie zmieniając danych). W DAO, kwerenda złożona jest tworzona przez umieszczenie dwóch lub więcej instrukcji SQL (rozdzielonych średnikami) we właściwości SQL obiektu typu QueryDef.


ciąg połączenia <definicja Jet>

ciąg połączenia

Ciąg wykorzystywany do zdefiniowania źródła danych dla zewnętrznej bazy danych. Ciąg połączenia jest zwykle przypisywany do właściwości Connect obiektu QueryDef, TableDef, Connection lub Database albo jest podawany jako argument metody OpenDatabase.


spójny <definicja Jet>

spójny

Stan wielotabelowego obiektu Recordset pozwalający wyłącznie na takie aktualizacje, które nie naruszają spójności danych. Na przykład, w obiekcie Recordset będącym sprzężeniem dwóch lub więcej tabel (związek jeden-do-wielu), spójna kwerenda nie pozwoli na nadanie kluczowi po stronie "wielu" wartości nie występującej po stronie "jeden".


stała <definicja Jet>

stała

Element o ustalonej nazwie, przechowujący wartość, która nie zmienia się w trakcie wykonywania w trakcie wykonywania programu, w przeciwieństwie do zmiennej, której wartość podczas wykonywania programu może ulegać zmianie. Każda aplikacja na komputerze głównym może definiować własny zestaw stałych. Użytkownik może definiować dodatkowe stałe za pomocą instrukcji Const. Stałe mogą być stosowane w dowolnym miejscu w kodzie zamiast przypisanych im wartości. Stała może być literałem znakowym lub numerycznym, inną stałą lub dowolną kombinacją zawierającą operatory arytmetyczne lub logiczne z wyjątkiem instrukcji Is i operacji potęgowania. Na przykład:

Const strdb = "c:\Program files\Microsoft Office\Access\Samples\Northwind.mdb"


ograniczenie <definicja Jet>

ograniczenie

Ograniczenie nałożone na wartości, które użytkownik może wprowadzić do pola. Do aparatu Microsoft® Jet w wersji 4.X dodano ograniczenie CHECK standardu ANSI SQL DDL przy wykorzystywaniu mechanizmu Microsoft OLE DB Provider for Jet. Ograniczenie CHECK umożliwia tworzenie reguł biznesowych, które obejmują całą tabelę lub kilka innych tabel.


bufor kopii <definicja Jet>

bufor kopii

Miejsce utworzone przez aparat bazy danych Microsoft® Jet do przechowywania zawartości rekordu otwartego do edycji. Metoda Edit powoduje skopiowanie bieżącego rekordu do bufora kopii. Metoda AddNew powoduje wyczyszczenie bufora dla nowego rekordu i ustawienie wartości domyślnych. Metoda Update powoduje zapisanie danych zawartych w buforze kopii do bazy danych z zastąpieniem bieżącego rekordu lub wstawieniem nowego rekordu. Każda instrukcja resetująca lub przenosząca wskaźnik bieżącego rekordu powoduje usunięcie zawartości bufora kopii. Na przykład, wywołanie metody MoveNext lub zmiana właściwości Index tabeli powoduje usunięcie zawartości bufora kopii.


nazwa skorelowana <definicja Jet>

nazwa skorelowana

Zgodnie ze standardem ANSI nazwa odnosząca się do kolumny w tabeli lub do widoku (zapisana w programie kwerenda). Określana również jako alias, nazwa zastępcza.


Autonumer - typ danych <definicja Jet>

Autonumer - typ danych

Atrybut pola, który automatycznie przechowuje unikatową wartość dla każdego rekordu w momencie dodania go do tabeli. Pole typu Autonumer wykorzystuje typ danych Long i ma właściwość Attributes ustawioną na dbAutoIncrement. Liczby generowane przez pole Autonumer nie mogą być modyfikowane bez specjalnego zezwolenia, które może być nadane tabeli za pomocą instrukcji Grant lub Revoke według składni SQL DDL. Pole Autonumer znane jest również jako pole typu Licznik lub Identyfikator.

Uwaga. W replikowanych tabelach, znajdujących się w replikowanych bazach danych, wartość pola typu Autonumer nie jest zwiększana kolejno o 1, lecz przyjmuje wartość losową z zakresu od -2 000 000 000 do 2 000 000 000.

Zobacz także

Atrybut identyfikacji


kryteria <definicja Jet>

kryteria

Zbiór warunków ograniczających, takich jak = "Francja" (oznaczający "równe Francja") lub > 30000, wykorzystywanych przy tworzeniu kwerendy lub filtru w celu wyświetlenia określonego zestawu rekordów.


kwerenda krzyżowa <definicja Jet>

kwerenda krzyżowa

Kwerenda obliczająca sumę, wartość średnią, liczbę wystąpień lub inne podsumowanie dotyczące rekordów, a następnie grupująca wynik na dwa sposoby. Nagłówki pierwszego podsumowania umieszczane są pionowo po lewej stronie siatki (nagłówki wierszy), a nagłówki drugiego podsumowania są umieszczane poziomo u góry siatki (nagłówki kolumn). Przykładem kwerendy krzyżowej jest kwerenda [Kwartalne zamówienia na poszczególne asortymenty] w przykładowej bazie danych Northwind.


znak sterujący <definicja Jet>

znak sterujący

Dowolna kombinacja klawiszy rozpoczynająca się od klawisza CTRL lub ESC.


Currency - typ danych <definicja Jet>

Currency - typ danych

Typ danych przydatny przy obliczeniach dotyczących wielkości pieniężnych lub obliczeniach stałoprzecinkowych, w których dokładność jest bardzo istotnym czynnikiem. Ten typ danych może przechowywać liczby zawierające do 15 cyfr przed przecinkiem i do 4 cyfr po przecinku. Ponieważ typ danych Currency wykorzystuje do przechowywania wszystkich danych wartości dyskretne, zaokrąglenie binarne nie ma wpływu na wyniki obliczeń.


bieżąca baza danych <definicja Jet>

bieżąca baza danych

Obiekt Database zwracany przez funkcję CurrentDB( ). Odwołanie postaci DBEngine.Workspaces(0).Databases(0) zwraca pierwszą otwartą bazę danych. To pojęcie ma zastosowanie tylko w programie Microsoft® Access®.


bieżący indeks <definicja Jet>

bieżący indeks

Indeks ostatnio ustawiony za pomocą właściwości Index dla indeksowanego obiektu Recordset typu tabela. Indeks ten jest podstawą do uporządkowania rekordów w obiekcie Recordset typu tabeli i jest on wykorzystywany przez metodę Seek do wyszukiwania rekordów. Obiekt Recordset może mieć więcej niż jeden indeks, ale tylko jeden indeks może być wykorzystywany w danej chwili (aczkolwiek obiekt TableDef może mieć kilka indeksów). Aparat bazy danych Microsoft® Jet może przy wykonywaniu kwerendy wykorzystywać wiele indeksów.


bieżący rekord <definicja Jet>

bieżący rekord

Rekord w obiekcie Recordset wykorzystywany do modyfikowania lub przeglądania danych. Do zmiany położenia bieżącego rekordu w zestawie rekordów służą metody z grupy Move. Do zmiany położenia bieżącego rekordu zgodnie z podanymi kryteriami służą metody z grupy Find (dla obiektów Recordset typu zestaw dynamiczny lub typu utrwalonego) lub metoda Seek (dla obiektu Recordset typu tabela).

Tylko jeden rekord może być rekordem bieżącym w obiekcie Recordset. Obiekt Recordset może również nie mieć bieżącego rekordu. Na przykład, bieżący rekord nie jest zdefiniowany po usunięciu rekordu z obiektu Recordset typu zestaw dynamiczny albo w sytuacji, gdy obiekt Recordset nie zawiera rekordów. W takim przypadku operacje odwołujące się do bieżącego rekordu spowodują błąd przechwytywalny.


bieżąca transakcja <definicja Jet>

bieżąca transakcja

Wszystkie zmiany wprowadzone w obiekcie Recordset po ostatnim wywołaniu metody BeginTrans i przed wywołaniem metody Rollback lub CommitTrans.


obiekty dostępu do danych (DAO Data Access Objects) <definicja Jet>

obiekty dostępu do danych (DAO Data Access Objects)

Interfejs programowania umożliwiający uzyskiwanie dostępu do obiektów bazy danych i operowanie na nich.


obiekt DAO <definicja Jet>

obiekt DAO

Obiekt zdefiniowany w bibliotece obiektów dostępu do danych (Data Access Objects, DAO). Obiektów DAO, takich jak Database, TableDef, Recordset i QueryDef, można używać do reprezentowania w kodzie programu obiektów służących do porządkowania i operowania na danych (na przykład tabele i kwerendy).


aparat bazy danych <definicja Jet>

aparat bazy danych

Część systemu bazy danych pobierająca i zapamiętująca dane w bazach danych systemowych i użytkownika.


język definicji danych (Data Definition Language, DDL) <definicja Jet>

język definicji danych (Data Definition Language, DDL)

Język wykorzystywany do opisywania atrybutów bazy danych, w szczególności tabel, pól, indeksów i strategii przechowywania danych. Standard ANSI rezerwuje dla niego następujące słowa kluczowe CREATE, DROP i ALTER.


kwerenda definiująca dane <definicja Jet>

kwerenda definiująca dane

Kwerenda specyficzna dla języka SQL służąca do utworzenia, zmiany lub usunięcia tabeli, a także do utworzenia lub usunięcia indeksu w bazie danych. Standard ANSI definiuje je jako kwerendy typu DDL i korzysta ze słów kluczowych CREATE, DROP i ALTER.

Zobacz także

DDL (Data Definition Language - język definicji danych)


źródło danych <definicja Jet>

źródło danych

Nazwany zasób ODBC (Open Database Connectivity) określający położenie, typ sterownika i inne parametry wymagane przez sterownik ODBC do dostępu do bazy danych ODBC. Źródłem danych może być dowolne źródło informacji pochodzących z bazy danych.


typ danych <definicja Jet>

typ danych

Cecha charakterystyczna zmiennej określająca, jakiego rodzaju dane mogą być przechowywane w tej zmiennej. Rozróżniane są następujące typy danych: Big Integer, Binary, Byte, Boolean, Char, Currency, Date, Decimal, Double, Float, GUID, Integer, Long, Long Binary (obiekt OLE), Memo, Numeric, Single, String, Text, Time, TimeStamp, VarBinary, Variant (domyślny), typy zdefiniowane przez użytkownika (utworzone za pomocą instrukcji Type) oraz obiektowe typy danych, do których zaliczane są obiektowe typy udostępniane i obiektowe typy DAO.


literał daty <definicja Jet>

literał daty

Ciąg znaków w określonym formacie, umieszczony między znakami numeru (#). Poprawny format daty to format określony przez ustawienia regionalne dla kodu programu lub uniwersalny format daty.

Na przykład, #31.12.92# jest literałem daty reprezentującym 31 grudnia 1992 roku, przy czym ustawieniem regionalnym dla aplikacji jest "Polska". Literały daty służą ułatwieniu przenoszenia programów pomiędzy wersjami narodowymi.


daty i godziny <definicja Jet>

daty i godziny

Daty i godziny są przechowywane wewnętrznie jako różne części liczby rzeczywistej.

Wartość całkowita takiej liczby reprezentuje datę między 30 grudnia 1899 roku i 30 grudnia 9999 roku włącznie. Wartości ujemne oznaczają daty przed 30 grudnia 1899 roku.

Część ułamkowa reprezentuje godziny między 0:00:00 i 23:59:59 włącznie. Południe jest reprezentowane przez 0,5.


Decimal - typ danych <definicja Jet>

Decimal - typ danych

Typ danych przechowujący dokładną wartość numeryczną ze znakiem, o precyzji p i skali s (1 ≤ p ≤15; 0 ≤ s ≤ p).


domyślny obszar roboczy <definicja Jet>

domyślny obszar roboczy

Obiekt Workspace ustanawiany automatycznie przez obiekt DAO, gdy aplikacja po raz pierwszy odwołuje się do dowolnego obiektu DAO. Do takiego obiektu Workspace można się odwoływać przez DBEngine.Workspaces(0) lub po prostu przez Workspaces(0).


kwerenda usuwająca <definicja Jet>

kwerenda usuwająca

Kwerenda funkcjonalna usuwająca zestaw wierszy odpowiadający podanym kryteriom. Kwerenda usuwająca nie zwraca wierszy.


czas projektowania <definicja Jet>

czas projektowania

Okres, w którym aplikacja jest tworzona w środowisku do tworzenia aplikacji. W tym czasie dodawane są formanty, ustawiane są właściwości sterowania i formularzy itd. Dla odróżnienia, w czasie wykonywania aplikacja działa w sposób umożliwiający korzystanie z niej użytkownikowi.


pole przeznaczenia <definicja Jet>

pole przeznaczenia

Pole wymienione w kwerendzie, które będzie zawierało wyniki kwerendy.


synchronizacja bezpośrednia <definicja Jet>

synchronizacja bezpośrednia

Typ synchronizacji występujący wówczas, gdy dwie repliki mogą być otwarte jednocześnie w trakcie procesu synchronizacji.


biblioteka dołączana dynamicznie (dynamic-link library, DLL) <definicja Jet>

biblioteka dołączana dynamicznie (dynamic-link library, DLL)

Zestaw podprogramów, które mogą być wywoływane przez procedury. Biblioteki DLL są ładowane i konsolidowane z aplikacją w czasie wykonywania programu.


Double - typ danych <definicja Jet>

Double - typ danych

Podstawowy typ danych służący do przechowywania liczb zmiennoprzecinkowych podwójnej precyzji w formacie IEEE. Zmienna typu Double przechowywana jest jako liczba 64-bitowa (8-bajtowa) o wartości z przedziału od -1,79769313486231E308 do -4,94065645841247E-324 dla wartości ujemnych, od 4,94065645841247E-324 do 1,79769313486231E308 dla wartości dodatnich i 0.


kursor dynamiczny <definicja Jet>

kursor dynamiczny

Dynamiczny zestaw wierszy, który można stosować w celu dodania, zmiany lub usunięcia wierszy z tabeli lub tabel bazy danych. Kursor dynamiczny może zawierać kolumny z jednej lub więcej tabel bazy danych. Przynależność do tego zestawu nie jest niezmienna.


dynamiczny zestaw rekordów <definicja Jet>

dynamiczny zestaw rekordów

Typ obiektu Recordset zwracającego dynamiczny zestaw wskaźników do rzeczywistych danych z bazy danych. Podobnie jak obiekty Recordset typu tabela i typu utrwalonego, obiekt dynamicznego zestawu rekordów zwraca dane ułożone w rekordach (wierszach) i polach (kolumnach). W przeciwieństwie do obiektu Recordset typu tabela, obiekt Recordset typu zestaw dynamiczny może być wynikiem kwerendy sprzęgającej dwie lub więcej tabel. Rekordy w dynamicznym zestawie rekordów mogą być uaktualniane, jeśli właściwość Updatable obiektu Recordset jest ustawiona na True, jeśli obiekt Field, który ma zostać zmieniony, może być aktualizowany i jeśli strona danych zawierająca bieżący rekord nie jest zablokowana. Strona danych jest zablokowana, gdy zastosowano metodę Update (w przypadku gdy właściwość LockEdits ma wartość False) lub gdy zastosowano metodę Edit (w przypadku gdy właściwość LockEdits ma wartość True).


równosprzężenie <definicja Jet>

równosprzężenie

Sprzężenie, w którym rekordy z dwóch tabel są łączone i dodawane do obiektu Recordset tylko wtedy, gdy w sprzężonych polach znajdują się takie same wartości. Określane również jako sprzężenie wewnętrzne.


wyłączność <definicja Jet>

wyłączność

Tryb dostępu chroniący dane w bazie danych współużytkowanej w sieci. Otwarcie bazy danych w trybie wyłącznym uniemożliwia innym użytkownikom otwarcie tej bazy danych.


wyrażenie <definicja Jet>

wyrażenie

Dowolna kombinacja operatorów, stałych, literałów i funkcji, a także nazw pól, formantów i właściwości, która daje w wyniku pojedynczą wartość. Wyrażenia mogą być używane jako wartości dla wielu właściwości i argumentów, do określania kryteriów lub do definiowania w kwerendach pól obliczanych.


zewnętrzna baza danych <definicja Jet>

zewnętrzna baza danych

Baza danych ODBC, na przykład Microsoft® SQL Server, znajdująca się na odległym serwerze lub jedna z następujących baz danych: Paradox, dBASE, FoxPro®, Microsoft Excel, Microsoft Access, Lotus 1-2-3, HTML i baza tekstowa.


tabela zewnętrzna <definicja Jet>

tabela zewnętrzna

Tabela bazy danych znajdująca się poza otwartą bazą danych Microsoft® Jet. Tabela zewnętrzna może pochodzić z innego pliku lub może być tabelą w innej relacyjnej bazie danych.


pole <definicja Jet>

pole

Kategoria informacji przechowywanej w tabeli bazy danych — kolumna danych. Element tabeli bazy danych przechowujący konkretną informację, na przykład nazwisko.


właściwości pola <definicja Jet>

właściwości pola

Atrybuty pola określające rodzaj zawartych w nim danych. Przykładami właściwości są Size i Type.


filtr <definicja Jet>

filtr

Zbiór kryteriów używany w odniesieniu do rekordów w celu utworzenia podzbioru tych rekordów.


Float - typ danych <definicja Jet>

Float - typ danych

Typ danych przechowujący przybliżoną wartość numeryczną ze znakiem, o precyzji mantysy równej 15 (zero lub wartość bezwzględna od 10^-308 do 10^+308).


klucz obcy <definicja Jet>

klucz obcy

Jedno lub więcej pól tabeli odwołujących się do pola lub pól klucza podstawowego w innej tabeli. Klucz obcy wskazuje, w jaki sposób tabele są powiązane ľ dane w polach klucza podstawowego i obcego muszą być zgodne. Na przykład, spis dopuszczalnych numerów części mógłby zawierać klucz obcy do tabeli stanów magazynowych zawierającej odesłania do dopuszczalnych numerów części. Klucz obcy jest wykorzystywany do utrzymywania integralności referencyjnej w bazie danych.


tabela obca <definicja Jet>

tabela obca

Tabela zawierająca klucz obcy wskazujący na inną tabelę bazy danych. Ogólnie, tabelę obcą wykorzystuje się do ustanowienia lub wymuszenia integralności referencyjnej. Tabela obca znajduje się po stronie "wielu" związku jeden-do-wielu. Przykładem tabeli obcej jest tabela Zamówienia.


formularz <definicja Jet>

formularz

Okno lub okno dialogowe. Formularze są kontenerami dla formantów. Formularz interfejsu wielodokumentowego (multiple-document interface, MDI) może także służyć jako kontener dla formularzy potomnych i niektórych formantów.


kursor typu progresywnego <definicja Jet>

kursor typu progresywnego

Zestaw wynikowy, w którym bieżąca pozycja może przenosić się tylko do przodu o określoną liczbę rekordów lub do ostatniego rekordu. Bieżąca pozycja nie może być przeniesiona wstecz do początku zestawu wynikowego ani do poprzednich rekordów. Po otwarciu kursora takiego typu warunki przynależności, kolejność i wartości są w zasadzie ustalone. Jeśli inni użytkownicy uaktualniają, usuwają lub wstawiają wiersze, kursor nie odzwierciedla tych zmian, aż zostanie on zamknięty i ponownie otwarty.


przewijanie do przodu <definicja Jet>

przewijanie do przodu

Przemieszczanie się ku końcowi (EOF) obiektu Recordset.


obiekt Recordset typu progresywnego <definicja Jet>

obiekt Recordset typu progresywnego

Obiekt Recordset, w którym rekordy mogą być przeszukiwane tylko w kierunku od początku do końca. Bieżąca pozycja rekordu nie może być cofnięta do pierwszego rekordu. Obiekty Recordset typu progresywnego redukują narzut związany z przetwarzaniem w odległych bazach danych. Na przykład, obiektu Recordset typu progresywnego bazującego na połączonej tabeli odległej można użyć przy tworzeniu niestandardowego raportu do szybkiego, jednoprzebiegowego przetwarzania danych.


FTP <definicja Jet>

FTP

Protokół przesyłania plików (File Transfer Protocol). Protokół umożliwiający użytkownikowi przesyłanie plików z jednego położenia w drugie poprzez sieć Internet. Adresy URL plików na serwerach FTP zaczynają się od ftp://.


procedura typu Function <definicja Jet>

procedura typu Function

Procedura wykonująca określone zadanie w programie napisanym w języku Visual Basic® i zwracająca wartość. Procedura Function rozpoczyna się instrukcją Function, a kończy się instrukcją End Function.


grupa <definicja Jet>

grupa

Zbiór kont użytkowników w obiekcie Workgroup, identyfikowany przez nazwę grupy i identyfikator osobisty (PID). Uprawnienia nadane grupie dotyczą wszystkich użytkowników należących do grupy.


GUID - typ danych <definicja Jet>

GUID - typ danych

Unikatowy identyfikator globalny / unikatowy identyfikator uniwersalny (Globally Unique Identifier/Universally Unique Identifier). Unikatowy ciąg identyfikacyjny używany przy wywoływaniu procedur zdalnych. Każda klasa obiektu i interfejsu używa do identyfikacji wartości GUID. GUID jest wartością 128-bitową. Na przykład, ciąg znaków 12345678-1234-1234-1234-123456789ABC jest poprawną składniowo wartością GUID. Ciągi GUID klienta i serwera muszą być zgodne, by mogło nastąpić powiązanie między nimi. Dostawcy obiektów mogą zażądać, aby firma Microsoft przydzieliła jeden lub więcej zestawów złożonych z 256 ciągów GUID do ich wyłącznego użytku. Można także wykorzystać program narzędziowy o nazwie Uuidgen.exe, który udostępnia zestaw 256 ciągów GUID w oparciu o godzinę, datę i unikatowy numer karty sieciowej.


HTTP <definicja Jet>

HTTP

Protokół przesyłania hipertekstowego. Zakulisowy protokół sieci Internet dostarczający informacji za pośrednictwem sieci World Wide Web. Protokół ten umożliwia użytkownikowi, za pośrednictwem programu klienta, wprowadzenie adresu URL (lub kliknięcie hiperłącza) i odczytanie w ten sposób tekstu, grafiki, dźwięku i innych informacji cyfrowych z serwera Web. Adresy URL plików na serwerach Web zaczynają się od http://.


hyperlink - typ danych <definicja Jet>

hyperlink - typ danych

Typ danych stosowany dla pól przechowujących hiperłącza. Pole typu hyperlink zawiera tekst lub kombinację tekstu i liczb przechowywaną jako tekst i stosowane jest jako adres typu hyperlink. Adres typu hyperlink o podanej niżej składni może składać się z maksymalnie trzech elementów, z których każdy może zawierać do 2048 znaków:

tekst_wyświetlany#adres#podadres


atrybut identyfikacji <definicja Jet>

atrybut identyfikacji

Dodany dla zapewnienia zgodności składniowej z serwerem SQL. Dostępny wyłącznie w języku SQL DDL przy wykorzystaniu mechanizmu Microsoft® OLE DB Provider for Jet.Ten typ danych ma taką samą funkcjonalność jak typy danych Counter i Autonumer. Jest dla nich synonimem i nie posiada żadnej dodatkowej funkcjonalności.

Zobacz także

Autonumer - typ pola


niespójny <definicja Jet>

niespójny

Stan wielotabelowego obiektu Recordset pozwalający na aktualizację wszystkich pól (kolumn). Na przykład, w obiekcie Recordset utworzonym przez sprzężenie typu jeden-do-wielu dwóch tabel (tabele Klienci i Zamówienia) można uaktualnić pole Zamówienia.KodKlienta w taki sposób, że nie będzie mu odpowiadało pole Klienci.KodKlienta, chyba że integralność referencyjna uniemożliwi taką aktualizację.


przyrost <definicja Jet>

przyrost

Opcjonalny parametr używany dla typów danych Licznik i Identyfikator. Dostępny wyłącznie w języku SQL DDL przy wykorzystaniu mechanizmu Microsoft® OLE DB Provider for Jet. Jest to liczba używana do przypisania kolejnej wartości dla nowego wiersza w tablicy zawierającej dane typu Licznik lub Identyfikator. Jest drugim z dwóch możliwych parametrów dla tych typów danych.

Zobacz także

wartość początkowa


indeks <definicja Jet>

indeks

Dynamiczne wzajemne powiązanie jednego lub większej liczby pól tabeli (kolumn) umożliwiające szybsze wydobywanie z tabeli określonych rekordów. W trakcie dodawania, zmieniania lub usuwania rekordów system zarządzania bazą danych automatycznie uaktualnia indeks zgodnie ze zmianami w bazie danych.

W przypadku posługiwania się obiektem Recordset typu tabela bieżący indeks określa kolejność, w jakiej rekordy przesyłane są do obiektu Recordset. Tabela może mieć kilka indeksów.

Obiekt Index typu DAO reprezentuje indeks dla obiektu TableDef.


synchronizacja pośrednia <definicja Jet>

synchronizacja pośrednia

Typ synchronizacji występujący wówczas, gdy jeden z Synchronizatorów pozostawia w folderze skrzynki informacje o zmianach, które mają być pobrane i zastosowane w replice zarządzanej przez inny Synchronizator.


sprzężenie wewnętrzne <definicja Jet>

sprzężenie wewnętrzne

Sprzężenie, w którym rekordy z dwóch tabel są łączone i dodawane do obiektu Recordset tylko wtedy, gdy wartości pól sprzężenia spełniają określony warunek. Na przykład, równosprzężenie jest sprzężeniem wewnętrznym, w którym wartość łączonych pól musi być równa.


instalowalny sterownik ISAM <definicja Jet>

instalowalny sterownik ISAM

Wybierany sterownik umożliwiający dostęp do formatów zewnętrznych baz danych, takich jak dBASE, Microsoft® Excel i Paradox. ISAM jest akronimem angielskiego terminu Indexed Sequential Access Method (indeksowo - sekwencyjna metoda dostępu). Aparat bazy danych Microsoft instaluje (ładuje) sterowniki ISAM, gdy zostaną wywołane przez aplikację. Położenie tych sterowników jest zarządzane przez Rejestr Microsoft Windows®.


wystąpienie <definicja Jet>

wystąpienie

Każdy z obiektów współdzielących tę samą klasę. Na przykład, wiele wystąpień klasy Form używa tego samego kodu i ładowane są z tymi samymi formantami, z którymi klasa Form została zaprojektowana. W czasie wykonywania programu można nadać różne wartości poszczególnym właściwościom formantów w każdej instancji.


Integer - typ danych <definicja Jet>

Integer - typ danych

Podstawowy typ danych służący do przechowywania liczb całkowitych. Zmienna typu Integer przechowywana jest jako liczba 16-bitowa (2-bajtowa) o wartości z zakresu od -32 768 do 32 767.


Internet <definicja Jet>

Internet

Ogólnoświatowa sieć złożona z tysięcy małych sieci komputerowych i milionów komputerów komercyjnych, edukacyjnych, rządowych i osobistych. Sieć Internet jest podobna do elektronicznego miasta z wirtualnymi bibliotekami, sklepami, biurami, galeriami sztuki itp.


synchronizacja internetowa <definicja Jet>

synchronizacja internetowa

Typ synchronizacji, w którym wykorzystywana jest seria wymian wiadomości między replikami pozostawionymi w folderze skrzynki. Jedynie replika zarządzana przez Synchronizatora na serwerze internetowym ma skrzynkę. Skrzynka ta jest dostępna za pomocą połączenia HTTP lub FTP.


intranet <definicja Jet>

intranet

Sieć wewnątrz organizacji stosująca technologie przeznaczone dla Internetu (takie jak protokoły HTTP lub FTP). Sieć intranet może być wykorzystywana do poruszania się pomiędzy obiektami, dokumentami, stronami Web i innymi informacjami za pomocą hiperłączy.


stała wewnętrzna <definicja Jet>

stała wewnętrzna

Stała udostępniana przez aplikację. Na przykład, stałe obiektów dostępu do danych (Data Access Objects, DAO) są zawarte w bibliotece obiektów DAO i mogą być przeglądane za pomocą Przeglądarki obiektów.


źródło danych ODBC dołączone do aparatu Microsoft Jet <definicja Jet>

źródło danych ODBC dołączone do aparatu Microsoft Jet

Źródło danych ODBC, do którego dostęp jest realizowany z wykorzystaniem obiektów dostępu do danych (DAO) i aparatu bazy danych Microsoft® Jet.


sprzężenie <definicja Jet>

sprzężenie

Operacja bazodanowa łącząca niektóre lub wszystkie rekordy z jednej lub kilku tabel. Wyróżnia się następujące sprzężenia: równosprzężenie, sprzężenie wewnętrzne, sprzężenie zewnętrzne i samosprzężenie. Ogólnie, sprzężenie odwołuje się do logicznego powiązania pól tych samych typów w dwóch różnych tabelach. Sprzężenie można zrealizować za pomocą instrukcji SQL.

Przy definiowaniu związku między dwoma tabelami sprzężenie jest tworzone przez określenie pól z tabeli podstawowej i obcej. Przy dodawaniu tabeli do kwerendy sprzężenie pomiędzy odpowiednimi polami należy utworzyć w instrukcji języka SQL definiującej kwerendę.


kursor kluczowy <definicja Jet>

kursor kluczowy

Zestaw wierszy, który można stosować w celu dodania, zmiany lub usunięcia wierszy z tabeli lub tabel bazy danych. Poruszanie się w tym zestawie jest nieograniczone. Kursor kluczowy może zawierać kolumny z jednej lub więcej tabel bazy danych. Przynależność do tego zestawu nie jest niezmienna.


lewostronne sprzężenie <definicja Jet>

lewostronne sprzężenie

Lewostronne sprzężenie zewnętrzne zawiera wszystkie rekordy z pierwszej z dwóch tabel (lewej), także wtedy, gdy wartości te nie odpowiadają żadnemu z rekordów w drugiej (prawej) tabeli.


lewostronne sprzężenie zewnętrzne <definicja Jet>

lewostronne sprzężenie zewnętrzne

Sprzężenie zewnętrzne, w którym do obiektu Recordset dodawane są wszystkie rekordy z tabeli z lewej strony operatora LEFT JOIN użytego w kwerendzie SQL, nawet te, które nie mają odpowiadających wartości w sprzężonych polach z tabeli z prawej strony. Rekordy z tabeli prawej są łączone z rekordami z tabeli lewej tylko wtedy, gdy w polach sprzężenia znajdują się odpowiadające sobie wartości. Gdy pole po lewej stronie nie ma odpowiednika, po prawej stronie dołączany jest wiersz z wartościami Null.


tabela podłączona <definicja Jet>

tabela podłączona

Tabela z innej bazy danych podłączona do bazy danych Microsoft® Jet. Dane w podłączonej tabeli pozostają w zewnętrznej bazie danych, gdzie mogą być przetwarzane przez inne aplikacje. Tabele te dawniej nazywane były tabelami dołączanymi.


zablokowany <definicja Jet>

zablokowany

Stan strony danych, obiektu Recordset lub obiektu Database, który powoduje, że element może służyć tylko do odczytu wszystkim użytkownikom, poza użytkownikiem aktualnie wprowadzającym dane do tego elementu.


Long Binary - typ danych <definicja Jet>

Long Binary - typ danych

Typ danych dla pól mogący przechowywać do 2,14 GB danych. Pola Long Binary mogą zawierać dowolne dane typu binarnego. Znany również jako obiektowy typ danych OLE programu Microsoft® Access.


Long - typ danych <definicja Jet>

Long - typ danych

Podstawowy typ danych służący do przechowywania liczb całkowitych długich. Zmienna typu Long jest przechowywana jako liczba 32-bitowa (4-bajtowa) o wartości z zakresu od -2 147 483 648 do 2 147 483 647.


kwerenda tworząca tabelę <definicja Jet>

kwerenda tworząca tabelę

Kwerenda funkcjonalna tworząca nową tabelę z obiektu Recordset istniejącej kwerendy.


tabela "tylko wielu" <definicja Jet>

tabela "tylko wielu"

Tabela, dla której żadne sprzężenie w kwerendzie nie jest "jednostronne".


Memo - typ danych <definicja Jet>

Memo - typ danych

Typ danych dla pól. Pola takie mogą przechowywać do 2,14 GB danych tekstowych.


komunikat <definicja Jet>

komunikat

Pakiet informacji przekazywany z jednej aplikacji do innej.


metoda <definicja Jet>

metoda

Podobna do funkcji procedura, która operuje na konkretnych obiektach.


baza danych Microsoft Jet <definicja Jet>

baza danych Microsoft Jet

Baza danych utworzona przez aparat bazy danych Microsoft® Jet. Plik bazy danych Microsoft Jet ma rozszerzenie nazwy .mdb.


obszar roboczy Microsoft Jet <definicja Jet>

obszar roboczy Microsoft Jet

Obszar roboczy wykorzystujący aparat bazy danych Microsoft Jet w celu uzyskiwania dostępu do źródła danych. Źródłem danych może być plik bazy danych Microsoft Jet (.mdb), baza danych ODBC, jak np. baza danych Paradox, lub baza danych ISAM.


typy danych dla pól <definicja Jet>

typy danych dla pól

Poniższa tabela podaje typy danych dla obiektów Field.

Typ danych dla pola DAO | Stała
Big Integer | DbBigInt
Binary | DbBinary
Boolean | DbBoolean
Byte | DbByte
Char | DbChar
Currency | DbCurrency
Date/Time | DbDate
Decimal | DbDecimal
Double | DbDouble
Float | DbFloat
GUID | DbGUID
Integer | DbInteger
Long | DbLong
Long Binary (obiekt OLE) | DbLongBinary
Memo | DbMemo
Numeric | DbNumeric
Single | DbSingle
Tekst | DbText
Time | DbTime
TimeStamp | DbTimeStamp
VarBinary | DbVarBinary


aparat bazy danych Microsoft Jet <definicja Jet>

aparat bazy danych Microsoft Jet

System zarządzania bazą danych pobierający i zapamiętujący dane w bazach danych systemowych i użytkownika. Aparat bazy danych Microsoft® Jet może być traktowany jako składnik zarządzający danymi wbudowany w inne systemy dostępu do danych, takie jak Microsoft Access i Visual Basic®.


wielodostępna baza danych <definicja Jet>

wielodostępna baza danych

Baza danych pozwalająca więcej niż jednemu użytkownikowi na dostęp i modyfikowanie tego samego zestawu danych w tym samym czasie. W niektórych przypadkach dodatkowym "użytkownikiem" może być kolejna instancja tej samej aplikacji lub inna aplikacja uruchomiona w systemie i korzystająca z tych samych danych, co pozostałe aplikacje.


normalizacja <definicja Jet>

normalizacja

Służy zminimalizowaniu powielania informacji w relacyjnej bazie danych przez odpowiednie zaprojektowanie tabel.


Null <definicja Jet>

Null

Wartość oznaczająca brakującą lub nieznaną daną. Wartości Null można wprowadzać w pola, których zawartość nie jest znana oraz w wyrażeniach i kwerendach. W języku Visual Basic słowo kluczowe Null oznacza wartość Null. Niektóre pola, na przykład te, które zdefiniowane są jako zawierające klucz podstawowy, nie mogą zawierać wartości Null.


pole puste <definicja Jet>

pole puste

Pole nie zawierające znaków ani wartości. Pole puste nie jest tym samym, co łańcuch o długości zerowej ("") lub pole z wartością 0. Pole jest ustawiane jako puste, gdy jego zawartość nie jest znana. Na przykład, pole "Data zakończenia" będzie pozostawało puste do momentu zakończenia zadania.


Numeric - typ danych <definicja Jet>

Numeric - typ danych

Typ danych przechowujący dokładną wartość numeryczną ze znakiem, o precyzji p i skali s (1 ≤ p ≤15; 0 ≤ s ≤ p).


wyrażenie numeryczne <definicja Jet>

wyrażenie numeryczne

Dowolne wyrażenie, którego wynikiem jest liczba. Może to być dowolna kombinacja zmiennych, stałych, funkcji i operatorów, która w wyniku daje liczbę.


Przeglądarka obiektów <definicja Jet>

Przeglądarka obiektów

Okno dialogowe, które można wykorzystać do przeglądania zawartości biblioteki obiektów w celu uzyskania informacji o umieszczonych w niej obiektach.


wyrażenie obiektowe <definicja Jet>

wyrażenie obiektowe

Wyrażenie określające konkretny obiekt. Wyrażenie to może zawierać dowolne kontenery obiektów. Na przykład, jeżeli w aplikacji istnieje obiekt Aplikacja, w którym zawarty jest obiekt Dokument, zawierający z kolei obiekt Tekst, to poprawne są niżej podane wyrażenia obiektowe:

Aplikacja.Dokument.Tekst

Aplikacja.Tekst

Dokument.Tekst

Tekst


biblioteka obiektów <definicja Jet>

biblioteka obiektów

Biblioteka dołączana dynamicznie (dynamic-link library, DLL), zwykle o rozszerzeniu nazwy .olb, zawierająca jeden lub więcej typów zasobów bibliotecznych. Do przeglądania zawartości biblioteki obiektów w celu uzyskania informacji o umieszczonych tam obiektach można użyć Przeglądarki obiektów.


zmienna obiektowa <definicja Jet>

zmienna obiektowa

Zmienna zawierająca odwołanie do obiektu.


ODBC (Open Database Connectivity) <definicja Jet>

ODBC (Open Database Connectivity)

Standardowy protokół pozwalający na łączenie się aplikacji z różnymi zewnętrznymi serwerami baz danych lub z plikami. Sterowniki ODBC wykorzystywane przez aparat bazy danych Microsoft® Jet umożliwiają dostęp do serwera Microsoft SQL Server™ i kilku innych zewnętrznych baz danych.

Za pomocą interfejsu programowania aplikacji (application programming interface, API) ODBC można także uzyskać dostęp do sterowników ODBC i baz danych, z którymi mogą się one łączyć, bez używania aparatu bazy danych Microsoft Jet.


źródła danych ODBC <definicja Jet>

źródła danych ODBC

Termin wykorzystywany do odwoływania się do bazy danych lub do serwera bazy danych jako do źródła danych. Do źródeł danych ODBC można się odwoływać przez nazwę źródła danych (Data Source Name, DSN). Źródła danych można tworzyć za pomocą Panelu sterowania Windows® lub metody RegisterDatabase.


sterownik ODBC <definicja Jet>

sterownik ODBC

Biblioteka dołączana dynamicznie (dynamic-link library, DLL) wykorzystywana przez inne aplikacje (klientów) do łączenia się z określonym źródłem danych ODBC.


Menedżer sterowników ODBC <definicja Jet>

Menedżer sterowników ODBC

Aplikacja zarządzająca połączeniami pomiędzy źródłami danych ODBC a sterownikami umożliwiającymi dostęp do nich.


OLE <definicja Jet>

OLE

Oparta na obiektach technologia firmy Microsoft pozwalająca na tworzenie aplikacji zawierających składniki pochodzące z innych aplikacji.


obiekt ActiveX <definicja Jet>

obiekt ActiveX

Obiekt, który udostępniany jest innym aplikacjom lub narzędziom programistycznym za pomocą interfejsu automatyzacji (poprzednio automatyzacji OLE). Na przykład Microsoft® Access może tworzyć obiekty i operować obiektami Microsoft ActiveX® w programie Microsoft Word lub Microsoft Excel.


obiekt OLE - typ danych <definicja Jet>

obiekt OLE - typ danych

Typ danych pól służący do przechowywania utworzonych w innych aplikacjach obiektów, które mogą być łączone lub osadzane w bazie danych Microsoft® Jet. Na przykład pole typu obiekt OLE można wykorzystać do przechowywania zbioru rysunków.


relacja jeden-do-wielu <definicja Jet>

relacja jeden-do-wielu

Skojarzenie dwóch tabel w którym:

  • Wartości klucza podstawowego każdego rekordu w tabeli podstawowej odpowiada wartość pola lub pól wielu rekordów w tabeli powiązanej;
  • Wartości klucza podstawowego każdego rekordu w tabeli powiązanej odpowiada wartość pola lub pól jednego i tylko jednego rekordu w tabeli podstawowej.


relacja jeden-do-jednego <definicja Jet>

relacja jeden-do-jednego

Skojarzenie dwóch tabel w którym:

  • Wartości klucza podstawowego każdego rekordu w tabeli podstawowej odpowiada wartość pola lub pól jednego i tylko jednego rekordu w tabeli powiązanej;
  • Wartości klucza podstawowego każdego rekordu w tabeli powiązanej odpowiada wartość pola lub pól jednego i tylko jednego rekordu w tabeli podstawowej.


optymistyczne <definicja Jet>

optymistyczne

Typ blokowania rekordów, w którym strona danych zawierająca jeden lub więcej rekordów, łącznie z rekordem poddawanym edycji, jest niedostępna dla użytkowników tylko w czasie, gdy rekord jest uaktualniany przez metodę Update, a między wywołaniem metody Edit i metody Update jest dostępna. Blokowanie optymistyczne jest używane przy korzystaniu z baz danych ODBC lub wtedy, gdy właściwość LockEdits obiektu Recordset jest ustawiona na False.


sprzężenie zewnętrzne <definicja Jet>

sprzężenie zewnętrzne

Sprzężenie, w którym do obiektu Recordset dodawane są wszystkie rekordy z pierwszej tabeli, także wtedy, gdy w sprzężonych polach drugiej tabeli nie ma odpowiadających wartości. Rekordy z drugiej tabeli są łączone z rekordami z pierwszej tabeli tylko wtedy, gdy w sprzężonych polach występują odpowiadające sobie wartości. Jeśli brak odpowiadających wartości, dołączane są rekordy puste.


strona <definicja Jet>

strona

Fragment bazy danych, w którym przechowywany jest rekord danych. W zależności od rozmiaru rekordów, strona może zawierać jeden lub więcej rekordów. W bazach danych Microsoft® Jet (.mdb) strona ma rozmiar 2048 bajtów (2 KB). Format plików Jet 4.X odpowiada 4096 bajtom na stronie (4KB).


parametr <definicja Jet>

parametr

Element zawierający wartość, którą można zmieniać, wpływając w ten sposób na wynik kwerendy. Na przykład, kwerenda zwracająca dane o pracowniku może mieć jako parametr nazwisko tego pracownika. Można w ten sposób, nadając parametrowi oznaczającemu nazwisko odpowiednią wartość, wykorzystać jeden obiekt QueryDef do wyszukiwania danych o dowolnym pracowniku.

Używając mechanizmu Microsoft® OLE DB Provider for Jet w programie Microsoft Jet w wersji 4.X, można ujawnić parametry z procedury za pomocą znaków zapytania (?) jako znaczników ANSI. Używając składni SQL, można utworzyć równoważnik obiektu QueryDef.


kwerenda parametryczna <definicja Jet>

kwerenda parametryczna

Kwerenda wymagająca przed uruchomieniem podania wartości jednego lub więcej kryteriów, na przykład Warszawa dla parametru Miasto. Kwerenda parametryczna nie jest, ściśle mówiąc, oddzielnym typem kwerendy, a raczej rozszerzeniem uniwersalności innych kwerend.

Używając mechanizmu Microsoft® OLE DB Provider for Jet w programie Microsoft Jet w wersji 4.X, można ujawnić parametry z procedury za pomocą znaków zapytania (?) jako znaczników ANSI. Używając składni SQL, można utworzyć równoważnik obiektu QueryDef.


analiza składniowa <definicja Jet>

analiza składniowa

Służy do wyodrębnienia części składowych instrukcji lub wyrażenia i do sprawdzenia zgodności tych części z odpowiednimi regułami języka.


replika częściowa <definicja Jet>

replika częściowa

Baza danych zawierająca tylko podzbiór rekordów pełnej repliki. Posługując się repliką częściową, można ustawiać filtry oraz identyfikować związki definiujące, jaki podzbiór rekordów pełnej repliki powinien być pamiętany w bazie danych.


kwerenda przekazująca <definicja Jet>

kwerenda przekazująca

Charakterystyczna dla języka SQL kwerenda służąca do przekazywania poleceń bezpośrednio do serwera bazy danych SQL (na przykład Microsoft® SQL Server). Za pomocą kwerend przekazujących pracuje się bezpośrednio z tabelami na serwerze, a nie z tabelami połączonymi. Kwerendy przekazujące wykorzystywane są do wykonywania kwerend SQL i specyficznych dla systemu poleceń napisanych w dialektach języka SQL rozpoznawanych tylko przez serwer.

Kwerendy przekazujące mogą zwracać rekordy lub nie. Jeżeli rekordy są zwracane, to zawsze zwracane są w zestawie utrwalonym.


uprawnienie <definicja Jet>

uprawnienie

Jeden lub więcej atrybutów określających zakres dostępu użytkownika do danych lub obiektów w bazie danych. Jeżeli na przykład użytkownik ma uprawnienie do odczytu danych tabeli lub kwerendy, to może on przeglądać lub pobierać te dane, ale nie może ich poddawać edycji.


obiekt trwały <definicja Jet>

obiekt trwały

Obiekt przechowywany w bazie danych, na przykład tabela bazy danych lub obiekt QueryDef. Obiekty Recordset typu zestaw dynamiczny lub utrwalonego nie są zaliczane do obiektów trwałych, ponieważ jeśli są potrzebne, tworzone są w pamięci.


pesymistyczne <definicja Jet>

pesymistyczne

Typ blokowania rekordów, w którym strona danych zawierająca jeden lub więcej rekordów, łącznie z rekordem poddawanym edycji, jest niedostępna dla użytkowników w czasie działania metody Edit i pozostaje niedostępna do momentu użycia metody Update. Blokowanie pesymistyczne jest uaktywnione, gdy właściwość LockEdits obiektu Recordset jest ustawiona na True.


identyfikator osobisty (PID, personal identifier) <definicja Jet>

identyfikator osobisty (PID, personal identifier)

Ciąg alfanumeryczny o długości od 4 do 20 znaków, w którym istotna jest wielkość liter, używany przez aparat bazy danych Microsoft® Jet, w połączeniu z nazwą konta użytkownika, do zidentyfikowania użytkownika lub grupy w obiekcie Workgroup. Identyfikator osobisty (PID) i nazwa konta podawane są przy tworzeniu nowego konta użytkownika lub grupy użytkowników.


klucz podstawowy <definicja Jet>

klucz podstawowy

Jedno lub więcej pól, których wartość jednoznacznie identyfikuje każdy rekord w tabeli. W relacji, klucz podstawowy służy do powiązania rekordów w jednej tabeli z rekordami z innej tabeli. Klucz podstawowy jest nazywany kluczem obcym, gdy odwołanie do niego pochodzi z innej tabeli. Może istnieć jedynie jeden klucz podstawowy. Na przykład w tabeli Pracownicy kluczem podstawowym może być numer dowodu osobistego.


tabela podstawowa <definicja Jet>

tabela podstawowa

Tabela, która w relacji jeden-do-wielu z tabelą obcą stoi po stronie "jeden". Ogólnie, klucz tabeli podstawowej wykorzystywany jest do ustalenia lub wymuszenia integralności referencyjnej.


priorytet <definicja Jet>

priorytet

Wartość długa wskazująca priorytet repliki do użycia podczas rozwiązywania konfliktów. Prawidłowa wartość priorytetu dla repliki globalnej zawiera się między 0 i 100 włącznie. Repliki lokalne i anonimowe mają zawsze priorytet 0. Jeśli występuje konflikt podczas synchronizacji, wygrywa replika o najwyższym priorytecie. Utrata danych będzie zarejestrowana w tabeli konfliktów.


procedura <definicja Jet>

procedura

Podobna do widoku, ale składnia SQL dopuszcza instrukcje SELECT (kwerendy zwracające wiersz), aby przekazać parametry i polecenia DML (kwerendy nie zwracające wierszy), takie jak UPDATE, INSERT, DELETE i SELECT INTO. Dosłownie taka sama jak obiekt QueryDef, poza faktem, że może być utworzona zgodnie ze składnią języka SQL, bez użycia obiektowego modelu DAO.


kwerenda proceduralna <definicja Jet>

kwerenda proceduralna

Instrukcja SQL wykonująca procedurę przechowywaną w bazie danych.


właściwość <definicja Jet>

właściwość

Nazwany atrybut obiektu. Właściwości definiują takie cechy obiektu, jak rozmiar, kolor, położenie na ekranie lub stan obiektu - na przykład aktywny lub nieaktywny.


pseudoindeks <definicja Jet>

pseudoindeks

Dynamiczne wzajemne powiązanie co najmniej jednego pola danych tabeli (kolumny) pozwalające na edycję tabeli ODBC (tabeli serwera) nie posiadającej unikatowego indeksu. Pseudoindeks nie jest w istocie indeksem tabeli serwera, lecz wzajemnym powiązaniem, które może być wykorzystane przez aparat bazy danych Microsoft Jet do wprowadzania zmian. Pseudoindeks jest niezbędny tylko wtedy, gdy tabela ODBC nie ma unikatowego indeksu, pozwalającego na uaktualnianie tabeli. Jeżeli tabela ma już indeks unikatowy lub nie ma potrzeby uaktualniania tabeli, pseudoindeks nie jest potrzebny. (Tabele mogą nie mieć unikatowego indeksu, jeżeli przeznaczone są tylko do odczytu.) W poprzednich wersjach pseudoindeksy były nazywane specyfikacjami indeksów.


kwerenda <definicja Jet>

kwerenda

Sformalizowana instrukcja skierowana do bazy danych mająca zwrócić zestaw rekordów lub wykonać określoną operację na zestawie rekordów. Na przykład następująca instrukcja kwerendy SQL zwraca rekordy:

SELECT NazwaFirmy FROM Wydawcy WHERE Region = 'GD'

Tworzone i uruchamiane mogą być kwerendy wybierające, funkcjonalne, krzyżowe, parametryczne i specyficzne dla języka SQL.


tylko do odczytu <definicja Jet>

tylko do odczytu

Sposób dostępu do danych, w którym dane mogą być pobierane, ale nie mogą być modyfikowane.


rekord <definicja Jet>

rekord

Zestaw powiązanych logicznie danych o osobie, miejscu, zdarzeniu lub innej rzeczy. Dane tabel przechowywane są w bazie danych w postaci rekordów (wierszy). Każdy rekord składa się z zestawu powiązanych pól (kolumn). Każde pole definiuje jeden atrybut informacji rekordu. Połączone razem tworzą rekord będący jednostką informacji możliwą do pobrania z bazy danych.

Rekord nazwy się też wierszem.

Zobacz też

wiersz


integralność referencyjna <definicja Jet>

integralność referencyjna

Reguły wykorzystywane do ustalenia i zachowywania relacji pomiędzy tabelami przy dodawaniu, zmienianiu lub usuwaniu rekordów. Wymuszanie integralności referencyjnej uniemożliwia użytkownikowi dodawanie rekordów do tabeli sprzężonej, dla której nie ma klucza podstawowego, dokonywanie zmian wartości w tabeli podstawowej, prowadzących do powstawania w tabeli sprzężonej rekordów osieroconych oraz usuwanie rekordów z tabeli podstawowej, gdy w tabeli sprzężonej istnieją odpowiadające im rekordy.

Jeżeli dla związku wybrana zostanie opcja dbRelationDeleteCascade lub dbRelationUpdateCascade, aparat bazy danych Microsoft® Jet umożliwi dokonywanie zmian i usuwanie, ale będzie zmieniać lub usuwać powiązane rekordy tak, by te reguły były zachowane.

W programie Microsoft Jet w wersji 4.X, dzięki mechanizmowi Microsoft OLE DB Provider for Jet, dostępny jest dużo bogatszy zestaw ANSI SQL a także akcja referencyjna ANSI z kaskadowym przekazywaniem wartości NULL.


relacja <definicja Jet>

relacja

Powiązanie ustalane pomiędzy wspólnymi polami (kolumnami) dwóch tabel. Relacja może być typu jeden-do-jednego, wiele-do-wielu lub jeden-do-wielu.


ponowienie kwerendy <definicja Jet>

ponowienie kwerendy

Ponowne wykonanie kwerendy w celu odzwierciedlenia zmian dokonanych w rekordach, pobrania nowo dodanych rekordów i wyeliminowania rekordów usuniętych.


słowo zastrzeżone <definicja Jet>

słowo zastrzeżone

Słowo, które jest częścią pewnego języka, na przykład języka SQL aparatu bazy danych Microsoft Jet. Słowami zastrzeżonymi są nazwy instrukcji, predefiniowane funkcje i typy danych, metody, operatory i obiekty. Przykładami są: SELECT, UPDATE, BETWEEN, SET, INSERT. Nie należy używać słów zastrzeżonych dla nazw zmiennych lub obiektów.

Podczas korzystania z mechanizmu Microsoft OLE DB Provider for Jet, lista słów zastrzeżonych w programie Microsoft Jet w wersji 4.X została zwiększona zgodnie z wymaganiami normy ANSI SQL-92.


prawostronne sprzężenie <definicja Jet>

prawostronne sprzężenie

Prawostronne sprzężenie zewnętrzne zawiera wszystkie rekordy drugiej z tabel (prawej), nawet jeżeli nie ma w niej rekordów odpowiadających rekordom z pierwszej tabeli (lewej).

Na przykład, do wybrania wszystkich wydziałów, także tych, do których nie są przypisani pracownicy, należy użyć operacji lewostronnego sprzężenia (operator LEFT JOIN) z tabelą Wydziały (lewa) i tabelą Pracownicy (prawa). Aby wybrać wszystkich pracowników, w tym tych, którzy nie są przypisani do wydziałów, należy użyć operatora RIGHT JOIN.


prawostronne sprzężenie zewnętrzne <definicja Jet>

prawostronne sprzężenie zewnętrzne

Sprzężenie zewnętrzne, w którym do obiektu Recordset dodawane są wszystkie rekordy tabeli z prawej strony operatora RIGHT JOIN w kwerendzie SQL, nawet te, które nie mają odpowiadających im wartości w sprzężonych polach z lewej tabeli. Rekordy z lewej tabeli są łączone z rekordami z prawej tabeli tylko wtedy, gdy w sprzężonych polach znajdują się odpowiadające sobie wartości.


cofnięcie <definicja Jet>

cofnięcie

Wykorzystanie mechanizmu Microsoft® OLE DB Provider for Jet pozwala na rozpoczęcie (BeginTrans), zatwierdzenie (CommitTrans) lub cofnięcie (RollBack) transakcji bez wykorzystania obiektowego modelu DAO lub ADO. Operacja cofnięcia (RollBack) pozwala na zakończenie lub usunięcie transakcji, rozpoczętej operacją (Begin Trans).


wiersz <definicja Jet>

wiersz

Zestaw powiązanych logicznie kolumn lub pól wykorzystywany do przechowywania danych. Dla aparatu bazy danych Microsoft® Jet wiersz jest tym samym co rekord. Tabela składa się z zera lub większej liczby wierszy danych.


blokowanie na poziomie wiersza <definicja Jet>

blokowanie na poziomie wiersza

Nowa funkcja programu Microsoft® Jet w wersji 4.X, która umożliwia zablokowanie wiersza zamiast strony, podczas aktualizowania lub usuwania wiersza. Blokowanie na poziomie wierszy nie jest zaimplementowane dla kolumn, które są indeksowane lub typów danych LV (wartość długa) - Memo.


śledzenie na poziomie wierszy <definicja Jet>

śledzenie na poziomie wierszy

Śledzenie na poziomie wierszy jest mechanizmem, w którym cały wiersz uczestniczy w określaniu i rozwiązywaniu konfliktów. Konflikt występuje, jeśli co najmniej jedna replika modyfikuje ten sam wiersz, nawet jeśli zmienione istnieją w różnych kolumnach tego wiersza.


błąd wykonania <definicja Jet>

błąd wykonania

Błąd, który pojawia się w czasie wykonywania kodu. Błędy wykonania pojawiają się wtedy, gdy instrukcja próbowała wykonać niepoprawną operację.


czas wykonywania <definicja Jet>

czas wykonywania

Czas, w którym wykonywany jest kod. W czasie wykonywania program może komunikować się z użytkownikiem.


zasięg <definicja Jet>

zasięg

Atrybut zmiennej lub procedury określający, w których sekcjach modułów będzie ona rozpoznawana. Istnieją trzy poziomy zasięgów: publiczny, modułu i procedury. Zmienne z zadeklarowanym zasięgiem Public mogą być wykorzystywane w dowolnym module, podczas gdy zmienne zadeklarowane w pewnym module mogą być wykorzystywane tylko w tym module. Podobnie, zmienne zadeklarowane w procedurze Sub lub Function mogą być wykorzystywane tylko w tej jednej procedurze.


chroniona grupa robocza <definicja Jet>

chroniona grupa robocza

Obiekt Workgroup bazy danych Microsoft® Jet, do którego użytkownicy logują się z podaniem nazwy i hasła, w którym dostęp do obiektów bazy danych jest ograniczany zgodnie z uprawnieniami określonymi dla kont użytkowników i grup.


bezpieczeństwo <definicja Jet>

bezpieczeństwo

Zbiór własności wykorzystywany do określania lub ograniczania dostępu określonych użytkowników i grup do danych oraz obiektów w bazie danych.


wartość początkowa <definicja Jet>

wartość początkowa

Opcjonalny parametr używany dla typów danych Licznik i Identyfikator. Dostępny wyłącznie w języku SQL DDL przy wykorzystaniu mechanizmu Microsoft® OLE DB Provider for Jet. Jest pierwszym z dwóch możliwych parametrów dla typów danych Licznik i Identyfikator.

Poniższa instrukcja języka SQL jest przykładem z użyciem tych parametrów:

CREATE TABLE Customers (CustId IDENTITY (100, 10) CONSTRAINT pkCustomers PRIMARY KEY, CFrstNm VARCHAR(10), CLstNm VARCHAR(15));

Kolumna CustId w pierwszym wierszu będzie miała wartość 100, dla drugiego wiersza wartość ta wyniesie 110.

Jeśli opcjonalne parametry są użyte i nie mają wartości (1,1) , to mechanizm Microsoft® OLE DB Provider for Jet nie zmieni wartości początkowej na wartość maksymalną dla tablicy. W poprzednich wersjach mechanizmu działało to odwrotnie. Jeśli nie korzysta się z tych parametrów lub nie mają one wartości (1,1), to w momencie kompaktowania bazy danych wartość początkowa będzie zmieniona na maksymalną w tabeli wartość kolumny Licznik lub Identyfikator.

Zobacz także

przyrost


kwerenda wybierająca <definicja Jet>

kwerenda wybierająca

Kwerenda formułująca zapytanie o dane przechowywane w tabelach i zwracająca obiekt Recordset bez dokonywania jakichkolwiek zmian w tych danych. Po pobraniu danych do obiektu Recordset dane te można przejrzeć i wprowadzić zmiany do tabel, z których pochodzą. Przeciwieństwem są kwerendy funkcjonalne, które mogą dokonywać zmian danych, ale nie zwracają rekordów danych.


samosprzężenie <definicja Jet>

samosprzężenie

Sprzężenie, w którym rekordy z tabeli są łączone z innymi rekordami z tej samej tabeli, gdy w polach sprzężonych znajdują się odpowiadające sobie wartości. Samosprzężenie może być sprzężeniem wewnętrznym lub zewnętrznym. Samosprzężenie jest przydatne przy zadawaniu zapytań hierarchicznych, jak na przykład kwerenda wyszukująca wszystkich menedżerów i ich bezpośrednich podwładnych.


serwer <definicja Jet>

serwer

System zarządzania bazą danych zaprojektowany do współużytkowania danych z aplikacjami-klientami. Serwery i klienci są często połączeni siecią. Serwer baz danych zwykle zawiera i zarządza głównymi zasobami danych, które zdalne aplikacje (klienci) mogą pobierać i na których mogą operować.


kursor po stronie serwera <definicja Jet>

kursor po stronie serwera

Kursory funkcjonujące na serwerze, w przeciwieństwie do kursorów funkcjonujących na komputerze klienta. Kursory po stronie klienta kopiują kursor do stacji roboczej, natomiast kursory po stronie serwera wykorzystują do obsługi tego kursora zasoby serwera bazy danych.


sesja <definicja Jet>

sesja

Sesja określa kolejność operacji wykonywanych przez aparat bazy danych Microsoft® Jet. Sesja rozpoczyna się, gdy użytkownik loguje się, a kończy się, gdy użytkownik wylogowuje się. Wszystkie operacje wykonywane w czasie sesji, są w zasięgu jednej transakcji i wykonywane są zgodnie z uprawnieniami określonymi na podstawie nazwy użytkownika i hasła podanych przy logowaniu. Sesje są zaimplementowane przez DAO jako obiekty Workspace.


Short - typ danych <definicja Jet>

Short - typ danych

Podstawowy typ danych aparatu bazy danych Microsoft Jet odpowiadający typowi danych Integer zdefiniowanemu w systemie Visual Basic for Applications. Zmienna typu Short jest przechowywana jako liczba 16-bitowa (2-bajtowa) o wartości z zakresu od -32 768 do 32 767.


Single - typ danych <definicja Jet>

Single - typ danych

Podstawowy typ danych przechowujący zmiennoprzecinkowe liczby pojedynczej precyzji w formacie IEEE. Zmienna typu Single jest przechowywana jako liczba 32-bitowa (4-bajtowa) o wartości z zakresu od -3,402823E38 do -1,401298E-45 dla wartości ujemnych, z zakresu od 1,401298E-45 do 3,402823E38 dla wartości dodatnich oraz 0.


utrwalony zestaw rekordów <definicja Jet>

utrwalony zestaw rekordów

Trwała kopia zbioru rekordów pobranych z bazy danych i skopiowanych do pamięci. Taki zestaw rekordów wydobyty ze źródła danych połączonego z Microsoft® Jet nie może być uaktualniany. Obiekty Recordset typu utrwalonego mogą być tworzone z tabeli bazowej, kwerendy lub innego obiektu typu Recordset. Wszystkie kwerendy przekazujące SQL zwracają ustalone zestawy rekordów.


kolejność sortowania <definicja Jet>

kolejność sortowania

Zasada ustalania kolejności wykorzystywana do porządkowania danych alfabetycznie lub numerycznie. Kolejność sortowania może być rosnąca albo malejąca.


kwerenda specyficzna dla SQL <definicja Jet>

kwerenda specyficzna dla SQL

Kwerenda, która może być utworzona wyłącznie przez podanie instrukcji języka SQL. Kwerendami specyficznymi dla SQL są podkwerendy, kwerendy przekazujące, kwerendy składające i kwerendy definiujące dane.


instrukcja/ciąg SQL <definicja Jet>

instrukcja/ciąg SQL

Wyrażenie definiujące polecenie języka SQL (Structured Query Language), jak na przykład SELECT, UPDATE lub DELETE, mogące zawierać klauzule, jak np. WHERE i ORDER BY. Ciągi i instrukcje SQL są zwykle wykorzystywane w kwerendach, obiektach typu Recordset i funkcjach agregacji, ale mogą być także używane do tworzenia lub modyfikowania struktury bazy danych.


odchylenie standardowe <definicja Jet>

odchylenie standardowe

Parametr określający sposób, w jaki funkcja prawdopodobieństwa jest rozłożona wokół wartości średniej. Jest on równy pierwiastkowi kwadratowemu z wariancji, która jest odchyleniem kwadratowym od wartości średniej. Odchylenie standardowe jest wykorzystywane do opisywania zbiorów wartości w celu określenia, jak bardzo te wartości różnią się od średniej (wartości oczekiwanej).


standardowe konwencje nazewnictwa <definicja Jet>

standardowe konwencje nazewnictwa

Zbiór specyficznych reguł nazywania obiektów DAO. Nazwy mogą mieć do 64 znaków i mogą być dowolną kombinacją liter, cyfr, spacji i znaków specjalnych. W skład nazwy nie może wchodzić kropka (.), wykrzyknik (!), znak akcentu słabego (`), nawiasy ([ ]) i znaki sterujące (o kodach ASCII od 0 do 31). Nazwa nie może też zaczynać się od spacji.


kursor statyczny <definicja Jet>

kursor statyczny

Zestaw wynikowy, w którym przynależność, uporządkowanie i wartości są generalnie niezmienne od chwili otwarcia kursora. Jeśli inni użytkownicy uaktualniają, usuwają lub wstawiają wiersze, kursor nie odzwierciedla tych zmian, aż zostanie on zamknięty i ponownie otwarty.


porównanie ciągów znaków <definicja Jet>

porównanie ciągów znaków

Wykorzystanie operatora w celu określenia, czy jeden ciąg jest większy lub równy drugiemu. Jeżeli w sekcji Declarations modułu stosowana jest klauzula Option Compare Text, wielkość liter przy porównywaniu ciągów nie jest brana pod uwagę. Jeżeli stosowana jest klauzula Option Compare Binary, wielkość liter jest istotna. Jeżeli natomiast stosowana jest klauzula Option Compare Database, metoda porównywania wyznaczana jest przez bieżącą bazę danych.


String - typ danych <definicja Jet>

String - typ danych

Podstawowy typ danych służący do przechowywania informacji znakowych. Zmienna typu String ma stałą lub zmienną długość i zawiera po jednym znaku na bajt. Ciągi znaków o stałej długości mają zadeklarowaną konkretną długość i mogą zawierać od 1 do maksymalnie 65 536 (2^16) znaków. Ciągi o zmiennej długości mogą mieć długość do około 2 miliardów (2^31) znaków (około 65 000 (2^16) znaków w Microsoft® Windows® w wersji 3.1 i wcześniejszych), minus pewien niewielki narzut pamięciowy.


wyrażenie znakowe <definicja Jet>

wyrażenie znakowe

Dowolne wyrażenie, którego wynikiem jest sekwencja kolejnych znaków. Składnikami wyrażenia mogą być funkcje zwracające ciąg znaków, literały znakowe, stałe znakowe, zmienne znakowe, ciągi typu Variant lub funkcje zwracające ciągi typu Variant (VarType 8).


język SQL (Structured Query Language) <definicja Jet>

język SQL (Structured Query Language)

Język wykorzystywany do formułowania kwerend, uaktualniania i zarządzania relacyjnymi bazami danych. Język SQL można wykorzystywać do pobierania, sortowania i filtrowania określonych danych pochodzących z bazy danych.

Instrukcji SELECT języka SQL można używać w każdym miejscu, w którym dopuszczalne jest użycie nazwy tabeli, nazwy kwerendy lub nazwy pola. Na przykład, w metodzie OpenRecordset instrukcji SQL można użyć zamiast nazwy tabeli.


podkwerenda <definicja Jet>

podkwerenda

Podkwerenda jest instrukcją SELECT zagnieżdżoną wewnątrz instrukcji SELECT, SELECT...INTO, INSERT...INTO, DELETE lub UPDATE, lub też zagnieżdżoną wewnątrz innej podkwerendy.


błąd składniowy <definicja Jet>

błąd składniowy

Błąd, który występuje po wprowadzeniu wiersza kodu nie rozpoznawanego przez program Microsoft® Visual Basic®.

Uwaga Reguły składniowe dotyczące poszczególnych słów kluczowych są zdefiniowane w sekcji Składnia odpowiedniego tematu pomocy. Aby w środowisku programistycznym uzyskać pomoc na temat słowa kluczowego, należy zaznaczyć to słowo i nacisnąć klawisz F1.


obiekt systemowy <definicja Jet>

obiekt systemowy

Obiekt bazy danych zdefiniowany przez aparat bazy danych Microsoft® Jet, na przykład tabela MSysIndexes.


tabela <definicja Jet>

tabela

Podstawowa jednostka przechowywania informacji w relacyjnej bazie danych. Tabela przechowuje dane w rekordach (wierszach) i polach (kolumnach) i zwykle zawiera dane o pojedynczej kategorii rzeczy, na przykład o pracownikach lub częściach. Zwana jest także tabelą bazową.

Obiekt Recordset typu tabela jest logiczną reprezentacją tabeli bazowej bazy danych.


TEMP <definicja Jet>

TEMP

Zmienna środowiska TEMP jest ustawiana w pliku autoexec.bat w czasie startu systemu. Ogólnie, zmienna TEMP wskazuje na obszar na dysku twardym, który wykorzystywany jest przez system Microsoft Windows i inne programy, jak na przykład aparat bazy danych Microsoft Jet, do przechowywania informacji, które nie muszą być zapisywane w czasie zamykania systemu. Następujący przykładowy wiersz umieszczony w pliku autoexec.bat spowoduje, że zmienna środowiska TEMP będzie wskazywała na folder D:\ObszTymc:

SET TEMP=D:\ObszTymc


dysk tymczasowy <definicja Jet>

dysk tymczasowy

Dysk lub katalog wskazywany przez zmienną środowiska TEMP systemu operacyjnego, w którym aparat bazy danych Microsoft® Jet przechowuje pliki tymczasowe i wynikowe. Nazywany także napędem tymczasowym. Chociaż zmienna systemowa TEMP może wskazywać dysk wirtualny (RAM dysk), nie jest to zalecane.


Text(n) - typ danych (z określeniem długości) <definicja Jet>

Text(n) - typ danych (z określeniem długości)

Typ danych dla pól. Pola typu Text mogą zawierać do 255 znaków lub liczbę znaków określoną przez właściwość Size obiektu Field, w zależności od tego, która liczba jest mniejsza. Jeżeli właściwość Size ma wartość 0, tekst może zawierać do 255 znaków.


Dane tekstowe (bez określenia długości) <definicja Jet>

Dane tekstowe (bez określenia długości)

Typ danych dla pól. Pola tekstowe bez podanej długości są takie same jak pola Memo i mogą zawierać do 2,14 GB danych znakowych.


Time - typ danych <definicja Jet>

Time - typ danych

Typ danych przechowujący wartość oznaczającą godzinę. Wartość zależy od ustawień zegara w źródle danych.


transakcja <definicja Jet>

transakcja

Seria zmian wykonanych na danych i schemacie bazy danych. Początek transakcji oznaczany jest instrukcją BeginTrans, zatwierdzenie transakcji wykonywane jest instrukcją CommitTrans, a wszystkie zmiany wykonane od momentu wykonania instrukcji BeginTrans mogą zostać wycofane przez wywołanie instrukcji Rollback. Stosowanie transakcji nie jest obowiązkowe.

Transakcje mogą być zagnieżdżane do pięciu poziomów. Transakcje zwiększają szybkość wykonywania operacji zmieniających dane i dają możliwość łatwego anulowania zmian.

Transakcje są globalne względem obiektu Workspace zawierającego obiekty bazy danych, których dotyczą.


Unicode - format reprezentacji danych <definicja Jet>

Unicode - format reprezentacji danych

Zestaw 16-bitowych znaków wprowadzony i zarządzany przez konsorcjum Unicode. Zawiera wszystkie znaki niezbędne do reprezentacji każdego języka na świecie. Stosowany coraz częściej dla uproszczenia oprogramowania obsługującego wiele języków.


kwerenda składająca <definicja Jet>

kwerenda składająca

Kwerenda specyficzna dla SQL tworząca obiekt Recordset typu utrwalonego zawierający dane ze wszystkich rekordów z dwóch lub więcej tabel, przy czym powtarzające się rekordy są usuwane. Aby zachować także rekordy powtarzające się, należy dodać słowo kluczowe ALL.

Na przykład, kwerenda składająca tabele Klienci i Dostawcy da w wyniku obiekt Recordset typu utrwalonego zawierający wszystkich dostawców i wszystkich klientów.


replika nie zarządzana <definicja Jet>

replika nie zarządzana

Replika, która nie jest zarządzana przez Synchronizator. Nie zarządzane repliki pojawiają się w oknie Synchronization ze specjalną ikoną. Z nie zarządzanej repliki nie można ustawić planów synchronizacji, mimo że taka replika może być synchronizowana przez inny Synchronizator lub za pośrednictwem kodu DAO.


aktualizacja <definicja Jet>

aktualizacja

Proces zapisujący w rekordzie zmiany dokonane w danych. Zanim rekord zostanie zapisany, zmiany przechowywane są w rekordzie tymczasowym zwanym buforem kopii. Klauzula UPDATE w instrukcji SQL zmienia wartości danych w jednym lub wielu rekordach (wierszach) tabeli bazy danych.


kwerenda aktualizująca <definicja Jet>

kwerenda aktualizująca

Kwerenda funkcjonalna zmieniająca zestaw rekordów zgodnie z określonymi kryteriami. Kwerenda aktualizująca nie zwraca żadnych rekordów.


konto użytkownika <definicja Jet>

konto użytkownika

Konto identyfikowane przez nazwę użytkownika i jego identyfikator osobisty (PID, personal identifier), tworzone w celu zarządzania dostępem do obiektów bazy danych w obiekcie Workgroup bazy danych Microsoft® Jet.


kontrola poprawności <definicja Jet>

kontrola poprawności

Proces sprawdzania, czy wprowadzone dane spełniają określone warunki i ograniczenia.


właściwości kontroli poprawności <definicja Jet>

właściwości kontroli poprawności

Właściwości wykorzystywane do ustalania warunków dotyczących pól i rekordów tabeli. Należą do nich ValidationRule, Required i AllowZeroLength.


reguła poprawności <definicja Jet>

reguła poprawności

Reguła narzucająca ograniczenia i warunki na dane, wprowadzane do jednego lub wielu pól. Reguły poprawności mogą być ustalane dla obiektów Field lub TableDef. Reguły poprawności są sprawdzane, gdy uaktualniany jest rekord zawierający pole wymagające kontroli. Jeżeli reguła zostanie naruszona, pojawia się błąd przechwytywalny.


VarBinary - typ danych <definicja Jet>

VarBinary - typ danych

Typ danych przechowujący dane binarne o zmiennej długości. Maksymalna długość wynosi 255 bajtów.


zmienna <definicja Jet>

zmienna

Nazwane miejsce do przechowywania danych, które mogą być modyfikowane w trakcie wykonywania programu. Każda zmienna ma nazwę, która identyfikuje ją jednoznacznie w jej zasięgu widzialności. Typ danych może być podany lub nie.

Nazwy zmiennych:

  • Muszą rozpoczynać się literą.
  • Nie mogą zawierać kropki ani znaku deklaracji typu.
  • Muszą być unikatowe w obrębie tego samego zakresu.
  • Nie mogą być dłuższe niż 255 znaków.


wariancja <definicja Jet>

wariancja

Kwadrat odchylenia standardowego. Jest to miara wielkości, o którą różnią się wszystkie wartości w grupie od wartości średniej dla tej grupy.


Variant - typ danych <definicja Jet>

Variant - typ danych

Specjalny typ danych, mogący zawierać zarówno dane liczbowe, dane znakowe, daty, jak i wartości specjalne Empty i Null. Funkcja VarType określa sposób traktowania danych typu Variant. Wszystkie zmienne są typu Variant, jeżeli nie zostały zadeklarowane jawnie jako zmienne jakiegoś innego typu.


wyrażenie wariantowe <definicja Jet>

wyrażenie wariantowe

Dowolne wyrażenie, które może dawać w wyniku liczby, ciągi znaków lub daty oraz wartości specjalne Empty i Null.


widok <definicja Jet>

widok

Widok jest zgodną ze standardem ANSI definicją tablicy wirtualnej. Synonim kwerendy zapisanej w programie Access, która zawiera bezparametrowe polecenie SELECT. Widok to zapamiętana w programie definicja, która materializuje się w trakcie jego wykonania. Różni się tym od tabeli, że nie zawiera w sobie żadnych danych fizycznych. Wyłącznie zwraca dane.

Widok może być utworzony zgodnie z nową składnią polecenia CREATE VIEW w języku ANSI SQL, dostępną dzięki mechanizmowi Microsoft® OLE DB Provider for Jet. Innym rozwiązaniem jest utworzenie procedury, korzystającej z poleceń języka SQL DML oraz polecenia SELECT z parametrami. Może to być wykonane zgodnie z nową składnią polecenia CREATE PROCEDURE, dostępną dzięki mechanizmowi Microsoft OLE DB Provider for Jet.


symbole wieloznaczne <definicja Jet>

symbole wieloznaczne

Gwiazdka (*), procent (%), znak zapytania (?), podkreślenie (_), znak numeru (#), wykrzyknik (!), myślnik (-) i nawiasy ([ ]) są symbolami wieloznacznymi. Symboli tych można używać w kwerendach i wyrażeniach w celu uwzględnienia wszystkich rekordów, nazw plików i innych elementów, które zaczynają się określonym znakiem lub pasują do określonego wzoru. Symboli wieloznacznych i znaków dopasowywanych można także używać do dalszego uściślania kryteriów wyszukiwania w instrukcji SQL

Uwaga Symbole wieloznaczne, procent (%) i podkreślenie (_) są używane jedynie podczas korzystania z mechanizmu Microsoft® OLE DB Provider for Jet. Nie są one dostępne w DAO ani interfejsie programu Microsoft Access. W DAO lub interfejsie programu Access są one traktowane jako wartości literalne.

Symbol | Przykład | Wykorzystanie
* lub % | ko* wyszuka kot, koza, kokoszka. *at spowoduje wybranie bat, kat, krat. | Odpowiada dowolnej liczbie znaków i może być stosowany w dowolnym miejscu ciągu znaków.
? or _ | b?k wyszuka bak, bok, byk. | Odpowiada jednemu dowolnemu znakowi.
# | 1#3 wyszuka 103, 113, 123. | Odpowiada jednej dowolnej cyfrze.
[ ] | b[oy]k wyszuka bok i byk, ale nie bak. | Odpowiada jednemu ze znaków umieszczonych w nawiasie.
! | b[!ao]k wyszuka byk i buk, ale nie bak i bok. | Odpowiada dowolnemu znakowi z wyjątkiem tych, które podano w nawiasie.
- | r[a-c]d wyszuka rad, rbd i rcd. | Odpowiada jednemu ze znaków z zakresu.

Uwaga Symbole wieloznaczne * (gwiazdka), ? (znak zapytania), # (znak numeru) i [ (nawias kwadratowy otwierający) mogą odpowiadać samym sobie tylko wtedy, gdy są umieszczone w nawiasach.


grupa robocza <definicja Jet>

grupa robocza

Grupa użytkowników w środowisku wielodostępnym, współużytkujących dane i plik informacyjny grupy roboczej (zwykle jest to plik System.mdw).


administrator grupy roboczej <definicja Jet>

administrator grupy roboczej

Członek grupy Admins obiektu Workgroup bazy danych Microsoft Jet. Administrator grupy roboczej ma zawsze pełne uprawnienia do każdego obiektu bazy danych utworzonego w obrębie obiektu Workgroup.


ciąg o długości zerowej <definicja Jet>

ciąg o długości zerowej

Ciąg nie zawierający żadnych znaków (""). Funkcja Len wywołana dla takiego ciągu zwraca wartość 0.


Inicjowanie sterownika baz danych programu dBASE

Podczas instalacji sterownika baz danych programu dBASE program instalacyjny wpisuje zestaw wartości domyślnych do podkluczy Engines i ISAM Formats w Rejestrze Windows. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio; dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika baz danych programu dBASE.

Ustawienia inicjujące dla sterownika baz danych programu dBASE

Folder Jet\4.0\Engines\Xbase zawiera ustawienia inicjujące dla sterownika msxbde40.dll, używanego do dostępu do zewnętrznych źródeł danych dBASE. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<path>\msxbde40.dll

NetworkAccess=On

PageTimeout=600

INFPath=C:\DBASE\SYSTEM

CollatingSequence=ASCII

DataCodePage=OEM

Deleted=On

DbcsStr=On

Century=Off

Date=MDY

Mark=47

Exact=Off

Sposób wykorzystania pozycji folderu Xbase przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
win32 | Położenie pliku Msxbse35.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
NetworkAccess | Binarny wskaźnik wybranej metody blokowania dostępu do plików. Jeśli wartość pozycji NetworkAccess wynosi 00, tabele są otwierane w trybie dostępu wyłącznego, niezależnie od ustawień argumentu exclusive metod OpenDatabase i OpenRecordset. Wartością domyślną jest 01. W systemie Windows 95 i Windows NT 4.0 wartość ta jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.
PageTimeout | Limit czasu między umieszczeniem danych w wewnętrznym buforze a ich unieważnieniem. Wartość jest podawana jako wielokrotność 100 milisekund. Wartością domyślną jest 600 jednostek, czyli 60 sekund. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
INFPath Pełna ścieżka dostępu do katalogu zawierającego plik .ini. Aparat baz danych Microsoft Jet początkowo szuka pliku .ini w katalogu zawierającym tabelę. Jeśli plik .inf nie znajduje się w katalogu baz danych, szukany jest w INFPath. Jeśli nie ma katalogu INFPath, aparat korzysta z dowolnego pliku indeksowego (.cdx lub .mdx) znalezionego w katalogu baz danych. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.

Ta pozycja nie jest wpisywana przez procedurę instalacyjną.
CollatingSequence To ustawienie używane jest jedynie w przypadku, gdy aparat BDE nie jest zainstalowany w systemie.

Sekwencja sortowania dla wszystkich tabel dBASE utworzonych lub otwartych za pomocą aparatu baz danych Microsoft Jet. Dopuszczalnymi wartościami są ASCII i International. Wartością domyślną jest ASCII. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
DataCodePage To ustawienie używane jest jedynie w przypadku, gdy aparat BDE nie jest zainstalowany w systemie.

Wskaźnik sposobu przechowywania stron tekstu. Dopuszczalne są następujące ustawienia:

  • OEM — są wykonywane konwersje OemToAnsi i AnsiToOem.
  • ANSI — nie są wykonywane konwersje OemToAnsi i AnsiToOem.

Wartością domyślną jest OEM. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
Deleted | Binarny wskaźnik określający sposób obsługi przez aparat baz danych Microsoft Jet rekordów zaznaczonych do usunięcia. Wartość 01 odpowiada poleceniu SET DELETED ON języka dBASE i oznacza, że usunięty rekord nie jest widoczny dla operacji wykonywanych na bazie danych. Wartość 00 odpowiada poleceniu SET DELETED OFF języka dBASE i oznacza, że usunięty rekord jest traktowany przez aparat jak każdy inny rekord. Wartością domyślną jest 00. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.
DbcsStr | Binarny wskaźnik określający sposób obsługi zestawów znaków dalekiego wschodu. Wartość 01 odpowiada poleceniu SET KANJISTRING ON języka dBASE i wskazuje na sposób traktowania ciągów jako ciąg znaków dbcs. Wartość 00 wskazuje na sposób traktowania ciągów jako prosty ciąg bajtowy.
Century | Binarny wskaźnik sposobu formatowania części daty oznaczającej stulecie w przypadku, gdy w wyrażeniach indeksowych używane są funkcje konwersji daty na ciąg znaków. Wartość 01 odpowiada poleceniu SET CENTURY ON języka dBASE, zaś wartość 00 odpowiada poleceniu SET CENTURY OFF. Wartością domyślną jest 00. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.
Date | Styl formatowania daty używany w przypadkach, gdy w wyrażeniach indeksowych występują funkcje konwersji daty na ciąg znaków. Dopuszczalnymi ustawieniami tej pozycji, odpowiadającymi poleceniu SET DATE języka dBASE, są: American, ANSI, British, French, DMY, German, Italian, Japan, MDY, USA i YMD. Wartością domyślną jest MDY. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
Mark Wartość dziesiętna znaku w kodzie ASCII używanego do oddzielania części składowych daty. Wartość domyślna zależy od ustawienia Date i wynosi:
  • "/" (American, MDY)
  • "." (ANSI)
  • "/" (British, French, DMY)
  • "." (German)
  • "-" (Italian)
  • "/" (Japan, YMD)
  • "-" (USA)

Wartość 0 oznacza, że w systemie powinien być używany separator zwykle występujący w wybranym formacie daty.

Wartością domyślną jest 0. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
Exact | Binarny wskaźnik sposobu porównywania ciągów znaków. Wartość 01 odpowiada poleceniu SET EXACT ON języka dBASE. Wartość 00 odpowiada poleceniu SET EXACT OFF języka dBASE. Wartością domyślną jest 00. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.

Formaty ISAM dla programu dBASE

Folder Jet\4.0\ISAM Formats\dBASE III zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Xbase
ExportFilter | REG_SZ | String | dBASE III (*.dbf)
ImportFilter | REG_SZ | String | dBASE III (*.dbf)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 01
IndexFilter | REG_SZ | String | dBASE Index (*.ndx)
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej baz danych do pliku dBASE III. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Folder Jet\4.0\ISAM Formats\dBASE IV zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Xbase
ExportFilter | REG_SZ | String | dBASE IV (*.dbf)
ImportFilter | REG_SZ | String | dBASE IV (*.dbf)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 01
IndexFilter | REG_SZ | String | dBASE Index (*.ndx; *.mdx)
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku dBASE IV. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Folder Jet\4.0\ISAM Formats\dBASE 5.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Xbase
ExportFilter | REG_SZ | String | dBASE 5 (*.dbf)
ImportFilter | REG_SZ | String | dBASE 5 (*.dbf)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 01
IndexFilter | REG_SZ | String | dBASE Index (*.ndx; *.mdx)
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku dBASE IV. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika baz danych programu Microsoft Excel

Podczas instalacji sterownika baz danych Microsoft® Excel program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows®. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio; dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika baz danych programu Microsoft Excel.

Ustawienia inicjujące sterownika baz danych programu Microsoft Excel

Folder Jet\4.0\Engines\Excel zawiera ustawienia inicjujące sterownika msexcl40.dll, używanego przy zewnętrznym dostępie do arkuszy programu Microsoft Excel. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\ msexcl40.dll

TypeGuessRows=8

ImportMixedTypes=Text

AppendBlankRows=1

FirstRowHasNames=Yes

Sposób wykorzystania pozycji folderu Excel przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
win32 | Położenie pliku msexcl40.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
TypeGuessRows | Liczba wierszy sprawdzanych przy ustalaniu typu danych. Typ danych jest określany na podstawie typu danych najczęściej występującego w zaznaczonym obszarze. Jeśli jakieś typy danych występują jednakowo często, typ określany jest w następującej kolejności: Number, Currency, Date, Text, Boolean. Jeśli wystąpił typ danych nie zgadzający się z typem danych odgadniętym dla kolumny, zwracana jest wartość Null. Jeśli w trakcie importu kolumna zawiera różne typy danych, typ danych całej kolumny jest ustalany zgodnie z ustawieniem ImportMixedTypes. Domyślna liczba sprawdzanych wierszy wynosi 8. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
ImportMixedTypes | Dopuszczalnymi wartościami są MajorityType lub Text. Jeśli ustawiona jest wartość MajorityType, kolumnom zawierającym dane różnych typów będzie narzucony typ przeważający wśród importowanych danych. Jeśli ustawiona jest wartość Text, podczas importu danych różnych typów typ danych będzie zamieniany na Text. Wartością domyślną jest Text. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
AppendBlankRows | Liczba pustych wierszy dołączanych do końca arkusza kalkulacyjnego w formacie wersji 3.5 lub 4.0 przed dodaniem nowych danych. Na przykład, jeśli wartość AppendBlankRows ustawiono na 4, aparat Microsoft Jet przed dodaniem wierszy zawierających dane dołączy na końcu arkusza kalkulacyjnego 4 puste wiersze. Wartości tego ustawienia muszą być liczbami całkowitymi z przedziału od 0 do 16; wartością domyślną jest 01 (dołączany jest jeden pusty wiersz). W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
FirstRowHasNames | Binarna wartość określająca, czy pierwszy wiersz tabeli zawiera nazwy kolumn. Wartość 01 oznacza, że podczas importu nazwy kolumn są pobierane z pierwszego wiersza. Wartość 00 oznacza, że pierwszy wiersz nie zawiera nazw kolumn; kolumny otrzymują wówczas nazwy F1, F2, F3 itd. Wartością domyślną jest 01. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.

Formaty ISAM dla programu Microsoft Excel

Folder Jet\4.0\ISAM Formats\Excel 3.0 zawiera następujące pozycje.

Nazwa pozycji | Windows NT Type | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Excel
ExportFilter | REG_SZ | String | Microsoft Excel 3 (*.xls)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Microsoft Excel 3.0. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Excel 4.0 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Excel
ExportFilter | REG_SZ | String | Microsoft Excel 4 (*.xls)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Microsoft Excel 4.0. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Excel 5.0 zawiera następujące pozycje, obowiązujące dla wersji 5.0 i 7.0 programu Microsoft Excel.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Excel
ExportFilter | REG_SZ | String | Microsoft Excel 5-7 (*.xls)
ImportFilter | REG_SZ | String | Microsoft Excel (*.xls)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Microsoft Excel 5.0. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Excel 8.0 zawiera następujące pozycje, obowiązujące dla programu Microsoft Excel 97.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Excel
ExportFilter | REG_SZ | String | Microsoft Excel 97-2000 (*.xls)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Microsoft Excel 97. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika aparatu baz danych Microsoft Jet 3.5

Podczas instalacji sterownika aparatu baz danych Microsoft® Jet 3.5, program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows®. Dodawanie, usuwanie lub zmiana tych ustawień powinny być wykonywane za pośrednictwem pomocą Edytora Rejestru. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika aparatu baz danych Microsoft Jet.

Ustawienia inicjujące dla sterownika Microsoft Jet

Folder Jet\4.0\Engines\Jet 3.x zawiera ustawienia inicjujące sterownika msrd3x40.dll, używanego przy dostępie do arkuszy programu Microsoft Access 97. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\ msrd3x40.dll

FlushTransactionTimeout=500

LockDelay=100

LockRetry=20

MaxBufferSize= 0

MaxLocksPerFile= 9500

PageTimeout=5000

Threads=3

UserCommitSync=Yes

ImplicitCommitSync=No

ExclusiveAsyncDelay=2000

SharedAsyncDelay=0

RecycleLVs=0

SortMemorySource=0

Aparat baz danych Microsoft Jet korzysta z następujących pozycji:

Pozycja | Opis
win32 | Położenie sterownika aparatu baz danych (.dll). Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
PageTimeout | Limit czasu między umieszczeniem danych nie zablokowanych przed odczytem w wewnętrznym buforze a ich unieważnieniem, wyrażony w milisekundach. Wartością domyślną jest 5000 milisekund, czyli 5 sekund. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
FlushTransactionTimeout | Pozycja zawiesza działanie dwóch pozycji Rejestru: ExclusiveAsyncDelay i SharedAsyncDelay. W celu przywrócenia działania tych pozycji należy zmienić jej wartość na zero. Pozycja FlushTransactionTimeout zmienia sposób, w jaki aparat baz danych Microsoft Jet dokonuje asynchronicznych zapisów do pliku bazy danych. Poprzednio aparat baz danych Microsoft Jet używał wartości ExclusiveAsyncDelay lub SharedAsyncDelay w celu określenia, ile czasu trwa oczekiwanie przed wymuszeniem asynchronicznego zapisywania. Pozycja FlushTransactionTimeout zmienia to zachowanie, wprowadzając wartość wymuszającą rozpoczęcie asynchronicznego zapisywania wtedy, gdy upłynie określony czas ORAZ gdy do bufora nie dodano stron. Jedynym wyjątkiem jest przypadek, gdy pamięć podręczna przekroczy wartość MaxBufferSize, gdyż wtedy asynchroniczne zapisy z bufora rozpoczną się niezależnie od upływu czasu. A zatem, sygnałem do rozpoczęcia zapisów asynchronicznych przez aparat baz danych Microsoft Jet 3.5 będzie upłynięcie 500 milisekund przy braku aktywności albo przekroczenie rozmiaru bufora.
LockDelay | To ustawienie działa w połączeniu z ustawieniem LockRetry w ten sposób, iż powoduje odczekanie 100 milisekund przed ponowieniem żądania blokady. Ustawienie LockDelay zostało dodane w celu uniknięcia tworzenia "paczek" żądań, co mogłoby mieć miejsce w niektórych sieciowych systemach operacyjnych.
MaxLocksPerFile | To ustawienie ogranicza liczbę blokad w transakcjach obsługiwanych przez aparat Microsoft Jet. Jeśli liczba blokad w transakcji przekracza podaną wartość, wtedy transakcja zostaje podzielona na dwie lub więcej części i zatwierdzana częściowo. To ustawienie zostało dodane w celu zapobieżenia upadkom serwera Netware 3.1 po przekroczeniu przez serwer limitu blokad oraz w celu poprawy wydajności zarówno w systemie Netware, jak i NT.
LockRetry | Liczba prób dostępu do zablokowanej strony przed zwróceniem komunikatu o konflikcie wynikającym z blokady. Wartością domyślną jest 20. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
klucz RecycleLVs To ustawienie, jeśli jest aktywne, powoduje, że aparat Microsoft Jet ponownie używa stron typu LV, czyli zawierających wartości długie (o typach danych Memo, Long Binary [obiekt OLE] i Binary). Te strony nie będą ponownie przetwarzane przez aparat Microsoft Jet 3.0, dopóki ostatni użytkownik nie zamknie bazy danych. Jeśli ustawienie RecyleLVs jest aktywne, aparat Microsoft Jet 3.5 zacznie ponownie używać większości stron typu LV podczas powiększania bazy danych (to znaczy wtedy, gdy dodawane są grupy stron).

Uwaga Po uaktywnieniu tego ustawienia użytkownik może zaobserwować zwolnienie pracy systemu podczas przetwarzania danych typów długich. W programie Microsoft Access 97 to ustawienie jest automatycznie włączane i wyłączane podczas pracy z modułami, formularzami i raportami, eliminując w ten sposób konieczność włączania go podczas modyfikowania tych obiektów. Wartość domyślna wynosi 0. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
MaxBufferSize Wielkość wewnętrznego bufora aparatu baz danych, mierzona w kilobajtach (KB). Wartość MaxBufferSize musi być liczbą całkowitą większą lub równą 512. Wartość domyślna jest obliczana z następującego wzoru:

((CałaPamięćRAM w MB - 12 MB) / 4) + 512 KB

Na przykład, dla systemu z pamięcią RAM równą 32 MB domyślny rozmiar bufora wynosi ((32 MB - 12 MB) / 4) + 512 KB, czyli 5632 KB. Aby ustawić taką domyślną wartość, należy temu kluczowi rejestru nadać wartość

MaxBufferSize=

W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
Threads | Liczba wątków pracujących w tle dostępnych dla aparatu baz danych Microsoft Jet. Wartością domyślną jest 3. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
UserCommitSync | Określa, czy system czeka na zakończenie zatwierdzania. Wartość Yes wymusza oczekiwanie, natomiast wartość No powoduje, że system przeprowadza zatwierdzanie asynchronicznie. Wartością domyślną jest Yes. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ImplicitCommitSync | Określa, czy system czeka na zakończenie zatwierdzania. Wartość No nakazuje systemowi, kontynuację pracy bez czekania na zakończenie zatwierdzania; wartość Yes nakazuje systemowi czekanie na zakończenie zatwierdzenia. Wartością domyślną jest No. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ExclusiveAsyncDelay | Określa w milisekundach opóźnienie asynchronicznego przymusowego zapisu bazy danych otwartej w trybie wyłączności. Domyślna wartość wynosi 2000, czyli 2 sekundy. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
SharedAsyncDelay | Określa w milisekundach opóźnienie asynchronicznego zapisu do bazy danych otwartej w trybie współdzielenia. Wartość domyślna wynosi 0. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
SortMemorySource | Określa jak aparat Microsoft Jet uzyskuje pamięć dla kluczy sortowania. Wartość 0 wskazuje, że pamięć powinna być wzięta ze sterty. Wartość 1 wskazuje, że pamięć powinna być wzięta z pamięci globalnej, używając wywołania funkcji malloc.

Formaty ISAM dla aparatu Microsoft Jet

Folder Jet\4.0\ISAM Formats\Jet 3.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Jet 3.x
OneTablePerFile | REG_BINARY | Binary | 00
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 0

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika aparatu baz danych Microsoft Jet 4.0

Podczas instalacji sterownika aparatu baz danych Microsoft® Jet 4.0, program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows®. Dodawanie, usuwanie lub zmiana tych ustawień powinny być wykonywane za pośrednictwem pomocą Edytora Rejestru. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika aparatu baz danych Microsoft Jet.

Ustawienia inicjujące dla sterownika Microsoft Jet

Folder Jet\4.0\Engines zawiera ustawienia inicjujące sterownika aparatu baz danych msjet40.dll, używanego przy dostępie do baz danych Microsoft Access. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

SystemDB = <ścieżka>\System.mdb

CompactBYPkey = 1

PrevFormatCompactWithUNICODECompression=1

Aparat baz danych Microsoft Jet korzysta z następujących pozycji:

Pozycja | Opis
SystemDB | Określa pełną ścieżkę i nazwę pliku z informacjami o grupie roboczej. Domyślnie, jest to odpowiednia ścieżka, po której następuje nazwa pliku System.mdb. W systemie Windows 95 i Windows NT 4.0 wartość ta jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
CompactByPKey Określa, że podczas defragmentacji tabel są one kopiowane w porządku wyznaczonym przez klucz podstawowy, jeśli taki klucz istnieje. Jeśli w tabeli nie ma klucza podstawowego, tabele są kopiowane w porządku wyznaczanym przez tabelę bazową.

Wartość 0 wskazuje, że tabele powinny być defragmentowane w kolejności wyznaczonej przez tabelę bazową; wartość niezerowa wskazuje, że tabele powinny być defragmentowane w kolejności wyznaczonej przez klucz podstawowy, jeśli taki klucz istnieje. Domyślna wartość jest różna od zera. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.

Uwaga To ustawienie ma znaczenie wyłącznie podczas defragmentacji baz danych utworzonych za pomocą aparatu baz danych Microsoft Jet w wersji 3.0 lub późniejszej; podczas defragmentacji baz danych utworzonych za pomocą aparatu baz danych Microsoft Jet w wersji 2.x dane są zawsze kopiowane w kolejności wyznaczonej przez tabelę bazową
PrevFormatCompactWithUNICODECompression Bazy danych aparatu Microsoft Jet 4.0 używają zestawu znaków Unicode do przechowywania danych tekstowych. Kompresja danych Unicode może znacznie zwiększyć wydajność bazy danych dzięki zmniejszonej ilości operacji odczytu/zapisu stron.

Ten klucz określa, czy baza danych stworzona przez aparat baz danych Microsoft Jet w wersji 3.x lub wcześniejszej powinny używać skompresowanego, czy nieskompresowanego zestawu Unicode.

Uwaga To ustawienie nie dotyczy kompaktowania baz danych Microsoft Jet 4.0. Bazy danych Microsoft Jet 4.0 będą używać ustawień kompresji, przy których zostały utworzone.

Folder Jet\4.0\Engines\Jet 4.0 zawiera ustawienia inicjujące dla aparatu baz danych msjet40.dll, używanego przy dostępie do baz danych Microsoft Access. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

FlushTransactionTimeout=500

LockDelay=100

LockRetry=20

MaxBufferSize= 0

MaxLocksPerFile= 9500

PageTimeout=5000

Threads=3

UserCommitSync=Yes

ImplicitCommitSync=No

ExclusiveAsyncDelay=2000

SharedAsyncDelay=0

RecycleLVs=0

PagesLockedToTableLock=0

Aparat baz danych Microsoft Jet korzysta z następujących pozycji:

Pozycja | Opis
PageTimeout | Limit czasu pomiędzy momentem, gdy dane, nie będące zablokowane do odczytu, są umieszczone w pamięci podręcznej, a czasem, gdy są one unieważnione, wyrażony w milisekundach. Wartością domyślną jest 5000 milisekund, czyli 5 sekund. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
FlushTransaction
Timeout 		Pozycja zawiesza działanie dwóch pozycji Rejestru: ExclusiveAsyncDelay i SharedAsyncDelay. W celu przywrócenia działania tych pozycji należy zmienić jej wartość na zero. Pozycja FlushTransactionTimeout zmienia sposób, w jaki aparat baz danych Microsoft Jet dokonuje asynchronicznych zapisów do pliku bazy danych. Poprzednio aparat baz danych Microsoft Jet używał wartości ExclusiveAsyncDelay lub SharedAsyncDelay w celu określenia, ile czasu trwa oczekiwanie przed wymuszeniem asynchronicznego zapisywania. Pozycja FlushTransactionTimeout zmienia to zachowanie, wprowadzając wartość wymuszającą rozpoczęcie asynchronicznego zapisywania wtedy, gdy upłynie określony czas ORAZ gdy do bufora nie dodano stron. Jedynym wyjątkiem jest sytuacja, gdy pamięć podręczna przekroczy wartość określoną w MaxBufferSize, kiedy pamięć podręczna zacznie asynchroniczny zapis niezależnie od tego czy czas nie minął. A zatem, sygnałem do rozpoczęcia zapisów asynchronicznych przez aparat baz danych Microsoft Jet 3.5 będzie upłynięcie 500 milisekund przy braku aktywności albo przekroczenie rozmiaru bufora.
LockDelay | To ustawienie działa w połączeniu z ustawieniem LockRetry w ten sposób, iż powoduje odczekanie 100 milisekund przed ponowieniem żądania blokady. Ustawienie LockDelay zostało dodane w celu uniknięcia tworzenia "paczek" żądań, co mogłoby mieć miejsce w niektórych sieciowych systemach operacyjnych.
MaxLocksPerFile | To ustawienie ogranicza liczbę blokad w transakcjach obsługiwanych przez aparat Microsoft Jet. Jeśli liczba blokad w transakcji przekracza podaną wartość, wtedy transakcja zostaje podzielona na dwie lub więcej części i zatwierdzana częściowo. To ustawienie zostało dodane w celu zapobieżenia upadkom serwera Netware 3.1 po przekroczeniu przez serwer limitu blokad oraz w celu poprawy wydajności zarówno w systemie Netware, jak i NT.
LockRetry | Liczba prób dostępu do zablokowanej strony przed zwróceniem komunikatu o konflikcie wynikającym z blokady. Wartością domyślną jest 20. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
klucz RecycleLVs To ustawienie, jeśli jest aktywne, powoduje, że aparat Microsoft Jet ponownie używa stron typu LV, czyli zawierających wartości długie (o typach danych Memo, Long Binary [obiekt OLE] i Binary). Te strony nie będą ponownie przetwarzane przez aparat Microsoft Jet 3.0, dopóki ostatni użytkownik nie zamknie bazy danych. Jeśli ustawienie RecyleLVs jest aktywne, aparat Microsoft Jet 3.5 zacznie ponownie używać większości stron typu LV podczas powiększania bazy danych (to znaczy wtedy, gdy dodawane są grupy stron).

Uwaga Po uaktywnieniu tego ustawienia użytkownik może zaobserwować zwolnienie pracy systemu podczas przetwarzania danych typów długich. W programie Microsoft Access 97 to ustawienie jest automatycznie włączane i wyłączane podczas pracy z modułami, formularzami i raportami, eliminując w ten sposób konieczność włączania go podczas modyfikowania tych obiektów. Wartość domyślna wynosi 0. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
MaxBufferSize Wielkość wewnętrznego bufora aparatu baz danych, mierzona w kilobajtach (KB). Wartość MaxBufferSize musi być liczbą całkowitą większą lub równą 512. Wartość domyślna jest obliczana z następującego wzoru:

((CałaPamięćRAM w MB - 12 MB) / 4) + 512 KB

Na przykład, dla systemu z pamięcią RAM równą 32 MB domyślny rozmiar bufora wynosi ((32 MB - 12 MB) / 4) + 512 KB, czyli 5632 KB. Aby ustawić taką domyślną wartość, należy temu kluczowi rejestru nadać wartość

MaxBufferSize=

W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
Threads | Liczba wątków pracujących w tle dostępnych dla aparatu baz danych Microsoft Jet. Wartością domyślną jest 3. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
UserCommitSync | Określa, czy system czeka na zakończenie zatwierdzania. Wartość Yes wymusza oczekiwanie, natomiast wartość No powoduje, że system przeprowadza zatwierdzanie asynchronicznie. Wartością domyślną jest Yes. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ImplicitCommitSync | Określa, czy system czeka na zakończenie zatwierdzania. Wartość No nakazuje systemowi, kontynuację pracy bez czekania na zakończenie zatwierdzania; wartość Yes nakazuje systemowi czekanie na zakończenie zatwierdzenia. Wartością domyślną jest No. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ExclusiveAsyncDelay | Określa w milisekundach opóźnienie asynchronicznego przymusowego zapisu bazy danych otwartej w trybie wyłączności. Domyślna wartość wynosi 2000, czyli 2 sekundy. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
SharedAsyncDelay | Określa w milisekundach opóźnienie asynchronicznego zapisu do bazy danych otwartej w trybie współdzielenia. Wartość domyślna wynosi 0. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
PagesLockedToTableLock Podczas dużych operacji bardziej wydajne jest zablokowanie całej tabeli, niż blokowanie każdej strony z osobna podczas próby dostępu.

To ustawienie określa ilość stron, na których blokadę aparat Microsoft Jet zezwoli podczas jakiejkolwiek transakcji zanim aparat Jet spróbuje zablokować całą tabelę.

Wartość domyślna 0 wskazuje, że aparat Jet nigdy nie będzie automatycznie zmieniał blokowania stron na blokowanie tabeli.

Uwaga To ustawienie powinno być używane ostrożnie. Jeśli baza danych przeznaczona jest do współużytkowania, wtedy blokada całej tabeli mogłaby spowodować konflikt blokad dla innych użytkowników. Ten problem byłby szczególnie uciążliwy, jeżeli ustawiono by małą wartość. Nawet przy użyciu większej wartości, jak 25 albo 50, reakcja dla innych użytkowników mogłaby być nieprzewidziana.

Ustawienia replikacji aparatu baz danych Microsoft Jet

Klucz Jet\4.0\Transporter zawiera ustawienia inicjujące synchronizacji replikacji aparatu Jet przez Synchronizator Jet. Ustawienia te określają porządek w jakim poszczególne transporty będą podejmowane przez Synchronizator. Poprawne wartości: 0-100. Wartość 0 sygnalizuje, że próba transportu nie powinna być podejmowana. Wszystkie typy transportu z wartościami niezerowymi będą podejmowane w porządku rosnącym, dopóki jeden pomyślnie wykona synchronizację lub wszystkie próby zawiodą.

Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

Priority_FS=1

Priority_Internet=2

Priority_direct=3

Aparat baz danych Microsoft Jet używa następujących zapisów priorytetów.

Pozycja | Opis
Priority_FS | Synchronizacja systemu plików (pośrednia) polega na seriach wymiany komunikatów pomiędzy replikami. Synchronizator, który zarządza repliką zbiera zmiany w plikach komunikatów (*.msg), które następnie są kopiowane do udostępnianego folderu nazwanego skrzynką docelową, używaną przez drugiego Synchronizatora i dostępną przez system plików.
Priority_Internet | Synchronizacja internetowa (pośrednia) polega na seriach wymiany komunikatów pomiędzy replikami. Tylko replika zarządzana przez Synchronizator na serwerze internetowym posiada skrzynkę docelową dostępną przez HTTP lub połączenie FTP.
Priority_direct | Synchronizacja bezpośrednia jest procesem wymiany danych i zmian projektu pomiędzy dwoma członkami zestawu replik, które są bezpośrednio połączone bądź na tym samym komputerze, bądź przez sieć. Synchronizator otwiera obie bazy danych.

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika aparatu baz danych Microsoft Jet 2.5

Podczas instalacji sterownika aparatu baz danych Microsoft Jet 2.5, program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows. Dodawanie, usuwanie lub zmiana tych ustawień powinny być wykonywane za pośrednictwem pomocą Edytora Rejestru. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika aparatu baz danych Microsoft Jet.

Ustawienia inicjujące dla sterownika Microsoft Jet

Folder Jet\4.0\Engines\Jet 2.x zawiera ustawienia inicjujące sterownika msrd2x40.dll, używanego przy dostępie do arkuszy programu Microsoft Access 2.0. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\ msrd2x40.dll

PageTimeout=5

LockedPageTimeout=5

CursorTimeout=5

LockRetry=20

CommitLockRetry=20

MaxBufferSize=512

ReadAheadPages=16

IdleFrequency=10

ForceOsFlush = 0

Następujące pozycje są używane do konfigurowania aparatu baz danych Microsoft Jet:

Pozycja | Opis
win32 | Położenie sterownika aparatu baz danych (.dll). Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
PageTimeout | Limit czasu między umieszczeniem danych nie zablokowanych przed odczytem w wewnętrznym buforze a ich unieważnieniem. Wartość ta jest określana jako wielokrotność 100 milisekund. Wartością domyślną jest 5 jednostek, czyli 0,5 sekundy. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
LockedPageTimeout | Limit czasu między umieszczeniem danych zablokowanych przed odczytem w wewnętrznym buforze a ich unieważnieniem. Wartość ta jest określana jako wielokrotność 100 milisekund. Wartością domyślną jest 5 jednostek, czyli 0,5 sekundy. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
CursorTimeout | Limit czasu, przez który odwołanie do strony pozostaje na niej, wyrażony w wielokrotnościach 100 milisekund. Wartością domyślną jest 5 jednostek, czyli 0,5 sekundy. To ustawienie jest obowiązujące tylko dla wersji 1.x aparatu baz danych Microsoft Jet. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
LockRetry | Liczba prób dostępu do zablokowanej strony przed zwróceniem komunikatu o konflikcie wynikającym z blokady. Wartością domyślną jest 20; pozycja LockRetry jest powiązana z pozycją CommitLockRetry. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
CommitLockRetry Liczba prób przeprowadzanych przez aparat baz danych Microsoft Jet w celu zablokowania danych niezbędnego do zatwierdzenia dokonanych w nim zmian. Jeśli aparat baz danych Microsoft Jet nie otrzymał blokady zatwierdzającej, nie może dokonać zmian w danych.

Liczba prób, jakie aparat baz danych Microsoft Jet przeprowadza w celu uzyskania blokady zatwierdzającej, jest bezpośrednio powiązany z wartością LockRetry. Dla każdej próby uzyskania blokady zatwierdzającej aparat baz danych Microsoft Jet wykona tyle prób, ile wynosi wartość LockRetry. Na przykład, jeśli pozycja CommitLockRetry ma wartość 20, zaś pozycja LockRetry ma wartość 20, to aparat baz danych wykona 20 prób uzyskania blokady zatwierdzającej, a podczas każdej z tych prób aparat baz danych wykona 20 prób uzyskania blokady, czyli łącznie 400 takich prób.

Wartością domyślną pozycji CommitLockRetry jest 20. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
MaxBufferSize | Wielkość wewnętrznego bufora aparatu baz danych, mierzona w kilobajtach (KB). MaxBufferSize musi być liczbą całkowitą z przedziału od 9 do 4096 włącznie. Wartością domyślną jest 512. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
ReadAheadPages | Liczba stron czytanych w przód podczas operacji sekwencyjnego przeszukiwania. Wartością domyślną jest 16. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
ForceOSFlush | Ustawienie różne od 0 oznacza, że zatwierdzenie lub zapis wymusza zapisanie bufora systemu operacyjnego na dysk. Ustawienie równe 0 (jest to wartość domyślna) oznacza, że nie nastąpi wymuszony zapis na dysk. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
IdleFrequency | Czas, mierzony wielokrotnością 100 milisekund, przez który program Microsoft Jet będzie odczekiwał przed zwolnieniem blokady odczytu. Wartością domyślną jest 10, czyli jedna sekunda. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.

Formaty ISAM dla aparatu Microsoft Jet

Folder Jet\4.0\ISAM Formats\Jet 2.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Jet 2.x
OneTablePerFile | REG_BINARY | Binary | 00
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 0

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika baz danych programu Lotus

Podczas instalacji sterownika baz danych programu Lotus program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio; dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika baz danych programu Lotus.

Ustawienia inicjujące dla sterownika baz danych programu Lotus

Folder Jet\4.0\Engines\Lotus zawiera ustawienia inicjujące sterownika Msltus40.dll, umożliwiającego dostęp z zewnątrz do arkuszy kalkulacyjnych programu Lotus. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\msltus40.dll

TypeGuessRows=8

ImportMixedTypes=Text

AppendBlankRows=4

FirstRowHasNames=Yes

Sposób wykorzystania pozycji folderu Lotus przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
win32 | Położenie pliku msltus40.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
TypeGuessRows | Liczba wierszy sprawdzanych przy ustalaniu typu danych. Typ danych jest określany na podstawie typu danych najczęściej występującego w wybranym obszarze. Jeśli jakieś typy danych występują jednakowo często, typ określany jest w następującej kolejności: Number, Currency, Date, Text, Long Text. Jeśli wystąpił typ danych nie zgadzający się z typem danych odgadniętym dla kolumny, zwracana jest wartość Null. Jeśli w trakcie importu kolumna zawiera różne typy danych, typ danych całej kolumny jest ustalany zgodnie z ustawieniem ImportMixedTypes. Domyślna liczba sprawdzanych wierszy wynosi 8. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
ImportMixedTypes | Dopuszczalnymi wartościami są MajorityType lub Text. Jeśli ustawiona jest wartość MajorityType, kolumnom zawierającym dane różnych typów będzie narzucony typ przeważający wśród importowanych danych. Jeśli ustawiona jest wartość Text, podczas importu danych różnych typów typ danych będzie zamieniany na Text. Wartością domyślną jest Text. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
AppendBlankRows | Liczba pustych wierszy dołączanych do końca arkusza kalkulacyjnego WK1 przed dodaniem nowych danych. Na przykład, jeśli wartość AppendBlankRows ustawiono na 4, aparat Microsoft Jet przed dodaniem wierszy zawierających dane dołączy na końcu arkusza kalkulacyjnego 4 puste wiersze. Wartości tego ustawienia muszą być liczbami całkowitymi z przedziału od 0 do 16; wartością domyślną jest 01 (dołączany jest jeden pusty wiersz). W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
FirstRowHasNames | Binarna wartość określająca, czy pierwszy wiersz tabeli zawiera nazwy kolumn. Wartość 01 oznacza, że podczas importu nazwy kolumn są pobierane z pierwszego wiersza. Wartość 00 oznacza, że pierwszy wiersz nie zawiera nazw kolumn; kolumny otrzymują wówczas nazwy F1, F2, F3 itd. Wartością domyślną jest 01. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.

Formaty ISAM dla programu Lotus

Folder Jet\4.0\ISAM Formats\Lotus WK1 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Lotus
ExportFilter | REG_SZ | String | Lotus 1-2-3 WK1 (*.wk1)
ImportFilter | REG_SZ | String | Lotus 1-2-3 (*.wk* )
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Lotus 1-2-3 Wersja 2. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Lotus WK3 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Lotus
ExportFilter | REG_SZ | String | Lotus 1-2-3 WK3 (*.wk3)
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Lotus 1-3-3 Wersja 2. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Lotus WK4 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Lotus
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Lotus WJ2 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Lotus
ExportFilter | REG_SZ | String | Lotus 1-2-3 WJ2 (*.wj2)
ImportFilter | REG_SZ | String | Lotus 1-2-3/DOS (*.wj* )
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Lotus 1-2-3 Wersja 2. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Folder Jet\4.0\ISAM Formats\Lotus WJ3 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Lotus
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 1
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 01
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Konfigurowanie aparatu baz danych Microsoft Jet do współpracy z ODBC

Następujące paragrafy objaśniają ustawienia Rejestru systemowego Microsoft® Windows® dla aparatu baz danych Microsoft Jet przy współpracy z bazami danych ODBC.

Ustawienia inicjujące dla aparatu baz danych Microsoft Jet potrzebne do współpracy z bazami danych ODBC

Folder \HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC zawiera ustawienia inicjujące aparatu baz danych Microsoft Jet.

Uwaga Typowe ustawienia pozycji w folderze Jet\4.0\Engines\ODBC są przedstawione w poniższym przykładzie.

LoginTimeout=20

QueryTimeout=60

ConnectionTimeout=600

AsyncRetryInterval=500

AttachCaseSensitive=0

AttachableObjects='TABLE','VIEW','SYSTEM TABLE','ALIAS','SYNONYM'

SnapshotOnly=0

TraceSQLMode=0

TraceODBCAPI=0

DisableAsync=1

TryJetAuth=1

PreparedInsert=0

PreparedUpdate=0

FastRequery=0

FatBlastRows=-1

FatBlastTimeout=3

ODBCISAMAttach=0

Sposób wykorzystywania przez aparat baz danych Microsoft Jet pozycji odnoszących się do ODBC jest przedstawiony w poniższej tabeli.

Pozycja | Opis
LoginTimeout | Wyrażony w sekundach maksymalny czas trwania próby zalogowania się w systemie. Wartość domyślna wynosi 20 (wartości są typu REG_DWORD).
QueryTimeout | Wyrażony w sekundach maksymalny czas wykonywania się kwerendy (całkowity czas przetwarzania). Jeżeli DisableAsync=0 (wartość domyślna), to QueryTimeout jest liczbą sekund oczekiwania na odpowiedź serwera pomiędzy cyklicznymi zapytaniami o zakończenie kwerendy. Wartość domyślna wynosi 60 (wartości są typu REG_DWORD).
ConnectionTimeout | Wyrażony w sekundach maksymalny czas przez jaki buforowane połączenie może pozostać nieaktywne. Wartość domyślna wynosi 600 (wartości są typu REG_DWORD).
AsyncRetryInterval | Wyrażony w milisekundach czas pomiędzy cyklicznymi zapytaniami o zakończenie przetwarzania kwerendy przez serwer. Ta pozycja jest używana wyłącznie przy przetwarzaniu asynchronicznym. Wartość domyślna wynosi 500 (wartości są typu REG_DWORD).
AttachCaseSensitive | Wskaźnik określający sposób porównywania nazw tabel podczas ich dołączania. Dopuszczalne wartości to 0 (utwórz łącze do pierwszej napotkanej tabeli o podanej nazwie, niezależnie od wielkości liter) i 1 (utwórz łącze do tabeli tylko wtedy, gdy nazwy są identyczne). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD).
AttachableObjects | Lista typów obiektów serwerów, do których dopuszczalne będzie tworzenie łącz. Wartością domyślną jest: 'TABLE', 'VIEW', 'SYSTEM TABLE', 'ALIAS', 'SYNONYM' (wartości są typu REG_SZ).
SnapshotOnly | Wskaźnik określający, czy obiekty Recordset muszą być typu utrwalonego. Dopuszczalne wartości to 0 (dynamiczne zestawy rekordów są dozwolone) i 1 (dopuszczalne są tylko utrwalone zestawy rekordów). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD).
TraceSQLMode | Wskaźnik określający, czy aparat baz danych Microsoft Jet będzie śledził i zapisywał w pliku SQLOUT.txt instrukcje SQL przesyłane do źródła danych ODBC. Dopuszczalne wartości to 0 (nie) i 1 (tak). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD). Ta pozycja jest używana zamiennie z pozycją SQLTraceMode.
TraceODBCAPI | Wskaźnik określający, czy wywołania API ODBC będą śledzone i zapisywane w pliku ODBCAPI.txt. Dopuszczalne wartości to 0 (nie) i 1 (tak). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD).
DisableAsync | Wskaźnik określający, czy jest wymuszane synchroniczne wykonywanie kwerend. Dopuszczalne wartości to 0 (wykonywanie kwerend w sposób asynchroniczny, jeśli jest to możliwe) i 1 (wymuszone synchroniczne wykonywanie kwerend). Wartość domyślna wynosi 1 (wartości są typu REG_DWORD).
TryJetAuth | Wskaźnik określający, czy przed monitem podjąć próbę zalogowania się do serwera, używając nazwy użytkownika i jego hasła znanego programowi w systemie Microsoft Access. Dopuszczalne wartości to 0 (nie) i 1 (tak). Wartość domyślna wynosi 1 (wartości są typu REG_DWORD).
PreparedInsert | Wskaźnik określający, czy używana będzie przygotowana instrukcja INSERT wstawiająca dane do wszystkich kolumn. Dopuszczalne wartości to 0 (używana będzie niestandardowa wersja instrukcji INSERT wstawiająca wyłącznie wartości różne od Null) i 1 (używana będzie przygotowana instrukcja INSERT). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD). Używanie przygotowanych instrukcji INSERT może spowodować, że wartości Null zastąpią wartości domyślne dla serwera i uruchomienie wyzwalaczy w stosunku do kolumn, które nie były wstawione jawnie.
PreparedUpdate | Wskaźnik określający, czy używana będzie przygotowana instrukcja UPDATE aktualizująca dane we wszystkich kolumnach. Dopuszczalne wartości to 0 (używana będzie niestandardowa wersja instrukcji UPDATE ustawiająca wyłącznie kolumny zmienione) i 1 (używana będzie przygotowana instrukcja UPDATE). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD). Użycie przygotowanych instrukcji UPDATE może spowodować uruchomienie wyzwalaczy w stosunku do kolumn, które nie zostały zmienione.
FastRequery | Wskaźnik określający, czy w kwerendach parametrycznych zostanie użyta przygotowana instrukcja SELECT. Dopuszczalne wartości to 0 (nie) i 1 (tak). Wartość domyślna wynosi 0 (wartości są typu REG_DWORD).
FatBlastRows |
FatBlastTimeout |
ODBCISAMAttach |

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika baz danych programu Paradox

Podczas instalacji sterownika baz danych programu Paradox program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio (chyba że jest to konieczne); dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika baz danych programu Paradox.

Sterownik baz danych programu Paradox funkcjonować będzie w jednym z dwóch trybów, zależnie od tego, czy aparat baz danych Borland (BDE) jest zainstalowany. Dane z baz danych Paradox mogą być aktualizowane tylko, jeśli aparat BDE jest zainstalowany. Bez BDE, dane z baz danych Paradox mogą być czytane, eksportowane lub połączone do tylko-do-odczytu.

Ustawienia inicjujące dla sterownika baz danych programu Paradox

W folderze Jet\4.0\Engines\Paradox znajdują się ustawienia służące do inicjowania sterownika Mspdox35.dll, umożliwiającego dostęp do zewnętrznych danych w formacie Paradox. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\ mspbde40.dll

PageTimeout=600

CollatingSequence=ASCII

DataCodePage=OEM

ParadoxUserName=Kimberly

ParadoxNetPath=P:\PDOXDB

ParadoxNetStyle=4.X

Sposób wykorzystania pozycji folderu Paradox przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
win32 | Położenie pliku mspbde40.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
PageTimeout | Limit czasu między umieszczeniem danych w wewnętrznym buforze a ich unieważnieniem. Wartość jest podawana jako wielokrotność 100 milisekund. Wartością domyślną jest 600 jednostek, czyli 60 sekund. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
CollatingSequence To ustawienie używane jest jedynie w przypadku, gdy aparat BDE nie jest zainstalowany w systemie.

Sekwencja porządkująca dla wszystkich tabel Paradox utworzonych lub otwartych za pomocą aparatu baz danych Microsoft Jet. Dopuszczalnymi wartościami są ASCII, International, Norwegian-Danish i Swedish-Finnish. Pozycja CollatingSequence musi zgadzać się z sekwencją porządkującą zastosowaną podczas budowania tabeli Paradox. Wartością domyślną jest ASCII. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
DataCodePage To ustawienie używane jest jedynie w przypadku, gdy aparat BDE nie jest zainstalowany w systemie.

Wskaźnik sposobu przechowywania stron tekstu. Dopuszczalne są następujące ustawienia:

  • OEM — są wykonywane konwersje OemToAnsi i AnsiToOem.
  • ANSI — nie są wykonywane konwersje OemToAnsi i AnsiToOem.

Wartością domyślną jest OEM. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ParadoxUserName Nazwa wyświetlana przez system Paradox w przypadku, gdy tabela została zablokowana przez Paradox ISAM, zaś użytkownik mający dostęp z systemu Paradox (a nie z systemu ISAM) usiłuje założyć niezgodną blokadę. Ta pozycja nie jest dodawana przez program instalacyjny. Należy ją wpisać samodzielnie. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.

Uwaga Jeśli nadano wartość pozycji ParadoxUserName, to należy również wypełnić pozycje ParadoxNetPath i ParadoxNetStyle, gdyż w przeciwnym przypadku przy próbie dostępu do zewnętrznych danych w formacie Paradox wystąpi błąd. Jeżeli baza danych Paradox ma być współużytkowana w sieci, należy dodać lub zmienić niniejszą pozycję ręcznie.
ParadoxNetPath Pełna ścieżka do katalogu zawierającego plik PARADOX.NET (dla Paradox 3.x) lub PDOXUSRS.NET (dla Paradox 4.x). Ta pozycja nie jest dodawana przez program instalacyjny. Należy ją wpisać samemu. Pełna ścieżka ParadoxNetPath (łącznie z nazwą dysku) musi być jednakowa dla wszystkich użytkowników korzystających z tej samej bazy danych (katalogu). W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.

Uwaga Jeśli nadano wartość pozycji ParadoxNetPath, to należy również wypełnić pozycje ParadoxUserName i ParadoxNetStyle, gdyż w przeciwnym przypadku przy próbie dostępu do zewnętrznych danych w formacie Paradox wystąpi błąd. Jeżeli baza danych Paradox ma być współużytkowana w sieci, należy dodać lub zmienić niniejszą pozycję ręcznie.
ParadoxNetStyle Sposób dostępu poprzez sieć do danych w formacie Paradox. Dozwolone są następujące wartości:
  • 3.x
  • 4.x

Uwaga Użytkownicy baz danych Paradox 3.x nie mogą nadać temu ustawieniu wartości 4.x, gdyż w takim przypadku sterownik użyje nieprawidłowej metody blokowania. Użytkownicy baz danych Paradox 5.0 muszą używać ustawienia 4.x w celu zapewnienia poprawnego działania operacji blokowania.

Ta pozycja nie jest dodawana przez program instalacyjny. Należy ją wpisać samodzielnie. Powinna ona odpowiadać wersji bazy Paradox używanej przez grupę użytkowników. Musi być jednakowa dla wszystkich użytkowników korzystających z określonej bazy danych (katalogu). Wartością domyślną jest 4.x. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.

Uwaga Jeśli nadano wartość pozycji ParadoxNetStyle, to należy również wypełnić pozycje ParadoxUserName i ParadoxNetPath, gdy w przeciwnym przypadku przy próbie dostępu do zewnętrznych danych w formacie Paradox wystąpi błąd.

Formaty ISAM dla programu Paradox

Folder Jet\4.0\ISAM Formats\Paradox 3.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Paradox
ExportFilter | REG_SZ | String | Paradox 3 (*.db)
ImportFilter | REG_SZ | String | Paradox (*.db)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Paradox 3 file. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Folder Jet\4.0\ISAM Formats\Paradox 4.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Paradox
ExportFilter | REG_SZ | String | Paradox 4 (*.db)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Paradox 4 file. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Folder Jet\4.0\ISAM Formats\Paradox 5.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Paradox
ExportFilter | REG_SZ | String | Paradox 5 (*.db)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Paradox 5 file. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Folder Jet\4.0\ISAM Formats\Paradox 7.x zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Paradox
ExportFilter | REG_SZ | String | Paradox 7 (*.db)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 0
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku Paradox 7 file. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 00

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Inicjowanie sterownika źródła danych typu tekst i HTML

Ten sam sterownik baz danych jest używany dla źródeł danych typu tekst i HTML.

Podczas instalacji sterownika tekstowej bazy danych program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio; dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika tekstowej bazy danych.

Ustawienia inicjujące dla tekstowych źródeł danych

W folderze Jet\4.0\Engines\Text znajdują się ustawienia służące do inicjowania sterownika Mstext35.dll, umożliwiającego dostęp z zewnątrz do plików z danymi tekstowymi. Typowe ustawienia pozycji tego folderu są przedstawione w poniższym przykładzie.

win32=<ścieżka>\ mstext40.dll

MaxScanRows=25

FirstRowHasNames=True

CharacterSet= ANSI

Format=CSVDelimited

Extensions= txt,csv,tab,asc

ExportCurrencySymbols=Yes

Sposób wykorzystania pozycji folderu Text przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
win32 | Położenie pliku mstext40.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
MaxScanRows | Liczba wierszy przeglądanych podczas próby odgadnięcia typu kolumny. Jeśli wartość jest równa 0, zostanie przeszukany cały plik. Wartością domyślną jest 25. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu DWORD, zaś w systemie Windows NT 3.51 jest typu REG_DWORD.
FirstRowHasNames | Binarna wartość określająca, czy pierwszy wiersz tabeli zawiera nazwy kolumn. Wartość 01 oznacza, że podczas importu nazwy kolumn są pobierane z pierwszego wiersza. Wartość 00 oznacza, że pierwszy wiersz nie zawiera nazw kolumn. Wartością domyślną jest 01. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.
CharacterSet Wskaźnik sposobu przechowywania stron tekstu. Dopuszczalne są następujące ustawienia:
  • ANSI — Strona kodowa ANSI na tym komputerze. Wykonywane konwersje AnsiToUnicode i UnicodeToAnsi.
  • OEM — — Strona kodowa OEM na tym komputerze. Wykonywane konwersje OemToUnicode i UnicodeToOem.
  • Unicode — Konwersje stron kodowych nie są wykonywane.
  • <numer dziesiętny> — Numer strony kodowej określonego zestawu znaków. Konwersje do i z zestawu Unicode będą przeprowadzane.

Ustawieniem domyślnym jest ANSI. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
Format | Może przyjąć jedną z następujących wartości: TabDelimited, CSVDelimited, Delimited (<pojedynczy znak>). Pojedynczy znak rozdzielający w formacie Delimited może być dowolnym znakiem za wyjątkiem podwójnego cudzysłowu (“). Wartością domyślną jest CSVDelimited. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
Extensions | Rozszerzenie pliku, który będzie przeglądany podczas szukania danych tekstowych. Wartością domyślną jest txt, csv, tab, asc. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.
ExportCurrencySymbols | Binarna wartość określająca, czy podczas eksportu pól typu pieniężnego jest dołączany symbol waluty. Wartość 01 oznacza, że symbol waluty jest dołączany. Wartość 00 oznacza, że eksportowane są wyłącznie dane numeryczne. Wartością domyślną jest 01. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu Binary, zaś w systemie Windows NT 3.51 jest typu REG_BINARY.

Formaty ISAM dla tekstowych źródeł danych

Folder Jet\4.0\ISAM Formats\Text zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Tekst
ExportFilter | REG_SZ | String | Pliki tekstowe (*.txt; *.csv; *.tab; *.asc)
ImportFilter | REG_SZ | String | Pliki tekstowe (*.txt; *.csv; *.tab; *.asc)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku tekstowego. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Formaty ISAM dla importu HTML

Folder Jet\4.0\ISAM Formats\HTML Import zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Tekst
ImportFilter | REG_SZ | String | Pliki HTML (*.ht*)
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextImport | REG_SZ | String | Importuj dane z zewnętrznego pliku do bieżącej bazy danych. Zmiana danych w bieżącej bazie danych nie spowoduje zmiany danych w zewnętrznym pliku.
ResultTextLink | REG_SZ | String | W bieżącej bazie danych utwórz tabelę połączoną z zewnętrznym plikiem. Zmiana danych w bieżącej bazie danych spowoduje zmianę danych w zewnętrznym pliku.
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Formaty ISAM dla eksportu HTML

Folder Jet\4.0\ISAM Formats\HTML Export zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Tekst
ExportFilter | REG_SZ | String | Plik HTML (*.htm)
CanLink | REG_BINARY | Binary | 00
OneTablePerFile | REG_BINARY | Binary | 01
IsamType | REG_DWORD | DWORD | 2
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
ResultTextExport | REG_SZ | String | Eksportuj dane z bieżącej bazy danych do pliku tekstowego. Jeśli plik istnieje, dane w nim zostaną zastąpione.
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Dostosowywanie pliku Schema.ini File dla danych typu Text i HTML

Aby odczytać, importować, lub eksportować dane tekstowe i HTML, należy utworzyć plik Schema.ini oprócz umieszczenia informacji Text ISAM w pliku .ini. Schema.ini zawiera szczegóły dotyczące źródła danych: jak plik tekstowy jest formatowany, jak ma być odczytany podczas importowania, i jaki jest domyślny format eksportu dla plików. W poniższym przykładzie pokazano, jak zdefiniować układ pliku o stałej szerokości wierszy, o nazwie Filename.txt.

[Filename.txt]

ColNameHeader=False

Format=FixedLength

FixedFormat= RaggedEdge

MaxScanRows=25

CharacterSet=OEM

Col1=columnname Char Width 24

Col2=columnname2 Date Width 9

Col3=columnname7 Float Width 10

Col4=columnname8 Integer Width 10

Col5=columnname9 LongChar Width 10

Podobnie format dla pliku z separatorem przedstawia się następująco:

[Delimit.txt]

ColNameHeader=True

Format=Delimited(!)

MaxScanRows=0

CharacterSet=OEM

Col1=username char width 50

Col2=dateofbirth Date width 9

Jeśli dane są eksportowane do pliku tekstowego z separatorem, to również dla tego pliku należy określić format.

[Export: Mój specjalny plik eksportu]

ColNameHeader=True

Format=TabDelimited

MaxScanRows=25

CharacterSet=OEM

DateTimeFormat=dd.mm.yy.hh.mm.ss

CurrencySymbol=zł

CurrencyPosFormat=3

CurrencyDigits=2

CurrencyNegFormat=0

CurrencyThousandSymbol=.

CurrencyDecimalSymbol=,

DecimalSymbol=,

NumberDigits=2

NumberLeadingZeros=1

TextDelimeter=”

Poniższy przykład odwołuje się do specyficznej opcji eksportu; podczas nawiązywania połączenia można określić dowolną kombinację opcji eksportu. Ten ostatni przykład odwołuje się również do nazwy źródła danych (DSN, data source name), która opcjonalnie może być przekazana podczas nawiązywania połączenia. Wszystkie trzy sekcje formatu mogą być umieszczone w tym samym pliku .ini.

Sposób wykorzystania pozycji pliku Schema.ini przez aparat baz danych Microsoft Jet jest przedstawiony w poniższej tabeli.

Pozycja | Opis
ColNameHeader | Może przyjmować wartość True (wskazując, że pierwszy rekord danych zawiera nazwy kolumn) lub False.
Format | Może przyjąć jedną z następujących wartości: TabDelimited, CSVDelimited, Delimited (<pojedynczy znak>). Pojedynczy znak rozdzielający w formacie Delimited może być dowolnym znakiem za wyjątkiem podwójnego cudzysłowu (“).
FixedFormat Używany jedynie, gdy Format ma wartość FixedLength, może przyjmować następujące wartości: RaggedEdge lub TrueFixedLength.

RaggedEdge pozwala kończyć wiersze znakiem powrotu karetki.

TrueFixedLength wymaga jednakowej liczby znaków w każdym wierszu, a każdy znak powrotu karetki nie mieszczący się w granicy wiersza jest uważany za osadzony w polu.

Jeśli to ustawienie nie jest obecne, domyślną wartością jest RaggedEdge.
MaxScanRows | Liczba wierszy przeglądanych podczas próby odgadnięcia typu kolumny. Jeśli wartość ta jest równa 0, zostanie przeszukany cały plik.
CharacterSet | Może być ustawiony na OEM, ANSI, UNICODE lub numer dziesiętny odpowiedniej strony kodowej i wskazuje zestaw znaków pliku źródłowego.
DateTimeFormat | Może przyjąć postać ciągu formatującego daty i godziny. Ta pozycja musi być podana, jeśli podczas importu i eksportu dla wszystkich pól daty i godziny jest używany taki sam format. Dopuszczalne są wszystkie formaty używane przez aparat baz danych Microsoft Jet prócz formatów AM i PM. W przypadku braku ciągu formatującego stosowane są krótkie formaty daty i godziny z Panelu sterowania.
CurrencySymbol | Określa symbol waluty używany w pliku tekstowym do oznaczania jednostek pieniężnych. Przykładami są znak dolara ($) i zł. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
CurrencyPosFormat Może przyjmować jedną z następujących wartości:

Symbol waluty poprzedzający wartość bez odstępu ($1)

Symbol waluty następujący po wartości bez odstępu (1$)

Symbol waluty poprzedzający wartość z jednym znakiem odstępu ($ 1)

Symbol waluty następujący po wartości z jednym znakiem odstępu (1 $)

Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
CurrencyDigits | Określa liczbę cyfr stosowaną do przedstawienia części ułamkowej wielkości pieniężnej. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
CurrencyNegFormat Może przyjmować jedną z następujących wartości:

($1)

–$1

$–1

$1–

(1$)

–1$

1–$

1$–

–1 $

–$ 1

1 $–

$ 1–

$ –1

1– $

($ 1)

(1 $)

Znak dolara jest tu używany wyłącznie jako przykład, lecz w programie powinien zostać zastąpiony odpowiednią wartością CurrencySymbol. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
CurrencyThousandSymbol | Określa jednoznakowy symbol używany do oddzielania grup trzycyfrowych w wartościach pieniężnych występujących w plikach tekstowych. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
CurrencyDecimalSymbol | Może przyjąć wartość pojedynczego znaku oddzielającego w wartości pieniężnej część całkowitą od ułamkowej. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
DecimalSymbol | Może przyjąć wartość pojedynczego znaku oddzielającego część całkowitą liczby od jej części ułamkowej. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
NumberDigits | Określa liczbę cyfr dziesiętnych w części ułamkowej liczby. Jeśli nie ma tej pozycji, stosowana jest wartość domyślna z Panelu sterowania.
NumberLeadingZeros | Określa, czy liczba mniejsza niż 1 i większa niż -1 powinna zawierać zera wiodące; pozycja ta może przyjmować wartość False (bez zer wiodących) lub True.
Col1, Col2, ... Lista wczytywanych kolumn z pliku tekstowego. Format tej pozycji wygląda następująco:

Coln=nazwa_kolumny typ [szerokość]

nazwa_kolumny: nazwy kolumn zawierające odstępy powinny być ujęte w cudzysłów.

typ: Może być to Bit, Byte, Short, Long, Decimal, Currency, Single, Double, DateTime. Binary, OLE, Text, lub Memo.

Dodatkowo, obsługiwane są następujące typy danych typowe dla tekstowego sterownika ODBC:

Char (ten sam co Text)
Float (ten sam co Double)
Integer (ten sam co Short)
LongChar (ten sam co Memo)
Date format_daty

W przypadku typu Memo dodatkowy znacznik formatu [Attribute Hyperlink] może zostać użyty do określenia kolumn, które powinny być aktywnymi adresami URLs w programie Microsoft Access.

W przypadku typu Decimal powinny zostać użyte dodatkowe znaczniki formatu [Scale #] [Precision #].

TextDelimiter Pozycja ta może zostać ustawiona na każdy pojedynczy znak, który jest użyty do ograniczania ciągu zawierającego jakikolwiek z innych znaków specjalnych.

Np. “abc”,”xyz,pqr”,”hij”

Jeśli niniejsza pozycja nie jest obecna, wartością domyślną jest cudzysłów. Jeśli niniejsza pozycja ma wartość “none”, wtedy żaden znak nie będzie traktowany jako ogranicznik.

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Tworzenie fragmentu w drzewie rejestru aplikacji do zarządzania ustawieniami

W celu dostosowania ustawień Rejestru systemowego Microsoft® Windows®, można utworzyć w drzewie rejestru aplikacji fragment dla Microsoft Jet, aby zarządzać ustawieniami aparatu baz danych Microsoft Jet.Najłatwiej to uczynić, eksportując istniejący klucz Microsoft Jet, a następnie importując go do konkretnej aplikacji, za pomocą poleceń Eksportuj i Importuj z programu Regedit.exe. Następnie można zmienić dowolną z wartości w nowym drzewie rejestru. Jeśli podano wartości dla podfoldera Engines, to zostają one wczytane przez aparat Microsoft Jet podczas uruchamiania aplikacji. Wszystkie wartości nie wprowadzone do drzewa rejestru aplikacji–klienta są pobierane z ustawień w pierwotnym drzewie.

Aby aplikacja użytkownika mogła załadować prawidłowy fragment klucza Rejestru Windows, należy określić jego położenie, używając do tego właściwości DAO INIPath. Ustawienie właściwości INIPath w aplikacji musi poprzedzać wszystkie inne polecenia DAO. Zakres ważności tego ustawienia jest ograniczony do aplikacji użytkownika i nie może być zmieniony bez ponownego uruchomienia tej aplikacji.

Uwaga Utworzenie fragmentu dla aparatu Microsoft Jet w części Rejestru dotyczącej aplikacji daje użytkownikowi więcej swobody w porównaniu ze zmianą domyślnych ustawień aparatu Microsoft Jet, lecz nadal wymaga utrzymywania drzewa Rejestru. Gdy tylko konieczne są zmiany domyślnych ustawień, trzeba dokonywać zmian w Rejestrze.

Zobacz też
Używanie programu Regedit.exe do zastąpienia ustawień domyślnych | Używanie właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet
Używanie metody DAO SetOption |


Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet

Uwaga Jeśli domyślne ustawienia aparatu baz danych Microsoft Jet nie zapewniają poprawnej współpracy z aplikacją, może zaistnieć potrzeba zmiany tych ustawień w Rejestrze® systemu Windows® w celu ich dostosowania do potrzeb użytkownika. Zmieniając ustawienia Rejestru, można również usprawnić działanie instalowalnego sterownika ISAM i sterownika ODBC.

Można dostosować ustawienia Rejestru Windows na cztery różne sposoby:

Używając programu Regedit.exe do zastąpienia ustawień domyślnych

Tworząc fragment w drzewie rejestru aplikacji do zarządzania ustawieniami

Używanie metody DAO SetOption

Używając właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet

Użytkownik może dokonywać edycji Rejestru również w celu określenia:

  • Ustawień stosowanych w komunikacji z programami Microsoft Excel, Lotus, Paradox, i bazami danych dBASE. Zobacz Inicjowanie sterownika baz danych programu Paradox, Inicjowanie sterownika baz danych programu Microsoft Excel, Inicjowanie sterownika baz danych programu Lotus, oraz Inicjowanie sterownika baz danych programu dBASE.
  • Ustawień stosowanych przez system Microsoft ODBC przy współpracy z bazami danych SQL. Patrz Konfigurowanie aparatu baz danych Microsoft Jet do współpracy z ODBC.
  • Ustawień wpływających na sposób, w jaki aparat baz danych Microsoft Jet odczytuje i zapisuje dane. Zobacz Inicjowanie sterownika aparatu baz danych Microsoft Jet 2.5, Inicjowanie sterownika aparatu baz danych Microsoft Jet 3.5, and Inicjowanie sterownika aparatu baz danych Microsoft Jet 4.0.
  • Ustawień kontrolujących sposób, w jaki aparat baz danych Microsoft Jet współpracuje z Internetem i programem Microsoft Exchange. Zobacz Inicjowanie sterownika źródła danych typu Text i HTML i Inicjowanie sterownika źródła danych programu Microsoft Exchange.
  • Ustawień kontrolujących sposób, w jaki aparat baz danych Microsoft Jet pracuje z danymi importowanymi jako zwykły tekst. Zobacz Inicjowanie sterownika źródła danych typu tekst i HTML.
Zobacz też
Inicjowanie sterownika baz danych programu dBase | Konfigurowanie aparatu baz danych Microsoft Jet do współpracy z ODBC
Inicjowanie sterownika baz danych programu Lotus | Inicjowanie sterownika baz danych programu Paradox
Inicjowanie sterownika aparatu baz danych Microsoft Jet 2.5 | Inicjowanie sterownika źródła danych typu Text i HTML
Inicjowanie sterownika aparatu baz danych Microsoft Jet 3.5 | Inicjowanie sterownika źródła danych programu Microsoft Exchange
Inicjowanie sterownika aparatu baz danych Microsoft Jet 4.0 | Inicjowanie sterownika baz danych programu Microsoft Excel


Inicjowanie sterownika źródła danych programu Microsoft Exchange

Podczas instalacji sterownika źródła danych programu Microsoft® Exchange program instalacyjny wpisuje zestaw domyślnych wartości do podkluczy Engines i ISAM Formats w Rejestrze Windows®. Zmiany tych ustawień nie należy przeprowadzać bezpośrednio; dodawanie, usuwanie lub zmiana ustawień powinny być wykonywane za pośrednictwem programu instalacyjnego aplikacji. W następnych punktach opisano inicjowanie i ustawienia formatu ISAM właściwe dla sterownika źródła danych programu Microsoft Exchange.

Ustawienia inicjujące dla sterownika źródła danych programu Microsoft Exchange

Folder Jet\4.0\Engines\Exchange zawiera ustawienia inicjujące sterownika msexch40.dll, używanego przy zewnętrznym dostępie do folderów programów Microsoft Outlook i Microsoft Exchange. W tym folderze znajduje się tylko jedna pozycja:

win32=<ścieżka>\msexch40.dll

Aparat baz danych Microsoft Jet używa tego ustawienia, aby wskazać pozycję pliku msexch40.dll. Pełna ścieżka jest określana podczas instalacji. W systemie Windows 95 i Windows NT 4.0 wartość tej pozycji jest typu String, zaś w systemie Windows NT 3.51 jest typu REG_SZ.

Rezultaty użycia formatu Outlook ISAM i formatu klienta Exchange ISAM są podobne. Jedyną różnicą jest różne nazewnictwo tych samych kolumn dla dwóch różnych klientów. Zostały utworzone dwa formaty ISAM, tak więc aparat Microsoft Jet może zwracać nazwy kolumn w taki sposób, jaki sobie życzy użytkownik.

Formaty ISAM klienta programu Microsoft Outlook

Folder Jet\4.0\ISAM Formats\Exchange 9.0 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Exchange
ImportFilter | REG_SZ | String | Outlook()
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 3
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Formaty ISAM klienta programu Microsoft Exchange

Folder Jet\4.0\ISAM Formats\Exchange 4.0 zawiera następujące pozycje.

Nazwa pozycji | Typ danych w Windows NT 3.51 | Typ danych w Windows 95 i Windows NT 4.0 | Wartość
Engine | REG_SZ | String | Exchange
ImportFilter | REG_SZ | String | Exchange
CanLink | REG_BINARY | Binary | 01
OneTablePerFile | REG_BINARY | Binary | 00
IsamType | REG_DWORD | DWORD | 3
IndexDialog | REG_BINARY | Binary | 00
CreateDBOnExport | REG_BINARY | Binary | 00
SupportsLongNames | REG_BINARY | Binary | 01

Uwaga Aby nowe ustawienia zaczęły obowiązywać, po ich zmianie w Rejestrze Windows należy zakończyć pracę z aparatem baz danych i uruchomić aparat ponownie.

Dostosowywanie pliku Schema.ini dla danych programów Outlook i Exchange

Plik Schema.ini używany jest przez ISAM programów Outlook i Exchange w bardzo podobny sposób jak przez Text ISAM. Schema.ini zawiera szczegóły dotyczące źródła danych: jak dane są formatowane, oraz nazwy kolumn, do których powinien być dostęp.

Nie jest konieczna modyfikacja pliku Schema.ini, zanim dane mogą być czytane, importowane lub eksportowane do programów Outlook lub Exchange. Wiele z ustawień wewnątrz pliku Schema.ini dla programów Outlook i Exchange określonych jest dla wewnętrznych etykiet wymaganych przez MAPI. Nie powinno się próbować modyfikacji wartości tych etykiet.

Zobacz też

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet


Używanie właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet

W celu dostosowania ustawień Rejestru systemowego Microsoft® Windows®, można użyć właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet. Następuje to poprzez odwołanie do właściwości połączenia obiektu i zmianie jej wartości. Na przykład, zakładając, że obiekt połączenia nazwany jest ADOConnection, następująca instrukcja spowoduje taki sam rezultat, jak wywołanie z ADO:

ADOConnection.Properties("Jet OLEDB:Max Locks Per File") = 20000

Nazwy właściwości są inne niż stałe DAO i ustawienia rejestru. Nazwy właściwości wyglądają następująco:

Jet OLEDB:Max Locks Per File

Jet OLEDB:Implicit Commit Sync

Jet OLEDB:Flush Transaction Timeout

Jet OLEDB:Lock Delay

Jet OLEDB:Max Buffer Size

Jet OLEDB:User Commit Sync

Jet OLEDB:Lock Retry

Jet OLEDB:Exclusive Async Delay

Jet OLEDB:Shared Async Delay

Jet OLEDB:Page Timeout

Jet OLEDB:Recycle Long-Valued Pages

Zobacz też
Używanie programu Regedit.exe do zastąpienia ustawień domyślnych | Używanie metody DAO SetOption
Tworzenie części w drzewie rejestru aplikacji do zarządzania ustawieniami |


Używanie programu Regedit.exe do zastąpienia ustawień domyślnych

W celu dostosowania ustawień Rejestru systemowego Microsoft® Windows®, można użyć programu Regedit.exe, aby zastąpić ustawienia domyślne, które są ustanowione podczas rejestracji aparatu baz danych Microsoft Jet. Ta metoda jest najmniej elastyczna, ponieważ dla wszystkich aplikacji, które nie określą innego położenia w rejestrze nowe ustawienia będą ustawieniami domyślnymi.

Zobacz też
Tworzenie fragmentu w drzewie rejestru aplikacji do zarządzania ustawieniami | Używanie właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet
Używanie metody DAO SetOption |


Używanie metody DAO SetOption

DAO w wersji 3.6 zapewnia nowe możliwości modyfikacji ustawień domyślnych. Ustawienia rejestru systemowego Microsoft® Windows® mogą być teraz zmieniane w czasie pracy za pomocą metody SetOption. Aby dostosować ustawienia Rejestru Windows, można zastosować metodę SetOption z DAO. Korzystając z tej możliwości, aplikacja otrzymuje maksymalną kontrolę i elastyczność. To podejście umożliwia tworzenie aplikacji, które są łatwiejsze w obsłudze i osiągają maksymalną wydajność.

Składnia metody wygląda następująco: dbEngine.SetOption, stała, NowaWartośćUstawienia. Na przykład, następująca składnia: dbEngine.SetOption dbMaxLocksPerfFile, 20000, pozwala na śledzenie 20000 blokad naraz przez aparat Microsoft Jet. Nazwy zdefiniowanych stałych są takie same jak nazwy w rejestrze z prefiksem db.

Jest to zalecany sposób dopasowywania ustawień rejestru do potrzeb aplikacji. Ta metoda jest najbardziej elastycznym podejściem i zapewnia największą kontrolę nad zmianami w rejestrze. Za pomocą metody SetOption można określić nowe ustawienia dla każdego z następujących ustawień domyślnych:

  • klucz PageTimeout
  • klucz SharedAsyncDelay
  • klucz ExclusiveAsyncDelay
  • klucz LockRetry
  • klucz UserCommitSync
  • klucz ImplicitCommitSync
  • klucz MaxBufferSize
  • klucz MaxLocksPerFile
  • klucz LockDelay
  • klucz RecycleLVs
  • klucz FlushTransactionTimeout
Zobacz też
Używanie programu Regedit.exe do zastąpienia ustawień domyślnych | Używanie właściwości połączenia w mechanizmie Microsoft OLE DB Provider dla aparatu baz danych Jet
Tworzenie części w drzewie rejestru aplikacji do zarządzania ustawieniami |


SQL - funkcje agregujące (Microsoft Jet SQL)

SQL - funkcje agregujące

Używając funkcji agregujących SQL, można wyliczyć różne dane statystyczne dotyczące zbiorów wartości. Funkcje te mogą zostać użyte w kwerendzie i wyrażeniach agregujących we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Avg - funkcja

Count - funkcja

First, Last - funkcje

Min, Max - funkcje

StDev, StDevP - funkcje

Sum - funkcja

Var, VarP - funkcje


ALL <słowo zastrzeżone Microsoft Jet SQL>

ALL

Słowo kluczowe ALL jest wykorzystywane w następujących konstrukcjach:

ALL, DISTINCT, DISTINCTROW, TOP - predykaty

Podkwerendy SQL

UNION - operacja


ALTER TABLE <słowo zastrzeżone Microsoft Jet SQL>

ALTER

Słowo kluczowe ALTER jest używane w następujących konstrukcjach:

ALTER TABLE - instrukcja

ALTER USER lub DATABASE - instrukcja


ASC/DESC <słowo zastrzeżone Microsoft Jet SQL>

ASC/DESC

Słowa kluczowe ASC i DESC są wykorzystywane w następujących konstrukcjach:

CREATE INDEX - instrukcja

ORDER BY - klauzula


AS <słowo zastrzeżone Microsoft Jet SQL>

AS

Słowo kluczowe AS jest wykorzystywane w następujących konstrukcjach:

SELECT - instrukcja

CREATE VIEW - instrukcja

CREATE PROCEDURE - instrukcja


BY <słowo zastrzeżone Microsoft Jet SQL>

BY

Słowo kluczowe BY jest wykorzystywane w następujących konstrukcjach:

GROUP BY - klauzula

ORDER BY - klauzula


CONTAINER <słowo zastrzeżone Microsoft Jet SQL>

CONTAINER

Słowo kluczowe CONTAINER jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


CREATE <słowo zastrzeżone Microsoft Jet SQL>

CREATE

Słowo kluczowe CREATE jest wykorzystywane w następujących konstrukcjach:

CREATE INDEX - instrukcja

CREATE TABLE - instrukcja

CREATE VIEW - instrukcja

CREATE PROCEDURE - instrukcja

CREATE USER lub GROUP - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


DELETE <słowo zastrzeżone Microsoft Jet SQL>

DELETE

Słowo kluczowe DELETE jest używane w następujących konstrukcjach:

DELETE - instrukcja

CREATE PROCEDURE - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


DROP <słowo zastrzeżone Microsoft Jet SQL>

DROP

Słowo kluczowe DROP jest wykorzystywane w następujących konstrukcjach:

ALTER TABLE - instrukcja

DROP - instrukcja

DROP USER lub GROUP - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


FIRST <słowo zastrzeżone Microsoft Jet SQL>

FIRST

Słowo kluczowe FIRST jest używane w następujących konstrukcjach:

First, Last - funkcje

First, Last – funkcje - przykład


FROM <słowo zastrzeżone Microsoft Jet SQL>

FROM

Słowo kluczowe FROM jest wykorzystywane w następujących konstrukcjach:

SELECT - instrukcja

DROP USER lub GROUP - instrukcja

REVOKE - instrukcja


INDEX <słowo zastrzeżone Microsoft Jet SQL>

INDEX

Słowo kluczowe INDEX jest wykorzystywane w następujących konstrukcjach:

CREATE INDEX - instrukcja

DROP - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


IN <słowo zastrzeżone Microsoft Jet SQL>

IN

Słowo kluczowe IN jest wykorzystywane w następujących konstrukcjach:

In - operator

IN - klauzula

Podkwerendy SQL

TRANSFORM - instrukcja


INSERT <słowo zastrzeżone Microsoft Jet SQL>

INSERT

Słowo kluczowe INSERT jst używane w następujących konstrukcjach:

INSERT INTO - instrukcja

CREATE PROCEDURE - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


INTO <słowo zastrzeżone Microsoft Jet SQL>

INTO

Słowo kluczowe INTO jest wykorzystywane w następujących konstrukcjach:

INSERT INTO - instrukcja

SELECT ... INTO - instrukcja


JOIN <słowo zastrzeżone Microsoft Jet SQL>

JOIN

Słowo kluczowe JOIN jest wykorzystywane w następujących konstrukcjach:

INNER JOIN - operacja

LEFT JOIN, RIGHT JOIN - operacja


LAST <słowo zastrzeżone Microsoft Jet SQL>

LAST

Słowo kluczowe LAST jest używane w następujących konstrukcjach:

First, Last - funkcje

First, Last – funkcje - przykład


ON <słowo zastrzeżone Microsoft Jet SQL>

ON

Słowo kluczowe ON jest wykorzystywane w następujących konstrukcjach:

INNER JOIN - operacja

LEFT JOIN, RIGHT JOIN - operacja

CONSTRAINT - klauzula

GRANT - instrukcja

REVOKE - instrukcja


SCHEMA <słowo zastrzeżone Microsoft Jet SQL>

SCHEMA

Słowo kluczowe SCHEMA jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


SELECT <słowo zastrzeżone Microsoft Jet SQL>

SELECT

Słowo kluczowe SELECT jest wykorzystywane w następujących konstrukcjach:

SELECT - instrukcja

SELECT ... INTO - instrukcja

CREATE VIEW - instrukcja

CREATE PROCEDURE - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


SELECTSCHEMA <słowo zastrzeżone Microsoft Jet SQL>

SELECTSCHEMA

Słowo kluczowe SELECTSCHEMA jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


SELECTSECURITY <słowo zastrzeżone Microsoft Jet SQL>

SELECTSECURITY

Słowo kluczowe SELECTSECURITY jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


TABLE <słowo zastrzeżone Microsoft Jet SQL>

TABLE

Słowo kluczowe TABLE jest wykorzystywane w następujących konstrukcjach:

ALTER TABLE - instrukcja

CREATE INDEX - instrukcja

CREATE TABLE - instrukcja

DROP - instrukcja

UNION - operacja

GRANT - instrukcja

REVOKE - instrukcja


TO <słowo zastrzeżone Microsoft Jet SQL>

TO

Słowo kluczowe TO jest używane w następujących konstrukcjach:

ADD USER - instrukcja

GRANT - instrukcja


UPDATE <słowo zastrzeżone Microsoft Jet SQL>

UPDATE

Słowo kluczowe UPDATE jest używane w następujących konstrukcjach:

UPDATE - instrukcja

CREATE PROCEDURE - instrukcja

GRANT - instrukcja

REVOKE - instrukcja


UPDATEIDENTITY <słowo zastrzeżone Microsoft Jet SQL>

UPDATEIDENTITY

Słowo kluczowe UPDATEIDENTITY jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


UPDATEOWNER <słowo zastrzeżone Microsoft Jet SQL>

UPDATEOWNER

Słowo kluczowe UPDATEOWNER jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


UPDATESECURITY <słowo zastrzeżone Microsoft Jet SQL>

UPDATESECURITY

Słowo kluczowe UPDATESECURITY jest używane w następujących konstrukcjach:

GRANT - instrukcja

REVOKE - instrukcja


USER <słowo zastrzeżone Microsoft Jet SQL>

USER

Słowo kluczowe USER jest używane w następujących konstrukcjach:

CREATE USER lub GROUP - instrukcja

ADD USER - instrukcja

DROP USER lub GROUP - instrukcja

ALTER USER lub DATABASE - instrukcja


VIEW <słowo zastrzeżone Microsoft Jet SQL>

VIEW

Słowo kluczowe VIEW jest używane w następujących konstrukcjach:

CREATE VIEW - instrukcja

DROP - instrukcja


WITH <słowo zastrzeżone Microsoft Jet SQL>

WITH

Słowo kluczowe WITH jest wykorzystywane w następujących konstrukcjach:

CREATE INDEX - instrukcja

WITH OWNERACCESS OPTION - deklaracja


Zbyt skomplikowane wyrażenie. (Błąd 2445)

To wyrażenie jest zbyt skomplikowane dla aparatu bazy danych Microsoft Jet. Spróbuj uprościć wyrażenie.


Nie można otworzyć tabeli Paradox 4.x lub 5.x, ponieważ w Rejestrze Windows ParadoxNetStyle jest ustawiony na 3.x. (Błąd 3419)

Aparat bazy danych Microsoft Jet nie mógł otworzyć zewnętrznej tabeli programu Paradox z powodu niezgodności występujących między wersją tabeli i ustawieniami ParadoxNetStyle w Rejestrze Windows®.

Aby rozwiązać ten problem

  1. Zamknij aplikację.
  2. Uruchom Edytor Rejestru, ustaw się na \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox i zaznacz wartość ParadoxNetStyle.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. W oknie Dane wartości podaj wartość 4.x.
  5. Ustawienie ParadoxNetStyle musi być takie samo dla wszystkich użytkowników bazy danych.
  6. Ponownie uruchom aplikację.
  7. Spróbuj ponownie otworzyć tabelę.


Nie można naprawić tej bazy danych. (Błąd 3056)

Ta baza danych jest uszkodzona lub nie jest bazą danych aparatu Microsoft Jet. Odtwórz uszkodzoną bazę danych Microsoft® Jet z kopii zapasowej lub utwórz nową bazę danych.


Operacja została anulowana. (Błąd 3642)

Kwerenda została przerwana przez źródło danych. Część z wierszy spełniających kryteria nie została przekazana. Należy ponowić kwerendę.


Brak koniecznego zezwolenia na użycie obiektu <nazwa>. Zwróć się do administratora systemu lub osoby, która utworzyła ten

Brak koniecznego zezwolenia na użycie obiektu <nazwa>. Zwróć się do administratora systemu lub osoby, która utworzyła ten obiekt, aby uzyskać właściwe zezwolenia. (Błąd 3033)

Nie posiadasz wymaganych zezwoleń do określonego obiektu. Aby zmienić przypisane zezwolenia, zwróć się do administratora systemu lub twórcy obiektu.


Nazwa konta już istnieje. (Błąd 3390)

Wystąpił problem bezpieczeństwa. Próbowano założyć konto użytkownika, używając już istniejącej nazwy. Sprawdź, czy w kolekcji Users istnieje już taka nazwa użytkownika, lub podaj inną nazwę.


Żądana kolumna nie jest zwracana do obiektu Recordset. (Błąd 3647)

Jedna z żądanych kolumn nie jest dostępna.


Nie udało się dodać wierszy potrzebnych do przekształcenia bazy danych w bazę replikowalną. (Błąd 3580)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można umieścić funkcji agregującej w wyrażeniu <wyrażenie>. (Błąd 3095)

Nie można używać funkcji agregującej w tym wyrażeniu.


Nie można umieścić funkcji agregującej w klauzuli GROUP BY <klauzula>. (Błąd 3098)

Nie można używać funkcji agregującej w klauzuli GROUP BY instrukcji SQL.


Nie można umieścić funkcji agregującej w operacji JOIN <operacja>. (Błąd 3099)

Nie można używać funkcji agregującej w operacji JOIN instrukcji SQL .


Nie można umieścić funkcji agregującej w klauzuli ORDER BY <klauzula>. (Błąd 3097)

Nie można używać funkcji agregującej w klauzuli ORDER BY instrukcji SQL.


Nie można umieścić funkcji agregującej w klauzuli WHERE <klauzula>. (Błąd 3096)

Nie można używać funkcji agregującej w klauzuli WHERE instrukcji SQL.


Podkwerendy nie mogą być stosowane w wyrażeniu <wyrażenie>. (Błąd 3203)

Podane wyrażenie zawiera podkwerendę lub inne wyrażenie działające jak podkwerenda.

Możliwa przyczyna:

  • Została użyta instrukcja SELECT zawierająca funkcję agregującą, której wartością jest inna funkcja agregująca. Na przykład błąd ten wystąpi, jeżeli zostanie wykonana następująca instrukcja:

    TRANSFORM Sum([WielkośćZamówienia]) AS Suma1

    SELECT Sum([Suma1]) AS Suma2, NrZamówienia, Sum([Suma2]) AS Wyrażenie1

    FROM Zamówienia

    GROUP BY NrZamówienia

    PIVOT NazwaOdbiorcy;

    Parametr <wyrażenie> komunikatu o błędzie zawierałby w takim przypadku wyrażenie Sum([Suma2]) z klauzuli SELECT, ponieważ odwołuje się ono do aliasu użytego w tej samej instrukcji SELECT i działa jako podkwerenda na Sum([Suma1]).


Wyrażenia agregujące nie mogą korzystać z GUID. (Błąd 3600)

Instrukcja SQL nie może zawierać kolumny typu GUID w agregacji, takiej jak MAX, MIN, SUM,itp.


Wszystkie dopuszczalne nazwy replik są już w użyciu. (Błąd 3555)

Maksymalna dozwolona liczba replik (32,768) w zestawie replik została przekroczona. Należy rozpocząć nowy zestaw replik.


Aparat baz danych Microsoft Jet został już zainicjowany. (Błąd 3279)

Usiłowano zainicjować aparat bazy danych Microsoft Jet, który został już zainicjowany.


Metoda AddNew lub Edit została już użyta. (Błąd 3023)

Bieżące zmiany nie zostały zapisane lub zostały wycofane, gdy nastąpiła próba zmiany innego rekordu lub dodania nowego. Użyj metody Rollback lub Update, a następnie zastosuj metodę AddNew lub Edit.


Separator pól specyfikacji pliku tekstowego odpowiada separatorowi dziesiętnemu lub ogranicznikowi tekstu. (Błąd 3441)

Dwa lub więcej z następujących ustawień ograniczników używanych przez format tekstowy ISAM są takie same:

  • TxtDelimiter
  • NumberDecimalSymbol
  • CurrencyDecimalSymbol
  • Format


Błąd składniowy. (Błąd 2438)

Wprowadzone wyrażenie ma niepoprawną składnię. Na przykład, może brakować operatora lub argumentu, został wprowadzony niewłaściwy znak lub przecinek, lub wprowadzony tekst nie został ujęty w cudzysłów ("). Sprawdź wyrażenie, aby upewnić się, że zostało wprowadzone poprawnie.


Błąd składniowy w dacie. (Błąd 2421)

Niepoprawna składnia wartości typu Date. Błąd ten występuje, gdy podana zostanie nieprawidłowa data. Na przykład, wyrażenie 31/9/94 jest niepoprawne (wrzesień ma tylko 30 dni).


Niepoprawne użycie ".", "!" lub "()". (Błąd 2423)

Wyrażenie niepoprawnie używa ograniczniki. Aby odnieść się do właściwości obiektu DAO, sugerowane jest użycie składni .nazwa_właściwości.


Funkcja IIF bez nawiasów (). (Błąd 2440)

Dla funkcji IIf wymagane jest ujęcie jej argumentów w nawias tak, jak to pokazano poniżej:

IIf(wyrażenie, część_true, część_false)


Operator In bez (). (Błąd 2429)

Podczas formułowania instrukcji SQL zawierającej operator In listę elementów testowych należy ująć w nawias. Na przykład, aby sprawdzić, czy dana wartość jest jedną ze zbioru wartości, można w klauzuli WHERE kwerendy SQL użyć następującego kodu:

WHERE Region In ('GD', 'WA', 'WR')

Kod ten pozwala sprawdzić, czy pole Region zawiera którykolwiek z powyższych skrótów, które reprezentują województwo gdańskie, warszawskie i wrocławskie.


Nieprawidłowe użycie operatora Is. (Błąd 2443)

Operator Is służy do określania, czy wyrażenie jest równe Null. Operatora Is można użyć w wyrażeniu tylko ze słowami NULL lub NOT NULL.


Tabela MSysConf serwera istnieje, ale ma nieprawidłowy format. Skontaktuj się z administratorem systemu. (Błąd 3407)

Tabela MSysConf utworzona na serwerze w celu usprawnienia komunikacji pomiędzy aparatem bazy danych Microsoft Jet i połączonym źródłem danych ODBC wymaga bardzo specyficznego formatu.


Błąd składniowy w liczbie. (Błąd 2420)

Wprowadzona wartość jest niepoprawna. Błąd ten może wystąpić, jeżeli wartość nienumeryczna została wprowadzona jako część wyrażenia.


Nieprawidłowy zakres. (Błąd 3181)

Usiłowano dokonać importu z arkusza kalkulacyjnego komórek z nieprawidłowego zakresu.


Błąd składniowy w ciągu znaków. (Błąd 2422)

Wprowadzone wyrażenie zawiera niepoprawny ciąg znaków. Sprawdź wyrażenie, aby upewnić się, że zostało wprowadzone poprawnie.


Niepoprawne użycie kresek pionowych. (Błąd 2437)

Wprowadzono wyrażenie, które zawiera niepoprawne kreski pionowe (|). Sprawdź wyrażenie, aby upewnić się, że zostało wprowadzone poprawnie.


Nieprawidłowa nazwa tabeli. (Błąd 3177)

Podana nazwa nie spełnia wymagań standardowej konwencji nazewnictwa. Wprowadź nową nazwę i powtórz operację.


W filtrze typu Boolean nie można użyć kolumny <nazwa> typu Binary. (Błąd 3658)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nieprawidłowy format pliku. (Błąd 3182)

Prawdopodobne przyczyny:

  • Plik, który usiłowano odczytać lub do którego usiłowano się dołączyć, jest uszkodzony. Należy skopiować zapasową kopię pliku na dysk, a następnie powtórzyć operację.
  • Nie można rozpoznać formatu pliku. Jeśli plik jest plikiem Btrieve, dBASE lub Paradox, należy uruchomić ponownie program instalacyjny w celu zainstalowania instalowalnego sterownika ISAM, a następnie dołączyć się do pliku.


Błąd przy obliczaniu wartości wyrażenia filtru typu Boolean dla tabeli <nazwa>. (Błąd 3657)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można synchronizować repliki częściowej z inną repliką częściową. (Błąd 3648)

Nastąpiła próba synchronizacji z bazy danych, która jest repliką częściową. Nie można synchronizować repliki częściowej z inną repliką częściową, ponieważ ta druga może nie zawierać wszystkich rekordów spełniających warunki filtr pierwszej repliki.


Operator Between bez And. (Błąd 2430)

Stosując operator Between do testowania, czy wartość wyrażenia leży w określonym zakresie, należy określić dolną i górną granicę, rozdzielając je zarezerwowanym słowem And. Na przykład, aby sprawdzić zawieranie się w zakresie od A do C, można użyć poniższego kodu:

WHERE NazwaPola Between "A" And "C"


Synchronizator nie ma dostępu do bazy danych zawierającej komunikaty. (Błąd 3525)

Baza danych zawierająca komunikaty nie jest dostępna dla Synchronizatora. Prawdopodobnie pliki tej bazy danych są używane przez inny program lub użytkownika (użytkownicy nie powinni otwierać bazy danych komunikatów Synchronizatora). Należy zamknąć wszystkie aplikacje, które mogą korzystać bazy danych zawierającej komunikaty.


Nie można utworzyć repliki tego typu z podanej repliki źródłowej. (Błąd 3737)

Nie można utworzyć repliki o innym zakresie, za wyjątkiem repliki globalnej. Na przykład, lokalna replika może utworzyć jedynie lokalną replikę, a replika anonimowa może utworzyć jedynie replikę anonimową. Z replik globalnych można utworzyć repliki globalne, lokalne, lub anonimowe.


Nie można utworzyć częściowej repliki systemowej bazy danych. (Błąd 3635)

Nastąpiła próba utworzenia repliką częściową z wykorzystaniem pliku informacyjnego grupy roboczej jako źródła. Plik informacyjny grupy roboczej nie może być replikowany.


Nie można utworzyć repliki, korzystając z repliki częściowej. (Błąd 3634)

Nastąpiła próba utworzenia repliki przy użyciu repliki częściowej jako źródła. Repliki częściowe nie mogą być replikowane.


Nie można znaleźć .dll <nazwa>. (Błąd 3463)

Upewnij się, czy podana biblioteka DLL znajduje się na swoim miejscu lub zainstaluj ponownie Menedżera replikacji (bądź swoją aplikację).


Synchronizator nie może znaleźć zapisu o danej synchronizacji w tabeli MSysExchangeLog. (Błąd 3522)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie może odnaleźć pliku wykonywalnego (mstran40.exe). (Błąd 3627)

Próbowano uruchomić program Synchronizator, ale plik Mstran40.exe nie został znaleziony w podanym katalogu.


Synchronizator lub Menedżer replikacji nie mogą zlokalizować obiektu systemowego. (Błąd 3527)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie może znaleźć odpowiedniego numeru wersji w tabeli MSysSchChange. (Błąd 3523)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Obiektu <nazwa> zawartego w kontenerze <nazwa> nie można uczynić replikowalnym. (Błąd 3583)

Obiekt (tabela, formularz, raport, moduł, makro) zawarty we wskazanym kontenerze nie może być przekształcony do postaci replikowalnej.

Przykładem takiego obiektu jest tabela zawierająca 253 lub więcej pól. Ponieważ w wyniku replikacji liczba pól w tabeli jest zwiększana o co najmniej 3, zostałaby przekroczona maksymalna dozwolona w tabeli liczba 255 pól.


Nie można modyfikować systemowego obiektu replikacji <nazwa>. (Błąd 3665)

Nastąpiła próba wykonania błędnej operacji, takiej jak usunięcie tabeli systemowej, zmiana nazwy tabeli systemowej, lub usunięcie kolumny systemu replikacji, albo wewnętrznego obiektu systemu replikacji.


Nie można modyfikować systemowego obiektu replikacji <nazwa>. (Błąd 3666)

Nastąpiła próba wykonania błędnej operacji, takiej jak usunięcie tabeli systemowej, zmiana nazwy tabeli, lub usunięcie kolumny replikacji, albo wewnętrznego obiektu systemu replikacji.


Nie można uruchomić aplikacji. Plik informacyjny grupy roboczej nie istnieje lub został otwarty w trybie wyłączności przez

Nie można uruchomić aplikacji. Plik informacyjny grupy roboczej nie istnieje lub został otwarty w trybie wyłączności przez innego użytkownika. (Błąd 3028)

Aby zapewnić integralność referencyjną w bazach danych utworzonych przez aparat bazy danych Microsoft Jet, Twoja aplikacja musi odczytywać plik System.mdw aparatu Microsoft® Jet. Upewnij się, że plik jest w miejscu określonym w wartości SystemDB klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet Rejestru systemowego Windows.


Nie można zmienić nazwy instalowalnego pliku ISAM. (Błąd 3013)

Nastąpiła próba zmiany nazwy tabeli Btrieve, dBASE lub Paradox umieszczonej w pliku, którego nazwa nie może być zmieniana.

Prawdopodobne przyczyny:

  • Plik w systemie operacyjnym lub stosowanej sieci został zdefiniowany jako tylko do odczytu.
  • Nie posiadasz uprawnień zapisu do pliku w środowisku sieciowym.


Nie można otworzyć pliku Paradox.net. (Błąd 3172)

Prawdopodobne przyczyny:

  • Wartość ParadoxNetPath klucza Rejestru \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox jest nieprawidłowa. Ten błąd powstaje, gdy używana jest zewnętrzna baza danych Paradox, a wartość ParadoxNetPath wskazuje na nieistniejący katalog. Należy zakończyć pracę z aplikacją, poprawić nieprawidłową pozycję i powtórzyć operację.
  • Wartość Rejestru ParadoxNetPath wskazuje na dysk sieciowy, ale połączenie z tym dyskiem nie zostało nawiązane. Należy upewnić się, że napęd sieciowy jest dostępny, a następnie powtórzyć operację.


Nie można umieścić w tabeli drugiego pola typu Autonumer przeznaczonego na identyfikator repliki (ReplicaID). (Błąd 3486)

Tabela, którą próbujesz zmienić, posiada już jedno pole typu Autonumer (lub GUID) przeznaczone na identyfikator repliki. Jeżeli tworzone drugie pole z identyfikatorem repliki ma służyć jako klucz obcy, powinno być typu numerycznego, a nie typu Autonumer.


Osiągnięto maksymalny rozmiar bazy danych. (Błąd 3036)

Aby dodać dane do bazy danych, należy zmniejszyć jej rozmiar, usuwając zbędne dane. Maksymalny rozmiar bazy danych dla aparatu Microsoft® Jet 3.X jest mniejszy niż 1,07 GB. Maksymalny rozmiar bazy danych dla aparatu Microsoft Jet 4.0 wynosi 2,14 GB.


Synchronizacja nie powiodła się, ponieważ nie można było wykonać zmiany projektu jednej z replik. (Błąd 3492)

Aparat bazy danych Microsoft Jet usiłował uaktualnić projekt bazy danych w jednej z replik. Wśród możliwych przyczyn tego błędu są następujące:

  • Obiekt, którego usiłowano uaktualnić jest już otwarty w replice.
  • Dodano wymuszony związek w replice, która posiada klucz obcy odwołujący się do nieistniejącego klucza podstawowego.

Aby uzyskać dodatkowe informacje o przyczynie błędu operacji synchronizacji, należy zapoznać się z zawartością tabeli MSysSchemaProb we wzorcu lub w replice, która była przedmiotem synchronizacji.


Nie można rozpocząć sesji. (Błąd 3002)

Nastąpiła próba zainicjowania operacji wymagającej nowej sesji, lecz limit sesji jednocześnie aktywnych został wyczerpany. Poczekaj, aż inne operacje zakończą się lub przerwij je, a następnie powtórz operację.


Nie można zbudować klucza. (Błąd 3250)

Podczas tworzenia indeksu podstawowego aparat baz danych Microsoft Jet nie mógł utworzyć klucza podstawowego. Należy upewnić się, że pola klucza mają prawidłowe nazwy, oraz że nie istnieją powtarzające się rekordy bazujące na tym kluczu.

Ten błąd może wystąpić, jeśli użyto metody Seek, do której przekazano wartość pola nie będącego częścią indeksu. Na przykład załóżmy, że chcemy użyć metody Seek na obiekcie Recordset, którego bieżący indeks używa pola Nazwisko w odpowiedniej tabeli. Można to zapisać w następujący sposób:

rstPracownicy.Seek "=", "Kowalski", "Jan"

Aparat Microsoft® Jet będzie usiłował skonstruować klucz podstawowy z dwóch pól, lecz ponieważ tylko jedno z nich jest indeksowane, próba ta nie powiedzie się i wystąpi błąd.


Nie można zmienić hasła dla współużytkowanej otwartej bazy danych. (Błąd 3621)

Aby zmienić hasło, baza danych musi być otwarta w trybie wyłączności.


Nie można dokonać zmiany projektu replikowanej bazy danych. (Błąd 3452)

Zmiany projektu replikowanych baz danych mogą być dokonywane jedynie we wzorcu. Replika, którą próbujesz zmienić nie jest wzorcem głównym zestawu replik. W tej sytuacji należy odszukać właściwy wzorzec i w nim dokonać żądanych zmian.


Baza danych poddawana replikacji nie może być przekształcona. (Błąd 3487)

Replikowane mogą być jedynie bazy danych utworzone za pomocą aparatu bazy danych Microsoft Jet o numerze wersji 3.0 lub późniejszym. Chociaż bazę danych można otworzyć przy użyciu instalowalnego sterownika ISAM, nie można jej jednak przekształcić do postaci replikowalnej. Jeżeli baza danych została utworzona za pomocą wcześniejszej wersji aparatu Microsoft® Jet, można poddać ją konwersji do nowszego formatu uruchamiając program Microsoft Access. Z menu Narzędzia należy wybrać polecenie Narzędzia bazy danych, a następnie kliknąć przycisk Konwertuj bazę danych. Jeżeli baza danych jest w innym formacie, należy najpierw dane wyeksportować do nowej bazy danych Microsoft Jet i spróbować ponownie.


Nie można utworzyć wartości typu GUID. (Błąd 3553)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można utworzyć repliki systemowej bazy danych. (Błąd 3639)

Nastąpiła próba replikacji pliku informacyjnego grupy roboczej. Plik informacyjny grupy roboczej nie może być replikowany.


Nie można usunąć podanego parametru Rejestru dla Synchronizatora. (Błąd 3551)

Należy na komputerze ponownie skonfigurować Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. Z menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Błąd przy replikacji bazy danych; nie można określić, czy baza danych jest otwarta w trybie wyłączności. (Błąd 3578)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można ustanawiać ani aktualizować wymuszonych relacji pomiędzy tabelą replikowaną a tabelą lokalną. (Błąd 3453)

Podjęta została próba utworzenia lub aktualizacji wymuszonej relacji pomiędzy tabelą replikowaną i tabelą nie replikowaną. Replikacja wyklucza wymuszone relacje między tabelami, takimi jak:

  • Tabela replikowana i tabela lokalna.
  • Dwie lokalne tabele, które zostały tabelami replikowanymi;
  • Dwie tabele o różnych ustawieniach właściwości KeepLocal.

Zakwestionowaną relację między tabelami należy usunąć przed przystąpieniem do kolejnych operacji.


Błąd przy wyliczaniu ograniczenia <nazwa> CHECK. <Dodatkowa informacja.> (Błąd 3802)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Menedżer replikacji nie znalazł wartości ExchangeID w tabeli MSysExchangeLog. (Błąd 3496)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej firmy Microsoft.


Synchronizator nie może znaleźć źródłowego pliku komunikatów. (Błąd 3564)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Docelowy Synchronizator nie został skonfigurowany do wykonywania synchronizacji pośredniej oraz docelowa replika jest

Docelowy Synchronizator nie został skonfigurowany do wykonywania synchronizacji pośredniej oraz docelowa replika jest niedostępna dla synchronizacji bezpośredniej. (Błąd 3516)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Brak Synchronizatora w tabeli MSysTranspAddress. (Błąd 3518)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można znaleźć prawidłowego transportu dla danego Synchronizatora. (Błąd 3509)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można załadować biblioteki DLL <nazwa>. (Błąd 3633)

Podana biblioteka DLL nie jest zarejestrowana lub nie znajduje się na ścieżce.


Podczas otwierania już używanej tabeli <tabela> nastąpiła próba zablokowania jej, co nie jest możliwe w przypadku tabeli

Podczas otwierania już używanej tabeli <tabela> nastąpiła próba zablokowania jej, co nie jest możliwe w przypadku tabeli będącej już w użyciu. Poczekaj chwilę, a następnie powtórz operację. (Błąd 3009)

Inny użytkownik zablokował wyłącznie tabelę, do której nastąpiła próba dostępu w trybie współużytkowania lub inny użytkownik zablokował w trybie współużytkowania tabelę, gdy nastąpiła próba jej wyłącznego otwarcia. Zwrócona nazwa użytkownika pokaże, kto obecnie posiada blokadę.


Nie można otworzyć pliku .inf. (Błąd 3165)

Podczas próby połączenia tabeli dBASE nie można było utworzyć lub otworzyć odpowiadającego jej pliku .inf zawierającego informacje dotyczące indeksów.

Prawdopodobne przyczyny:

  • Nie ma dość miejsca na dysku, aby utworzyć plik .inf.
  • Nie posiadasz uprawnień do zapisu dla dysku sieciowego w środowisku sieciowym.


Baza danych nie może zostać przekształcona do postaci replikowalnej. (Błąd 3455)

Aparat bazy danych Microsoft Jet przeprowadzał proces przekształcania bazy danych do postaci replikowalnej. Operacja nie powiodła się z powodu niewystarczających zasobów systemowych. W tej sytuacji należy upewnić się, że całkowita liczba pól w jednej tabeli po replikacji nie przekroczy 255, a całkowita liczba bajtów w rekordzie nie przekroczy 2048.


Replika częściowa nie może stać się wzorcem zestawu replik. (Błąd 3479)

Wybierz inną replikę na wzorzec główny.


Po wykonaniu na bazie danych operacji replikowania nie można już z tej bazy usunąć żadnych cech związanych z replikacją. (Błąd

Po wykonaniu na bazie danych operacji replikowania nie można już z tej bazy usunąć żadnych cech związanych z replikacją. (Błąd 3459)

Cechy związane z replikacją nie mogą być usunięte z bazy danych ani przez ustawienie właściwości Replicable na wartość "T", ani przez konwersję za pomocą Aktówki Windows®, programu Microsoft Access lub Menedżera replikacji. Również ustawienie za pomocą DAO właściwości Replicable bazy danych na wartość "F" lub na dowolną inną wartość nie ma wpływu na bazę danych poddaną replikacji. Jeżeli jest potrzebna kopia bazy danych nie zawierająca właściwości, pól, tabel i innych elementów związanych z replikacją, należy otworzyć kopię zapasową bazy danych wykonaną zanim baza danych została pierwszy raz poddana replikacji.


Nie można otworzyć pliku <nazwa>. (Błąd 3176)

Określony plik tekstowy lub arkusz nie mógł być otwarty. Specyfikacja pliku może być nieprawidłowa, inny użytkownik może aktualnie operować na pliku, lub też możesz nie mieć uprawnień do odczytu pliku. Należy zaczekać, aż inny użytkownik przestanie korzystać z pliku i następnie powtórzyć operację albo też skontaktować się z administratorem systemu lub administratorem sieci.


Plik dziennika <nazwa> nie może być otwarty do pisania. (Błąd 3474)

Należy sprawdzić prawa dostępu do pliku dziennika.


Próbowano łączyć lub importować plik korespondencji seryjnej Microsoft Word. Pliki takie można eksportować, ale nie można ich

Próbowano łączyć lub importować plik korespondencji seryjnej Microsoft Word. Pliki takie można eksportować, ale nie można ich łączyć ani importować. (Błąd 3439)

Próbowano łączyć lub importować plik korespondencji seryjnej Microsoft® Word. Pliki takie można eksportować, ale nie można ich łączyć ani importować.


Baza danych chroniona hasłem nie może być replikowana; dla replikowanej bazy danych nie można też ustawić hasła. (Błąd 3592)

Jeśli baza danych jest chroniona hasłem, usuń to hasło.


Nie można wypełnić repliki lub zmienić filtru repliki, gdyż w replice występują konflikty lub błędy danych. (Błąd 3636)

Nastąpiła próba zmiany filtru repliką częściową lub próba jej wypełnienia, podczas gdy w replice występują konflikty lub błędy danych. Aby kontynuować pracę, należy usunąć te konflikty lub błędy. Chroni to przed niezamierzoną utratą informacji o konfliktach i zapewnia całościowe poprawienie błędów.


Nie można uzyskać informacji o pełnej ścieżce dla danego elementu zestawu replik. (Błąd 3499)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można odczytać z Rejestru wartości podanego parametru Synchronizatora. (Błąd 3494)

Należy na komputerze ponownie skonfigurować Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom Menedżera replikacji.
  2. Z menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Nie można ustawić wartości. (Błąd 2448)

Nastąpiła próba ustawienia wartości obiektu, który jest tylko do odczytu lub nie posiada wartości.


Nie można ustawić właściwości KeepLocal dla obiektu, który już został zreplikowany. (Błąd 3457)

Właściwości KeepLocal nie można ustawić dla obiektu replikowanego. Ustawienie dla lokalnego obiektu właściwości KeepLocal po tym, jak baza danych została zreplikowana, jest ignorowane. Aby uniknąć replikowania obiektu do innych replik w danym zestawie, należy ustawić dla tego obiektu właściwości Replicable na wartość "F".


Nie można zmienić atrybutu trybu aktualizacji danych dla zestawu replik. Dopuszcza on zmiany tylko we wzorcu. (Błąd 3594)

Atrybut określający, czy zestaw replik pozwala użytkownikom zmieniać dane we wszystkich replikach czy jedynie we wzorcu głównym, jest określony przy pierwszym przekształceniu bazy danych do wzorca głównego. Po tym przekształceniu atrybut określający dopuszczalność wielokrotnej aktualizacji danych nie może być zmieniony.


Nie można zmienić atrybutu trybu aktualizacji danych dla zestawu replik. (Błąd 3593)

Atrybut określający, czy zestaw replik pozwala użytkownikom zmieniać dane we wszystkich replikach czy jedynie we wzorcu głównym, jest określony przy pierwszym przekształceniu bazy danych do wzorca głównego. Po tym przekształceniu atrybut określający dopuszczalność wielokrotnej aktualizacji danych nie może być zmieniony.


Podany parametr Synchronizatora nie może być ustawiony w Rejestrze. (Błąd 3493)

Należy na komputerze ponownie skonfigurować Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom Menedżera replikacji.
  2. Z menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Nie można zmienić zawartości systemowej kolumny replikacji. (Błąd 3577)

Kolumna, której zawartość usiłowano zmienić, jest kolumną systemową, przeznaczoną tylko do odczytu.


Operacja na tabeli bazy danych Paradox nie może być wykonana bez określenia klucza podstawowego. (Błąd 3207)

Uruchom aplikację, która utworzyła tabelę, następnie dodaj klucz podstawowy. Po wykonaniu tej czynności powtórz operację.


Wystąpił błąd podczas pisania do dziennika Synchronizatora. (Błąd 3471)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można pisać do pliku <nazwa>. (Błąd 3180)

Nastąpiła próba eksportu danych do określonego pliku tekstowego lub arkusza, ale plik nie może być modyfikowany.

Prawdopodobne przyczyny:

  • Inny użytkownik aktualnie może operować na pliku. Należy zaczekać, aż inny użytkownik przestanie korzystać z pliku i następnie powtórzyć operację.
  • Plik w systemie operacyjnym lub stosowanej sieci został zdefiniowany jako tylko do odczytu. Należy zmienić tryb dostępu do pliku i następnie powtórzyć operację.
  • Nie posiadasz praw zapisu dla pliku w środowisku sieciowym.

Może zajść potrzeba skontaktowania się z administratorem systemu lub administratorem sieci.


Ta tabela zawiera komórki o wartościach spoza zakresu zdefiniowanego w tym arkuszu. (Błąd 3673)

Odczytywany plik arkusza nie jest utworzony poprawnie. Zawiera on dane wykraczające poza zakres określony w nagłówku pliku. Sterownik arkusza nie potrafi stabilnie odczytywać danych z niepoprawnie utworzonego arkusza.

Plik może nie być arkuszem lub mógł zostać uszkodzony. Spróbuj odczytać plik w programie, w którym został on utworzony i zapisać go do innego pliku. Oryginalny program może naprawić błędy.


Nie można zmienić nazwy pola <nazwa>. Jest ono częścią jednej lub więcej relacji. (Błąd 3720)

Ten błąd występuje podczas próby zmiany nazwy lub definicji klucza podstawowego, do którego odwołują się inne klucze obce. Aby zmienić definicję lub nazwę kolumn uczestniczących w kluczu podstawowym, należy najpierw usunąć wszystkie odwołania klucza obcego do klucza podstawowego. To zdarza się najczęściej przy użyciu instrukcji ALTER TABLE ALTER COLUMN.


Ograniczenie CHECK <nazwa> nie istnieje. (Błąd 3755)

Ten błąd występuje, gdy przy użyciu składni ALTER TABLE ALTER COLUMN, próbujesz użyć instrukcji DROP na ograniczeniu CHECK, które nie istnieje. Ten błąd może się także pojawić przy próbie użycia mechanizmu Microsoft® OLE DB Provider dla aparatu Jet w celu otrzymania informacji na temat ograniczenia CHECK, które nie istnieje.


Błąd składniowy w ograniczeniu klauzuli CHECK. (Błąd 3765)

Ten błąd występuje przy użyciu bibliotek DLL języka SQL do definicji ograniczenia CHECK. Pojawia się on, gdy warunek poszukiwania (instrukcja SELECT) w klauzuli CHECK odwołuje się do nieprawidłowej tabeli lub nazwy kolumny.


Ograniczenie CHECK <nazwa> już istnieje. (Błąd 3756)

Ten błąd występuje, gdy przy użyciu składni ALTER TABLE ALTER COLUMN, próbujesz użyć nazwy ograniczenia dla ograniczenia CHECK użytego już w tej tabeli. Ten błąd może także pojawić się przy próbie użycia mechanizmu Microsoft® OLE DB Provider dla aparatu Jet i próbie dodania ograniczenia CHECK posiadającego taką samą nazwę jak inne ograniczenie CHECK w tej samej tabeli.


Klient zażądał, by Synchronizator zakończył działanie. (Błąd 3535)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Tabela wynikowa nie może mieć więcej niż jedno pole typu Autonumer. (Błąd 3090)

Nastąpiła próba wykonania kwerendy, której wynikiem jest tabela z więcej niż jednym polem typu Autonumer. Zmień kwerendę tak, aby zawierała tylko jedno pole typu Autonumer.


Nie można utworzyć indeksu dla tego pola. (Błąd 3287)

Nastąpiła próba utworzenia indeksu dla pola typu Memo lub obiekt OLE. Należy określić inne pole, a następnie powtórzyć operację.

Błąd ten może również wystąpić, jeśli próbowano utworzyć indeks dla jednobajtowego pola z tabeli Btrieve.


Liczby kolumn z dwóch wybranych tabel lub kwerend kwerendy składającej nie są zgodne. (Błąd 3307)

Dwie tabele lub kwerendy składane przez operację UNION muszą generować taką samą liczbę kolumn. Usuń kolumny z tej instrukcji SELECT, która ma za dużo kolumn lub dołącz więcej kolumn do tej instrukcji SELECT, która ma ich za mało.

Uwaga W tej instrukcji SELECT, która ma za mało kolumn, można zamiast kolumn umieścić stałą. Na przykład następująca kwerenda składająca generuje trzy kolumny w pierwszej instrukcji i tylko jedną kolumnę i dwie stałe w drugiej instrukcji SELECT. Kwerenda zwraca wszystkie kraje z tabeli Pracownicy i Regiony. Ponadto z tabeli Pracownicy kwerenda zwraca nazwisko i imię pracownika. Jeżeli jednak nazwa kraju pochodzi z tabeli Regiony, kwerenda zwraca Null w kolumnach Imię i Nazwisko.

SELECT Kraj, Imię, Nazwisko FROM Pracownicy

UNION SELECT Kraj, NULL, NULL FROM Regiony;


Pole nie mieści się w rekordzie. (Błąd 3016)

Nastąpiła próba importu lub wstawienia zbyt dużego pola. Rozważ możliwość rozbicia pola na mniejsze fragmenty i import lub wstawienie danych do wielu pól, bądź też możliwość zmiany typu danych pola.

Rozmiar rekordów jest ograniczony do prawie 2K, z wyłączeniem pól typu Memo i obiekt OLE.


Nie można zdefiniować pola więcej niż jeden raz. (Błąd 3191)

Usiłowano utworzyć tabelę, w której więcej niż jedno pole zostało zdefiniowane z tą samą nazwą. Każda nazwa pola w tabeli musi być unikatowa.


Nie można usunąć tego pola. Wchodzi ono w skład jednej lub więcej relacji. (Błąd 3303)

Nastąpiła próba usunięcia pola, dla której zdefiniowana została relacja w bazie danych. Aby usunąć pole, trzeba najpierw usunąć jego relacje.


Nie można usunąć pola będącego częścią indeksu lub niezbędnego dla systemu. (Błąd 3280)

Aby usunąć pole będące częścią indeksu, należy przedtem usunąć indeks.


Nie można zmienić właściwość śledzenia na poziomie kolumny (Column Level Tracking) dla obiektów replikowalnych. (Błąd 3779)

Jeżeli obiekt został już przekształcony na postać replikowalną, właściwość śledzenia na poziomie kolumny (Column Level Tracking) nie może zostać zmieniona. Jeśli chcesz zmienić śledzenie obiektu, obiekt musi stać się lokalny. Następnie można zmienić właściwość Column Level Tracking i ponownie uczynić obiekt replikowalnym.


Nie można znaleźć pola. (Błąd 3018)

Prawdopodobne przyczyny:

  • Określone pole nie istnieje.
  • Nazwa obiektu została podana nieprawidłowo. Sprawdź, czy nie brakuje znaków podkreślenia ( _ ) lub innych znaków interpunkcyjnych, sprawdź też, czy nie wprowadzono spacji poprzedzających nazwę.
  • Wprowadzono niewłaściwy identyfikator pola. Na przykład, [Moja Tabela]_[Moje Pole] zamiast MojaTabela![Moje Pole].
  • Nie zastosowano nawiasów, aby zamknąć w nich nazwę pola zawierającą spacje.


Nie można znaleźć pola <nazwa>. (Błąd 3799)

Nastąpiło odwołanie do nieistniejącej kolumny.


Operacja JOIN <operacja> odwołuje się do pola nie znajdującego się w jednej z podanych tabel. (Błąd 3082)

Nastąpiła próba wykonania instrukcji SQL, która zawiera błędne sprzężenie. Błąd ten występuje przy próbie utworzenia sprzężenia za pomocą pola, którego brak w jednej ze sprzęganych tabel. Poniższy przykład powoduje wystąpienie tego błędu:

SELECT Autorzy.Nazwisko, Tytuły.ISBN

FROM Autorzy, Tytuły, TytułyAutorów,

Autorzy INNER JOIN Tytuły ON Autorzy.ID = TytułyAutorów.ISBN;

Błąd występuje, gdyż sprzężenie dotyczy tabel Autorzy i Tytuły, natomiast sprzęgane pola znajdują się w tabelach Autorzy i TytułyAutorów.


Pole nie może zostać zaktualizowane. (Błąd 3164)

Prawdopodobne przyczyny:

  • Usiłowano uaktualnić pola w rekordzie lub tabeli, które są aktualnie zablokowane przez innego użytkownika. Należy poczekać, dopóki ten inny użytkownik nie zakończy pracy z rekordem, a następnie powtórzyć operację.
  • Podczas pracy z bazą Microsoft® Access usiłowano zmienić wartość formantu, którego właściwość Locked jest ustawiona na Yes.


Nie można dokonać replikacji tabeli; liczba kolumn przekroczyła dopuszczalną wartość maksymalną. (Błąd 3585)

Tabela przekroczyła maksymalną dozwoloną liczbę kolumn. Jeśli tabela ma mniej niż 251 kolumn, operacja kompaktowania bazy danych może odzyskać dostępne kolumny, które zaliczają się do tej liczby.


Rozmiar pola jest zbyt duży. (Błąd 3017)

Prawdopodobne przyczyny:

  • Nastąpiła próba zdefiniowania lub utworzenia pola typu Text dłuższego niż 254 znaki. Podaj liczbę z przedziału między 1 i 254, a następnie powtórz operację lub utwórz dla danych pole typu Memo.
  • Nastąpiła próba zdefiniowania parametru kwerendy, którego długość przekracza 255 znaków.


Szerokość kolumny tekstu Unicode musi zajmować parzystą liczbę bajtów. (Błąd 3702)

Baza danych przechowuje dane używając zestawu znaków Unicode, w którym każdy znak jest wartością zajmującą słowo (dwa bajty). Kolumny dla tekstu muszą być zdeklarowane tak, aby zajmowały parzystą liczbę bajtów i pomieściły dokładną liczbę znaków Unicode.

  • Jeżeli ten komunikat błędu pojawia się podczas tworzenia bazy danych, program próbujący utworzyć niepoprawną bazę danych powinien być poprawiony.
  • Jeżeli ten komunikat pojawia się podczas normalnej pracy, prawdopodobną przyczyną jest uszkodzenie bazy, która musi być skompaktowana i lub naprawiona.


Długość połączonej nazwy serwera internetowego, nazwy HTTP i aliasu FTP nie powinna przekroczyć 252 znaków. (Błąd 3745)

Podane wartości pośrednie lub internetowe przekraczają wewnętrzny limit 252 znaków. Należy skrócić nazwę przekraczającą limit.


Nie można odczytać rekordu -- jest on obecnie zablokowany przez innego użytkownika (Błąd 3624)

Nie można odczytać rekordu — jest on obecnie zablokowany przez innego użytkownika (Błąd 3624)

Nastąpiła próba odczytu rekordu z 2-kilobajtowej strony bazy danych, która jest aktualnie zablokowana przez innego użytkownika. Należy poczekać, aż ten użytkownik zakończy pracę z danym rekordem i ponowić próbę operacji.


Nie można dokonać odczytu; strona aktualnie zablokowana przez użytkownika <nazwa> na komputerze <nazwa>. (Błąd 3187)

Nastąpiła próba odczytu informacji ze strony bazy danych, która jest obecnie zablokowana przez innego użytkownika. Należy poczekać, dopóki inny użytkownik nie zakończy pracy z rekordem, a następnie powtórzyć operację.


Schemat jednoczesnych zmian spowodował niepomyślne zakończenie operacji tworzenia repliki. Należy ponowić próbę. (Błąd 3763)

Podczas operacji tworzenia repliki nowe obiekty nie pozwalające na pomyślne zakończenie operacji mogły zostać utworzone w replice źródłowej. Należy ponowić próbę.


Opcje kaskadowe dla nowego odwołania pozostają w konflikcie z istniejącym odwołaniem <nazwa>. (Błąd 3707)

Ten błąd pojawia się, jeżeli akcja CASCADE zdefiniowana jest dla kolumny posiadającej już inny typ akcji CASCADE. Na przykład, jeżeli określona jest już akcja CASCADE DELETE, użytkownik nie będzie mógł dodać akcji CASCADE UPDATE. Aby zastosować żądaną akcję CASCADE, oryginalne ograniczenie CONSTRAINT musi być opuszczone. Możne to być wykonane za pomocą składni ALTER TABLE ALTER COLUMN lub DROP CONSTRAINT.


Nie można dodać nowych kolumn do tabeli <nazwa>. Usuń zbędne kolumny i skompaktuj bazę danych. (Błąd 3740)

Limit kolumn dla określonej tabeli został przekroczony. Zaprojektuj tabelę z mniejszą ilością kolumn.


Nie można zmienić nazw tabel powodujących konflikt. (Błąd 3769)

Tabela powodująca konflikt jest tabelą systemową, której nazwy nie można zmienić. Aby usunąć konflikt z repliki, zawartość konfliktowej tabeli może zostać usunięta i sama tabela może również zostać usunięta.


Ciąg połączenia jest za długi. (Błąd 3210)

Ciąg połączenia w klauzuli IN instrukcji SQL nie może mieć więcej niż 255 znaków. Należy poprawić ten element i ponowić operację.


Nieznane lub nieprawidłowe odwołanie do pola <nazwa>. (Błąd 3345)

Podane wyrażenie odwołuje się do pola w niepoprawny sposób lub odwołuje się do nieistniejącego pola. Podaj prawidłową nazwę pola.


Nie udało się zablokować pliku. (Błąd 3050)

System operacyjny nie zezwolił, by aparat Microsoft® Jet utworzył plik blokad (.LDB) w tym samym katalogu, w którym znajduje się plik bazy danych (.MDB). Należy posiadać uprawnienia zapisu do katalogu zawierającego bazę danych, którą próbujesz otworzyć. Ten błąd może także wystąpić jeśli próbujesz użyć właściwości pasywne zamknięcie/kontrola połączenia podczas, gdy baza danych jest otwarta w trybie wyłączności.


Aktualizacja nie jest możliwa z powodu blokady. (Błąd 3218)

Nastąpiła próba aktualizacji danych znajdujących się na aktualnie zablokowanej stronie.

Prawdopodobne przyczyny:

  • Zapisywana kwerenda jest aktualnie używana przez kogoś innego. Aby zapisać kwerendę, trzeba poczekać, aż zostanie ona zwolniona przez innego użytkownika.
  • Można też zapisać ją pod inną nazwą. Próbowano zastosować metodę Edit na stronie danych zawierającej otwarty lub zablokowany rekord.


Definicja licznika w niepoprawnym zakresie. (Błąd 3770)

Ten błąd pojawia się podczas próby utworzenia kolumny typu danych IDENTITY lub COUNTER i podania opcjonalnej wartości początkowej i wartości przyrostu. Wartość początkowa i przyrost muszą zawierać się w zakresie typu danych LONG.


Błąd podczas tworzenia pliku. (Błąd 3436)

Błąd podczas próby utworzenia pliku tekstowego lub pliku w formacie Microsoft Excel lub instalowalnego sterownika ISAM w formacie Lotus.

Prawdopodobne przyczyny:

  • Brak pamięci dyskowej,
  • Błąd sieci.


Ta operacja wymaga innej biblioteki kursorów. (Błąd 3663)

Typ kursora wybrany podczas otwarcia zestawu rekordów nie obsługuje żądanej operacji. Otwórz zestawu rekordów ponownie z odpowiednim typem kursora lub użyj właściwej operacji dla obecnego typu kursora. Ten błąd występuje jedynie podczas użycia ODBCDirect.


Baza danych, którą próbowano otworzyć, jest używana przez inną aplikację. (Błąd 3576)

Przy próbie otwarcia bazy danych w trybie wyłącznym błąd ten może oznaczać, iż baza jest już otwarta przez inną aplikację. Przy próbie otwarcia bazy danych w trybie współużytkowania błąd ten może oznaczać, że inna aplikacja otworzyła tę bazę w trybie wyłączności. Zamknij aplikacje używające tej bazy danych i ponów próbę.


W bazie danych wystąpił problem. Usuń ten problem przez naprawę i kompaktowanie bazy danych. (Błąd 3428)

W bazie danych, z której próbowano korzystać, występuje bliżej nieokreślony problem i dlatego została ona oznaczona jako uszkodzona.

Aby rozwiązać ten problem

  1. Zamknij bazę danych.
  2. Napraw bazę danych, stosując metodę RepairDatabase. Operację tę można również wykonać w programie Microsoft Access, przechodząc do menu Narzędzia, wybierając opcję Narzędzia bazy danych a następnie polecenie Napraw bazę danych.
  3. Wykonaj kompaktowanie bazy danych, stosując metodę CompactDatabase. Operację tę można również wykonać w programie Microsoft Access, przechodząc do menu Narzędzia, wybierając opcję Narzędzia bazy danych a następnie polecenie Defragmentuj bazę danych.

Uwaga Należy wykonać wszystkie wymienione kroki.


Baza danych już istnieje. (Błąd 3204)

Wystąpiła próba utworzenia lub zmiany nazwy bazy danych przy użyciu nazwy, która już istnieje. Należy wpisać inną nazwę i ponowić operację.


Arkusz kalkulacyjny jest zapełniony. (Błąd 3437)

Próbowano dodać nowe rekordy do pliku w formacie Lotus 1-2-3 lub Microsoft® Excel 3.0 lub 4.0, ale plik jest już zapełniony. Wymienione typy plików mogą zawierać maksymalnie 16 384 rekordów.


Baza danych <nazwa bazy danych> jest używana przez inną osobę lub proces. Powtórz operację, gdy baza danych będzie ponownie

Baza danych <nazwa bazy danych> jest używana przez inną osobę lub proces. Powtórz operację, gdy baza danych będzie ponownie dostępna. (Błąd 3196)

Inny użytkownik lub sesja aktualnie ma wyłączny dostęp do podanej bazy danych. Należy poczekać, dopóki inny użytkownik lub sesja nie zakończy pracy z tą bazą danych, a następnie powtórzyć operację.


<Nazwa bazy danych> nie jest poprawną nazwą bazy danych. (Błąd 3005)

Określona nazwa bazy danych nie spełnia standardowych konwencji nazewnictwa dla nazw plików. Być może nazwa jest zbyt długa w stosunku do bufora zawierającego ścieżkę i nazwę pliku. Wprowadź nową nazwę i powtórz operację.


Baza danych <nazwa> jest zablokowana w sposób wyłączny. (Błąd 3006)

Nastąpiła próba użycia bazy danych otwartej aktualnie przez innego użytkownika do wyłącznego użytku. Poczekaj, aż użytkownik ten zakończy pracę z zablokowaną bazą danych, i powtórz operację.


Obiekt nie może być replikowany, ponieważ baza danych nie jest bazą replikowaną. (Błąd 3485)

Obiektu należącego do bazy danych nie można replikować, jeśli przedtem nie została replikowana sama baza danych. Bazę danych można replikować przez:

  • Przeciągając ją do Aktówki Microsoft® Windows®.
  • Używając programowania DAO do ustawienia właściwości Replicable na "T" lub właściwości ReplicableBool na True.
  • Wykorzystanie programu Microsoft Access.
  • Wykorzystanie Menedżera replikacji.

Podczas replikacji bazy danych wszystkie jej obiekty, które nie mają ustawionej właściwości KeepLocal, są również replikowane.


Nie można otworzyć bibliotecznej bazy danych <nazwa>. (Błąd 3007)

Podana baza danych jest wewnętrzną biblioteczną bazą danych aparatu baz danych Microsoft Jet, która nie może być otwierana.


Baza danych jest już replikowalna. (Błąd 3784)

Baza danych jest już replikowalna i nie może być ponownie uczyniona replikowalną. Jeżeli w bazie danych istnieją obiekty lokalne, które chcesz uczynić replikowalnymi, ustaw właściwość replikowalności na True we wzorcu głównym.


Tabele systemowe repliki są niepewne i replika nie powinna być używana. (Błąd 3595)

Replika na komputerze użytkownika jest zniszczona. Naprawiając replikę, aparat bazy danych Microsoft Jet mógł zmienić jedną lub kilka tabel systemowych. Należy usunąć tę replikę i zastąpić ją nową.


Baza danych aparatu Jet jest nieprawidłowa lub nie istnieje dla tego zestawu replik SQL/Jet. (Błąd 3778)

Baza danych aparatu Microsoft® Jet jest nieprawidłowa lub nie istnieje, ponieważ:

  • Ścieżka źródła danych podana w połączeniach serwera SQL wskazuje na nieprawidłową replikę dla tej publikacji. Replika mogła zostać zastąpiona, zniszczona lub nie została poprawnie utworzona.
  • Wiersz centralny jest nieprawidłowy lub nie istnieje.
  • Określona baza danych nie jest replikowalna.

Rozwiązaniem jest ponowne inicjowanie subskrybenta aparatu Jet za pomocą narzędzi ponownego inicjowania na serwerze SQL.


Aparat baz danych Microsoft Jet zatrzymał proces, ponieważ inny użytkownik próbuje jednocześnie zmienić te same dane.

Aparat baz danych Microsoft Jet zatrzymał proces, ponieważ inny użytkownik próbuje jednocześnie zmienić te same dane. (Błąd 3197)

Ten błąd może wystąpić w środowisku wielodostępnym.

Inny użytkownik zmienił dane, które usiłujesz uaktualnić. Ten błąd może wystąpić, gdy wielu użytkowników otwiera tabelę lub tworzy obiekt Recordset i stosuje blokowanie optymistyczne. W czasie między zastosowaniem metod Edit i Update inny użytkownik zmienił te same dane.

Aby zastąpić zmiany innego użytkownika własnymi zmianami, należy ponownie wykonać metodę Update.


Data znajduje się poza zakresem lub jest w nieprawidłowym formacie. (Błąd 3175)

Rozpoznawane są wyłącznie daty pomiędzy 30 grudnia 1899 a 30 grudnia 9999.

Prawdopodobne przyczyny:

  • Wprowadzono datę spoza dopuszczalnego zakresu.
  • Wprowadzono poprawną datę w formacie, którego nie można rozpoznać. Należy sprawdzić, czy data została prawidłowo wprowadzona, a następnie powtórzyć operację.


Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>.

Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>. Spróbuj ponownie, gdy baza danych będzie już dostępna. (Błąd 3704)

Ten błąd pojawia się, jeżeli baza danych jest otwarta w trybie wyłączności i nie jest współużytkowana. Ten błąd powstaje jeśli użytkownik utworzy nową bazę danych w DAO, ADO lub programie Microsoft® Access i nie zamknie bazy danych. Inni użytkownicy mogą otworzyć bazę danych, ale otrzymają powyższy komunikat.


Nie można wykonać tej operacji, ponieważ własności występujące w tej wersji są niedostępne w bazach danych zapisanych w

Nie można wykonać tej operacji, ponieważ własności występujące w tej wersji są niedostępne w bazach danych zapisanych w starszych formatach. (Błąd 3301)

Baza danych została zapisana we wcześniejszej wersji aparatu baz danych Microsoft Jet , która nie obsługuje tej własności. W takiej sytuacji należy wykonać konwersję bazy danych na format Microsoft® Jet 2.0 lub 3.0, bądź też tak zmodyfikować określoną operację, aby uniknąć korzystania z danej własności.


Błąd składniowy w poleceniu ALTER TABLE. (Błąd 3293)

Wpisano instrukcję SQL zawierającą nieprawidłową instrukcję ALTER TABLE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w definicji pola. (Błąd 3292)

Wystąpił błąd w definicji pola w instrukcjach CREATE TABLE lub ALTER TABLE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Pole <nazwa> już istnieje w tabeli <nazwa>. (Błąd 3380)

Podano tą samą nazwę pola dwa razy. Zmień kod, nadając każdemu polu niepowtarzalną nazwę. Sprawdź, czy określona nazwa pola istnieje w kolekcji Fields.


Nie można usunąć pola <nazwa>. Wchodzi ono w skład jednej lub więcej relacji. (Błąd 3383)

Nastąpiła próba usunięcia pola, dla którego zostały zdefiniowane relacje w bazie danych. Aby usunąć pole, trzeba najpierw usunąć jego relacje.


Brak pola o podanej nazwie <nazwa> w tabeli <nazwa>. (Błąd 3381)

Określona tabela nie zawiera podanego pola. Sprawdź, czy określona nazwa pola istnieje w kolekcji Fields.


Podane pola nie są jednoznacznie indeksowane w tabeli <nazwa>. (Błąd 3374)

Podane pola nie są jednoznacznie indeksowane w tabeli wskazywanej w klauzuli CONSTRAINT.


Rozmiar pola <nazwa> jest za duży. (Błąd 3382)

Pola tekstowe w tabelach Microsoft® FoxPro® nie mogą zawierać więcej niż 254 znaki, a w tabelach Microsoft Jet nie więcej niż 255 znaków. Zmień rozmiar pola.


Błąd składniowy w klauzuli CONSTRAINT. (Błąd 3289)

Wpisano instrukcję SQL zawierającą nieprawidłową klauzulę CONSTRAINT.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w poleceniu CREATE INDEX. (Błąd 3291)

Wpisano instrukcję SQL zawierającą nieprawidłową instrukcję CREATE INDEX.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w poleceniu CREATE TABLE. (Błąd 3290)

Wpisano instrukcję SQL zawierającą nieprawidłową instrukcję CREATE TABLE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Relacja musi dotyczyć takiej samej liczby pól o takich samych typach danych. (Błąd 3368)

Klauzula CONSTRAINT użyta przy tworzeniu relacji zawiera inną liczbę pól dla każdej tabeli lub zawiera pola o innym typie danych. Sprawdź liczbę pól w klauzuli CONSTRAINT, typy danych w polach tak, aby zapewnić ich zgodność, i spróbuj ponownie.


Błąd składniowy w poleceniu DROP INDEX. (Błąd 3294)

Wpisano instrukcję SQL zawierającą nieprawidłową instrukcję DROP INDEX.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w poleceniu DROP TABLE lub DROP INDEX. (Błąd 3295)

Wpisano instrukcję SQL zawierającą nieprawidłową instrukcję DROP.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone bądź argument.
  • Zastosowano niewłaściwe znaki przestankowe.


Tabela <nazwa> ma już indeks <nazwa>. (Błąd 3375)

Nastąpiła próba utworzenia indeksu, który już istnieje.


Brak takiego indeksu <nazwa> w tabeli <nazwa>. (Błąd 3372)

Podany indeks nie istnieje w określonej tabeli. Sprawdź kod, czy nie ma w nim błędu w pisowni nazwy (albo innego) lub też sprawdź, czy kolekcja Indexes zawiera określony indeks.


Nie można utworzyć relacji do narzucenia integralności referencyjnej. Dane istniejące w tabeli <nazwa> naruszają reguły

Nie można utworzyć relacji do narzucenia integralności referencyjnej. Dane istniejące w tabeli <nazwa> naruszają reguły integralności referencyjnej w tabeli <nazwa>. (Błąd 3379)

Nastąpiła próba utworzenia relacji używając klauzuli CONSTRAINT instrukcji ALTER TABLE, ale istniejące dane w obu tabelach łamią ograniczenia integralności referencyjnej. Na przykład w powiązanej tabeli mogą znajdować się rekordy dotyczące pracownika, ale nie ma odpowiadającego rekordu dla tego pracownika w tabeli podstawowej.

Aby utworzyć związek, należy wykonać edycję danych, tak by dla wszystkich powiązanych rekordów istniały rekordy podstawowe.


Nie można utworzyć relacji. Wskazywana tabela <nazwa> nie ma klucza podstawowego. (Błąd 3373)

Tabela wskazana w klauzuli CONSTRAINT nie ma klucza podstawowego. Aby utworzyć relację, należy albo w tabeli wskazywanej utworzyć klucz podstawowy, albo jawnie wskazać jedno lub więcej jednoznacznie indeksowanych pól tej tabeli, które będą używane w tej relacji.


Nie można znaleźć tabeli lub ograniczenia. (Błąd 3371)

Podana tabela lub relacja nie istnieje. Podaj prawidłową nazwę tabeli lub ograniczenia.


Nie można modyfikować projektu tabeli <nazwa>. Znajduje się ona w bazie danych przeznaczonej tylko do odczytu. (Błąd 3370)

Nie można modyfikować projektu tabeli w bazie danych tylko do odczytu.


W bieżącej bazie danych istnieje już relacja o podanej nazwie <nazwa>. (Błąd 3378)

Należy podać unikatową nazwę dla każdej relacji dodawanej do bazy danych przy użyciu kwerend definiujących dane. Sprawdź, czy podana nazwa istnieje w kolekcji Relations.


Brak relacji <nazwa> odnoszącej się do tabeli <nazwa>. (Błąd 3377)

Podana relacja nie istnieje w tej bazie danych. Sprawdź, czy podana nazwa istnieje w kolekcji Relations.


DDL nie może zostać zakończone dla tej tabeli, ponieważ odwołuje się do niej ograniczenie <nazwa> dla tabeli <nazwa>. (Błąd

DDL nie może zostać zakończone dla tej tabeli, ponieważ odwołuje się do niej ograniczenie <nazwa> dla tabeli <nazwa>. (Błąd 3803)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Tabela <nazwa> nie istnieje. (Błąd 3376)

Podana tabela nie istnieje. Sprawdź, czy podana nazwa istnieje w kolekcji TableDefs.


Skalowanie wartości dziesiątkowych spowodowało przepełnienie danych. (Błąd 3760)

Ten błąd występuje, gdy dane uaktualniane lub dodawane do typu DECIMAL są większe od skali zdefiniowanej dla kolumny.


Precyzja pola dziesiętnego jest zbyt mała, aby zaakceptować podaną liczbę. (Błąd 3761)

Ten błąd występuje, gdy dane uaktualniane lub dodawane do typu danych DECIMAL nie odpowiadają zdefiniowanej precyzji kolumny.


Skalowanie wartości dziesiątkowych spowodowało obcięcie danych. (Błąd 3758)

Ten błąd występuje, gdy dane uaktualniane lub dodawane do typu danych DECIMAL nie odpowiadają zdefiniowanej skali i precyzji kolumny.


Nie można odszyfrować pliku. (Błąd 3161)

Nastąpiła próba dostępu do zaszyfrowanej tabeli Btrieve lub Paradox , ale podane hasło jest nieprawidłowe. Należy powtórzyć operację, podając przy tym poprawne hasło.


Skalowanie wartości dziesiątkowych spowodowało obcięcie danych. (Błąd 3759)

Ten błąd występuje, gdy dane uaktualniane lub dodawane do typu danych DECIMAL nie odpowiadają zdefiniowanej skali i precyzji kolumny.


Błąd składniowy w wartości domyślnej. (Błąd 3355)

Prawdopodobne przyczyny:

  • Nieznana nazwa funkcji zawarta została w wartości domyślnej wyrażenia w regule poprawności na poziomie tabeli.
  • Wyrażenie na wartość domyślną w regule poprawności na poziomie tabeli jest składniowo niepoprawne.


Nie powiodło się usunięcie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu

Nie powiodło się usunięcie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu i zapisu. (Błąd 3682)

Nie powiodło się usunięcie pliku z serwera internetowego. Należy się upewnić, czy serwer jest uruchomiony i uprawnienia zapisu/odczytu są poprawnie skonfigurowane dla skrzynki FTP.


Usuwanie danych z połączonej tabeli nie jest obsługiwane przez tę wersję ISAM. (Błąd 3617)

Używany instalowalny sterownik ISAM nie pozwala na usuwanie rekordów z tabel zewnętrznych. Można tylko dodawać nowe rekordy.


Nie można usunąć jednego lub więcej obiektów: <nazwa>. (Błąd 3773)

Ten błąd występuje przy użyciu składni DROP TABLE, gdy podana tabela nie istnieje lub jest otwarta przez innego użytkownika.


Konflikt usunięcie/integralność referencyjna. (Błąd 3717)

Rekord zawierający klucz podstawowy został usunięty przez inną replikę, więc odwołujący się do niego rekord został odrzucony. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej, lub usuń rekord powodujący konflikt.


Repliki lokalne lub anonimowe nie mogą zostać przekształcone do postaci wzorca głównego. (Błąd 3771)

Repliki lokalne lub anonimowe wzorca głównego nie mogą zostać przekształcone do postaci wzorca głównego, ponieważ nie zawierają one pełnej informacji zestawu replik. Jedynie repliki globalne mogą zostać przekształcone do postaci wzorca głównego. Nowy wzorzec główny należy utworzyć jedynie gdy obecny jest uszkodzony, lub musi on zostać przeniesiony.


Brak uprawnień dostępu do folderu skrzynki docelowej. (Błąd 3562)

Użytkownik powinien sprawdzić, czy ma odpowiednie uprawnienia do dysku, na którym znajduje się folder skrzynki.


Wykonywanie tej operacji jest wstrzymywane przez inną operację. (Błąd 3667)

Ten błąd oznacza w większości przypadków, że operacja asynchroniczna zajmuje obiekt i żadna inna operacja nie będzie dozwolona, dopóki operacja asynchroniczna nie zostanie zakończona lub anulowana.


Próba synchronizacji replik z dwóch różnych zestawów replik. (Błąd 3545)

Replik z dwóch różnych zestawów replik nie można synchronizować. Należy upewnić się, że do synchronizacji została wybrana właściwa replika.


Dysk, na który próbowano pisać, jest pełen. (Błąd 3575)

Na dysku jest zbyt mało wolnego miejsca, by można było dokończyć operację. Należy udostępnić potrzebne miejsce, usuwając z dysku zbędne pliki. Warto mieć na dysku więcej miejsca niż wynika to z rozmiaru zapisywanego pliku.


Nastąpiła próba dostępu do dysku, z którego nie można czytać. (Błąd 3465)

Jeżeli problem dotyczy dyskietki, należy sprawdzić, czy stacja jest zamknięta. W przypadku dysku twardego, powodem może być uszkodzony sektor dysku.


Błąd dysku lub sieci. (Błąd 3043)

Wewnętrzny błąd dysku lub stacji uniemożliwia odczyt z dysku lub zapis na dysk.

Prawdopodobne przyczyny:

  • Nastąpiła próba odczytania danych z dysku sieciowego, lecz sieć jest tymczasowo zajęta lub utracono połączenie z siecią. Sprawdź połączenia sieciowe i powtórz operację.
  • Dysk lub jego stacja są uszkodzone.


Błąd dyskowej operacji wejścia/wyjścia dla folderu skrzynki docelowej. (Błąd 3558)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Podczas dostępu do pliku dziennika <nazwa> wystąpił błąd dysku. (Błąd 3473)

Dysk, na którym znajduje się plik dziennika, ma prawdopodobnie uszkodzony sektor.

Aby wybrać inny dysk dla pliku dziennika, otwórz Menedżera replikacji, a następnie wybierz z menu Narzędzia (Tools) polecenie konfiguracji Menedżera replikacji. Inną metodą jest uruchomienie programu instalacyjnego aplikacji używającej replikacji.


Podczas dostępu do folderu skrzynki <nazwa> wystąpił błąd dysku. (Błąd 3470)

Prawdopodobnie dysk ma uszkodzony sektor.


Brak wolnego obszaru na dysku. (Błąd 3026)

Nastąpiła próba wykonania operacji wymagającej więcej obszaru dyskowego niż aktualnie dostępny. Usuń z dysku nie używane pliki, skompaktuj bazę danych, a następnie powtórz operację.


Nastąpił błąd systemowy lub zapełnił się plik wymiany. (Błąd 3539)

Po wywołaniu funkcji systemowej przez Synchronizator pojawił się nieoczekiwany problem. Należy zamknąć system, wyłączyć komputer i uruchomić go ponownie.


Nie można grupować według pól przy użyciu '*' <nazwa tabeli>. (Błąd 3120)

Nastąpiła próba wykonania instrukcji SELECT, która grupuje lub sumuje wszystkie pola z pojedynczej tabeli, wybrane przy użyciu znaku gwiazdki ( * ). Błąd ten występuje, na przykład, gdy zostanie wprowadzona poniższa instrukcja SQL:

SELECT Zamówienia.* FROM Zamówienia GROUP BY Spedytor;


Brak praw dostępu do folderu skrzynki <nazwa>. (Błąd 3468)

Należy sprawdzić prawa dostępu do folderu skrzynki.


Adres skrzynki <nazwa> jest syntaktycznie niepoprawny. (Błąd 3477)

Należy zresetować folder skrzynki. Otwórz Menedżera replikacji, a następnie wybierz z menu Narzędzia (Tools) polecenie konfiguracji Menedżera replikacji. Inną metodą jest uruchomienie programu instalacyjnego aplikacji używającej replikacji.


Brak miejsca na dysku zawierającym folder skrzynki <nazwa>. (Błąd 3469)

Brak wystarczającej ilości miejsca na dysku zawierającym folder skrzynki, aby dokończyć operację. Należy udostępnić potrzebne miejsce, usuwając z dysku zbędne pliki.


Hasło użyte przez Synchronizator podczas pisania do docelowego folderu skrzynki jest nieprawidłowe. (Błąd 3484)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Niespodziewanie napotkano koniec pliku. (Błąd 3179)

Podczas próby importu pliku nieoczekiwanie napotkano w nim na znacznik końca pliku.

Prawdopodobne przyczyny:

  • Importowany plik jest uszkodzony. Należy użyć zapasowej kopii importowanego pliku i powtórzyć operację.
  • Używana specyfikacja importu/eksportu nie jest zgodna z danymi w pliku importu. Należy dokonać edycji specyfikacji importu/eksportu, a następnie powtórzyć operację.


Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ jest ona używana przez użytkownika <nazwa> na komputerze

Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ jest ona używana przez użytkownika <nazwa> na komputerze komputera <nazwa>. (Błąd 3413)

Ten błąd występuje, kiedy integralność referencyjna zdefiniowana jest przy pomocy jednej z następujących funkcji: CASCADE DELETE, UPDATE lub NULL. Błąd występuje podczas dokonywania zmian w tabeli zawierającej wskazany klucz podstawowy i jedna lub więcej tabeli klucza obcego jest otwarta w trybie uniemożliwiającym otwarcie tabel klucza obcego w trybie współdzielonym odczytu/zapisu.


Błąd krytyczny przy próbie dostępu do lokalnego folderu skrzynki. (Błąd 3563)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Błąd przy obliczaniu wartości wyrażenia filtru częściowego. (Błąd 3588)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Błąd podczas obliczania wartości wyrażenia częściowego. (Błąd 3656)

Wprowadzono niepoprawne wyrażenie dla filtru typu Boolean używanego do określenia, które rekordy mają być użyte w replice częściowej. Filtr repliki może przyjmować następujące wartości:

Wartość | Opis
Ciąg znaków | Kryterium, które rekord musi spełnić, aby pojawić się w replikowanej tablicy. Ciąg jest podobny do klauzuli WHERE języka SQL, ale nie można w kryterium używać podkwerend, funkcji agregacji (takich jak Count) ani funkcji definiowanych przez użytkownika
True | Replikowane są wszystkie rekordy.
False | (Wartość domyślna) Żadne rekordy nie są replikowane.


Wystąpił błąd niezgodności typów podczas tworzenia reguł poprawności w tabeli lub ograniczenia CHECK dla kolumny. (Błąd 3072)

Na przykład, reguła poprawności na poziomie tabeli, która odwołuje się do numerycznego typu danych, musi mieć numeryczną klauzulę poprawności. Jeśli użyto by klauzuli poprawności typu ciąg znaków, zostałby zwrócony błąd.


Przekroczony został limit czasu oczekiwania na zdarzenie. (Błąd 3531)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Połączenie umożliwiające przeglądanie arkuszy Microsoft Excel zostało zerwane. (Błąd 3620)

Połączenie umożliwiające przeglądanie arkuszy Microsoft® Excel zostało zerwane. Sesja Microsoft Excel mogła zostać zakończona.


Podczas importu/eksportu nie można utworzyć tabeli wyjątków. (Błąd 3618)

Wystąpił problem podczas importu lub eksportu do zewnętrznego pliku. Sterownik importu/eksportu nie mógł utworzyć tabeli wyjątków w bazie danych Microsoft® Access, aby zgłosić problem.


Nie można dodać rekordów do tabeli wyjątków. (Błąd 3619)

Wystąpił problem podczas importu lub eksportu do zewnętrznego pliku. Sterownik importu/eksportu nie mógł dodać wiersza do tabeli wyjątków w bazie danych Microsoft® Access, aby zgłosić problem.


Żądana wymiana nie powiodła się, ponieważ <opis>. (Błąd 3661)

Wymiana została anulowana.


Synchronizator internetowy niespodziewanie zakończył pracę na serwerze. Aby poznać przyczynę powstania tego problemu, należy

Synchronizator internetowy niespodziewanie zakończył pracę na serwerze. Aby poznać przyczynę powstania tego problemu, należy przejrzeć historię wymiany repliki współpracującej na serwerze internetowym. (Błąd 3683)

Serwer internetowy przesłał nieprawidłową odpowiedź. Ponów operację.


Nie można wyznaczyć dwóch Synchronizatorów do zarządzania tą samą repliką. (Błąd 3500)

W żądaniu synchronizacji skorzystaj z prawidłowego identyfikatora zdalnego Synchronizatora.


Niepoprawny typ synchronizacji. (Błąd 3546)

Żądana synchronizacja nie może być wykonana ponieważ w metodzie Synchronize użyto niepoprawnej opcji exchange. Należy w programie użyć poprawnego typu synchronizacji.


Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>.

Próba otwarcia bazy danych, która już została otwarta w trybie wyłączności przez użytkownika <nazwa> na maszynie <nazwa>. Spróbuj ponownie, gdy baza danych będzie już dostępna. (Błąd 3356)

Prawdopodobne przyczyny:

  • Próbowano otworzyć bazę danych, która została już otwarta w trybie wyłącznym przez określonego użytkownika <nazwa>. Nie można otworzyć bazy danych, dopóki ten inny użytkownik jej nie zamknie.
  • Próbowano otworzyć bazę danych w trybie wyłącznym, która wcześniej została otwarta w trybie współużytkowania (ale nie wyłączności) przez użytkownika <nazwa>. Dopóki ten inny użytkownik nie zamknie bazy danych, można ją otworzyć tylko w trybie współużytkowania.


Synchronizator lub Menedżer replikacji znalazły w pamięci wspólnej nie odczytane dane. Istniejące dane zostaną zastąpione

Synchronizator lub Menedżer replikacji znalazły w pamięci wspólnej nie odczytane dane. Istniejące dane zostaną zastąpione nowymi. (Błąd 3529)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Oczekiwano nazwy kwerendy po EXECUTE. (Błąd 3732)

Ten błąd powstaje podczas użycia instrukcji EXECUTE. Poprawna nazwa kwerendy zapisanej na serwerze (widoku lub procedury) jest wymagana po instrukcji EXECUTE.


Aparat bazy danych Microsoft Jet nie może wykonać instrukcji SQL, gdyż zawiera ona pole o nieprawidłowym typie danych. (Błąd

Aparat bazy danych Microsoft Jet nie może wykonać instrukcji SQL, gdyż zawiera ona pole o nieprawidłowym typie danych. (Błąd 3169)

Nastąpiła próba wykonania instrukcji SQL zawierającej pole o błędnym typie danych.

Prawdopodobne przyczyny:

  • Dołączono pole typu Memo lub OLE Object do wyrażenia, w którym nie jest ono dozwolone.
  • Użyto funkcji agregującej, takiej jak Sum lub StDev, która próbowała wykonać działanie na polu typu Text. Należy wybrać inną funkcję agregacji.


Nie zdefiniowana funkcja <nazwa> w wyrażeniu. (Błąd 3085)

Wprowadzono wyrażenie SQL zawierające nazwę funkcji , która nie została rozpoznana. Sprawdź, czy funkcja istnieje, czy może być użyta w wyrażeniach SQL i czy jej nazwa została wprowadzona poprawnie.


Zbędny ). (Błąd 2435)

Wprowadzono wyrażenie, które ma zbyt wiele nawiasów zamykających. Usuń nawiasy, które nie mają odpowiadających im nawiasów otwierających.


Nie można załadować pliku RDOCURS.DLL. (Błąd 3672)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Wystąpił błąd podczas czytania folderu skrzynki. (Błąd 3512)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Błąd operacji zapisu z powodu zapełnienia dysku docelowego. (Błąd 3559)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Wystąpił błąd podczas zapisu do folderu skrzynki. (Błąd 3513)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Błąd podczas pisania do dziennika Synchronizatora. (Błąd 3507)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Szybkie wyszukiwanie (FastFind) nie może operować na odwołaniach niekolumnowych. (Błąd 3768)

Metoda FIND z DAO nie może odwoływać się do kolumn opartych na parametrze lub wyrażeniu.


Operacja nie jest obsługiwana dla tego typu obiektu. (Błąd 3251)

Usiłowano wykonać metodę lub przypisać wartość właściwości. Operacje te są zazwyczaj dozwolone dla tego obiektu, lecz nie są obsługiwane w tym szczególnym przypadku. Na przykład metoda Edit jest zazwyczaj dozwolona dla obiektów typu Recordset, lecz nie dla utrwalonych obiektów Recordset. Ten błąd może również wystąpić w przypadku, gdy operacja nie jest dozwolona z uwagi na typ lub status obiektu — jak na przykład przy zastosowaniu metody MovePrevious w stosunku do obiektu Recordset typu progresywnego. Niektóre operacje są również niedostępne zależnie od tego, czy próbujesz uzyskać dostęp do źródła danych aparatu Microsoft Jet czy źródła danych ODBC.


Aparat baz danych Microsoft Jet nie może otworzyć pliku <nazwa>. Plik jest już otwarty do wyłącznego użytku przez innego

Aparat baz danych Microsoft Jet nie może otworzyć pliku <nazwa>. Plik jest już otwarty do wyłącznego użytku przez innego użytkownika lub potrzebne jest zezwolenie na oglądanie jego danych.(Błąd 3051)

Prawdopodobne przyczyny:

  • Aby obejrzeć dane zawarte w określonym pliku, niezbędne jest zezwolenie na odczyt danych z tego pliku. Aby zmienić posiadane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.
  • Nastąpiła próba wyłącznego otwarcia pliku w sytuacji, gdy inny użytkownik już otworzył ten plik.


Próba importu lub łączenia pustego pliku tekstowego. Plik tekstowy, który można importować lub łączyć, musi zawierać dane.

Próba importu lub łączenia pustego pliku tekstowego. Plik tekstowy, który można importować lub łączyć, musi zawierać dane. (Błąd 3440)

Próba importu lub łączenia pustego pliku tekstowego. Plik tekstowy, który można importować lub łączyć, musi zawierać dane.


Nie można zapisać; strona aktualnie zablokowana przez innego użytkownika. (Błąd 3046)

Nastąpiła próba zapisu informacji na stronie bazy danych, która jest obecnie zablokowana przez innego użytkownika. Aby zapisać zmiany, poczekaj, aż inny użytkownik zakończy pracę, a następnie powtórz operację.


Podana nazwa pliku jest za długa. (Błąd 3549)

Należy użyć krótszej nazwy pliku.


Nie można znaleźć pliku <nazwa>. (Błąd 3024)

Prawdopodobne przyczyny:

  • Określony plik nie istnieje.
  • Nazwa pliku została podana nieprawidłowo. Sprawdź, czy nie brakuje znaków podkreślenia ( _ ) lub innych znaków interpunkcji, sprawdź też, czy nie wprowadzono spacji poprzedzających nazwę.
  • Połączenie sieciowe nie zostało nawiązane lub uległo zerwaniu.


Nie można użyć <nazwa>; plik jest już w użyciu. (Błąd 3045)

Podany plik jest aktualnie zajęty przez innego użytkownika lub sesję. Poczekaj, aż inny użytkownik lub sesja zakończy pracę z tym plikiem, a następnie powtórz operację.


W specyfikacji <nazwa> pliku tekstowego opcja <nazwa> jest nieprawidłowa. (Błąd 3442)

Jedna z opcji w specyfikacji pliku tekstowego dla pliku tekstowego instalowalnego sterownika ISAM jest nieprawidłowa. Specyfikację można ustawiać różnymi sposobami:

  • Z programu Microsoft® Access wartości te są ustawiane w kreatorze połączonego tekstu (można z niego skorzystać wybierając z menu Plik opcję Pobierz dane zewnętrzne, a następnie polecenie Połącz tabele). Wartości można także zobaczyć w tabelach systemowych MSysIMEXSpecs i MSysIMEXColumns. Wartości można także zobaczyć w tabelach systemowych MSysIMEXSpecs i MSysIMEXColumns.
  • Z innych aplikacji hosta Microsoft Jet wartości te są zapisywane w pliku Schema.ini.


Nie można otworzyć bazy danych utworzonej przez poprzednią wersję aplikacji. (Błąd 3041)

Nastąpiła próba dostępu do bazy danych w niestosowanym już formacie. Skompaktuj bazę danych i powtórz operację.


<Komunikat> w wyrażeniu. (Błąd 3077)

Wprowadzone wyrażenie nie jest poprawne z powodu wymienionego w komunikacie. Sprawdź, czy nazwy pól i znaki przestankowe zostały wpisane poprawnie i powtórz operację.


Naruszenie klucza obcego. (Błąd 3719)

Niniejsze naruszenie klucza obcego wynika z błędnego rekordu zawierającego klucz podstawowy, który to rekord uczestniczył w konflikcie replikacji. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej i prześlij ponownie uaktualnienie, zmodyfikuj wartość klucza obcego w tym rekordzie, aby odpowiadał poprawnej wartości klucza podstawowego i prześlij ponownie uaktualnienie lub usuń rekord powodujący konflikt.


Nie powiodło się połączenie z usługą FTP pracującą na serwerze internetowym. Należy się upewnić, czy usługa FTP jest

Nie powiodło się połączenie z usługą FTP pracującą na serwerze internetowym. Należy się upewnić, czy usługa FTP jest uruchomiona na serwerze, oraz czy obsługuje połączenia anonimowe. (Błąd 3678)

Nie można się otworzyć połączenia FTP. Należy się upewnić, czy usługa FTP jest uruchomiona na serwerze internetowymi czy dana usługa FTP obsługuje połączenia anonimowe.


Funkcji nie można używać w wyrażeniach. (Błąd 2426)

Wprowadzono funkcję, która nie może zostać użyta w wyrażeniu. Funkcje DoEvents, LBound, UBound, Spc, i Tab nie są dostępne do użytku w wyrażeniach.


<zarezerwowany alarm o błędzie> (Błąd 3416)

Błąd ten został wygenerowany przez aplikację wydaną po tej wersji aparatu bazy danych Microsoft Jet. Skontaktuj się z biurem obsługi klienta firmy Microsoft.


Nie powiodło się pobranie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu.

Nie powiodło się pobranie pliku z serwera przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu. (Błąd 3680)

Nie powiodło się pobranie pliku z serwera internetowego. Należy się upewnić, czy serwer jest uruchomiony i uprawnienia zapisu/odczytu są poprawnie skonfigurowane dla skrzynki FTP. Plik, który próbujesz pobrać, mógł zostać usunięty.


Wartości GUID są niezgodne ze sobą lub nie można odszukać żądanej wartości GUID. (Błąd 3548)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można użyć klauzuli HAVING w instrukcji TRANSFORM. (Błąd 3092)

Jeśli mają być określone kryteria wyboru, zastosuj klauzulę WHERE.


Klauzula HAVING <nazwa> bez operacji grupowania lub agregacji. (Błąd 3091)

Ten błąd pojawia się, gdy kwerenda oblicza identyfikatory w instrukcji SELECT. Błąd występuje, ponieważ klauzula GROUP BY nie jest określona przed klauzulą HAVING lub kolumna, do której odwołuje się klauzula HAVING, nie jest funkcją agregacji. Na przykład, niniejszy błąd pojawiłby się przy instrukcji SELECT kol1 FROM tabela1 HAVING kol1 > 20. Jeśli instrukcja zostałaby zmieniona na SELECT kol1 FROM tabela1 GROUP BY kol1 HAVING kol1 > 20, to wtedy byłaby ona poprawna. Przykładem innej poprawnej instrukcji byłaby instrukcja SELECT kol1, count(kol2) FROM tabela1 GROUP BY kol1 HAVING count(kol1) > 20.


Nie powiodło się wykonanie żądania HTTP uruchomienia Synchronizatora internetowego na serwerze, należy użyć Menedżera replik.

Nie powiodło się wykonanie żądania HTTP uruchomienia Synchronizatora internetowego na serwerze, należy użyć Menedżera replik. (Błąd 3677)

Nie powiodła się próba wysłania żądania do serwera internetowego. Mogło to być jedno z następujących:

  • Próba otwarcia i odczytania pliku przez Internet.
  • Próba usunięcia pliku przez Internet.
  • Próba uruchomienia procesu synchronizacji MSTRAI40.exe na serwerze internetowym.


Błąd składniowy (przecinek). (Błąd 2432)

W wyrażeniu lub instrukcji przecinek został użyty w niewłaściwym miejscu, bądź brak jest przecinka do oddzielenia argumentów.


Nieprawidłowe argumenty funkcji. (Błąd 2428)

Wprowadzono niepoprawny argument w funkcji agregującej. Przeczytaj informacje na temat argumentów funkcji pod hasłem funkcje agregujące SQL, a następnie wybierz nazwę funkcji.


Niepoprawna wartość parametru Century klucza Xbase w Rejestrze Windows. (Błąd 3227)

Ustawienie parametru Century klucza Xbase w Rejestrze Windows jest niepoprawne.

Aby poprawić ustawienie parametru Century:

  1. Zamknij aplikację.
  2. Uruchom program Edytor rejestru, przejdź do klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase i wybierz własność Century.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Popraw dane dla własności Century wpisując je do pola Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Wybrana kolejność sortowania nie jest obsługiwana przez system operacyjny. (Błąd 3228)

Ustawienie parametru CollatingSequence klucza Paradox w Rejestrze Windows jest niepoprawne.

Aby poprawić ustawienie parametru CollatingSequence:

  1. Zamknij aplikację.
  2. Uruchom program Edytor Rejestru, przejdź do klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox i wybierz własność CollatingSequence.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Podaj ascii albo International w polu Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Niedozwolone ograniczenie na poziomie kolumny. (Błąd 3789)

Ten błąd występuje przy użyciu składni CREATE TABLE lub ALTER TABLE ALTER COLUMN. Podczas gdy język ANSI SQL pozwala na tworzenie ograniczeń CHECK jako części definicji tabeli, aparat Microsoft® Jet wymaga utworzenia ograniczenia CHECK niezależnie od definicji COLUMN. Można to uczynić wprowadzając słowo kluczowe CHECK po przecinku. Na przykład następująca składnia będzie odpowiednia, ponieważ ograniczenie CHECK jest zdefiniowane niezależnie od kolumny i występuje po przecinku:

CREATE TABLE Zamówienia (NrZamówienia IDENTITY (100,10) CONSTRAINT kpZamówienia PRIMARY KEY, NrKlienta LONG CONSTRAINT koKlienciNrKlienta REFERENCES Klienci (NrKlienta), Różnica DOUBLE, CONSTRAINT KlientPrzekroczyłLimitKredytu CHECK (NrKlienta IN (SELECT NrKlienta FROM Klienci C WHERE C.NrKlienta = Zamówienia.NrKlienta AND C.LimitKredytu >= (SELECT SUM(Różnica)FROM Zamówienia O WHERE O.NrKlienta = Zamówienia.NrKlienta))));.


Nieprawidłowe ustawienie inicjujące opcji DataCodePage. (Błąd 3337)

Podane ustawienie DataCodePage dla zewnętrznego źródła danych jest nieprawidłowe. To ustawienie jest w odpowiadającym \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engine\<ISAM zewnętrznego źródła danych > w Rejestrze Microsoft® Windows®.

Poprawne ustawienia tej opcji są następujące:

  • Poprawne ustawienia tej opcji są następujące: OEM — Dane są zapisywane jako dane typu OEM; konwersje danych typu OEM na dane typu ANSI i odwrotnie są realizowane.
  • ANSI — Dane są zapisywane jako ANSI; konwersje OemToAnsi i AnsiToOem nie są realizowane.


Niepoprawna wartość parametru Date klucza Xbase w Rejestrze Windows. (Błąd 3213)

Ustawienie parametru Date klucza Xbase w Rejestrze Windows jest niepoprawne.

Aby poprawić ustawienie parametru Date:

  1. Zamknij aplikację.
  2. Uruchom program Edytor Rejestru, przejdź do klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase i wybierz parametr Date.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Popraw dane dla własności Date, wpisując je do pola Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Niepoprawna wartość parametru Deleted klucza Xbase w Rejestrze Windows. (Błąd 3208)

Ustawienie parametru Deleted klucza Xbase w Rejestrze Windows jest niepoprawne.

Aby poprawić ustawienie parametru Deleted:

  1. Zamknij aplikację.
  2. Uruchom program Edytor rejestru, przejdź do klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase i wybierz parametr Deleted.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Popraw dane dla parametru Deleted, wpisując je do pola Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Próba wykonania kwerendy, która nie zawiera podanego wyrażenia <nazwa> jako elementu funkcji agregującej. (Błąd 3122)

Nastąpiła próba wykonania kwerendy, która nie zawiera określonego wyrażenia jako części funkcji agregującej lub grupowania.

Możliwa przyczyna:

  • Funkcja agregująca nie została podana w instrukcji TRANSFORM.


Nieprawidłowe ustawienie klucza Excel w sekcji Engines Rejestru Windows. (Błąd 3433)

Jedno z ustawień klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel Rejestru Microsoft® Windows® jest nieprawidłowe. Wykonaj edycję Rejestru Windows tak, aby wszystkie parametry były poprawne.


Niepoprawna wartość parametru Mark klucza Xbase w Rejestrze Windows. (Błąd 3214)

Ustawienie parametru Mark klucza Xbase w Rejestrze Windows jest niepoprawne.

Aby poprawić ustawienie parametru Mark:

  1. Zamknij aplikację.
  2. Uruchom program Edytor rejestru, przejdź do klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase i wybierz własność Mark.
  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Popraw dane dla parametru Mark wpisując je do pola Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Nieprawidłowa wartość parametru NetworkAccess w Rejestrze Windows. (Błąd 3248)

Ustawienie parametru NetworkAccess w Rejestrze Microsoft® Windows® jest niepoprawne.

Aby dokończyć tę operację:

  1. Zamknij aplikację.
  2. Uruchom program Edytor Rejestru i przejdź do wartości NetworkAccess

    Zależnie od wersji instalowalnego pliku ISAM, której próbujesz użyć, błędny wpis znajduje się w kluczu \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Podaj On albo Off w polu Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Nieprawidłowa operacja. (Błąd 3219)

Prawdopodobne przyczyny:

  • Próba zapisu właściwości, która jest dostępna tylko do odczytu. Należy sprawdzić w odpowiednim temacie Pomocy, czy jest ona dostępna do odczytu i zapisu.
  • Nastąpiła próba użycia metody lub właściwości na obiekcie typu Recordset, do którego dana metoda nie jest stosowana. Należy sprawdzić w temacie Pomocy Podsumowanie informacji, jakie metody i właściwości można stosować do danego typu obiektu Recordset.
  • Nastąpiła próba dodania właściwości do kolekcji Properties obiektu nie obsługującego właściwości zdefiniowanych przez użytkownika.
  • Próba zastosowania metody Update do obiektu Recordset, który jest dostępny tylko do odczytu.


Nie można otworzyć formularza, którego kwerenda podstawowa zawiera funkcję zdefiniowaną przez użytkownika usiłującą ustawić lub

Nie można otworzyć formularza, którego kwerenda podstawowa zawiera funkcję zdefiniowaną przez użytkownika usiłującą ustawić lub pobrać właściwość RecordsetClone formularza. (Błąd 3252)

Ten błąd może wystąpić w bazie danych Microsoft Access, jeśli wykonano kwerendę dającą w wyniku funkcję zdefiniowaną przez użytkownika, a następnie tworzącą formularz bazujący na tej kwerendzie.


Nieprawidłowe odwołanie w kwerendzie. (Błąd 3451)

Ten błąd występuje, gdy parametry są zdefiniowane z nierozpoznanymi typami danych.


Nie można utworzyć relacji. (Błąd 3300)

Nastąpiła próba utworzenia niedopuszczalnej relacji. Na przykład tabele znajdują się w różnych bazach danych.


Niedozwolona operacja wykonana na replice serwera aparatu Jet SQL. (Błąd 3777)

Wiele operacji nie może być wykonanych z replik SQL aparatu Microsoft® Jet. Na przykład nie można usunąć lub zmienić nazwy tabeli, dodać, usunąć lub zmienić nazwy kolumny w tabeli, uczynić lokalną tabeli replikowalnej, wymieniać danych z innym subskrybentem aparatu Jet w zestawie replik SQL aparatu Jet lub wykonać wymiany z mechanizmem publikacji SQL w żaden inny sposób, jak tylko poprzez bezpośrednią synchronizację.


Nieprawidłowa wartość parametru PageTimeout w Rejestrze Windows. (Błąd 3249)

Ustawienie parametru PageTimeout w Rejestrze Microsoft® Windows® jest niepoprawne.

Aby dokończyć tę operację:

  1. Zamknij aplikację.
  2. Uruchom program Edytor Rejestru i przejdź do wartości PageTimeout

    Zależnie od wersji instalowalnego pliku ISAM, której próbujesz użyć, błędny wpis znajduje się w kluczu \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. W menu Edycja kliknij opcję Modyfikuj.
  4. Podaj nową wartość w polu Dane wartości.
  5. Uruchom aplikację i wznów przerwaną operację.


Niezgodna wersja instalowalnej bazy danych ISAM. (Błąd 3429)

Nastąpiła próba użycia starszej wersji instalowalnej bazy danych ISAM z bieżącą wesją aparatu bazy danych Microsoft Jet. Uruchom ponownie program instalacyjny, aby zainstalować poprawną wersję bazy ISAM.


Błąd składniowy w kwerendzie. Niepełna klauzula kwerendy. (Błąd 3450)

Ten błąd występuje podczas próby zapisu kwerendy przechowywanej na serwerze (widoku lub procedury).


Bieżące pole musi być zgodne z kluczem sprzężenia <nazwa> w tabeli po stronie 'jeden' związku jeden-do-wielu. (Błąd 3341)

Bieżące pole musi być zgodne z kluczem sprzężenia <nazwa> w tabeli po stronie ‘jeden’ związku jeden-do-wielu. (Błąd 3341)

Nastąpiła próba wprowadzenia wartości do pola sprzężenia w tabeli “tylko-wielu” sprzężenia zewnętrznego bez odpowiadającej wartości w polu sprzężonym po stronie “jeden" tabeli.

Ten komunikat zawiera następującą instrukcję: Wprowadź rekord z żądaną wartością klucza do tabeli po stronie "jeden", a następnie wpisz żądany klucz sprzężenia do tabeli po stronie "tylko-wielu".


Długość rekordu zbyt duża dla indeksowanej tabeli bazy danych Paradox. (Błąd 3608)

Indeksowana tabela bazy danych Paradox ma maksymalną długość rekordu 1350 bajtów. Spróbuj zmniejszyć rozmiar niektórych pól typu Text lub Memo.


Indeks już istnieje. (Błąd 3284)

W tabeli nie mogą istnieć dwa indeksy o tej samej nazwie. Należy zmienić nazwę jednego z indeksów.


Indeks bazy danych Paradox nie jest indeksem podstawowym. (Błąd 3288)

Usiłowano utworzyć indeks dla tabeli Paradox, dla której nie zdefiniowano innych indeksów. Pierwszy indeks utworzony dla tabeli Paradox musi być indeksem podstawowym.

Możliwe rozwiązania:

  • Zdefiniowanie indeksu jako indeksu podstawowego.
  • Jeżeli indeks, który próbujesz utworzyć, nie jest indeksem podstawowym, utwórz najpierw indeks podstawowy.


Klucz podstawowy już istnieje. (Błąd 3283)

Nastąpiła próba zdefiniowania drugiego klucza podstawowego dla tej tabeli. Każda tabela może mieć tylko jeden klucz podstawowy. Należy usunąć odesłanie do drugiego klucza podstawowego.


Nie można usunąć tego indeksu lub tabeli. Jest to albo bieżący indeks, albo jest używany w relacji. (Błąd 3281)

Jeśli indeks jest używany w związku, należy usunąć ten związek przed próbą usunięcia indeksu lub tabeli. Jeśli indeks jest określony we właściwości Index jako bieżący indeks, należy przed próbą usunięcia indeksu ustawić w tej właściwości inny indeks.


Nieprawidłowa definicja indeksu. (Błąd 3285)

Prawdopodobne przyczyny:

Używasz tego samego pola dwa razy w indeksie lub relacji, na co nie zezwala aparat baz danych Microsoft Jet.

Relacja jest tworzona przy użyciu pól, których typy danych nie są zgodne. W bazach danych Microsoft® Jet można powiązać tylko pola o identycznych typach danych lub też pole typu Autonumer z polem typu Number ustawionym na wartość typu Long Integer.


Nie znaleziono indeksu. (Błąd 3015)

Nastąpiła próba użycia wartości, która nie jest indeksem. Istniejące nazwy indeksów można określić, przeglądając kolekcję Indexes obiektu TableDef.


<Nazwa> nie jest indeksem dla tej tabeli. (Błąd 3800)

Nieprawidłowa nazwa indeksu została użyta przy odwołaniu do niego.


Nieprawidłowy plik .inf. (Błąd 3168)

Podczas próby dostępu do tabeli systemu dBASE stwierdzono, że odpowiadający jej plik .inf jest nieprawidłowy lub został uszkodzony. Należy ponownie połączyć tabelę, upewniając się przy tym, że określono poprawne indeksy.


Nie można znaleźć pliku indeksowego. (Błąd 3256)

Usiłowano uzyskać dostęp do tabeli dBASE, lecz nie znaleziono jednego z indeksów wymienionych w odpowiadającym tabeli pliku .inf. Indeks mógł zostać przeniesiony, usunięty, lub też jego nazwa mogła zostać zmieniona. Należy ponownie połączyć tabelę lub też za pomocą Notatnika Microsoft® Windows® albo innego edytora tekstów uaktualnić plik .inf.


Aparat baz danych Microsoft Jet nie może znaleźć tabeli wejściowej lub kwerendy <nazwa>. Sprawdź, czy ona istnieje oraz czy

Aparat baz danych Microsoft Jet nie może znaleźć tabeli wejściowej lub kwerendy <nazwa>. Sprawdź, czy ona istnieje oraz czy nazwa jest poprawnie napisana. (Błąd 3078)

Prawdopodobne przyczyny:

  • Określona tabela lub kwerenda nie istnieje.
  • Błędnie napisano nazwę tabeli lub kwerendy. Sprawdź, czy nie brakuje znaków podkreślenia ( _ ) lub innych znaków interpunkcji, sprawdź też, czy nie wprowadzono spacji poprzedzających nazwę.


Instrukcja INSERT INTO zawiera następującą nieznaną nazwę pola: <nazwa pola>. Sprawdź pisownię tej nazwy i powtórz operację.

Instrukcja INSERT INTO zawiera następującą nieznaną nazwę pola: <nazwa pola>. Sprawdź pisownię tej nazwy i powtórz operację. Błąd 3127)

Nastąpiła próba użycia instrukcji INSERT INTO z nazwą pola, która nie występuje w tabeli wyjściowej. Upewnij się, czy nazwa została podana prawidłowo i powtórz operację.


Nie można odnaleźć instalowalnego pliku ISAM. (Błąd 3170)

Biblioteka DLL dla instalowalnego pliku ISAM nie została odnaleziona. Plik ten jest wymagany przy połączeniu zewnętrznych tabel (innych niż ODBC lub tabel baz danych aparatu Microsoft Jet). Lokalizacja wszystkich sterowników ISAM jest zapamiętywana w Rejestrze Windows®. Pozycje w Rejestrze są tworzone automatycznie podczas instalacji aplikacji. Po zmianie lokalizacji tych sterowników należy ponownie uruchomić program instalacyjny aplikacji w celu odzwierciedlenia tych zmian i dokonania korekcji pozycji w Rejestrze.

Prawdopodobne przyczyny:

  • Wpis w Rejestrze jest nieprawidłowy. Błąd ten może wystąpić podczas korzystania z zewnętrznej bazy danych Paradox, jeśli jedna z pozycji tej bazy wskazuje na nie istniejący katalog lub sterownik. Należy zakończyć pracę z aplikacją, wprowadzić poprawki do Rejestru Windows i powtórzyć operację.
  • Jeden z wpisów Rejestru wskazuje na dysk sieciowy, ale nie ma połączenia z siecią. Sprawdź, czy sieć jest dostępna i powtórz operację.


Brak pamięci do wykonania operacji. (Błąd 3584)

W trakcie próby replikacji bazy danych zabrakło pamięci. Zamknij inne działające aplikacje i ponów operację.


Nie można zmienić ani usunąć rekordu, ponieważ tabela <nazwa> zawiera rekordy z nim powiązane. (Błąd 3200)

Nastąpiła próba wykonania operacji, która mogłaby naruszyć reguły integralności referencyjnej dla powiązanych ze sobą tabel. Sytuacja ta wystąpi na przykład wówczas, gdy jest usuwany lub zmieniany rekord z tabeli po stronie "jeden", w relacji jeden-do-wielu, a w tabeli po stronie "wielu" znajdują się powiązane z nim rekordy.

Aby usunąć lub zmienić ten rekord, trzeba najpierw usunąć powiązane z nim rekordy z tabeli po stronie "wielu".


Nie można dodać ani zmienić rekordu, ponieważ w tabeli <nazwa> musi istnieć powiązany z nim rekord. (Błąd 3201)

Nastąpiła próba wykonania operacji, która mogłaby naruszyć reguły integralności referencyjnej dla powiązanych ze sobą tabel. Sytuacja ta wystąpi na przykład wówczas, gdy jest wstawiany lub zmieniany rekord z tabeli po stronie "wielu" relacji jeden-do-wielu, a powiązanego z nim rekordu brak w tabeli po stronie "jeden".

Aby dodać lub zmienić ten rekord, trzeba najpierw dodać do tabeli po stronie "jeden" rekord zawierający tę samą wartość dla odpowiedniego pola.


Błąd zarezerwowany <Element>; dla tego błędu nie ma komunikatu. (Błąd 3000)

Wystąpił niespodziewany błąd. Podany kod identyfikuje warunki, pod którymi błąd ten może wystąpić. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można było znaleźć internetowego pliku dll (wininet.dll) lub nie było możliwe jego załadowanie. (Błąd 3674)

Plik wininet.dll nie został znaleziony. Proszę ponownie uruchomić program instalacyjny.


Przekroczony został limit czasu oczekiwania na wykonanie funkcji internetowej. (Błąd 3742)

Przekroczony został limit czasu operacji internetowej przed jej zakończeniem. Zwiększ wartości limitów czasowych w Rejestrze. Wartości te są przechowywane w kluczu: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Transporter


Nie powiodło się czytanie z dojścia internetowego. Ponów operację. (Błąd 3675)

Wystąpił błąd internetowy podczas odczytu pliku lub reakcji z operacji internetowej.


Nie powiódł się zapis do dojścia internetowego. Ponów operację. (Błąd 3676)

Wystąpił błąd internetowy zapisu do pliku.


Sieć Internet jest zbyt wolna lub problem ma związek z instalatorem Menedżera replik na serwerze internetowym. (Błąd 3650)

Wystąpił błąd związany z szybkością transmisji przez Internet.


Błąd logowania w Internecie. (Błąd 3652)

Serwer nie rozpoznał wprowadzonej informacji koniecznej do zalogowania.


Internet nie jest skonfigurowany. (Błąd 3653)

Wystąpił problem dotyczący ustawień Internetu.


Transport internetowy nie jest udostępniony na zdalnym Synchronizatorze. (Błąd 3632)

Ten zdalny Synchronizator nie jest skonfigurowany do wykonania zdalnej synchronizacji.


Podczas transakcji wystąpiła operacja, która nie jest obsługiwana. (Błąd 3246)

Nastąpiła próba wykonania operacji niedozwolonej w trakcie transakcji. Transakcja może być jedną z utworzonych przy użyciu instrukcji BeginTrans lub transakcją wewnętrzną utworzoną przez aparat bazy danych Microsoft Jet, na przykład podczas usuwania wielu rekordów w pojedynczej operacji.


<Nazwa konta> nie jest poprawną nazwą konta. (Błąd 3030)

Podana nazwa konta (użytkownika) nie jest poprawna. Nazwy użytkowników mogą mieć długość od 1 do 20 znaków i mogą zawierać znaki alfabetyczne, znaki diakrytyczne, cyfry, spacje i symbole, z wyjątkiem poniższych:

  • znaków " / \ [ ] | < > + = ; , : ? *
  • spacji wiodących
  • znaków sterujących

W nazwach użytkowników nie jest uwzględniana wielkość liter.


Nieprawidłowy adres folderu skrzynki docelowej. (Błąd 3557)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nieprawidłowa zakładka. (Błąd 3159)

Usiłowano założyć zakładkę na nieprawidłowym ciągu znaków.

Ten błąd występuje, jeśli ustawiono właściwość Bookmark na nieprawidłowym ciągu znaków lub też ciągu nie zapisanym po wcześniejszym odczytaniu właściwości Bookmark. Na przykład, poniższy kod prowadzi do tego błędu:

Sub SetBookmark()

    Dim dbs As Database

    Dim rstPracownicy As Recordset

    Dim strSymbolZast As String

    Set dbs = OpenDatabase("Northwind.mdb")

    Set rstPracownicy = _

        dbs.OpenRecordset _

        ("Pracownicy", dbOpenDynaset)

    strSymbolZast = "1"

    rstPracownicy.Bookmark = strSymbolZast    ' Nieprawidłowa zakładka.

End Sub


Pole jest zbyt małe, aby pomieścić wprowadzane dane. Należy spróbować wstawić lub wkleić mniejszą ilość danych. (Błąd 3163)

Pole, do którego nastąpiła próba wstawienia lub wklejenia danych, nie jest wystarczająco duże aby je pomieścić. Należy spróbować wstawić lub wkleić mniejszą ilość danych.


Nieprawidłowa definicja pola <nazwa> w definicji indeksu lub relacji. (Błąd 3409)

Prawdopodobne przyczyny:

  • Nazwa podanego pola może być błędnie wpisana. Określona tabela nie zawiera podanego pola.
  • Używane pole nie może być indeksowane, gdyż jest typu Memo lub obiekt OLE.


Nieprawidłowy typ danych w polu. (Błąd 3259)

Typ danych podany we właściwości Type obiektu Field jest niepoprawny. Należy wybrać jeden z prawidłowych typów wymienionych w haśle Pomocy Type - właściwość.


Nie znaleziono kodu kraju w ciągu połączenia dla połączonej tabeli. (Błąd 3449)

Nie znaleziono kodu kraju w ciągu połączenia dla połączonej tabeli.


Nie można otworzyć bazy danych <nazwa>. Aplikacja nie rozpoznaje tej bazy danych lub plik jest uszkodzony. (Błąd 3049)

Prawdopodobne przyczyny:

  • Nastąpiła próba otwarcia bazy danych innej niż baza danych Microsoft Jet, takiej jak baza danych lub tabela Btrieve, dBASE lub Paradox. Zamiast otwierania, dołącz bazę danych lub tabelę do istniejącej bazy danych Microsoft Jet.
  • Nastąpiła próba importu lub połączenia bazy danych lub tabeli bazy Paradox, ale skojarzony plik .px nie został znaleziony. Upewnij się, że plik .px znajduje się w tym samym katalogu co tabela lub baza danych Paradox i powtórz operację.
  • Jeśli podana baza danych jest bazą Microsoft Jet, błąd ten sygnalizuje jej uszkodzenie. Spróbuj naprawić bazę danych. Jeśli baza danych nie może być naprawiona, odtwórz bazę z kopii zapasowej lub utwórz nową bazę danych.


Nieprawidłowe odwołanie do obiektu bazy danych. (Błąd 3276)

Podany obiekt Database nie jest wynikiem metody OpenDatabase, lub też został zmodyfikowany i nie jest już prawidłowy.


Nie rozpoznany format bazy danych <nazwa_pliku>. (Błąd 3343)

Prawdopodobne przyczyny:

  • Plik o podanej nazwie nie jest bazą danych Microsoft Jet.
  • Plik o podanej nazwie jest nazwą urządzenia, na przykład drukarki lub konsoli.
  • Niepoprawne informacje zawarte w nagłówku lub nieznana kolejność sortowania w pliku .mdb.
  • Trwa operacja zatwierdzenia innego użytkownika, ale nie można odnaleźć pliku blokad.
  • Podczas zatwierdzania nastąpiła próba zapisania wartości Long większej niż maksymalna wielkość strony (2KB).
  • Baza danych jest uszkodzona. Skompaktuj bazę danych i spróbuj otworzyć ponownie.


Nie można wykonać instrukcji definicji danych na połączonych źródłach danych. (Błąd 3611)

Aparat bazy danych Microsoft Jet nie może utworzyć indeksu na połączonej tabeli ISAM, lub na tabeli ODBC posiadającej indeks unikatowy.


Nieprawidłowa ścieżka folderu skrzynki docelowej. (Błąd 3556)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Hasło podane dla folderu skrzynki <nazwa> jest nieprawidłowe. (Błąd 3483)

Aby podać hasło, uruchom Menedżera replikacji. Z menu Narzędzia (Tools) wybierz polecenie konfiguracji Menedżera replikacji i ponownie wprowadź hasło dla folderu skrzynki.


Nieprawidłowa ścieżka dla skrzynki <nazwa>. (Błąd 3476)

Należy upewnić się, że ścieżka dostępu dla folderu skrzynki jest prawidłowa.

Otwórz Menedżera replikacji, a następnie wybierz menu Narzędzia (Tools) polecenie konfiguracji Menedżera replikacji. Inną metodą jest uruchomienie programu instalacyjnego aplikacji używającej replikacji.


Nieprawidłowa nazwa pliku. (Błąd 3055)

Nastąpiła próba użycia nazwy pliku, który nie spełnia wymagań konwencji nazewnictwa Twojego systemu operacyjnego. Określ ponownie nazwę pliku i ponów operację.


Wyrażenie definiujące filtr dla częściowej repliki jest nieprawidłowe. (Błąd 3482)

Właściwości ReplicaFilter przypisano nieprawidłowy ciąg znaków.


Relacja <nazwa> w wyrażeniu definiującym filtr jest nieprawidłowa. (Błąd 3480)

Należy podać prawidłową relację.


GUID nie jest dozwolone w wyrażeniu kryterium metody Find. (Błąd 3614)

Wyrażenie kryterium metody Find nie może odwoływać się do GUID.


Nieprawidłowy adres HTTP. (Błąd 3685)

Podany adres HTTP jest niepoprawny dla tego zestawu replik. Podany adres HTTP nie odpowiada żadnym wartościom pola InternetAddress w tabeli systemowej MSysTranspAddress.


Obiekt <nazwa> nie może zostać użyty w klauzuli ograniczenia CHECK. (Błąd 3801)

Ten błąd występuje przy użyciu składni CREATE TABLE lub ALTER TABLE ALTER COLUMN i użyciu klauzuli ograniczenia CHECK. Ten błąd występuje, gdy ograniczenie CHECK próbuje odwołać się do połączonej tabeli lub widoku/procedury/kwerendy zapisanej na serwerze SQL.


Nieprawidłowy adres internetowy. (Błąd 3651)

Zażądano adresu internetowego, który nie jest poprawny lub nie jest dostępny. Należy sprawdzić adres i jeżeli jest właściwy, po pewnym czasie ponowić próbę.


Nie można utworzyć bazy danych, ponieważ ustawienia regionalne są nieprawidłowe. (Błąd 3424)

Podany został nieprawidłowy parametr ustawienia_regionalne. Upewnij się, że użyto poprawnej stałej dostępnej w systemie Data Access Objects do określenia parametru ustawienia_regionalne.


Niewłaściwa nazwa konta lub niewłaściwe hasło. (Błąd 3029)

Wprowadzono niewłaściwą nazwę konta (użytkownika) lub niewłaściwe hasło.

Nazwy użytkowników

Nazwy użytkowników mogą mieć długość od 1 do 20 znaków i mogą zawierać znaki alfabetyczne, znaki diakrytyczne, cyfry, spacje i symbole, z wyjątkiem poniższych:

  • znaków " / \ [ ] | < > + = ; , : ? *
  • spacji wiodących
  • znaków sterujących

W nazwach użytkowników nie jest uwzględniana wielkość liter.

Hasła

Hasła mogą być dowolną kombinacją 14 lub mniej znaków; hasła nie mogą zawierać znaków sterujących. W hasłach uwzględniana jest wielkość liter.


<Nazwa> nie jest prawidłową nazwą. Upewnij się, że nie zawiera nieprawidłowych znaków lub znaków przestankowych oraz czy nazwa

<Nazwa> nie jest prawidłową nazwą. Upewnij się, że nie zawiera nieprawidłowych znaków lub znaków przestankowych oraz czy nazwa nie jest za długa. (Błąd 3125)

Podana nazwa nie spełnia standardowych konwencji nazewnictwa lub nie jest poprawnym parametrem lub aliasem. Proszę się upewnić, czy podana nazwa nie zawiera błędnych znaków lub interpunkcji i czy nie jest za długa.


Obiekt nieprawidłowy dla operacji. (Błąd 3350)

Zastosowano metodę RefreshLink w stosunku do obiektu innego niż tabela połączona. Obiekt przestaje istnieć, kiedy zostaje zniszczony bądź kiedy skojarzony obiekt DAO zostanie zamknięty lub nie jest dłużej zdefiniowany w obecnym zakresie.


Nie można wykonać operacji. (Błąd 3032)

Prawdopodobne przyczyny:

  • Nastąpiła próba usunięcia jedynego konta użytkownika w grupie Admins. Grupa Admins musi zawierać przynajmniej jedno konto użytkownika. Jeśli konto to ma być usunięte, należy utworzyć nowe konto i dodać je do grupy Admins lub dodać do grupy Admins istniejące konto, a następnie usunąć żądane konto.
  • Nastąpiła próba umieszczenia użytkownika w grupie, do której już należy. Usiłowano to uczynić albo przez dodanie obiektu Group do kolekcji Groups obiektu User, w której to kolekcji już znajduje się obiekt Group o takiej samej nazwie, albo przez dodanie obiektu User do kolekcji Users obiektu Group, w której to kolekcji już znajduje się obiekt User o takiej samej nazwie.


Nieprawidłowy argument. (Błąd 3001)

Nastąpiła próba wykonania operacji wykorzystującej procedurę zawartą w bibliotece DLL, gdzie jeden z argumentów procedury jest niepoprawny. Sprawdź wprowadzone polecenie, aby upewnić się, czy podany został właściwy argument, i powtórz operację.

Błąd ten także występuje w przypadku próby użycia wzajemnie wykluczających się stałych jako argumentów metody, na przykład po określeniu zarówno dbConsistent, jak i dbInconsistent w argumencie opcje metody OpenRecordset.


To nie jest właściwe hasło. (Błąd 3031)

Zostało wprowadzone niewłaściwe hasło. Hasła mogą być dowolną kombinacją 14 lub mniej znaków, oprócz znaków sterujących. W hasłach są uwzględniane wielkości liter.


<Ścieżka> nie jest poprawną ścieżką. Sprawdź, czy nazwa ścieżki jest wprowadzona poprawnie oraz czy istnieje połączenie z

<Ścieżka> nie jest poprawną ścieżką. Sprawdź, czy nazwa ścieżki jest wprowadzona poprawnie oraz czy istnieje połączenie z serwerem, na którym jest przechowywany plik. (Błąd 3044)

Prawdopodobne przyczyny:

  • Wprowadzono specyfikację pliku zawierającą niewłaściwą ścieżkę. Na przykład, wprowadzono ścieżkę, która nie istnieje lub błędnie wpisano element w podanej ścieżce.
  • Określony plik znajduje się na dysku sieciowym, z którym nie masz połączenia. Sprawdź, czy sieć jest dostępna i powtórz operację.


Musisz wprowadzić identyfikator osobisty (PID) składający się z co najmniej 4 i nie więcej niż 20 znaków. (Błąd 3304)

Identyfikator osobisty (PID) musi składać się z co najmniej 4 i nie więcej niż 20 znaków.


Nieprawidłowa precyzja dla dziesiętnego typu danych. (Błąd 3700)

Precyzja i skala dla typu danych DECIMAL musi być w przedziale pomiędzy 0 i 28. Na przykład następująca instrukcja SQL zwróciłaby niniejszy błąd: CREATE TABLE foo (foo DECIMAL(38,0));


Nieprawidłowa ścieżka lub nazwa replikacji. (Błąd 3686)

Synchronizator określony przez adres HTTP nie zarządza bazą danych określoną w adresie URL.


Nieprawidłowa skala dla dziesiętnego typu danych. (Błąd 3701)

Skala typu danych DECIMAL musi być zawsze mniejsza lub równa precyzji. Na przykład następująca instrukcja SQL zwróciłaby niniejszy błąd: CREATE TABLE foo (foo DECIMAL(10,12));


Nieprawidłowy obiekt bazy danych. (Błąd 3263)

Podany obiekt Database nie jest wynikiem metody OpenDatabase, lub też został zmodyfikowany i nie jest już prawidłowy.


Nazwa tabeli <nazwa> w wyrażeniu definiującym filtr jest nieprawidłowa. (Błąd 3481)

Należy sprawdzić, czy w wyrażeniu użyto właściwej nazwy tabeli.


Niepoprawna nazwa tabeli w filtrze. (Błąd 3631)

W filtrze typu Boolean wystąpiło odwołanie do niepoprawnej tablicy. Filtry typu Boolean mogą odwoływać się wyłącznie do aktualnie filtrowanej tabeli.


Nieprawidłowy argument TOP w kwerendzie SELECT. (Błąd 3308)

W klauzuli TOP instrukcji SELECT wystąpił nieprawidłowy parametr. Wartość umieszczona za zastrzeżonym słowem TOP musi być dodatnią liczbą całkowitą. Jeżeli jest używane również zastrzeżone słowo PERCENT, to liczba całkowita nie może być większa niż 100.


Identyfikator Synchronizatora jest niezgodny z identyfikatorem istniejącym w tabeli MSysTranspAddress. (Błąd 3504)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można utworzyć repliki z repliki aparatu Jet SQL. (Błąd 3753)

Zestaw replik aparatu Microsoft® Jet SQL obsługuje topologię gwiazdy, gdzie publikacja SQL jest centrum, a subskrybent aparatu Jet Subscriber odgałęzieniem. Jeśli potrzebne są dodatkowe repliki aparatu Jet, należy utworzyć dodatkową subskrypcję Push/Pull publikacji SQL.


Wyrażenia ze sprzężeniami nie są obsługiwane. (Błąd 3296)

Prawdopodobne przyczyny:

  • Podana instrukcja SQL zawiera wielokrotne sprzężenia, więc wynik kwerendy może zależeć od kolejności ich stosowania. W celu wykonania wybranego sprzężenia w pierwszej kolejności należy utworzyć dla niego kwerendę, a następnie dołączyć tę kwerendę do instrukcji SQL.
  • Instrukcja ON zawarta w operacji JOIN jest niekompletna lub zawiera zbyt wiele tabel. Można umieścić wyrażenie ON w klauzuli WHERE.


Nie można dodać rekordu (rekordów); w zestawie rekordów brak klucza sprzężenia tabeli <nazwa>. (Błąd 3348)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem obsługi klienta firmy Microsoft.


Tabela sprzężona <nazwa> nie podana na liście klauzuli FROM. (Błąd 3080)

Dodaj wskazaną nazwę tabeli do klauzuli FROM kwerendy i powtórz operację.


Ta właściwość nie jest obsługiwana dla zewnętrznych źródeł danych lub dla baz danych utworzonych za pomocą poprzedniej wersji

Ta właściwość nie jest obsługiwana dla zewnętrznych źródeł danych lub dla baz danych utworzonych za pomocą poprzedniej wersji aparatu Microsoft Jet. (Błąd 3310)

Usiłowano ustawić lub sprawdzić właściwość niedostępną dla tego obiektu w bazie danych Microsoft® Jet 1.x, 2.x lub w zewnętrznym źródle danych. Poszukaj danego obiektu w Pomocy, a następnie wyświetl dla niego temat Podsumowanie, aby zobaczyć listę dopuszczalnych właściwości tego obiektu.


Właściwość KeepLocal nie może być ustawiana dla całej bazy danych, a jedynie dla poszczególnych jej obiektów. (Błąd 3458)

Właściwość KeepLocal jest ustawiana na wartość "T" dla tych obiektów bazy danych, które nie mają być replikowane. Właściwości tej nie można ustawić dla całej bazy danych.


Nie wprowadzono zmian w tabeli, gdyż doprowadziłoby to do powtórzenia wartości w indeksie, kluczu podstawowym lub relacji.

Nie wprowadzono zmian w tabeli, gdyż doprowadziłoby to do powtórzenia wartości w indeksie, kluczu podstawowym lub relacji. (Błąd 3022)

Nastąpiła próba duplikacji wartości w polu, które jest kluczem podstawowym lub indeksem nie zezwalającym na duplikaty w podległej tabeli.

Komunikat zawiera następującą instrukcję: Zmień dane w polu lub polach zawierających dane powtarzające się, usuń indeks lub zdefiniuj ponownie indeks tak, aby dopuszczał powtarzanie się danych, i powtórz operację.


Operacja nie jest dopuszczalna dla tabel połączonych. (Błąd 3057)

Dokonaj importu danych z tabeli i powtórz operację.


Repliki lokalne lub anonimowe muszą być synchronizowane tylko poprzez wskazaną replikę globalną. (Błąd 3738)

Źródłowa replika jest repliką lokalną lub anonimową; próbujesz wymiany danych ze złą repliką. Repliki lokalne i anonimowe można synchronizować jedynie z repliką globalną, która je utworzyła.


Zablokowana tabela. Ten rekord nie mógł zostać uwzględniony podczas synchronizacji z powodu zablokowania tabeli przez innego

Zablokowana tabela. Ten rekord nie mógł zostać uwzględniony podczas synchronizacji z powodu zablokowania tabeli przez innego użytkownika. Prześlij ponownie rekord powodujący konflikt. (Błąd 3714)

Zsynchronizuj repliki ponownie, kiedy blokada zostanie usunięta z tabeli.


Wystąpiło przepełnienie dysku dla ścieżki <nazwa>. (Błąd 3472)

Należy zwolnić miejsce na dysku przez usunięcie zbędnych plików.


Nieprawidłowa ścieżka <nazwa> do pliku dziennika. (Błąd 3591)

Upewnij się, że plik znajduje się w miejscu określonym w wartości Logfile klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Transporter w Rejestrze Microsoft® Windows® lub skonfiguruj synchronizator ponownie.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. W menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Katalog, w którym poszukiwano listy replik, nie jest katalogiem zarządzanym. (Błąd 3573)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można uczynić tabeli <nazwa> replikowalną - zbyt wiele kolumn. (Błąd 3705)

Nie można uczynić tabeli <nazwa> replikowalną – zbyt wiele kolumn. (Błąd 3705)

Ta tabela nie może być replikowalną, ponieważ nie można dodać kolumn systemu replikacji. Dodanie tych kolumn przekroczyłoby limit kolumn. Należy zredukować liczbę kolumn w tabeli przed przekształceniem jej do postaci replikowalnej.


Nie można uczynić tabeli <nazwa> replikowalną - zbyt wiele indeksów. (Błąd 3706)

Nie można uczynić tabeli <nazwa> replikowalną – zbyt wiele indeksów. (Błąd 3706)

Ta tabela nie może być replikowalną, ponieważ nie można dodać indeksów systemu replikacji. Dodanie tych indeksów przekroczyłoby maksymalny limit indeksów.


Nie można znaleźć folderu MAPI lub książki adresowej. (Błąd 3710)

Sterownik programu Microsoft® Outlook/Exchange nie mógł znaleźć żądanego folderu lub książki adresowej.

  • Sprawdź dostęp i uprawnienia do miejsca, w którym MAPI przechowuje folder lub książkę adresową.
  • Sprawdź, czy informacja odnośnie połączenia nie zależy od lokalizacji, jak np. mapowanych dysków na innym komputerze.
  • Sprawdź, czy nazwa folderu lub książki adresowej jest podana poprawnie.


Nie można utworzyć indeksu dla tego folderu MAPI/książki adresowej. (Błąd 3788)

Wiele folderów i książek adresowych programu Microsoft® Outlook/Exchange są składnikami używanymi w systemie i nie mogą być zmieniane w żaden sposób. Niniejszy komunikat o błędzie wskazuje na próbę utworzenia indeksu dla obiektu, takiego jak globalna lista adresowa lub folder publiczny, do którego nie masz uprawnień.


Brak pamięci podczas obliczeń. (Błąd 2446)

Aplikacja nie ma wystarczającej ilości pamięci do zakończenia obliczeń. Upewnij się, że jest wystarczająco dużo pamięci RAM oraz że jest utworzony plik wymiany. Możliwe, że trzeba będzie zakończyć inne programy, usunąć tapety pulpitu lub usunąć sterowniki niepotrzebnych urządzeń, aby uzyskać wystarczającą ilość wolnej pamięci.


Wystąpiło naruszenie zasad współużytkowania w folderze skrzynki źródłowej, gdyż baza danych z komunikatami jest otwarta w innej

Wystąpiło naruszenie zasad współużytkowania w folderze skrzynki źródłowej, gdyż baza danych z komunikatami jest otwarta w innej aplikacji. (Błąd 3565)

Należy zamknąć bazę danych z komunikatami. Użytkownicy nie powinni bezpośrednio otwierać tej bazy.


Komunikat w folderze skrzynki należy do niewłaściwego Synchronizatora. (Błąd 3567)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można znaleźć pliku memo bazy danych Xbase. (Błąd 3166)

Nastąpiła próba dostępu do pliku dBASE (.dbf), ale skojarzony plik memo (.dbt) nie został odnaleziony. Należy upewnić się, że plik .dbt znajduje się w tym samym katalogu, co plik .dbf, a następnie powtórzyć operację.


Błąd składniowy (brak operatora). (Błąd 2431)

W wyrażeniu lub instrukcji brakuje operatora.


Błąd składniowy (brak operatora). (Błąd 2434)

W wyrażeniu lub instrukcji brakuje operatora.


Brak ), ] lub innego elementu. (Błąd 2436)

Wprowadzono wyrażenie, w którym brakuje okrągłego lub kwadratowego nawiasu zamykającego lub kreski pionowej. Sprawdź wyrażenie, aby upewnić się, że zostało wprowadzone poprawnie.


Nie można ustawić wielokrotnych atrybutów NULL, NOT NULL. (Błąd 3806)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie znaleziono obiektu w tej kolekcji. (Błąd 3265)

Próba odwołania do nazwy z kolekcji nie powiodła się.

Prawdopodobne przyczyny:

  • Obiekt nie istnieje w tej kolekcji. Przed odwołaniem się do obiektu należy się upewnić, że obiekt został dołączony do kolekcji.
  • W kolekcji znajduje się kilka obiektów o tej nazwie; nazwa jest więc niejednoznaczna. Należy odwołać się do obiektu poprzez jego numer porządkowy w kolekcji (na przykład Recordsets(3)).


Należy użyć bazy danych w formacie wersji 4.x lub większej aby wykonać operację. (Błąd 3808)

Podczas używania mechanizmu Microsoft® OLE DB Provider dla aparatu Jet z opcja bezpieczeństwa, konieczne jest aby plik bazy danych zabezpieczeń był w formacie aparatu Jet w wersji 4.x. Może to być za pomocą kompaktowania istniejącej bazy danych zabezpieczeń lub utworzenia nowej przez mechanizm Microsoft OLE DB Provider dla aparatu Jet.


Nie można otworzyć <nazwa tabeli>. Inny użytkownik otworzył tabelę, wykorzystując inny plik sterowania siecią lub styl

Nie można otworzyć <nazwa tabeli>. Inny użytkownik otworzył tabelę, wykorzystując inny plik sterowania siecią lub styl blokowania. (Błąd 3418)

Aparat bazy danych Microsoft Jet nie może otworzyć zewnętrznej tabeli programu Paradox z powodu niezgodności występujących między ustawieniami lokalnymi inicjującymi i ustawieniami użytkownika, który wcześniej otworzył tę tabelę i z nią pracuje. Ustawienia ParadoxNetPath i ParadoxNetStyle w \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox Rejestru Windows muszą być zgodne dla wszystkich użytkowników współużytkujących bazę danych. Zapewnij zgodność lokalnych ustawień inicjujących z ustawieniami wszystkich pozostałych użytkowników bazy danych i spróbuj ponownie otworzyć tabelę.


Błąd operacji wejścia/wyjścia w sieci. (Błąd 3566)

Wystąpił problem w komunikacji komputera z siecią. Sprawdź, czy sieć działa prawidłowo i czy kabel sieciowy nie jest luźny. Zamknij system, wyłącz zasilanie komputera, po czym ponownie uruchom komputer.


Nie można utworzyć nowej repliki, ponieważ obiekt <nazwa> w kontenerze <nazwa> nie może zostać obiektem replikowalnym. (Błąd

Nie można utworzyć nowej repliki, ponieważ obiekt <nazwa> w kontenerze <nazwa> nie może zostać obiektem replikowalnym. (Błąd 3582)

Baza danych nie mogła zostać przekształcona do postaci replikowalnej, ponieważ określony obiekt nie mógł być zreplikowany. Na przykład, jeśli przekroczony jest maksymalny numer dozwolonych indeksów dla tabeli, nie może ona być zreplikowana. Aby zapobiec powstawaniu tego błędu, upewnij się przed przekształceniem bazy danych do postaci replikowalnej, czy obiekty w bazie danych spełniają wymagania replikacji.


Nie można zrealizować tej operacji, ponieważ brak jest aktywnego połączenia. (Błąd 3668)

Następująca operacja nie mogła być wykonana bez otwartego połączenia z obiektem. Otwórz połączenie i powtórz operację.


Brak aktywnego transportu dla Synchronizatora. (Błąd 3508)

Należy zmienić konfigurację programu Menedżer replikacji.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. Z menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Ciąg znaków o zerowej długości jest dopuszczalny tylko w polu typu Text lub Memo. (Błąd 3415)

Nastapiła próba wpisania ciągu o długości zerowej w polu o typie danych innym niż Text lub Memo. W zamian można spróbować wprowadzić wartość Null.


Nie można znaleźć ścieżki sieciowej lub nazwy użytkownika. (Błąd 3171)

Co najmniej jedna pozycja klucza \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox w Rejestrze Windows® jest nieprawidłowa. Należy poprawić nieprawidłowe pozycje, a następnie powtórzyć operację.


Ograniczenie CHECK dla tabeli <nazwa> nie zostanie przeniesione dla tej tabeli. Ograniczenia CHECK mogą być tworzone jedynie

Ograniczenie CHECK dla tabeli <nazwa> nie zostanie przeniesione dla tej tabeli. Ograniczenia CHECK mogą być tworzone jedynie poprzez instrukcje DLL języka SQL. (Błąd 3805)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Operacja niedopuszczalna bez bieżącego indeksu. (Błąd 3019)

Ustaw Index, a następnie powtórz operację.


Brak bieżącego rekordu. (Błąd 3021)

Błąd ten pojawia się po zakończonym niepowodzeniem zastosowaniu jednej z metod Find lub metody Seek, kiedy odpowiadający im zbiór rekordów Recordset nie zawiera żadnych rekordów lub rekord został usunięty. Przejdź do innego rekordu lub wybierz inny rekord, a następnie powtórz operację. Jeśli zbiór Recordset jest pusty, nie można ustawić się na bieżącym rekordzie. Sprawdź właściwości BOF i EOF.


Brak określenia bazy danych w ciągu połączenia lub w klauzuli IN. (Błąd 3321)

Aparat bazy danych Microsoft Jet nie jest w stanie połączyć się z zewnętrzną bazą danych ISAM, ponieważ nie została określona jej nazwa. Aby połączyć się z zewnętrznym źródłem danych, należy podać nazwę bazy danych.

Prawdopodobne przyczyny:

  • W ciągu połączenia w klauzuli FROM instrukcji SELECT brak parametru DATABASE=.
  • Klauzula IN instrukcji SELECT zawiera argument określający typ bazy danych (wskazujący, że dane mają być pobierane z zewnętrznej bazy danych), ale nie zawiera argumentu określającego nazwę bazy danych.


Synchronizator nie znalazł do wykonania żadnej (ani zaplanowanej, ani na żądanie) synchronizacji. (Błąd 3514)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Brak indeksu dla kolumny GUID. (Błąd 3550)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Brak nazwy pola przeznaczenia w instrukcji INSERT INTO <instrukcja>. (Błąd 3352)

Nie można określić nazwy lub nazw pola przeznaczenia z wyrażenia umieszczonego w klauzuli SELECT instrukcji INSERT INTO.


Żądany klucz nie ma przypisanej wartości w Rejestrze Synchronizatora. (Błąd 3503)

Należy na komputerze ponownie skonfigurować Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. Z menu Narzędzia wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Nie ma klientów MAPI zainstalowanych na tym komputerze. Zainstaluj klienta MAPI, takiego jak program Outlook na tym komputerze.

Nie ma klientów MAPI zainstalowanych na tym komputerze. Zainstaluj klienta MAPI, takiego jak program Outlook na tym komputerze. (Błąd 3804)

IISAM programu Microsoft® Outlook/Exchange używa API obsługi wiadomości (MAPI) do otrzymania informacji o folderze lub książce adresowej. Aby mieć interfejs MAPI na komputerze, należy zainstalować jednego z klientów e-mail firmy Microsoft używającego MAPI, takiego jak Klient Outlook, Outlook Express, lub Klient Exchange. Zanim ta operacja nie zostanie przeprowadzona, Outlook/Exchange IISAM nie może funkcjonować.


Żadna z nazw importowanych pól nie jest zgodna z nazwą pola w tabeli dołączonej. (Błąd 3243)

Co najmniej jedna nazwa pola tabeli importowanej i jedna nazwa pola tabeli dołączanej muszą być takie same.


Synchronizator nie znalazł żadnych komunikatów do przetworzenia. (Błąd 3517)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można otworzyć więcej tabel ani kwerend. (Błąd 3037)

Limit tabeli i kwerend otwartych jednocześnie został wyczerpany. Zamknij jedną lub więcej tabel lub kwerend, a następnie powtórz operację.


Wyczerpanie dojść do plików MS-DOS. (Błąd 3042)

Zamknij część plików, zamknij inne aplikacje lub zwiększ liczbę dostępnych dojść do plików w systemie MS-DOS.

Aby zwiększyć liczbę dojść do plików

  1. Poddaj edycji plik CONFIG.sys, korzystając z Notatnika Microsoft Windows lub innego edytora tekstowego. Plik CONFIG.sys znajduje się w katalogu głównym dysku rozruchowego. Jeśli w systemie nie ma pliku CONFIG.sys, należy go utworzyć i umieścić w nim wiersz opisany w kroku 2.
  2. Odszukaj wiersz FILES = x, gdzie x jest pewną liczbą. Zwiększ liczbę określaną poleceniem FILES; właściwa liczba dojść zależy od uruchamianych aplikacji i liczby jednocześnie otwartych plików. Jeśli inne aplikacje wymagają otwarcia wielu plików, konieczne jest zwiększenie liczby dojść do plików.

    Przy zwiększaniu liczby dojść do plików należy pamiętać o tym, że każde dodatkowe dojście zużywa pamięć operacyjną. Dodatkowe informacje można uzyskać w podręczniku użytkownika systemu operacyjnego.

  3. Zakończ pracę systemu Microsoft Windows.
  4. Uruchom ponownie system, a następnie powtórz operację.


Nie można otworzyć tabeli 'MSysAccounts' w pliku informacyjnym grupy roboczej. (Błąd 3173)

Ta operacja wymaga pliku System.mdw, który zawiera ustawienia zabezpieczeń i opcji dla tabel baz danych aparatu Microsoft Jet.

Prawdopodobne przyczyny:

  • Wartość SystemDB klucza Rejestru \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet wskazuje na dysk sieciowy, który nie jest podłączony. Należy upewnić się, że stacja sieciowa jest dostępna, a następnie powtórzyć operację.
  • Plik System.mdw jest uszkodzony. Jeśli istnieje zapasowa kopia pliku System.mdw, należy ją skopiować w miejsce określone przez pozycję SystemDB Rejestru.


Nie można otworzyć tabeli 'MSysGroups' w pliku informacyjnym grupy roboczej. (Błąd 3174)

Ta operacja wymaga pliku System.mdw, który zawiera ustawienia zabezpieczeń i opcji dla tabel bazy danych aparatu Microsoft Jet.

Prawdopodobne przyczyny:

  • Wartość SystemDB klucza Rejestru Microsoft® Windows® \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet wskazuje na dysk sieciowy, który nie jest podłączony. Należy upewnić się, że stacja sieciowa jest dostępna, a następnie powtórzyć operację.
  • Plik System.mdw jest uszkodzony. Jeśli istnieje zapasowa kopia pliku System.mdw, należy ją skopiować w miejsce określone przez pozycję SystemDB Rejestru.


Brak w pamięci wspólnej nowych danych do czytania dla Synchronizatora lub Menedżera replikacji. (Błąd 3528)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Brak zaplanowanych synchronizacji pomiędzy dwoma Synchronizatorami. (Błąd 3495)

Harmonogram pomiędzy dwoma Synchronizatorami został usunięty lub próbujesz ustalić harmonogram pomiędzy Synchronizatorem Twojego komputera i nim samym. Należy skorzystać z programu Menedżer replikacji, aby ustawić plan synchronizacji z właściwym Synchronizatorem.


Brak nazwy pola przeznaczenia w instrukcji SELECT INTO: <instrukcja>. (Błąd 3105)

We wskazanej instrukcji wprowadź nazwę pola przeznaczenia i powtórz operację.


Specyfikacja stałej szerokości <nazwa> nie zawiera szerokości kolumn. (Błąd 3443)

Parametr określający stałą szerokość podany w specyfikacji pliku tekstowego dla instalowalnego sterownika ISAM jest nieprawidłowy, ponieważ nie określa szerokości kolumny. Specyfikację można ustawiać różnymi sposobami:

  • Z programu Microsoft Access wartości te są ustawiane w kreatorze połączonego tekstu (można z niego skorzystać wybierając z menu Plik opcję Pobierz dane zewnętrzne, a następnie polecenie Połącz tabele). Wartości można także zobaczyć w tabelach systemowych MSysIMEXSpecs i MSysIMEXColumns.
  • Z innych aplikacji hosta Microsoft Jet wartości te są zapisywane w pliku Schema.ini.


Specyfikacja pliku tekstowego <nazwa> nie istnieje. Nie można importować, eksportować, ani ustanawiać łączy, używając tej

Specyfikacja pliku tekstowego <nazwa> nie istnieje. Nie można importować, eksportować, ani ustanawiać łączy, używając tej specyfikacji. (Błąd 3625)

Program Microsoft® Access próbował importować/eksportować/łączyć się do pliku tekstowego używając nazwy tabeli specyfikacji, która nie istnieje w tabeli MSysIMEXSpecs bazy danych. Utwórz połączenie ponownie używając poprawnej tabeli specyfikacji.


Podana wartość nie jest równa identyfikatorowi repliki (ReplicaID) żadnego z elementów zestawu replik. (Błąd 3488)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie może znaleźć we właściwym zestawie repliki potrzebnej do zakończenia synchronizacji. (Błąd 3547)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Zewnętrzna tabela nie ma oczekiwanego formatu. (Błąd 3274)

Format tabeli uległ zmianie od chwili jej połączenia. Należy ponownie połączyć tabelę, a następnie powtórzyć operację.


Nie można importować tabeli lub kwerendy. Nie znaleziono rekordów lub wszystkie rekordy zawierają błędy. (Błąd 3297)

Aparat baz danych Microsoft Jet nie może znaleźć tabeli lub kwerendy, które miały być importowane, albo nie znaleziono rekordów w określonym źródle danych, albo wszystkie rekordy zawierają błędy. Należy sprawdzić podaną ścieżkę i powtórzyć operację.


Aparat bazy danych Microsoft Jet nie został zainicjowany. (Błąd 3278)

Nie można zainicjować aparatu bazy danych.

Prawdopodobne przyczyny:

  • Wystąpił konflikt z inną aplikacją korzystającą z aparatu baz danych Microsoft Jet. Należy zakończyć pracę z wszystkimi innymi aplikacjami, a następnie ponownie uruchomić własną aplikację.
  • Wystąpił błąd podczas instalacji. Należy ponownie zainstalować aplikację.


Próba zatwierdzenia lub wycofania transakcji bez uprzedniego wykonania rozpoczęcia transakcji. (Błąd 3034)

Nastąpiła próba zatwierdzenia lub wycofania transakcji, która nie została rozpoczęta instrukcją BeginTrans.


Brak dostępu do dowiązanego pliku DBF <nazwa_pliku> bazy FoxPro 3.0. (Błąd 3623)

Nastąpiła próba dostępu do dowiązanego pliku .dbf bazy Microsoft ® FoxPro® 3.0. Pliki dowiązane są dostępne tylko przez kontener bazy danych FoxPro, do którego są dowiązane.


Brak nazwy pola przeznaczenia w instrukcji UPDATE: <instrukcja>. (Błąd 3106)

We wskazanej instrukcji wprowadź nazwę pola przeznaczenia i powtórz operację.


Obiekt nie ma wartości. (Błąd 2427)

Wprowadzono wyrażenie zawierające identyfikator obiektu, który nie ma wartości. (Obiekty mogą mieć wartość domyślną właściwości lub zwracać domyślną metodę.)

Sprawdź wyrażenie, aby upewnić się, że zostało wprowadzone poprawnie.


Nie można przypisać wartości Null do pola <nazwa> w kluczu sprzężenia. (Błąd 3100)

Wykryto próbę przypisania wartości Null polu po którejś ze stron sprzężenia. Albo wybierz inne pola, albo wprowadź dane do pól i ponów operację.


Usiłowano przypisać wartości Null zmiennej o typie danych innym niż Variant. (Błąd 3162)

Nastąpiła próba przypisania wartości Null do zmiennej, która nie jest zmienną typu Variant . Należy zadeklarować zmienną jako Variant za pomocą instrukcji Dim, a następnie powtórzyć operację.


Indeks i klucz podstawowy nie mogą zawierać wartości Null. (Błąd 3058)

Prawdopodobne przyczyny:

  • Nastąpiła próba dodania wartości Null do pola klucza podstawowego.
  • Nastąpiła próba dodania nowego rekordu bez wprowadzenia wartości w pole klucza podstawowego.
  • Wykonano kwerendę, która próbowała nadać polu klucza podstawowego wartość Null.


Liczba określonych aliasów musi być równa liczbie wyjściowych kolumn. (Błąd 3731)

Ten błąd powstaje przy próbie utworzenia widoku poprzez DDL języka SQL. Pojawia się on, gdy jest zdefiniowana różna liczba powiązanych nazw lub aliasów od wynikającej z zawartości instrukcji SELECT. Na przykład, następująca składnia spowodowałaby powstanie niniejszego błędu: CREATE VIEW foo (col1, col2) AS SELECT col1 FROM table1.


Przepełnienie pola numerycznego. (Błąd 3349)

Dane wpisane w pole Btrieve są za duże dla aplikacji.


Nie można utworzyć nowej repliki, ponieważ obiekt <nazwa> kontenera <nazwa> nie może być replikowany. (Błąd 3490)

Aparat baz danych Microsoft Jet przeprowadzał proces tworzenia repliki. Podczas próby przetworzenia obiektu i pojemnika o podanych nazwach wystąpił błąd.


Obiekt <nazwa> już istnieje. (Błąd 3012)

Nastąpiła próba utworzenia obiektu o nazwie, która już istnieje w tej bazie danych. Wybierz inną nazwę i powtórz operację.


Podany obiekt nie może być replikowany, ponieważ brak potrzebnych zasobów. (Błąd 3489)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem obsługi klienta firmy Microsoft.


Aparat bazy danych Microsoft Jet nie może znaleźć obiektu <nazwa>. Upewnij się, że obiekt istnieje, a jego nazwa i nazwa

Aparat bazy danych Microsoft Jet nie może znaleźć obiektu <nazwa>. Upewnij się, że obiekt istnieje, a jego nazwa i nazwa ścieżki podane są prawidłowo. (Błąd 3011)

Prawdopodobne przyczyny:

  • Określony obiekt nie istnieje.
  • Nazwa obiektu została podana nieprawidłowo. Sprawdź, czy nie brakuje znaków podkreślenia ( _ ) lub innych znaków interpunkcji, sprawdź też, czy nie wprowadzono spacji poprzedzających nazwę.
  • Ścieżki wskazane w pliku definicji danych Plik.ddf przy próbie otwarcia tabeli Btrieve są niewłaściwe. Upewnij się, czy pliki danych (.dat) znajdują się we właściwych katalogach.


Obiekt <nazwa> zawarty w kontenerze <nazwa> nie może zostać przekształcony do postaci replikowalnej. (Błąd 3456)

Aparat bazy danych Microsoft Jet przeprowadzał proces przekształcania obiektu do postaci replikowalnej. Operacja się nie powiodła z powodu niewystarczających zasobów systemowych do manipulacji obiektem. Jeśli dany obiekt jest tabelą, należy upewnić się, że całkowita liczba pól tej tabeli nie przekroczy po replikacji 255, a całkowita liczba bajtów w rekordzie nie przekroczy 2048. Jeżeli liczba pól lub znaków przekracza dozwolony limit, należy zmniejszyć rozmiar rekordów.


Obiekt nie jest procedurą SQL. (Błąd 3749)

Ten błąd występuje przy użyciu słowa kluczowego EXECUTE, gdzie przekazywana jest nazwa procedury lub widoku, który nie istnieje w bazie danych lub przekazywana jest nazwa tabeli podstawowej.


Niepoprawne użycie ".", "!" lub "()". (Błąd 2447)

Wyrażenie nie używa ograniczników poprawnie. Aby odnieść się do właściwości obiektu DAO, sugerowane jest użycie składni .nazwa_właściwości.


Nieaktualny plik blokad bazy Paradox. (Błąd 3230)

Podczas próby korzystania z tabeli bazy Paradox okazało się, że plik blokad (.lck) jest nieaktualny. Należy usunąć plik .lck i ponowić operację.


Błąd niezgodności specyfikacji ODBC <komunikat>. Zawiadom projektanta aplikacji o błędzie. (Błąd 3299)

Ten błąd może być wynikiem problemów ze sterownikiem ODBC. Należy zapisać numer błędu podany w komunikacie i powiadomić o nim projektanta aplikacji, który następnie przekaże go producentowi sterownika.


Błąd otwarcia pliku w formacie Microsoft Excel 5.0. (Błąd 3432)

Podczas otwierania pliku w formacie Microsoft® Excel w wersji 5.0 wystąpił błąd OLE.


Podczas ładowania instalowalnej bazy danych ISAM programu Microsoft Excel nie można było zainicjować obsługi OLE. (Błąd 3430)

Podczas ładowania instalowalnego sterownika ISAM programu Microsoft® Excel system automatyzacji OLE nie był w stanie się zainicjować. Spróbuj ponownie zainstalować pliki DLL OLE.


To nie jest plik w formacie Microsoft Excel 5.0. (Błąd 3431)

Próbowano odczytać plik jako plik w formacie Microsoft® Excel w wersji 5.0, ale nie jest to plik w tym formacie.


Jeden z parametrów wiążących jest niepoprawny. (Błąd 3645)

Typ danych lub typ wiązania w strukturze wiążącej przekazanej do metod GetRows lub GetRowsEx miał nieprawidłową wartość lub maksymalna długość pola jest nieprawidłowa dla tego typu.

Należy sprawdzić poprawność struktury wiążącej.


Jeden z rekordów obiektu Recordset został usunięty przez inny proces. (Błąd 3643)

Jeden lub więcej rekordów obiektu Recordset zostało usuniętych po wykonaniu kwerendy. Należy odświeżyć obiekt Recordset i ponowić kwerendę.


Wywołanie asynchroniczne OpenConnection nie zostało ukończone; do czasu jego ukończenia nie można odwoływać się do zwracanego

Wywołanie asynchroniczne OpenConnection nie zostało ukończone; do czasu jego ukończenia nie można odwoływać się do zwracanego obiektu Connection. (Błąd 3664)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Aby mogła być replikowana, baza danych musi być otwarta w trybie wyłączności. (Błąd 3491)

Wykonano próbę replikacji bazy danych, która uprzednio została otwarta w trybie współużytkowania. Należy zamknąć bazę danych, otworzyć ponownie w trybie wyłącznym i ponowić próbę replikacji.


Nie powiodło się otwarcie pliku za pomocą usługi FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu.

Nie powiodło się otwarcie pliku za pomocą usługi FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do odczytu. (Błąd 3679)

Nie powiodło się otwarcie pliku na serwerze internetowym. Należy się upewnić, czy serwer jest uruchomiony i uprawnienia zapisu/odczytu są poprawnie skonfigurowane dla skrzynki FTP.


Operacja anulowana przez użytkownika. (Błąd 3059)

Operacja została zatrzymana przed jej normalnym zakończeniem. Niektóre zmiany w danych mogły nie zostać zapisane.


Podjęta operacja jest w konflikcie z aktualną operacją wykonywaną na danym elemencie zestawu replik. (Błąd 3460)

Inny użytkownik lub aplikacja wykonują tę samą operację, na tym samym elemencie zestawu replik. W tej sytuacji należy po pewnym czasie ponowić operację.


Operacja nie jest obsługiwana dla replikowalnych baz danych, które nie zostały skonwertowane do bieżącej wersji. (Błąd 3703)

Ta replika została utworzona za pomocą poprzedniej wersji aparatu Microsoft® Jet. Aby wykonać operację replikacji, najpierw należy skompaktować/skonwertować zestaw replik.


Ta operacja nie jest dozwolona w podkwerendach. (Błąd 3787)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Klauzula ORDER BY <klauzula> koliduje z predykatem DISTINCT. (Błąd 3093)

Utworzono instrukcję SQL, w której umieszczono predykat ALL, DISTINCT lub DISTINCTROW oraz klauzulę ORDER BY zawierającą pole nie podane na liście instrukcji SELECT. Usuń słowo zastrzeżone DISTINCT lub usuń określone pole z klauzuli ORDER BY.


Klauzula ORDER BY <klauzula> koliduje z klauzulą GROUP BY. (Błąd 3094)

Ten błąd występuje, gdy zostanie utworzona kwerenda wybierająca i po polach sortowanych, które nie podlegają grupowaniu, zostaną podane grupowane pola. Na przykład, utworzono instrukcję SQL z polem umieszczonym w klauzuli ORDER BY w niewłaściwej kolejności. Przenieś to pole na lewo od pól nie grupowanych lub usuń to pole z klauzuli ORDER BY.


Klauzula ORDER BY <wyrażenie> zawiera pola, które nie są wybierane przez kwerendę. Wyrażenie ORDER BY może zawierać tylko pola

Klauzula ORDER BY <wyrażenie> zawiera pola, które nie są wybierane przez kwerendę. Wyrażenie ORDER BY może zawierać tylko pola wybierane w pierwszej kwerendzie. (Błąd 3351)

W wyrażeniu ORDER BY kwerendy składającej zostały zawarte pola nie wybrane w kwerendzie. Wyrażenie ORDER BY może zawierać tylko pola wybierane w pierwszej kwerendzie.


Odwołanie cykliczne spowodowane przez alias <nazwa> na liście SELECT definicji kwerendy. (Błąd 3103)

Podany alias utworzył odwołanie, które nie może być poprawnie zinterpretowane. Na przykład, błąd ten może pojawić się, jeśli zostanie wprowadzona poniższa instrukcja SQL, w której A jest odwołaniem cyklicznym:

SELECT A + B AS C, C + D AS E, E + F AS A
FROM MojaTabela;

SELECT tydzień1 + tydzień 2 as godziny, godziny + nadgodziny as brutto, brutto + dodatki as tydzień1 FROM PracownikPłace


Nie można odnaleźć tabeli wynikowej <nazwa>. (Błąd 3192)

Nastąpiła próba użycia instrukcji INSERT INTO z tabelą, która nie istnieje. Należy się upewnić, że wprowadzono prawidłową nazwę, a następnie powtórzyć operację.

Jeżeli próbujesz wykonać kwerendę tworzącą tabelę, użyj składni SELECT INTO.


Plik wymiany przepełnił się lub jest uszkodzony. (Błąd 3540)

Synchronizator napotkał nieoczekiwany problem w systemie. Należy zamknąć system, wyłączyć komputer i uruchomić go ponownie.


Zażądano blokowania na poziomie stron, ale baza danych jest w trybie blokowania rekordów. (Błąd 3752)

Ten błąd występuje, gdy użytkownik zażąda otwarcia bazy danych w trybie blokowania wyłącznie na poziomie stron, ale inny użytkownik otworzył już bazę danych w trybie blokowania rekordów/stron.


Parametr <nazwa> nie posiada wartości domyślnej. (Błąd 3748)

Ten błąd występuje przy użyciu procedur. Pojawia się on, gdy nastąpi próba użycia wartości domyślnej, podczas gdy parametr nie ma zdefiniowanej takiej wartości. Aby zapobiec występowaniu tego błędu, zdefiniuj wartość domyślną w procedurze, lub przekaż wartość do parametru.


Parametr nie posiada wartości domyślnej. (Błąd 3747)

Ten błąd występuje przy użyciu procedur. Pojawia się on, gdy nastąpi próba użycia wartości domyślnej, podczas gdy parametr nie ma zdefiniowanej takiej wartości. Aby zapobiec występowaniu tego błędu, zdefiniuj wartość domyślną w procedurze lub przekaż wartość do parametru.


Rozmiar parametru Rejestru przekracza dopuszczalną wartość maksymalną. (Błąd 3552)

Każdy parametr w Rejestrze Microsoft® Windows® posiada rozmiar maksymalny. Ustawienie, które próbowano zastosować, przekracza ten rozmiar. Sprawdź, ile wynosi ograniczenie odnoszące się do ustawianego parametru.


Błąd składniowy w wyrażeniu filtru częściowego dla tabeli <nazwa>. (Błąd 3586)

Sprawdź poprawność składni wyrażenia.


Filtry definiujące replikę częściową nie są z sobą zsynchronizowane. (Błąd 3570)

Nastąpiła zmiana filtrów w replice częściowej od ostatniego wypełnienia repliki częściowej. Należy ponownie wypełnić replikę częściową przez Kreatora repliki częściowej, lub używając metody PopulatePartial Method w kodzie VBA.


Replika współpracująca nie jest zarządzana przez Synchronizator. (Błąd 3628)

Nastąpiła próba zsynchronizowania z repliką współpracującą, która nie jest zarządzana przez Synchronizator.


Nieprawidłowa replika do synchronizacji. Repliki lokalne lub anonimowe muszą synchronizować z wskazaną repliką globalną. (Błąd

Nieprawidłowa replika do synchronizacji. Repliki lokalne lub anonimowe muszą synchronizować z wskazaną repliką globalną. (Błąd 3741)

Podany synchronizator nie jest prawidłowy dla tego zestawu replik lub nie jest serwerem synchronizacji dla repliki anonimowej lub lokalnej. Replikę lokalną lub anonimową można synchronizować jedynie z repliką globalną, z której zostały one utworzone.


Arkusz kalkulacyjny chroniony hasłem nie może być importowany. (Błąd 3244)

Należy wrócić do aplikacji, za pomocą której zapisano arkusz kalkulacyjny, zapisać go ponownie jako nie chroniony hasłem, a następnie ponowić próbę importu.


Nie można uaktualnić. Baza danych lub obiekt przeznaczony jest tylko do odczytu. (Błąd 3027)

Nastąpiła próba zapisania zmian w bazie danych otwartej w trybie tylko do odczytu.

Baza danych pracuje w trybie tylko do odczytu z jednego z poniższych powodów:

  • Zastosowano metodę OpenDatabase i otwarto bazę danych w trybie tylko do odczytu.
  • W systemie Visual Basic® zastosowano formant Data, w którym ustawiono właściwość ReadOnly na wartość True.
  • Plik bazy danych jest zdefiniowany jako tylko do odczytu w systemie operacyjnym lub w sieci.
  • Plik bazy danych jest przechowywany na nośniku przeznaczonym tylko do odczytu.
  • Nie posiadasz uprawnień zapisu dla pliku bazy danych w środowisku sieciowym.
  • Podczas pracy z zabezpieczoną bazą danych, baza lub jeden z jej obiektów (taki jak pole lub tabela) może być ustawiony na tryb tylko do odczytu. Użytkownik o podanej nazwie i haśle może nie mieć zezwolenia na dostęp do tych danych.

Zamknij bazę danych, usuń przyczynę ustawienia pliku w tryb tylko do odczytu, a następnie otwórz ponownie plik w trybie do odczytu i zapisu.


Nie można usunąć danych z repliki Prevent Deletes. (Błąd 3754)

Replika Prevent Deletes jest repliką zaprojektowaną tak, aby uniemożliwić użytkownikom usuwanie rekordów. Jeżeli niezbędne jest usunięcie danych, operacja musi być wykonana na replice zezwalającej na usuwanie rekordów.


Nie można dodać rekordu (rekordów); w zestawie rekordów brak klucza podstawowego tabeli <nazwa>. (Błąd 3347)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem obsługi klienta firmy Microsoft.


Nieprawidłowa składnia SQL - oczekiwano nazwy procedury. (Błąd 3781)

Nieprawidłowa składnia SQL – oczekiwano nazwy procedury. (Błąd 3781)

Ten błąd występuje przy próbie utworzenia lub usunięcia procedury za pomocą składni CREATE PROCEDURE lub DROP PROCEDURE z języka DDL SQL. Pojawia się, gdy prawidłowa nazwa nie jest podana. Na przykład następująca instrukcja wygenerowałaby błąd: DROP PROCEDURE.


Proces został zatrzymany przy próbie zakończenia działania klienta Synchronizatora. (Błąd 3542)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Określona właściwość już istnieje. (Błąd 3311)

Usiłowano dołączyć nowy obiekt Property do kolekcji, która zawiera już właściwość o takiej samej nazwie. Sprawdź, czy nie ma błędu w pisowni właściwości Name nowego obiektu Property, lub skorzystaj z tematu Pomocy dla istniejącej właściwości o tej samej nazwie, aby zobaczyć, czy jest potrzebne utworzenie nowego obiektu Property.


Wartość właściwości jest za duża. (Błąd 3309)

Usiłowano ustawić właściwość obiektu na rozmiar większy niż największy dopuszczalny rozmiar wynoszący 2KB. Zmniejsz wartość właściwości.


Nie można zapisać właściwości, ponieważ jest to właściwość schematu. (Błąd 3394)

Próbowano ustawić lub zmienić właściwość schematu. Przy tworzeniu nowej właściwości schematu należy jako czwarty argument metody CreateProperty podać wartość True, co umożliwi ustawianie lub usuwanie tej właściwości.


Nie powiodło się umieszczenie pliku na serwerze przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do

Nie powiodło się umieszczenie pliku na serwerze przy użyciu FTP. Należy się upewnić, czy skrzynka FTP posiada uprawnienia do zapisu. (Błąd 3681)

Nie powiodło się umieszczenie pliku na serwerze internetowym. Należy się upewnić, czy serwer jest uruchomiony i uprawnienia zapisu/odczytu są poprawnie skonfigurowane dla skrzynki FTP.


<Nazwa> w wyrażeniu kryterium. (Błąd 3076)

Wprowadzone wyrażenie nie jest poprawne z powodu wymienionego w komunikacie. Sprawdź, czy nazwy pól i znaki przestankowe zostały wpisane poprawnie i powtórz operację.


W kwerendzie krzyżowej nie można określić więcej niż raz stałego nagłówka kolumny <wartość>. (Błąd 3104)

Podczas tworzenia kwerendy krzyżowej o stałych nagłówkach kolumn określane wartości muszą być unikatowe. Zmień jeden lub więcej powtarzających się nagłówków kolumn, a następnie powtórz operację.


Kwerenda <nazwa> zawiera niejednoznaczną nazwę kolumny, która pozostaje w konflikcie z nazwą powiązania (aliasem) <nazwa>.

Kwerenda <nazwa> zawiera niejednoznaczną nazwę kolumny, która pozostaje w konflikcie z nazwą powiązania (aliasem) <nazwa>. (Błąd 3807)

Określ w pełni nazwę kolumny lub zmień nazwę powiązania (alias). Instrukcja SELECT języka SQL używa nazwy powiązania (aliasu) użytej w jednej z tabel podstawowych w klauzuli FROM instrukcji. Poprzednie wersje aparatu Microsoft® Jet zwracały nieprawidłowy zestaw wyników w takiej sytuacji. Aby zapobiec zmianie zestawów wyników, wprowadzony został niniejszy komunikat o błędzie.

Ta instrukcja SELECT języka SQL funkcjonować będzie przy użyciu z mechanizmem Microsoft OLE DB Provider dla aparatu Jet lub poprzez Active Data Objects (ADO). Jeśli ta instrukcja SELECT języka SQL używana jest przez jakąkolwiek część programu Microsoft Access bez ADO używając mechanizmu Microsoft OLE DB Provider dla aparatu Jet, należy zmienić nazwę powiązania (alias) na coś innego, niż nazwę kolumny w tabeli podstawowej.

Przykładem tego byłoby następujące: CREATE TABLE Zamówienia (DataZamówienia DATE, FrachtDOUBLE);. Następująca instrukcja SELECT języka SQL zwróciłaby błąd: SELECT DataZamówieniaAS A1, Fracht + Fracht AS DataZamówienia. Innym rozwiązaniem byłaby zmiana nazwy powiązania (aliasu) DataZamówienia na inną nazwę lub wykonanie kwerendy poprzez ADO przy użyciu mechanizmu Microsoft OLE DB Provider dla aparatu Jet.


Podane odwołanie do pola <pole> może odnosić się do więcej niż jednej tabeli podanej na liście klauzuli FROM w instrukcji SQL.

Podane odwołanie do pola <pole> może odnosić się do więcej niż jednej tabeli podanej na liście klauzuli FROM w instrukcji SQL. (Błąd 3079)

Podane odesłanie do pola może odnosić się do więcej niż jednej tabeli wymienionej na liście klauzuli FROM instrukcji SQL. W poniższym przykładzie pole IdZamówienia istnieje zarówno w tabeli Zamówienia, jak i w tabeli Szczegóły zamówień:

SELECT NrZamówienia

FROM Zamówienia, [Szczegóły zamówień];

Ponieważ instrukcja nie podaje z której tabeli pole NrZamówienia pochodzi, generowany jest błąd. Aby zrealizować tę operację, należy podać pełne odesłanie do pola, kwalifikując je nazwą tabeli. Na przykład:

SELECT Zamówienie.NrZamówienia

FROM Zamówienia, [Szczegóły zamówień];


Nie można wykonać instrukcji SQL ze względu na niejednoznacze sprzężenia zewnętrzne. Aby wymusić wykonanie jednego ze sprzężeń

Nie można wykonać instrukcji SQL ze względu na niejednoznacze sprzężenia zewnętrzne. Aby wymusić wykonanie jednego ze sprzężeń w pierwszej kolejności, należy utworzyć osobną kwerendę wykonującą pierwsze sprzężenie i dołączyć ją do instrukcji SQL. (Błąd 3258)

Nastąpiła próba wykonania instrukcji SQL zawierającej sprzężenia wielokrotne; rezultat kwerendy może zależeć od kolejności stosowania sprzężeń. Na przykład ten błąd może wystąpić podczas wykonywania następującej instrukcji SQL:

SELECT * FROM Klienci, Zamówienia, [Opisy zamówień],

Klienci LEFT JOIN Zamówienia

ON Klienci.KodKlienta = Zamówienia.KodKlienta,

Zamówienia INNER JOIN [Opisy zamówień]

ON Zamówienia.NrZamówienia = [Opisy zamówień].NrZamówienia;

Wykonanie tej instrukcji powoduje wystąpienie błędu, ponieważ kolejność sprzężeń nie jest jednoznacznie ustalona. Aby wymusić wykonanie jednego ze sprzężeń w pierwszej kolejności, należy utworzyć osobną kwerendę wykonującą pierwsze sprzężenie i dołączyć ją do instrukcji SQL. Następująca kwerenda pokazuje, w jaki sposób można utworzyć poprzednią kwerendę tak, by operacja INNER JOIN była wykonana przed operacjami LEFT JOIN i RIGHT JOIN:

Kwerenda1

SELECT * FROM Zamówienia, [Opisy zamówień],

Zamówienia INNER JOIN [Opisy zamówień]

ON Zamówienia. NrZamówienia = [Opisy zamówień].NrZamówienia;

Kwerenda2

SELECT * FROM Klienci, Kwerenda1,

Klienci LEFT JOIN Kwerenda1

ON Klienci.KodKlienta = Zamówienia.KodKlienta;


Niewłaściwe nawiasy w nazwie <nazwa>. (Błąd 3126)

Określona nazwa nie powinna być ujęta w nawiasy lub zastosowane nawiasy nie odpowiadają sobie. Sprawdź wprowadzone polecenie, aby upewnić się, czy liczby nawiasów otwierających i zamykających są równe, i powtórz operację.


Niepoprawne odwołanie w instrukcji SELECT. (Błąd 3242)

W instrukcji SELECT występuje niewłaściwe odwołanie do pola lub tabeli. Na przykład, odwołanie może nie istnieć lub być błędnie podane.


Kwerenda krzyżowa zawiera jeden lub więcej nieprawidłowo ustalonych nagłówków kolumn. (Błąd 3322)

Lista wartości dla stałych nagłówków kolumn kwerendy krzyżowej (klauzula PIVOT w instrukcji TRANSFORM) jest niepoprawna.

Prawdopodobne przyczyny:

  • Lista nie zawiera żadnych pozycji. W klauzuli PIVOT za słowem zastrzeżonym IN musi występować co najmniej jedna wartość podana w nawiasach okrągłych.
  • Lista zawiera pustą pozycję. Pozycję taką tworzą dwa sąsiadujące ze sobą znaki przecinka (,,).
  • Lista zawiera nazwę pola składającą się z więcej niż 64 znaków.

Popraw klauzulę PIVOT i ponownie wykonaj kwerendę.


Nie można usunąć danych z podanych tabel. (Błąd 3086)

Nastąpiła próba usunięcia danych z jednej lub więcej tabel, lecz proces ten nie mógł zostać zakończony.

Prawdopodobne przyczyny:

  • Nie masz zezwoleń do modyfikacji tabeli. Aby zmienić przypisane zezwolenia, skontaktuj się z administratorem systemu lub z właścicielem tabeli.
  • Baza danych została otwarta w trybie dostępu tylko do odczytu. Baza danych pracuje w trybie tylko do odczytu z jednego z poniższych powodów:
    • Zastosowano metodę OpenDatabase i otwarto bazę danych w trybie tylko-do-odczytu.
    • Plik bazy danych został zdefiniowany w systemie operacyjnym serwera bazy danych lub w sieci jako plik przeznaczony tylko-do-odczytu.
    • Nie posiadasz uprawnienia zapisu dla pliku bazy danych w środowisku sieciowym.
    • W zastosowanym formancie Data języka Visual Basic® ustawiono właściwość ReadOnly na wartość True.

Aby usunąć dane, zamknij bazę danych, usuń problem związany z dostępem tylko do odczytu i otwórz ponownie bazę w trybie odczytu i zapisu.


Nie można wprowadzić wartości do pustego pola po stronie 'jeden' sprzężenia zewnętrznego. (Błąd 3332)

Nie można wprowadzić wartości do pustego pola po stronie ‘jeden’ sprzężenia zewnętrznego. (Błąd 3332)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem obsługi klienta firmy Microsoft.


Nie można uaktualnić <nazwa pola>; pole nie może być uaktualniane. (Błąd 3113)

Prawdopodobne przyczyny:

  • Określone pole jest elementem obiektu TableDef lub obiektu Recordset typu zestaw dynamiczny, który nie może być uaktualniany. Na przykład, błąd ten występuje przy próbie uaktualnienia pola typu Autonumer.
  • Wykonano kwerendę łączącą obiekty TableDef, które mogą być uaktualniane z tymi, które nie mogą być uaktualniane, a następnie próbowano uaktualnić jedno z pól wyniku kwerendy (obiektu Recordset typu zestaw dynamiczny).


Kwerenda nie może zawierać parametru typu Database. (Błąd 3222)

Zmień typ danych pola w kwerendzie parametrycznej na właściwy, następnie powtórz operację.


Powtarzający się wyjściowy alias <nazwa>. (Błąd 3062)

Nastąpiła próba wykonania instrukcji SQL, w której występuje więcej niż jeden alias o takiej samej nazwie. Poniższa przykładowa instrukcja powoduje wystąpienie tego błędu:

SELECT DataUrodzenia AS Data, DataZatrudnienia AS Data FROM Pracownicy;

Zmień nazwę jednego lub więcej aliasów i powtórz operację.


Powtarzające się przeznaczenie wyjścia <nazwa>. (Błąd 3063)

Nastąpiła próba wykonania kwerendy zawierającej więcej niż jedno pole przeznaczenia o takiej samej nazwie.

Możliwa przyczyna:

  • Utworzono instrukcję SQL zawierającą instrukcję INSERT INTO, SELECT...INTO lub UPDATE, która wymienia określoną nazwę pola więcej niż jeden raz.

Usuń powtarzające się pola lub alias z nazw pól przeznaczenia i powtórz operację.


Nie można użyć jako podkwerendy skrzyżowania kolumny, która nie jest stała. (Błąd 3637)

Nastąpiła próba sortowania według skrzyżowania kolumny, która jest zmienna. Należy zapisać wyniki kwerendy, a następnie posortować je za pomocą przycisków “Sortuj rosnąco” lub “Sortuj malejąco”.


Wyrażenie jest niepoprawnie napisane lub jest zbyt skomplikowane, aby mogło być obliczone. Na przykład, wyrażenie numeryczne

Wyrażenie jest niepoprawnie napisane lub jest zbyt skomplikowane, aby mogło być obliczone. Na przykład, wyrażenie numeryczne zawiera zbyt wiele skomplikowanych elementów. Uprość wyrażenie, przypisując do zmiennych elementy wyrażenia. (Błąd 3071)

Prawdopodobne przyczyny:

  • Wpisano wyrażenie o niepoprawnej składni. Na przykład, nie podano operandu lub operatora, wpisano niepoprawny znak lub przecinek bądź wpisano tekst, nie umieszczając go w cudzysłowie ( " ). Sprawdź wyrażenie, aby upewnić się, czy zostało ono poprawnie napisane.
  • Wpisano zbyt złożone wyrażenie. Na przykład, wyrażenie numeryczne zawiera zbyt wiele skomplikowanych elementów. Uprość wyrażenie, przypisując elementy wyrażenia do zmiennej.


Pole <nazwa> jest tworzone na podstawie wyrażenia i nie można go edytować. (Błąd 3327)

Na przykład, jeśli tworzona jest zachowana kwerenda lub widok z kolumną utworzoną na podstawie wyrażenia, nie będzie można uaktualniać danych w tej kolumnie. Następująca sekwencja spowoduje powstanie niniejszego błędu: CREATE VIEW VKlient AS SELECT (Imię & Nazwisko) AS Test FROM Klient po czym następuje UPDATE Test FROM VKlient


<Komunikat> w wyrażeniu kwerendy <wyrażenie>. (Błąd 3075)

Wprowadzone wyrażenie nie jest poprawne z powodu wymienionego w komunikacie. Sprawdź, czy nazwy pól i znaki przestankowe zostały wpisane poprawnie i powtórz operację.


Aby wprowadzić zmiany, należy najpierw zapisać rekord. (Błąd 3331)

Ten błąd występuje podczas próby edycji wiersza utworzonego za pomocą widoku lub zachowanej kwerendy opartej na więcej niż jednej tabeli.


Nie można wstawiać danych za pomocą kwerendy funkcjonalnej. (Błąd 3084)

Nastąpiła próba wykonania kwerendy dodającej rekordy przy użyciu kwerendy funkcjonalnej jako danych wejściowych. Zamień kwerendę funkcjonalną na kwerendę wybierającą i powtórz operację.


Nieprawidłowy alias. (Błąd 3068)

Podany alias nie spełnia wymagań standardowych konwencji nazewnictwa. Wprowadź nową nazwę i powtórz operację.


Nie można stosować kwerendy funkcjonalnej jako źródła wierszy. (Błąd 3417)

Możliwa przyczyna:

  • Kwerenda użyta jako źródło wierszy jest kwerendą funkcjonalną lub kwerendą definiującą dane.


Kwerenda funkcjonalna <nazwa> nie może być użyta jako źródło wierszy. (Błąd 3069)

Nie można użyć nazwy kwerendy funkcjonalnej jako źródła wierszy. Zamiast niej użyj nazwy kwerendy wybierającej. Aby uruchomić kwerendę funkcjonalną, zastosuj jako wejście dla klauzuli FROM metodę Execute, a nie nazwę kwerendy funkcjonalnej.


Wewnętrzna kwerenda raportu <nazwa> nie może być źródłem danych. (Błąd 3124)

Nastąpiła próba użycia instrukcji SQL zawierającej jawne odesłanie do zabronionej wewnętrznej kwerendy raportu.


Nazwa <parametru> jest niewłaściwa, ponieważ jest zbyt długa lub zawiera znaki niedozwolone. (Błąd 3223)

Nazwa parametru jest niewłaściwa, ponieważ jest zbyt długa lub zawiera znaki niedozwolone. Należy poprawić nazwę i ponowić operację.


Nie można otworzyć kwerendy funkcjonalnej <nazwa>. (Błąd 3064)

Nastąpiła próba otwarcia kwerendy funkcjonalnej za pomocą metody OpenQueryDef, która jest nie stosowaną już metodą oryginalnie dostępną tylko dla kwerendy wybierającej. Zalecanym sposobem wykonywania kwerend funkcjonalnych jest zastosowanie metody Execute obiektu QueryDef.


Kwerenda <nazwa> jest uszkodzona. (Błąd 3340)

Odwołano się do niezdefiniowanej nazwy kwerendy. Sprawdź listę nazw kwerend w kolekcji QueryDefs i odwołaj się do prawidłowej nazwy.


Kwerenda jest kwerendą DDL i nie może być użyta jako źródło wierszy. (Błąd 3324)

Nastąpiła próba wykonania kwerendy funkcjonalnej lub kwerendy definiującej dane bez użycia metody Execute.


Nie można użyć wewnętrznej kwerendy raportu. (Błąd 3083)

Nastąpiła próba użycia instrukcji SQL zawierającej jawne odwołanie do zabronionej wewnętrznej kwerendy raportu. Usuń niepoprawne odwołanie i powtórz operację.


Nie można wykonać kwerendy wybierającej. (Błąd 3065)

Nastąpiła próba użycia metody Execute dla kwerendy wybierającej. Metoda Execute jest poprawna tylko dla kwerendy funkcjonalnej. Kwerendy wybierające zawierają instrukcję SELECT i mogą zwracać rekordy; kwerendy funkcjonalne nie zwracają rekordów.


Ta kwerenda nie jest prawidłowo zbudowaną kwerendą definiującą dane. (Błąd 3357)

Ta kwerenda nie jest prawidłowo zbudowaną kwerendą definiującą dane.


Nie można używać kwerendy jako źródła wierszy. (Błąd 3323)

Prawdopodobne przyczyny:

Kwerenda użyta jako źródło danych jest kwerendą funkcjonalną lub kwerendą definiującą dane.


Nie można zmieniać tego zestawu rekordów. (Błąd 3326)

Nastąpiła próba edycji danych w polu związanym z obiektem typu utrwalony zestaw wyników. Utrwalony zestaw wyników w bazie danych aparatu Microsoft Jet nie może być edytowany.


Niezgodność typów w wyrażeniu JOIN. (Błąd 3615)

Wyrażenie JOIN próbuje wykonać sprzężenie dwóch tabel według pól o niezgodnych typach danych. Na przykład niniejszy błąd zostanie zwrócony przy próbie połączenia pola typu Memo z polem typu Text.


Nie można wykonać operacji sprzężenia, grupowania, sortowania lub indeksowanego wyboru. Poszukiwana lub sortowana wartość jest

Nie można wykonać operacji sprzężenia, grupowania, sortowania lub indeksowanego wyboru. Poszukiwana lub sortowana wartość jest zbyt długa. (Błąd 3393)

Maksymalna, całkowita długość wszystkich pól używanych w operacji sprzężenia, grupowania lub sortowania nie może przekraczać 255 bajtów. Zmniejsz liczbę pól wykorzystywanych w operacji sprzężenia, grupowania lub sortowania, lub też zastosuj krótsze typy danych i rozmiary pól.


Nie można umieszczać pól typu Memo, OLE, lub obiekt Hyperlink w argumentach agregacji <instrukcja>. (Błąd 3115)

Nie można włączyć pól typu Memo lub obiekt OLE do funkcji agregującej.


Nie można na liście wyboru umieścić pól typu Memo, OLE, lub obiekt Hyperlink, jeśli wybierane są wartości unikatowe <instrukcja

Nie można na liście wyboru umieścić pól typu Memo, OLE, lub obiekt Hyperlink, jeśli wybierane są wartości unikatowe <instrukcja>. (Błąd 3114)

Usuń słowo zastrzeżone DISTINCT lub pola typu Memo lub obiekt OLE z instrukcji.


Nie można grupować według pól typu Memo, OLE, lub obiekt Hyperlink <klauzula>. (Błąd 3119)

Klauzula GROUP BY instrukcji SQL nie może zawierać pól typu Memo lub obiekt OLE.


Nie można umieszczać pól typu Memo, OLE, lub obiekt Hyperlink w kryteriach <kryteria> funkcji agregacji. (Błąd 3116)

Klauzula HAVING instrukcji SQL nie może zawierać pól typu Memo lub obiekt OLE .


Nie można dokonywać sprzężenia według pól typu Memo, OLE, lub obiekt Hyperlink <nazwa>. (Błąd 3118)

Nie można sprząc pól typu Memo lub obiekt OLE . Pole wykorzystywane do logicznego powiązania dwóch lub więcej tabel musi być innego typu, takiego jak typ tekstowy lub numeryczny.


Nie można sortować według pól typu Memo, OLE, lub obiekt Hyperlink <klauzula>. (Błąd 3117)

Klauzula ORDER BY instrukcji SQL nie może zawierać pól typu Memo lub obiekt OLE.


W klauzuli SELECT kwerendy składającej nie można używać pola <nazwa> typu Memo, OLE, lub obiekt Hyperlink. (Błąd 3364)

Pole podane w części SELECT instrukcji SQL kwerendy składającej jest typu Memo lub OLE object. W tym kontekście nie można stosować żadnego z tych typów.


Nieprawidłowa wartość obiektu Memo, OLE, lub Hyperlink w podkwerendzie <nazwa>. (Błąd 3342)

Podkwerenda nie może zwracać danych typu Memo lub obiekt OLE, nie może być też porównana do danych typu Memo lub obiekt OLE w wyrażeniu.


W podkwerendzie nie można użyć wielopoziomowej klauzuli GROUP BY. (Błąd 3612)

Podkwerenda SQL nie może zwrócić więcej niż jednego pola w klauzuli GROUP BY.


Za mało parametrów. Oczekiwano <liczba>. (Błąd 3061)

Ta kwerenda parametryczna wymaga określonej liczby parametrów, które nie zostały podane. Podaj oczekiwaną liczbę parametrów i uruchom ponownie kwerendę.

W niektórych przypadkach komunikat ten jest generowany, gdy jako parametry kwerendy interpretowane są nieznane nazwy pól lub wyrażenia. Upewnij się, czy nazwy pól zawierających spacje lub znaki przestankowe zostały ujęte w nawiasy kwadratowe [ ].


Nie można usunąć rekordu lub rekordów; brak zezwolenia na usuwanie z <nazwa>. (Błąd 3109)

Aby usunąć dane z określonej tablicy lub kwerendy, konieczne jest posiadanie zezwolenia na usuwanie z nich danych. Aby zmienić posiadane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.


Określ tabelę zawierającą rekordy do usunięcia. (Błąd 3128)

Nastąpiła próba wykonania kwerendy usuwającej ale kwerenda nie określa tabeli zawierającej rekordy do usunięcia.

Możliwa przyczyna:

  • Nie wpisano znaku gwiazdki dla każdej tabeli w predykatach ALL, DISTINCT, DISTINCTROW. Zamiast tego wpisano nazwy pól (na przykład, Klienci.Adres zamiast Klienci.*).


Wejście kwerendy musi zawierać przynajmniej jedną tabelę lub kwerendę. (Błąd 3067)

Ten błąd występuje w bazach danych aparatu Microsoft Jet, jeżeli nie została określona tabela przy tworzeniu kwerendy. Wybierz przynajmniej jedną tabelę lub kwerendę.

W bazach danych ODBCDirect błąd ten występuje przy próbie wykonania kwerendy nie zawierającej instrukcji SQL. Umieść przynajmniej jedną kwerendę lub wywołanie zachowanej procedury we właściwości SQL obiektu QueryDef.


Nie można dodać rekordu lub rekordów; brak zezwolenia na wstawienie do <nazwa>. (Błąd 3107)

Aby wstawić dane do tablicy lub kwerendy, konieczne jest posiadanie zezwolenia na wstawianie do nich danych. Aby zmienić posiadane uprawnienia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.


Nie można dodać rekordu (rekordów); brak odpowiednich rekordów po stronie 'jeden'. (Błąd 3363)

Nie można dodać rekordu (rekordów); brak odpowiednich rekordów po stronie ‘jeden’. (Błąd 3363)

Ten błąd pojawia się podczas edycji zachowanej kwerendy lub widoku zawierającego więcej, niż jedną tabelę. Ten błąd mógł wystąpić podczas próby zapisu wiersza z widoku będącego sprzężeniem pomiędzy tabelami klient (strona ‘jeden’) i zamówienia (strona ‘wiele’). Jeśli wprowadzono informację dotyczącą jedynie zamówień i nie wprowadzono informacji odnośnie wartości klucza podstawowego, niniejszy błąd wystąpi dla tabeli klientów.


W kwerendzie musi być przynajmniej jedno pole przeznaczenia. (Błąd 3066)

Ten błąd występuje, jeżeli nie są określone żadne nazwy pól przeznaczenia podczas tworzenia kwerendy. Wybierz przynajmniej jedno pole przeznaczenia.


Nie można odczytać definicji; brak zezwolenia na czytanie definicji tabeli lub kwerendy <nazwa>. (Błąd 3110)

Aby odczytać definicję określonej tablicy lub kwerendy, konieczne jest posiadanie zezwolenia na czytanie definicji. Aby zmienić posiadane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.


Nie można odczytać rekordu lub rekordów; brak zezwolenia na czytanie z <nazwa>. (Błąd 3112)

Aby obejrzeć dane określonej tablicy lub kwerendy, konieczne jest posiadanie zezwolenia na czytanie z nich danych. Aby zmienić posiadane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.


Nie można poddać edycji rekordu lub rekordów; brak zezwolenia na uaktualnianie <nazwa>. (Błąd 3108)

Aby zmienić dane w określonej tablicy lub kwerendzie, konieczne jest posiadanie zezwolenia na uaktualnianie znajdujących się w nich danych. Aby zmienić posiadane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem tabeli lub kwerendy.


Nie można wykonać operacji tworzenia; brak zezwolenia na modyfikację projektu tabeli <nazwa>. (Błąd 3111)

Nastąpiła próba utworzenia określonej tabeli lub kwerendy, ale posiadasz wymaganych uprawnień modyfikacji projektu. Aby zmienić przypisane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem kwerendy.


Obsługa kwerendy niedostępna. (Błąd 3389)

Nastąpiła próba ustanowienia integralności referencyjnej w obiekcie Relation obiektu QueryDef object, co nie jest obsługiwane.

Zmień ustawienie właściwość Attributes obiektu Relation na wartość dbRelationDontEnforce.


Operacja musi wykorzystywać kwerendę, którą można aktualizować. (Błąd 3073)

Nastąpiła próba wykonania, otwarcia lub modyfikacji kwerendy, której nie można aktualizować.

Prawdopodobne przyczyny:

  • Nastąpiła próba uruchomienia kwerendy próbującej uaktualnić pole, które nie może być aktualizowane. Na przykład, utworzono kwerendę, w której próbowano uaktualnić pole po stronie "jeden" w związku jeden-do-wielu.
  • Nastąpiła próba zastosowania starej metody OpenQueryDef dla kwerendy znajdującej się w bazie danych otwartej w trybie tylko do odczytu.

Baza danych pracuje w trybie tylko do odczytu z jednego z poniższych powodów:

  • Zastosowano metodę OpenDatabase lub formant Data języka Visual Basic i otwarto bazę danych w trybie tylko do odczytu.
  • Plik bazy danych został zdefiniowany w sieciowym systemie operacyjnym jako plik przeznaczony tylko do odczytu.
  • Nie masz uprawnień do pliku bazy danych w środowisku sieciowym.

Zamknij bazę danych, usuń problem związany z dostępem tylko do odczytu i otwórz ponownie bazę w trybie odczytu i zapisu.

  • Nie masz zezwoleń na dokonywanie zmian w kwerendzie. Aby zmienić przypisane zezwolenia, skontaktuj się z administratorem systemu lub właścicielem kwerendy.


Na miejscu podanego parametru <nazwa> powinna być podana nazwa bazy danych. (Błąd 3217)

Utworzona została kwerenda parametryczna, w której podano parametr niewłaściwego typu. Przykładowo, błąd ten wystąpi przy wykonaniu następujących instrukcji:

PARAMETERS Param1 Text;

SELECT KodKlienta

FROM Klienci IN Param1;

Param1 jest parametrem typu tekstowego, a klauzula FROM oczekuje jako parametru nazwy bazy danych.

Należy zmienić typ parametru z Text na Database i ponowić operację.


Na miejscu podanego parametru <nazwa> powinna być podana nazwa tabeli. (Błąd 3216)

Utworzona została kwerenda parametryczna, w której podano parametr niewłaściwego typu. Poniższy przykład powoduje wystąpienie tego błędu:

PARAMETERS Param1 Text;

INSERT INTO Param1

SELECT *

FROM Klienci;

Param1 jest parametrem typu tekstowego, a instrukcja INSERT INTO oczekuje jako parametru nazwy tabeli.

Należy zmienić typ parametru z Text na TableID i ponowić operację.


Zły typ danych dla parametru <parametr>. (Błąd 3060)

Nastąpiła próba użycia argumentu o typie danych kolidującym z typem danych zdefiniowanym dla tego parametru. Na przykład, mogła nastąpić próba użycia wyrażenia znakowego w sytuacji, gdy jako parametr oczekiwany jest argument liczbowy. Użyj argumentu o poprawnym typie danych i powtórz operację.


Rekord w tabeli <nazwa> został usunięty przez innego użytkownika. (Błąd 3329)

Wiersz, który próbujesz edytować został usunięty przez innego użytkownika. Sytuacji tej można uniknąć, jeżeli wszyscy użytkownicy bazy danych używać będą pesymistycznego blokowania rekordów.


Rekord w tabeli <nazwa> został zablokowany przez innego użytkownika. (Błąd 3330)

Wiersz lub strona, którą próbujesz uaktualnić, jest obecnie zablokowana przez innego użytkownika. Aparat bazy danych Microsoft® Jet 4.0 pozwala użytkownikom mieć bazę danych otwartą w trybie pozwalającym na blokowanie na poziomie rekordów. Ten tryb może znacznie zredukować liczbę wystąpień niniejszego błędu.


Ta sama tabela <tabela> wymieniona jako źródłowa i docelowa w kwerendzie tworzącej tabelę. (Błąd 3610)

Nazwa jednej z tabel źródłowych w instrukcji SELECT INTO jest taka sama jak nazwa tabeli docelowej. Usuń tę tabelę z listy tabel źródłowych lub zmień nazwę tabeli docelowej.


Tabela <nazwa> jest dostępna tylko do odczytu. (Błąd 3328)

Ten błąd występuje podczas próby uaktualnienia kolumny w tabeli, którą inny użytkownik otworzył w trybie tylko do odczytu.


Kwerenda jest zbyt złożona. (Błąd 3360)

Kwerenda jest zbyt złożona. Zmniejsz liczbę pól w klauzuli SELECT lub liczbę podkwerend albo tabel w sprzężeniu.


Zbyt wiele wyrażeń dla wyjścia predykatu DISTINCT. (Błąd 3089)

Utworzono instrukcję SQL, w której umieszczono predykat ALL, DISTINCT lub DISTINCTROW zawierający ponad 10 wyrażeń. Usuń słowo zastrzeżone DISTINCT lub usuń niektóre pola z listy predykatu DISTINCT.


Zbyt wiele wyrażeń w klauzuli GROUP BY. (Błąd 3087)

Utworzono instrukcję SQL zawierającą ponad 10 pól na liście klauzuli GROUP BY. Usuń niektóre pola z listy klauzuli GROUP BY.


Zbyt wiele wyrażeń w klauzuli ORDER BY. (Błąd 3088)

Utworzona instrukcja SQL zawiera więcej niż dziesięć wyrażeń w klauzuli ORDER BY. Usuń niektóre pola z listy klauzuli ORDER BY.


Zbyt wiele nagłówków kolumn krzyżowych <wartość>. (Błąd 3205)

Wykonana instrukcja SQL próbowała utworzyć zbyt wiele kolumn. Podana wartość jest numerem kolumny, która spowodowała błąd.

Liczbę kolumn można zredukować, dodając nowe warunki do klauzuli WHERE albo, jeżeli nie ma klauzuli WHERE, dodać ją.


Wartości podane w klauzuli TOP są niedozwolone w kwerendach usuwających i raportach. (Błąd 3318)

Wartości podane w klauzuli TOP lub instrukcji SELECT nie są dozwolone w kwerendach usuwających i raportach.


Odwołanie cykliczne spowodowane przez <odwołanie do kwerendy>. (Błąd 3102)

Nastąpiła próba wykonania kwerendy, która zależy od własnych wyników. Na przykład, błąd ten wystąpi przy wykonaniu każdej z poniższych kwerend:

Kwerenda1

SELECT * FROM Pracownicy, Kwerenda2;

Kwerenda2

SELECT * FROM Kwerenda1;

Zmień kwerendy SQL tak, aby wyeliminować zależności tego typu.


Aparat bazy danych Microsoft Jet nie może rozpoznać <nazwa> jako poprawnej nazwy pola lub jako wyrażenia. (Błąd 3070)

Podana nazwa nie jest rozpoznana jako nazwa pola lub poprawne wyrażenie. W kwerendzie błąd ten występuje, jeśli wprowadzona nazwa odnosi się w sposób niewłaściwy do bazy danych, tabeli lub kwerendy.

Możliwe przyczyny w przypadku Microsoft® Access:

  • W kwerendzie krzyżowej lub w kwerendzie, na której bazuje kwerenda krzyżowa lub wykres, występuje parametr, którego typ danych nie został jawnie określony w oknie dialogowym Parametry kwerendy. Aby usunąć ten problem:
    • W kwerendzie zawierającej parametr określ parametr i jego typ danych w oknie dialogowym Parametry kwerendy.
    • Ustaw właściwość ColumnHeadings dla kwerendy zawierającej parametr.
  • W kwerendzie każdego typu, wystąpiło niepoprawne odwołanie do bazy danych, tabeli lub pola. Na przykład, błąd ten występuje, jeśli w wyrażeniu pojawia się odesłanie do pola o nazwie Wynagrodzenie, lecz nazwa pola została napisana błędnie, np. [Wynagrodzenie]*1.1.


Rekordy w tabeli <nazwa> nie miałyby rekordu po stronie 'jeden'. (Błąd 3333)

Rekordy w tabeli <nazwa> nie miałyby rekordu po stronie ‘jeden’. (Błąd 3333)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem obsługi klienta firmy Microsoft.


Liczba wartości kwerendy i pól docelowych nie są takie same. (Błąd 3346)

Kwerenda INSERT INTO (dołączająca) nie posiada wystarczającej liczby pól docelowych lub ma więcej wartości w liście VALUES lub SELECT, niż pól w tabeli docelowej. Ustal właściwą liczbę pól.


Nie można zapisać; strona aktualnie zablokowana przez innego użytkownika. (Błąd 3202)

Możliwa przyczyna:

  • Usiłowano zapisać rekord na 2-kilobajtowej stronie bazy danych, która aktualnie jest zablokowana przez innego użytkownika. Należy poczekać, aż ten użytkownik zakończy pracę z danym rekordem i ponowić operację.


Błąd operacji dyskowej podczas czytania. (Błąd 3040)

Nie można odczytać danych z dysku ze względu na wewnętrzny błąd dysku lub stacji.

Prawdopodobne przyczyny:

  • Nastąpiła próba odczytania danych z dysku sieciowego, lecz sieć jest tymczasowo zajęta lub utracono połączenie z siecią. Sprawdź połączenia sieciowe i powtórz operację.
  • Dysk lub jego stacja są uszkodzone.


Synchronizator otrzymał nieprawidłowy komunikat przeznaczony dla elementu zestawu replik, którym zarządza. (Błąd 3536)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Rekord jest usunięty. (Błąd 3167)

Nastąpiła próba użycia rekordu, który został usunięty przez bieżącego lub innego użytkownika systemu wielodostępnego. Należy przejść do innego rekordu i powtórzyć operację.


Nie można zapisać rekordu; rekord jest blokowany przez innego użytkownika. (Błąd 3158)

Nastąpiła próba zapisania rekordu znajdującego się na stronie bazy danych obecnie zablokowanej przez innego użytkownika. Aby zapisać wprowadzone zmiany należy poczekać, dopóki inny użytkownik nie zakończy pracy z rekordem, a następnie powtórzyć operację.


Wywołanie metody Update lub CancelUpdate bez wywołania metody AddNew lub Edit. (Błąd 3020)

W bazie danych Microsoft Jet nastąpiło wywołanie metody Update lub CancelUpdate bez wywoływania metody AddNew lub Edit przed zapisem danych do rekordu.

W bazie danych ODBCDirect błąd ten pojawia się podczas próby zapisu danych do rekordu bez uprzedniego wywołania metody AddNew lub Edit.


Rekord jest zbyt duży. (Błąd 3047)

Zdefiniowano lub importowano tabelę zawierającą rekordy o rozmiarze przekraczającym 2KB. Ten błąd występuje podczas wprowadzania danych do rekordu — nie w trakcie definiowania struktury tabeli. Zmień definicję tabeli poprzez skrócenie pewnych pól, usunięcie pól niepotrzebnych lub przeniesienie niektórych pól do innych tabel.


Odzyskano replikowalne dane. Ten wiersz został odzyskany z uszkodzonej replikowalnej bazy danych. Sprawdź zawartość rekordu,

Odzyskano replikowalne dane. Ten wiersz został odzyskany z uszkodzonej replikowalnej bazy danych. Sprawdź zawartość rekordu, popraw go i dodaj ponownie, lub usuń błędny rekord. (Błąd 3711)

Kiedy replika jest odzyskana, każde nowe rekordy istniejące w uszkodzonej replice są dodawane do tabeli konfliktów odzyskanej repliki. Ten mechanizm zapewnia możliwość przeanalizowania danych przez ich ponownym dodaniem.


Nie można znaleźć wskazywanego obiektu. (Błąd 3199)

Podano odwołanie do pliku, tabeli lub odwołania, które nie zostało odnalezione. Należy sprawdzić pisownię i interpunkcję, aby upewnić się, że nazwa obiektu została wprowadzona prawidłowo, a następnie powtórzyć operację.


Relacja <nazwa> nie jest wymuszona. W częściowym wyrażeniu filtru relacja musi być wymuszona. (Błąd 3659)

Nastąpiła próba zastosowania filtru w tabeli repliki częściowej, gdzie istnieje niewymuszona relacja. Należy wymusić relację we wzorcu głównym, a następnie ponowić stosowanie filtra i ponownie wypełnić replikę częściową.


Nie znaleziono unikatowego indeksu dla wskazywanego pola tablicy podstawowej. (Błąd 3609)

Podczas tworzenia relacji pomiędzy tabelami, wskazywane pole w tabeli podstawowej musi posiadać unikatowy indeks. Dalsze informacje na ten temat można znaleźć w tematach pomocy obiektu Index i właściwości Primary.


Ograniczenia CHECK nie są dozwolone dla replikowalnych baz danych. (Błąd 3798)

Usuń wszelkie ograniczenia CHECK przed przekształceniem bazy danych lub tabeli do postaci replikowalnej.


Próbowano usunąć lub uzyskać informacje na temat filtru częściowego, który nie istnieje w MsysFilters. (Błąd 3505)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Identyfikator (ReplicaID) tego elementu zestawu replik został zmieniony w efekcie procedury przeniesienia lub skopiowania.

Identyfikator (ReplicaID) tego elementu zestawu replik został zmieniony w efekcie procedury przeniesienia lub skopiowania. (Błąd 3574)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nastąpiła próba zmiany właściwości replikacji, która jest dostępna tylko do odczytu i nie może być zmieniana. (Błąd 3461)

Wiele właściwości związanych z replikacją jest przeznaczonych jedynie do użytku wewnętrznego lub jest dostępnych programiście tylko do odczytu. Należy przejrzeć tekst programu, aby upewnić się, że dana właściwość jest jedynie czytana i nie jest zmieniana jej wartość.


Wzorzec lub replika nie są zarządzane przez Synchronizator. (Błąd 3502)

Nastąpiła próba uzyskania informacji o wzorcu głównym lub replice nie zarządzanej przez program Synchronizator.


Ten element zestawu replik został logicznie usunięty z tego zestawu i nie jest już dostępny. (Błąd 3569)

Ten element zestawu replik, którego próbujesz użyć, został usunięty, ponieważ nie został zsynchronizowany w ciągu wymaganej ilości dni (okres przechowywania zmian danych) lub nie był zsynchronizowany z drugim wzorcem głównym. Element ten należy usunąć fizycznie z komputera.

Jeśli w tym elemencie pozostały jakieś dane nie zsynchronizowane z żadnym innym elementem zestawu replik, należy ręcznie wprowadzić te dane do innego elementu zestawu. Sprawdzenia, w których rekordach znajdują się nie zsynchronizowane dane, można dokonać, badając w każdej tabeli pole s_Generation. Wartość 0 w polu s_Generation oznacza, że rekord został wstawiony lub zmieniony, ale nie zsynchronizowany z inną repliką zestawu. Aby zobaczyć pole s_Generation , otwórz program Microsoft® Access, przejdź do menu Narzędzia, kliknij polecenie Opcje, wybierz kartę Widok i zaznacz pole Obiekty systemowe.

Jeśli element zestawu pełni rolę wzorca, należy porównać strukturę tej repliki z inną repliką i określić, czy pozostały nie zsynchronizowane jakieś dane projektowe.


Nazwa lub identyfikator repliki nie są zgodne z aktualnie obsługiwanym elementem zestawu replik. (Błąd 3520)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Próba synchronizacji elementu zestawu replik, który jest aktualnie używany w innej synchronizacji. (Błąd 3510)

Wzorzec główny lub replika może brać udział jednocześnie tylko w jednej synchronizacji. Chociaż nie można zainicjować drugiej synchronizacji, jeśli element jest zablokowany, to jednak można korzystać z tego elementu. Po odczekaniu kilku minut należy ponowić próbę synchronizacji.


Replika nie jest repliką częściową. (Błąd 3478)

Wystąpiła próba uzyskania informacji o filtrze lub innym elemencie repliki częściowej. Jednakże replika, do której została wystosowana kwerenda, nie jest repliką częściową. Potwierdzenie, że replika nie jest repliką częściową, można uzyskać za pomocą Menedżera replikacji, oglądając arkusz właściwości repliki.


Bez uprawnień administratora, priorytet repliki musi zawierać się w przedziale 0 - <numer>. (Błąd 3772)

Bez uprawnień administratora, priorytet repliki musi zawierać się w przedziale od 0 do wartości priorytetu repliki, z której powstaje nowa replika.


Oba synchronizowane ze sobą elementy zestawu replik pełnią rolę wzorca. (Błąd 3561)

Należy usunąć jeden z elementów pełniących rolę wzorca.


Oba synchronizowane ze sobą elementy zestawu replik mają ten sam identyfikator repliki (ReplicaID). (Błąd 3560)

Należy dokonać synchronizacji z innym docelowym elementem zestawu replik.


Właściwość replikacji, którą próbowano usunąć, jest przeznaczona tylko do odczytu i nie można jej usunąć. (Błąd 3607)

Sprawdź, czy rzeczywiście chcesz usunąć tę właściwość.


Nie udało się utworzyć tabel systemu replikacji, potrzebnych do przekształcenia bazy danych w bazę replikowalną. (Błąd 3579)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Dwa elementy zestawu replik nie mogą zostać zsynchronizowane, ponieważ brak wspólnego punktu, od którego można by zacząć

Dwa elementy zestawu replik nie mogą zostać zsynchronizowane, ponieważ brak wspólnego punktu, od którego można by zacząć synchronizację. (Błąd 3521)

Upłynęło zbyt dużo czasu, odkąd dane dwa elementy zestawu replik były ostatnio synchronizowane. Aparat baz danych Microsoft Jet nie może znaleźć wspólnego punktu odniesienia, od którego można by rozpocząć wprowadzanie zmian zawartości lub struktury bazy danych.


Żądana wymiana nie powiodła się, ponieważ <opis>. (Błąd 3660)

Aby uzyskać dokładne informacje na temat przyczyny niepowodzenia wymiany, zobacz historię wymiany. Jeżeli używany jest program Menedżer replikacji, można obejrzeć tę historię po kliknięciu replikowanego obiektu prawym przyciskiem myszy. Historię replikacji można również obejrzeć, wybierając polecenie Historia synchronizacji z menu Widok.

Jeżeli replikacja jest prowadzona za pomocą programu Access, historię wymiany można obejrzeć, otwierając tabele historii wymiany na widoku arkusza danych. Historia wymiany jest obiektem ukrytym. Obiekt ten można obejrzeć w oknie “Baza danych” po zaznaczeniu pola wyboru Obiekty systemowe na karcie Widok okna dialogowego Opcje, które jest dostępne po wybraniu polecenia Opcje z menu Narzędzia.


Replika nie została zsynchronizowana w czasie okresu przechowywania zmian danych. (Błąd 3743)

Jeśli minie okres przechowywania zmian danych dla repliki, nie można synchronizować zmian pomiędzy repliką, dla której ten okres minął i innymi replikami zestawu replik. Jeżeli replika nie zostanie zsynchronizowana z inną repliką w okresie przechowywania zmian danych, podczas następnej próby synchronizacji zostanie ona usunięta z zestawu replik. Okres przechowywania zmian danych ustalany jest podczas przekształcania bazy danych do postaci replikowalnej. Jeżeli baza danych replikowana jest przy użyciu Menedżera replikacji, DAO (Data Access Objects), lub ADO (ActiveX Data Objects), domyślny okres przechowywania zmian danych wynosi 60 dni. Jeżeli replikujesz bazę danych przy użyciu programu Microsoft® Access lub Aktówki, domyślny okres przechowywania zmian danych wynosi 1000 dni.


Nieprawidłowe dane wejściowe. Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ wprowadzona wartość jest za duża

Nieprawidłowe dane wejściowe. Nie można wykonać operacji kaskadowej w tabeli <nazwa>, ponieważ wprowadzona wartość jest za duża dla pola <nazwa>. (Błąd 3411)

Nastąpiła próba zapisania wartości do klucza podstawowego pola, które jest zawarte w relacji.

W programie Microsoft® Access opcja Kaskadowe aktualizowanie powiązanych pól jest wyznaczona dla związku; natomiast w kodzie DAO jest określona opcja dbRelationUpdateCascade dla właściwości Attributes obiektu Relation. Ustawienie którejkolwiek z tych opcji powoduje, że aplikacja próbuje aktualizować wartości odpowiadającego pola w powiązanej tabeli.

Aby zapisać zmiany w tym polu, wprowadzony tekst nie może być dłuższy niż rozmiar powiązanego pola, które aplikacja próbuje uaktualnić. W tym przypadku, powiązane pole ma mniejszy rozmiar od pola uaktualnianego. Aby w przyszłości uniknąć takich problemów, należy ustawić właściwość Size obu odpowiadających sobie pól na taką samą wartość.


Nie można wykonać operacji kaskadowej. Rezultatem tej operacji byłby powtarzający się klucz w tabeli <nazwa>. (Błąd 3399)

Próba wykonania operacji kaskadowej spowodowałaby wystąpienie zduplikowanych wartości klucza we wskazanej tabeli, która została skonfigurowana by nie akceptować duplikatów klucza podstawowego. Sprawdź wartości, które próbujesz uaktualnić i popraw je tak, by nie powodowały występowania duplikatów w kluczu.


Nie można wykonać operacji kaskadowej. Dałaby ona w rezultacie wartość Null klucza tabeli <nazwa>. (Błąd 3398)

Próba wykonania operacji kaskadowej spowodowałaby powstanie wartości Null w kluczu podstawowym pola w podanej tabeli, która była skonfigurowana aby nie akceptować wartości Null. Sprawdź wartości, które próbujesz uaktualnić i popraw je tak, by nie występowały wartości Null.


Nie można wykonać operacji kaskadowej na tabeli <nazwa>, ponieważ jest ona aktualnie używana. (Błąd 3414)

Nastąpiła próba zapisania wartości do klucza podstawowego pola zawartego w relacji.

W programie Microsoft® Access opcja Kaskadowe aktualizowanie powiązanych pól jest wyznaczona dla relacji; natomiast w kodzie DAO jest określona opcja dbRelationUpdateCascade dla właściwości Attributes obiektu Relation. Dlatego też aplikacja próbuje aktualizować odpowiednie pole z powiązanej tabeli.

Pole to nie może być aktualizowane, ponieważ zostało otwarte lub zablokowane. Aby zapisać rekord, trzeba najpierw zamknąć powiązaną tabelę.


Nie można wykonać operacji kaskadowej. Prowadziłoby to do przypisania polu <nazwa> wartości ciągu znaków o zerowej długości, co

Nie można wykonać operacji kaskadowej. Prowadziłoby to do przypisania polu <nazwa> wartości ciągu znaków o zerowej długości, co nie jest dozwolone. (Błąd 3402)

Nastąpiła próba wykonywania operacji kaskadowej powodującej przyjęcie wartości ciągu o długości zerowej przez wskazane pole, które nie dopuszcza ciągów o długości zerowej. Sprawdź wartości, które mają być aktualizowane, i ustal je tak, aby w wyniku wykonania operacji kaskadowej nie dawały w tym polu ciągów znaków o zerowej długości.


Nie można wykonać operacji kaskadowej. W wyniku tej operacji pole <nazwa> przyjęłoby wartość Null, co nie jest dozwolone. (Błąd

Nie można wykonać operacji kaskadowej. W wyniku tej operacji pole <nazwa> przyjęłoby wartość Null, co nie jest dozwolone. (Błąd 3401)

Nastąpiła próba wykonania operacji kaskadowej powodującej przyjęcie wartości Null przez wskazane pole, które nie dopuszcza wartości Null. Sprawdź wartości, które mają być aktualizowane, i ustal je tak, aby w wyniku operacji nie dawały wartości Null w tym polu.


Nie można wykonać operacji kaskadowej. Wprowadzona wartość jest zabroniona przez regułę poprawności <reguła> ustaloną dla

Nie można wykonać operacji kaskadowej. Wprowadzona wartość jest zabroniona przez regułę poprawności <reguła> ustaloną dla <nazwa>. (Błąd 3404)

Nastąpiła próba wykonania operacji kaskadowej powodującej przyjęcie niepoprawnej wartości we wskazanym polu, która jest zabroniona przez jego regułę poprawności. Sprawdź wartości, które mają być aktualizowane i ustal je tak, aby były zgodne z regułą poprawności.


Nie można wykonać operacji kaskadowej: <tekst kontrolny>. (Błąd 3403)

Wynikiem operacji kaskadowej, którą próbowano wykonać, są nieprawidłowe dane. Sprawdź wartości, które mają być aktualizowane i ustal je tak, aby spełniały reguły poprawności.


Nie można wykonać operacji kaskadowej. Wynikiem operacji byłyby dwie aktualizacje pola <nazwa> z tabeli <nazwa>. (Błąd 3400)

Nie można zakończyć danej operacji kaskadowej, ponieważ dałaby ona w wyniku dwie oddzielne aktualizacje wartości wskazanego pola. Sprawdź wartości, które mają być uaktualnione i ustal je tak, aby spełniały następujące wymagania:

  • Pole jest aktualizowane tylko jeden raz.
  • Jeżeli pole jest aktualizowane więcej niż jeden raz, to wynik każdej aktualizacji pola jest taki sam.


Nie można wykonać operacji kaskadowej. Ze względu na istnienie powiązanych rekordów w tabeli <nazwa> reguły integralności

Nie można wykonać operacji kaskadowej. Ze względu na istnienie powiązanych rekordów w tabeli <nazwa> reguły integralności referencyjnej zostałyby naruszone. (Błąd 3396)

Próba wykonania operacji kaskadowej narusza zasady integralności referencyjnej podanej tabeli. Sprawdź wartości, które mają być zmienione lub usunięte, i ustal je tak, aby spełniały reguły integralności referencyjnej.


Nie można wykonać operacji kaskadowej. Tabela <nazwa> musi zawierać powiązany rekord. (Błąd 3397)

Próba wykonania operacji kaskadowej narusza zasady integralności referencyjnej, która wymaga powiązanego rekordu we wskazanej tabeli. Sprawdź wartości, które mają być zmienione lub usunięte i popraw je tak, aby spełniały reguły integralności referencyjnej.


Nie można wykonać aktualizacji kaskadowej w tabeli, ponieważ jest ona aktualnie używana przez innego użytkownika. (Błąd 3412)

Nastąpiła próba zapisania wartości do pola będącego kluczem podstawowym wchodzącym w skład relacji.

W programie Microsoft Access opcja Kaskadowe aktualizowanie powiązanych pól jest wyznaczona dla relacji; natomiast w kodzie DAO jest określona opcja dbRelationUpdateCascade dla właściwości Attributes obiektu Relation. Aplikacja próbuje zatem aktualizować odpowiednie pole z powiązanej tabeli.

Pole to nie może być aktualizowane z powodu blokowania go przez innego użytkownika. Aby zachować rekord trzeba poczekać, aż powiązana tabela przestanie być używana przez innego użytkownika.


Nieprawidłowy ciąg połączenia w kwerendzie przekazującej. (Błąd 3305)

Ciąg połączenia w kwerendzie przekazującej powinien zaczynać się od "ODBC;".


ODBC -- Pole byłoby za długie; dane zostały obcięte. (Błąd 3231)

ODBC — Pole byłoby za długie; dane zostały obcięte. (Błąd 3231)

Nastąpiła próba wykonania operacji na źródle danych ODBC, która zwróciłaby zbyt długie pole. Dane zostały obcięte do największej dozwolonej długości.


ODBC -- Nie można utworzyć tabeli. (Błąd 3232)

ODBC — Nie można utworzyć tabeli. (Błąd 3232)

Nastąpiła próba eksportu tabeli do bazy danych ODBC, ale tabela nie mogła być utworzona. Ten błąd może wystąpić, gdy baza danych ODBC przeznaczona jest tylko do odczytu, lub nie posiadasz zezwoleń do utworzenia tabeli w bazie danych. Należy zmienić tryb dostępu do bazy lub też otrzymać konieczne zezwolenia od administratora systemu lub od osoby, która tę bazę utworzyła.


ODBC -- Nie powiodła się próba usunięcia z połączonej tabeli <tabela>. (Błąd 3156)

ODBC — Nie powiodła się próba usunięcia z połączonej tabeli <tabela>. (Błąd 3156)

Nie powiodła się próba usunięcia danych z bazy ODBC przy użyciu połączenia ODBC.

Prawdopodobne przyczyny:

  • Usunięcie spowodowałoby naruszenie reguły poprawności.
  • Baza danych ODBC jest przeznaczona tylko do odczytu, lub nie posiadasz uprawnień usuwania rekordów z tej bazy danych. Należy zmienić tryb dostępu do bazy lub też otrzymać konieczne uprawnienia od administratora systemu lub od osoby, która tę bazę utworzyła.
  • Baza danych ODBC znajduje się na dysku sieciowym, ale nie ma połączenia z siecią. Sprawdź, czy sieć jest dostępna i powtórz operację.


ODBC -- Nie można zablokować wszystkich rekordów. (Błąd 3254)

ODBC — Nie można zablokować wszystkich rekordów. (Błąd 3254)

Podczas korzystania z połączenia ODBC usiłowano zablokować wszystkie rekordy bazy danych ODBC.


Nie można używać ODBC do importowania, eksportowania lub dołączania do bazy danych tabeli z zewnętrznej bazy danych Microsoft

Nie można używać ODBC do importowania, eksportowania lub dołączania do bazy danych tabeli z zewnętrznej bazy danych Microsoft Jet lub ISAM. (Błąd 3423)

Próbowano dołączyć, importować lub eksportować dane z tabeli zewnętrznej bazy danych Microsoft Jet lub zewnętrznej bazy danych ISAM (na przykład dBASE, FoxPro®, Paradox lub Btrieve), ale jako źródło danych wybrano bazę danych SQL. Należy wybrać odpowiednie źródło danych dla danych, które próbujesz dołączyć.


ODBC -- Nie powiodła się próba wstawienia do połączonej tabeli <tabela>. (Błąd 3155)

ODBC — Nie powiodła się próba wstawienia do połączonej tabeli <tabela>. (Błąd 3155)

Nie powiodła się próba dodania danych do bazy danych ODBC przy użyciu połączenia ODBC.

Prawdopodobne przyczyny:

  • Wstawienie spowodowałoby naruszenie reguły poprawności.
  • Baza danych ODBC jest przeznaczona tylko do odczytu, lub nie posiadasz uprawnień dodawania rekordów do tej bazy danych. Należy zmienić tryb dostępu do bazy lub też otrzymać konieczne uprawnienia od administratora systemu lub od osoby, która tę bazę utworzyła.
  • Baza danych ODBC znajduje się na dysku sieciowym, ale nie ma połączenia z siecią. Sprawdź, czy sieć jest dostępna i powtórz operację.


ODBC -- Nie można nawiązać połączenia z <nazwa>. (Błąd 3151)

ODBC — Nie można nawiązać połączenia z <nazwa>. (Błąd 3151)

Połączenie ODBC do określonej bazy danych lub tabeli ODBC nie może zostać nawiązane. Jeśli dostęp do bazy danych ODBC następuje poprzez sieć, należy upewnić się, że sieć jest dostępna, a następnie powtórzyć operację.


Nie można wykonać kwerendy; nie można znaleźć połączonej tabeli. (Błąd 3184)

Prawdopodobne przyczyny:

  • Tabela połączona nie istnieje, została usunięta lub jej nazwa została zmieniona. Należy połączyć tabelę i spróbować ponownie wykonać kwerendę.
  • Połączona tabela znajduje się na dysku sieciowym, ale nie ma połączenia z siecią. Należy upewnić się, że sieć jest dostępna, a następnie powtórzyć kwerendę.


ODBC -- Definicja połączonej tabeli została zmieniona. (Błąd 3247)

ODBC — Definicja połączonej tabeli została zmieniona. (Błąd 3247)

Definicja lub struktura tabeli połączonej została zmieniona od czasu utworzenia połączenia. Należy usunąć połączenie, a następnie połączyć tabelę ponownie.


ODBC -- Nie można znaleźć pliku DLL <nazwa>. (Błąd 3154)

ODBC — Nie można znaleźć pliku DLL <nazwa>. (Błąd 3154)

Nastąpiła próba wykonania operacji przy użyciu połączenia ODBC, która wymaga określonej biblioteki DLL.

Prawdopodobne przyczyny:

  • Biblioteka DLL znajduje się na dysku sieciowym, ale nie ma połączenia z siecią.
  • Biblioteka DLL nie została zainstalowana poprawnie. Należy ponownie zainstalować sterownik ODBC, a następnie powtórzyć operację.


Kwerenda aktualizująca/usuwająca pojedynczy wiersz wpłynęła na kilka wierszy połączonej tabeli. Unikatowy indeks zawiera

Kwerenda aktualizująca/usuwająca pojedynczy wiersz wpłynęła na kilka wierszy połączonej tabeli. Unikatowy indeks zawiera powtarzające się wartości. (Błąd 3362)

Kwerenda aktualizująca lub usuwająca wpłynęła na więcej niż jeden rekord w połączonej tabeli SQL. Kwerenda aktualizująca lub usuwająca może jednocześnie oddziaływać tylko na jeden rekord.


W celu dostępu do tabeli serwera SQL posiadającej kolumnę IDENTITY należy w metodzie OpenRecordset użyć opcji dbSeeChanges.

W celu dostępu do tabeli serwera SQL posiadającej kolumnę IDENTITY należy w metodzie OpenRecordset użyć opcji dbSeeChanges. (Błąd 3622)

Generowane przez serwer wartości IDENTITY nie mogą być widoczne po stronie klienta dopóki nie zostanie użyta właściwość DAO dbSeeChanges.


ODBC -- Przekroczony został limit czasu przeznaczony na wykonanie kwerendy zdalnej. (Błąd 3234)

ODBC — Przekroczony został limit czasu przeznaczony na wykonanie kwerendy zdalnej. (Błąd 3234)

Serwer ODBC może być niewłaściwie zainstalowany, lub wymagane połączenie sieciowe nie jest aktywne. Należy spróbować zwiększyć wartość właściwości QueryTimeout.


Nieudane wywołanie ODBC. (Błąd 3146)

Nastąpiła próba wykonania operacji danych w źródle danych ODBC przy użyciu połączenia ODBC. Błąd ten może wystąpić, jeśli źródło danych ODBC jest umieszczone na dysku sieciowym, a komputer wykonujący operację nie jest dołączony do sieci. Sprawdź, czy sieć jest dostępna i powtórz operację.


Istnieje wiele tabel o tej samej nazwie. Należy podać nazwę właściciela tabeli, posługując się formatem "właściciel.tabela".

Istnieje wiele tabel o tej samej nazwie. Należy podać nazwę właściciela tabeli, posługując się formatem "właściciel.tabela". (Błąd 3298)

Istnieje więcej niż jedna tabela o tej samej nazwie w zdalnym źródle danych ODBC. Aby wykluczyć niejednoznaczność, określ właściciela tabeli, z której chcesz skorzystać, używając składni właściciel.tabela.


Wykonanie instrukcji SELECT INTO w zdalnej bazie danych prowadzi do utworzenia zbyt wielu pól. (Błąd 3185)

Baza danych Microsoft Jet obsługuje do 256 pól dla tabeli, lecz inne bazy danych mogą obsługiwać mniej pól. Instrukcja SELECT...INTO utworzyła tabelę zawierającą więcej pól niż może być obsłużonych przez odległą bazę danych. Należy zmniejszyć liczbę kolumn tworzonych przez instrukcję SELECT...INTO, a następnie powtórzyć operację.


ODBC -- Typ danych nie obsługiwany przez serwer. (Błąd 3235)

ODBC — Typ danych nie obsługiwany przez serwer. (Błąd 3235)

Serwer ODBC nie obsługuje tych samych typów danych SQL, co aparat bazy danych Twojej aplikacji. Dane nie zostały więc umieszczone na serwerze.


ODBC -- Nie powiodła się próba aktualizacji w połączonej tabeli <tabela>. (Błąd 3157)

ODBC — Nie powiodła się próba aktualizacji w połączonej tabeli <tabela>. (Błąd 3157)

Nie powiodła się próba uaktualnienia danych w bazie ODBC przy użyciu połączenia ODBC.

Prawdopodobne przyczyny:

  • Aktualizacja spowodowałaby naruszenie reguły poprawności.
  • Baza danych ODBC jest przeznaczona tylko do odczytu, lub nie posiadasz uprawnień uaktualniania rekordów tej bazy danych. Należy zmienić tryb dostępu do bazy lub też otrzymać konieczne uprawnienia od administratora systemu lub od osoby, która tę bazę utworzyła.
  • Baza danych ODBC znajduje się na dysku sieciowym, ale nie ma połączenia z siecią. Sprawdź, czy sieć jest dostępna i powtórz operację.


ODBC -- Dane spoza dozwolonego zakresu. (Błąd 3238)

ODBC — Dane spoza dozwolonego zakresu. (Błąd 3238)

Nastąpiła próba odczytu lub zapisu danych spoza dozwolonego zakresu do bazy danych ODBC przy użyciu połączenia ODBC.


Zażądano blokowania na poziomie rekordów, ale baza danych jest w trybie blokowania stron. (Błąd 3751)

Ten błąd występuje, gdy użytkownik zażąda otwarcia bazy danych w trybie blokowania rekordów/stron, ale inny użytkownik otworzył już bazę danych w trybie blokowania wyłącznie stron.


Nie można zmieniać reguły w czasie używania reguł tej tabeli. (Błąd 3302)

Rekord w tej tabeli został zmieniony przez innego użytkownika lub przez Ciebie w innej sesji aplikacji i obecnie jest zablokowany. Nie można modyfikować reguł w tabeli, dopóki rekord z tej tabeli jest zablokowany.

Jeżeli rekord został zablokowany podczas oddzielnej sesji, zapisz rekord, a następnie wykonaj planowane zmiany. Jeżeli rekord został zablokowany przez innego użytkownika, odczekaj chwilę i zapisz modyfikacje reguły.


Synchronizator <nazwa> wykorzystuje tę samą skrzynkę systemu plików <nazwa> (Błąd 3630)

Każdy Synchronizator powinien posiadać unikatową skrzynkę systemu plików. Korzystanie przez kilka Synchronizatorów z tej samej skrzynki może prowadzić do zagubienia komunikatów i niepełnych wymian. Aplikacja nie może utworzyć pliku sygnałowego, ponieważ jest on już otwarty przez innego dostawcę transportu.


Nie można dokonać zapisu; strona aktualnie zablokowana przez użytkownika <nazwa> na maszynie <nazwa>. (Błąd 3186)

Prawdopodobne przyczyny:

  • Usiłowano zapisać rekord na 2-kilobajtowej stronie bazy danych, która aktualnie jest zablokowana przez innego użytkownika. Należy poczekać, aż ten użytkownik zakończy pracę z danym rekordem i ponowić operację.


Historia zmian projektu w replice jest niezgodna z historią zmian we wzorcu. (Błąd 3524)

Program Synchronizator nie może zsynchronizować dwóch elementów zestawu replik, ponieważ historia zmian projektu (lub schematu) jest inna dla każdej repliki. Rozbieżności w historii zmian projektu mogą pojawić się, albo z powodu istnienia dwóch wzorców, albo gdy wzorzec jest odtworzony z nie najnowszej kopii zapasowej.


Klucz poszukiwania nie został znaleziony w żadnym rekordzie. (Błąd 3709)

Ten błąd występuje podczas wykonywania ISAM SEEK, gdy nie ma odpowiadających wartości w indeksie.


Nazwa wybrana dla obiektu systemowego jest już używana przez inny obiekt. (Błąd 3526)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można tworzyć relacji pola z samym sobą. (Błąd 3206)

Wystąpiła próba utworzenia relacji pomiędzy polem a nim samym. Należy wybrać inne pole dla tabeli podstawowej lub powiązanej tabeli i ponowić próbę.


Nie można załadować pliku mechanizmu Jet SQL Server Reconciler - MSRPJT40.dll. (Błąd 3775)

Nastąpiła próba wykonania operacji pomiędzy subskrybentem aparatu Microsoft® Jet i mechanizmem publikacji SQL. Plik msrpjt40.dll nie został odnaleziony na podanej ścieżce i nie został zarejestrowany.


Nie można dokonać aktualizacji; dane aktualnie zablokowane przez inną sesję na tym komputerze. (Błąd 3188)

Nastąpiła próba aktualizacji informacji, która jest obecnie zablokowana przez inną sesję. Należy poczekać, dopóki inna sesja nie zakończy się, lub też zamknąć tę inną sesję, a następnie powtórzyć operację.


W podkwerendzie operacje UNION są niedozwolone. (Błąd 3361)

Użycie operacji UNION w wyrażeniu podkwerendy jest niedozwolone. Aby użyć kwerendy składającej w podkwerendzie, należy najpierw utworzyć kwerendę składającą i zapisać ją jako kwerendę nazwaną. Następnie nazwę pisanej kwerendy należy włączyć do wyrażenia podkwerendy.


Przekroczony licznik blokad współużytkowania plików. Zwiększ wartość wpisu rejestru MaxLocksPerFile. (Błąd 3052)

Przekroczono maksymalą liczbę blokad, którą można założyć na zestaw rekordów. Liczba ta jest określona zmienną MaxLocksPerFile znajdującą się w rejestrze systemowym. Domyślna wartość wynosi 9500; może ona być zmieniona za pomocą programu Regedit.exe lub metody SetOption.

Niektóre z czynników mogących doprowadzić do osiągnięcia tej wartości progowej przez aplikację to:

  • ilość dostępnej pamięci,
  • rozmiar wierszy w zestawie rekordów,
  • ograniczenia sieciowego systemu operacyjnego.


Podczas próby otwarcia pliku dziennika <nazwa> w trybie zakazu pisania (Deny Write) nastąpiło naruszenie zasad współużytkowania

Podczas próby otwarcia pliku dziennika <nazwa> w trybie zakazu pisania (Deny Write) nastąpiło naruszenie zasad współużytkowania. (Błąd 3475)

Należy zamknąć plik dziennika we wszystkich pozostałych aplikacjach.


Jedynie proste kwerendy SELECT są dozwolone w widokach. (Błąd 3766)

Ten błąd powstaje podczas próby utworzenia widoku za pomocą DDL języka SQL. Pojawia się on przy próbie dołączenia parametrów lub części instrukcji wybierającej jako składnika definicji widoku.


Napisano podkwerendę, która może zwrócić więcej niż jedno pole, bez użycia zastrzeżonego słowa EXISTS w klauzuli FROM kwerendy

Napisano podkwerendę, która może zwrócić więcej niż jedno pole, bez użycia zastrzeżonego słowa EXISTS w klauzuli FROM kwerendy głównej. Zmień instrukcję SELECT podkwerendy tak, aby wybierała tylko jedno pole. (Błąd 3306)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Ta podkwerenda może zwrócić co najwyżej jeden rekord. (Błąd 3354)

Podkwerenda tego rodzaju może zwrócić co najwyżej jeden rekord. Zmień instrukcję SELECT podkwerendy tak, by wybierała tylko jeden rekord.


Biblioteki sortowania aparatu Jet nie mogą być poprawnie załadowane. (Błąd 3757)

Aparat Microsoft® Jet używa dwóch bibliotek sortowania DLL do porównań i indeksowania, MSWSTR10.DLL i MSWDAT10.DLL. Upewnij się, czy biblioteki znajdują się na ścieżce używanej dla bibliotek.

Jeśli inna aplikacja usunęła lub uszkodziła biblioteki, należy przeprowadzić ponowną ich instalację.


Bazy danych sterowanej źródłem nie można uczynić replikowalną. (Błąd 3638)

Nastąpiła próba replikacji bazy danych kontrolowanej przez program bazy danych, który nie obsługuje replikacji. Aby uczynić tę bazę danych replikowalną, należy zapewnić, że nie jest ona kontrolowana przez program sterowany źródłem.


Format eksportowanych danych nie jest zgodny z formatem opisanym w pliku Schema.ini. (Błąd 3438)

Zapewnij zgodność formatu eksportowanych danych z formatem opisanym w pliku Schema.ini.


Tabela <nazwa> nie może być zablokowana, ponieważ jest aktualnie używana przez użytkownika <nazwa> komputera <nazwa>. (Błąd

Tabela <nazwa> nie może być zablokowana, ponieważ jest aktualnie używana przez użytkownika <nazwa> komputera <nazwa>. (Błąd 3212)

Tabela nie może zostać zablokowana, ponieważ jest ona aktualnie w użyciu. Należy poczekać, aż transakcja innego użytkownika zostanie zakończona i ponowić operację.


Użytkownik <nazwa> na komputerze <nazwa> zablokował na wyłączność tabelę <nazwa>. (Błąd 3189)

Nie można uzyskać dostępu do podanej tabeli, ponieważ inny użytkownik założył na nią blokadę wyłączną. Należy skontaktować się z tym użytkownikiem lub poczekać, dopóki nie zwolni on blokady, a następnie powtórzyć operację.


Kwerenda przekazująca z właściwością ReturnsRecords ustawioną na wartość True nie zwróciła żadnego rekordu. (Błąd 3325)

Kwerenda przekazująca nie zwróciła żadnych rekordów, mimo że właściwość ReturnsRecords ma wartość True. Jeżeli kwerenda przekazująca nie zwraca rekordów, ustaw wartość właściwości ReturnsRecords na False.


Błędna składnia SQL - oczekiwano: ACTION. (Błąd 3762)

Błędna składnia SQL – oczekiwano: ACTION. (Błąd 3762)

Ten błąd występuje podczas definiowania ograniczeń integralności referencyjnej poprzez składnię CREATE TABLE lub składnię ALTER TABLE ALTER COLUMN. Pojawia się, gdy po słowie kluczowym NO nie występuje słowo kluczowe ACTION. Na przykład opuszczenie słowa kluczowego BOLD ON w następującej instrukcji wygenerowałoby błąd:

CREATE TABLE SzczegółyZamówienia (NrZamówienia LONG CONSTRAINT koZamówieniaNrZamówienia REFERENCES Zamówienia (NrZamówienia) ON UPDATE CASCADE ON DELETE NO ACTION, Opis LONG, NrProduktu LONG CONSTRAINT koProduktyNrProduktu REFERENCES Produkty (NrProduktu), Ilość LONG);


Nieprawidłowa składnia SQL - oczekiwano: AS. (Błąd 3728)

Ten błąd występuje podczas definiowania lub tworzenia widoku lub procedury poprzez język DDL języka SQL. Błąd wystąpiłby przy użyciu następującej składni: CREATE VIEW nazwa_widoku SELECT…. Aby zapobiec powstawaniu tego błędu, zmień składnię następująco: CREATE VIEW nazwa_widoku AS SELECT….


Po końcu instrukcji SQL znaleziono znaki. (Błąd 3142)

Po użyciu średnika (;) w instrukcji SQL, zostały wprowadzone znaki. Na przykład, “SELECT * FROM tabela1; śmieci” wygeneruje niniejszy błąd. Aby zapobiec generacji błędu, usuń wszelkie znaki znajdujące się po średniku (;).


Nieprawidłowa składnia SQL - oczekiwano: COMPRESSION za WITH. (Błąd 3723)

Ten błąd występuje przy użyciu składni CREATE TABLE lub ALTER TABLE ALTER COLUMN. Pojawia się przy odwołaniu się do jednego z synonimu NATIONAL CHARACTER dla typu kolumny bez użycia słowa kluczowego COMPRESSION za słowem kluczowym WITH. Następujące jest poprawną instrukcją SQL: CREATE TABLE foo (foo NCHAR WITH COMP);. Następująca instrukcja SQL zwróciłaby niniejszy błąd: CREATE TABLE foo (foo NCHAR WITH);.


Nieprawidłowa składnia SQL - oczekiwano nazwy dla słowa kluczowego CONSTRAINT. (Błąd 3721)

Nieprawidłowa składnia SQL – oczekiwano nazwy dla słowa kluczowego CONSTRAINT. (Błąd 3721)

Podczas definiowania integralności referencyjnej z instrukcji DDL języka SQL, należy nazwać ograniczenie, jeśli słowo kluczowe CONSTRAINT jest używane. Jeśli nie jest wymagane posiadanie nazwy ograniczenia, nie należy wtedy używać słowa kluczowego CONSTRAINT. Przykładem tego błędu byłoby następujące: CREATE TABLE Klienci (KOstNr TEXT(50), KPieNr TEXT(25), CONSTRAINT PRIMARY KEY (KPieNr, KOstNr));.

Aby zapobiec powstawaniu niniejszego błędu, należy dołączyć nazwę po słowie kluczowym CONSTRAINT:

CREATE TABLE Klienci (KOstNr TEXT(50), KPieNr TEXT(25), CONSTRAINT kpKlienci PRIMARY KEY (KPieNr, KOstNr));.

lub nie używać słowa kluczowego CONSTRAINT:

CREATE TABLE Klienci (KOstNr TEXT(50), KPieNr TEXT(25), PRIMARY KEY (KPieNr, KOstNr));.


Nieprawidłowa składnia SQL - oczekiwano: Baza danych. (Błąd 3785)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nieprawidłowa składnia SQL - oczekiwano przywileju bazy danych takiego jak CREATEDB lub CONNECT. (Błąd 3786)

Nieprawidłowa składnia SQL – oczekiwano przywileju bazy danych takiego jak CREATEDB lub CONNECT. (Błąd 3786)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nieprawidłowa składnia SQL - oczekiwano: DEFAULT. (Błąd 3722)

Ten błąd powstaje przy użyciu składni ALTER TABLE ALTER COLUMN. Pojawia się, gdy literał, lub jedno z następujących słów kluczowych USER lub NULL, są używane bez umieszczenia za nimi słowa kluczowego DEFAULT.


Błąd składniowy w instrukcji DELETE. (Błąd 3130)

Wprowadzono instrukcję SQL zawierającą niepoprawną instrukcję DELETE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nieprawidłowa składnia SQL - oczekiwano: CASCADE, SET NULL, lub NO ACTION. (Błąd 3725)

Ten błąd pojawia się przy definiowaniu integralności referencyjnej poprzez instrukcję CREATE TABLE lub instrukcję ALTER TABLE ALTER COLUMN. Pojawia się on, gdy po użytym słowie kluczowym UPDATE lub DELETE nie zostanie użyte jedno z następujących słów kluczowych: CASCADE, SET NULL, NO ACTION.


Nieprawidłowa składnia SQL - oczekiwano: NULL. (Błąd 3726)

Ten błąd występuje przy generowaniu instrukcji DDL skojarzonej z indeksem. Może się on pojawić, gdy słowo kluczowe NULL nie zostanie użyte za następującymi słowami kluczowymi: CREATE INDEX, WITH PRIMARY, lub IGNORE.


Błąd składniowy w klauzuli FROM. (Błąd 3131)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę FROM.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w klauzuli GROUP BY. (Błąd 3132)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę GROUP BY.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w klauzuli HAVING. (Błąd 3133)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę HAVING.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w instrukcji INSERT INTO. (Błąd 3134)

Wprowadzono instrukcję SQL zawierającą niepoprawną instrukcję INSERT INTO.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Kwerenda przekazująca musi zawierać co najmniej jeden znak. (Błąd 3359)

Ciąg SQL kwerendy przekazującej musi zawierać co najmniej jeden znak.


Błąd składniowy w operacji JOIN. (Błąd 3135)

Wprowadzono instrukcję SQL z błędną operacją sprzężenia. Może to być sprzężenie wewnętrzne, sprzężenie zewnętrzne, lub sprzężenie zwrotne.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Klauzula LEVEL zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe znaki

Klauzula LEVEL zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe znaki przestankowe. (Błąd 3136)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę ze słowem zastrzeżonym. Możliwe przyczyny:

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nie można utworzyć relacji pomiędzy połączonymi tabelami ODBC. (Błąd 3613)

Aparat bazy danych Microsoft Jet nie może utworzyć relacji na tabelach połączonych w tabelach źródła danych ODBC.


Brak średnika (;) na końcu instrukcji SQL. (Błąd 3137)

Instrukcja SQL może zawierać dodatkowe informacje za tekstem instrukcji. Na przykład, instrukcja “SELECT kol1 FROM tabela1 śmieci” zwróciłaby niniejszy błąd. “SELECT kol1 FROM tabela1; śmieci” jest poprawne.


Nieprawidłowa składnia SQL - dozwolona jest tylko jedna reguła uaktualniania i/lub jedna reguła usuwania. (Błąd 3727)

Nieprawidłowa składnia SQL – dozwolona jest tylko jedna reguła uaktualniania i/lub jedna reguła usuwania. (Błąd 3727)

Ten błąd występuje przy definiowaniu integralności referencyjnej poprzez język DDL języka SQL. Pojawia się on, gdy słowa kluczowe NULL lub DEFAULT nie zostaną użyte po słowie kluczowym SET.


Błąd składniowy w klauzuli ORDER BY. (Błąd 3138)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę ORDER BY.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w deklaracji WITH OWNERACCESS OPTION. (Błąd 3257)

Prawdopodobne przyczyny:

  • Deklaracja WITH OWNERACCESS OPTION nie jest kompletna lub zawiera odstęp między słowami OWNER i ACCESS.
  • Deklaracja znajduje się w nieoczekiwanym lub niedozwolonym miejscu instrukcji SQL. Na przykład:

    SELECT * WITH OWNERACCESS OPTION FROM [Moja tabela];

    Deklaracja WITH OWNERACCESS OPTION powinna znajdować się na końcu instrukcji SQL, zazwyczaj po klauzuli ORDER BY, jeśli takowa występuje:

    SELECT * FROM [Moja tabela] WITH OWNERACCESS OPTION;


Błąd składniowy w klauzuli PARAMETER. (Błąd 3139)

Wprowadzono instrukcję SQL z niepoprawną deklaracją PARAMETERS. Możliwe przyczyny:

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy SQL - oczekiwano: Przywileje. (Błąd 3689)

Ten błąd występuje przy użyciu słów kluczowych GRANT lub REVOKE. Przywileje nie zostały określone. Poprawnymi przywilejami są SELECT, UPDATE, DELETE, i INSERT.


Błąd składniowy w klauzuli PROCEDURE. (Błąd 3140)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę PROCEDURE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nieprawidłowa składnia SQL - oczekiwano: SELECT. (Błąd 3729)

Ten błąd występuje podczas próby utworzenia widoku z języka DDL języka SQL. Następujące spowodowałoby powstanie błędu: CREATE VIEW nazwa_widoku AS. Aby uniknąć błędu, należy użyć poprawnej instrukcji SELECT za słowem kluczowym AS.


Instrukcja SELECT zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe

Instrukcja SELECT zawiera niepoprawnie napisane albo błędne słowo zastrzeżone lub argument, bądź też zastosowano niewłaściwe znaki przestankowe. (Błąd 3141)

Wprowadzono instrukcję SQL zawierającą niepoprawną instrukcję SELECT.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Niewłaściwa instrukcja SQL; oczekiwano "DELETE", "INSERT", "PROCEDURE", "SELECT" lub "UPDATE". (Błąd 3129)

Podana instrukcja SQL nie mogła być rozpoznana, ponieważ nie zaczyna się żadnym z określonych słów zastrzeżonych.


Błąd składniowy w instrukcji TRANSFORM. (Błąd 3143)

Wprowadzono instrukcję SQL zawierającą niepoprawną instrukcję TRANSFORM.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Błąd składniowy w kwerendzie składającej. (Błąd 3319)

Wystąpił błąd składniowy w ciągu SQL kwerendy składającej.

Prawdopodobne przyczyny:

  • Błędnie podane słowo zastrzeżone lub nazwa argumentu.
  • Brak słowa zastrzeżonego lub argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nieprawidłowa składnia SQL - oczekiwano: UPDATE lub DELETE. (Błąd 3724)

Ten błąd występuje podczas definiowania integralności referencyjnej poprzez instrukcję CREATE TABLE lub instrukcję ALTER TABLE ALTER COLUMN. Niniejszy błąd pojawia się, gdy użyte jest słowo kluczowe CASCADE bez poprzedzenia go słowem kluczowym UPDATE lub DELETE.


Błąd składniowy w instrukcji UPDATE. (Błąd 3144)

Wprowadzono instrukcję SQL zawierającą niepoprawną instrukcję UPDATE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nieprawidłowa składnia SQL - oczekiwano nazwy widoku. (Błąd 3780)

Nieprawidłowa składnia SQL – oczekiwano nazwy widoku. (Błąd 3780)

Ten błąd występuje przy próbie utworzenia lub usunięcia widoku za pomocą składni CREATE VIEW lub DROP VIEW z języka DDL SQL. Pojawia się, gdy nie została określona poprawna nazwa. Na przykład następująca instrukcja wygenerowałaby błąd: CREATE VIEW AS SELECT * FROM tabela1.


Błąd składniowy w klauzuli WHERE. (Błąd 3145)

Wprowadzono instrukcję SQL zawierającą niepoprawną klauzulę WHERE.

Prawdopodobne przyczyny:

  • Nie podane lub podane błędnie słowo zastrzeżone lub nazwa argumentu.
  • Zastosowano niewłaściwe znaki przestankowe.


Nie można użyć '*' w kwerendzie krzyżowej. (Błąd 3123)

Nastąpiła próba wykonania kwerendy, która grupuje lub sumuje pola wybrane przy użyciu znaku gwiazdki ( * ). Wybierz konkretne pola i powtórz operację.


Nie można grupować według pól wybranych przy użyciu '*'. (Błąd 3121)

Nastąpiła próba wykonania instrukcji SELECT, która grupuje lub sumuje wszystkie pola z wszystkich tabel, wybrane przy użyciu znaku gwiazdki ( * ).

Możliwa przyczyna:

  • Utworzono instrukcję SQL, która zawiera funkcję agregującą lub klauzulę GROUP BY odnoszące się do pola wybranego przy użyciu znaku gwiazdki. Błąd ten występuje, na przykład, po wprowadzeniu następującej instrukcji SQL:

    SELECT * FROM Zamówienia GROUP BY Spedytor;


Baza danych została wprowadzona przez użytkownika <nazwa> komputera <nazwa> w stan uniemożliwiający jej zablokowanie lub

Baza danych została wprowadzona przez użytkownika <nazwa> komputera <nazwa> w stan uniemożliwiający jej zablokowanie lub otwarcie. (Błąd 3734)

Ten błąd występuje, gdy używana jest nowa kontrola połączenia/pasywne zamknięcie. Niniejszy komunikat błędu wskazuje, że inny użytkownik ustawił bazę danych w trybie uniemożliwiającym jej otwarcie przez innych użytkowników.


Baza danych została wprowadzona przez nieznanego użytkownika w stan uniemożliwiający jej zablokowanie lub otwarcie. (Błąd 3733)

Ten błąd występuje kiedy jest w użyciu nowa kontrola pasywnego zamknięcia/połączenia. Ten błąd wskazuje, że inny użytkownik ustawił bazę danych w trybie uniemożliwiającym jej otwarcie przez innych użytkowników. Błąd jest powiązany z błędem #3734 i jest zwracany, gdy aparat Microsoft® Jet nie może określić który użytkownik wywołał kontrolę pasywnego zamknięcia/połączenia.


Obiekt <nazwa> nie jest procedurą SQL. (Błąd 3750)

Ten błąd występuje przy użyciu słowa kluczowego EXECUTE, gdzie przekazywana jest nazwa procedury lub widoku, który nie istnieje w bazie danych lub przekazywana jest nazwa tabeli podstawowej.


Nie ma odpowiedniej repliki do wymiany. (Błąd 3684)

Nie ma odpowiedniej repliki do wymiany dla podanego adresu HTTP.


Synchronizacja z nie replikowaną bazą danych nie jest dopuszczalna. Baza danych <nazwa> nie jest repliką ani nie pełni roli

Synchronizacja z nie replikowaną bazą danych nie jest dopuszczalna. Baza danych <nazwa> nie jest repliką ani nie pełni roli wzorca. (Błąd 3605)

Dokonano próby synchronizacji replikowanej bazy danych z nie replikowaną bazą danych lub próby synchronizacji dwóch baz nie replikowanych. Synchronizować można tylko replikę tej samej replikowanej bazy danych.

Jeśli jedna z baz danych była już replikowana, użyj jej do utworzenia drugiej repliki.

Jeśli żadna z baz danych nie była replikowana, wybierz jedną bazę danych mającą posłużyć jako wzorzec główny dla zestawu replik. Otwórz tę bazę danych w programie Microsoft® Access, przejdź do menu Narzędzia, wskaż opcję Replikacja i kliknij polecenie Utwórz replikę. Jeśli nie jest dostępny program Microsoft Access, ale dostępna jest Aktówka Windows® 95, to do utworzenia repliki bazy danych wystarczy jej przeciągnięcie do Aktówki. Nie należy tworzyć repliki drugiej bazy danych i następnie synchronizować tych baz. Aby synchronizacja powiodła się, druga baza danych musi być repliką pierwszej.


Synchronizator <nazwa> wykorzystuje tę samą skrzynkę systemu plików <nazwa>. (Błąd 3629)

Każdy Synchronizator powinien posiadać unikatową skrzynkę systemu plików. Skutkiem korzystania przez kilka Synchronizatorów z tej samej skrzynki mogą być zagubione komunikaty i niepełne wymiany.

Nie można utworzyć pliku sygnałowego, jest on obecnie otwarty przez innego dostawcę transportu.


Błąd składniowy w kwerendzie. Wartość parametru. (Błąd 3746)

Ten błąd może wystąpić, gdy:

  • Nieprawidłowy typ danych parametru został użyty z kwerendami/procedurami parametrycznymi.
  • Procedura i nazwany parametr nie mogą być poprzedzone symbolem @.
  • Nieprawidłowa nazwa parametru została przekazana za symbolem @.
  • Nie ma znaku równości (=) za parametrem.
  • Słowa zastrzeżone są użyte jako parametry bez odpowiednich znaków sterujących.


Błąd składniowy w instrukcji Transaction. Oczekiwano TRANSACTION, WORK, lub nic. (Błąd 3708)

Przy użyciu transakcji jedynie poprzez aparat Microsoft® Jet (nie przez model obiektowy jak DAO lub ADO) trzeba użyć następującej składni: BEGIN/ROLLBACK TRANSACTION, WORK lub nic. Jeżeli jakiekolwiek inne znaki zostaną umieszczone za BEGIN lub ROLLBACK, wystąpi niniejszy błąd.


Nie można otworzyć pliku informacyjnego grupy roboczej aparatu Microsoft Jet. (Błąd 3358)

Próbowano wykonać zadanie dotyczące ochrony danych, ale nie znaleziono potrzebnego dla tego zadania pliku informacyjnego grupy roboczej (najczęściej jest to plik System.mdw).


Aparat bazy danych Microsoft Jet nie może odczytać wskazań zegara systemowego komputera. (Błąd 3515)

Aparat bazy danych Microsoft Jet korzysta podczas pewnych wewnętrznych operacji z zegara systemowego komputera. Próba odczytania zegara nie powiodła się. Należy wówczas zamknąć system i uruchomić ponownie komputer.


Obiekt systemowy wciąż istnieje chociaż proces, który z niego korzystał, już został zakończony. (Błąd 3533)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można otworzyć systemowej tabeli replikacji <nazwa>, gdyż ta tabela jest aktualnie w użyciu. (Błąd 3581)

Tabela systemowa niezbędna do przeprowadzenia tej operacji jest aktualnie używana. Należy poczekać kilka minut i spróbować ponownie wykonać operację.


Nie można usunąć komórek arkusza kalkulacyjnego. (Błąd 3435)

Nie można usunąć danych z komórek z określonego zakresu arkusza kalkulacyjnego. Komórki te mogą zawierać formuły lub też mogą być komórkami chronionymi.


Tabela <nazwa> już istnieje. (Błąd 3010)

Nastąpiła próba utworzenia tabeli o nazwie już istniejącej w bazie danych lub próba zmiany nazwy tabeli na taką nazwę. Wybierz inną nazwę, a następnie powtórz operację.

W wielodostępnej bazie danych błąd ten może także wystąpić, jeśli jeden użytkownik usunie tabelę, drugi utworzy tabelę o takiej samej nazwie, a następnie pierwszy podejmie próbę wycofania się z operacji usuwania tabeli. Aby odtworzyć usuniętą tabelę, należy przed wycofaniem tej operacji usunąć lub zmienić nazwę nowej tabeli.


Tabela <nazwa> jest już otwarta w sposób wyłączny przez innego użytkownika lub jest otwarta poprzez interfejs użytkownika i nie

Tabela <nazwa> jest już otwarta w sposób wyłączny przez innego użytkownika lub jest otwarta poprzez interfejs użytkownika i nie można nią manipulować programowo. (Błąd 3008)

Nastąpiła próba użycia tabeli, która jest już otwarta w sposób wyłączny przez innego użytkownika, lub próba programowej manipulacji tabeli otwartej przez interfejs użytkownika. Usuń właściwą przyczynę i powtórz operację.


Nie można rozszerzyć nazwanego zakresu. (Błąd 3434)

Podczas próby dodania wierszy do nazwanego zakresu Microsoft Excel 5.0 napotkano na komórki z wpisanymi wartościami. Te komórki nie mogą być zastąpione przy pomocy operacji dołączającej.


Nie można zablokować tabeli. (Błąd 3262)

Przy otwarciu usiłowano zablokować tabelę. Tabela nie może zostać zablokowana, ponieważ jest aktualnie używana. Poczekaj chwilę, a następnie powtórz operację.


Aparat bazy danych nie może zablokować dostępu do tabeli <nazwa>, ponieważ jest ona aktualnie wykorzystywana przez innego

Aparat bazy danych nie może zablokować dostępu do tabeli <nazwa>, ponieważ jest ona aktualnie wykorzystywana przez innego użytkownika lub proces. (Błąd 3211)

Aby dana operacja mogła być zakończona, musi być zablokowana tabela, która jest aktualnie używana przez innego użytkownika. Należy poczekać, aż ten użytkownik skończy pracę z tą tabelą i ponowić operację.


Użytkownik <nazwa> na maszynie <nazwa> zablokował na wyłączność tabelę <nazwa>. (Błąd 3261)

Usiłowano użyć tabeli, która jest aktualnie otwarta przez innego użytkownika do wyłącznego dostępu. Należy poczekać, aż ten użytkownik skończy pracę z tą tabelą i ponowić operację.


Nie można wykonać tej operacji na tabeli zawierającej dane. (Błąd 3282)

Nie jest możliwe dodanie pola lub indeksu do tabeli połączonej zawierającej dane. Po wypełnieniu tabeli danymi nie można zmienić projektu tabeli lub indeksów. Należy utworzyć nową, inaczej zaprojektowaną tabelę i przenieść do niej dane, używając kwerendy funkcjonalnej.


Nie można modyfikować struktury tabeli. Tabela jest otwarta przez innego użytkownika. (Błąd 3422)

Aparat bazy danych Microsoft Jet nie mógł zmodyfikować struktury tabeli, ponieważ jest ona aktualnie otwarta przez innego użytkownika. Poczekaj, aż tabela zostanie zamknięta i ponownie spróbuj wprowadzić zmiany.


Tabela nie jest otwarta. (Błąd 3160)

Nastąpiła próba wykonania operacji na tabeli, która nie została otwarta. Należy otworzyć tabelę, a następnie powtórzyć operację.


Tabela <nazwa> nie mogła zostać przekształcona do postaci replikowalnej, ponieważ nie mogła zostać otwarta w trybie wyłączności

Tabela <nazwa> nie mogła zostać przekształcona do postaci replikowalnej, ponieważ nie mogła zostać otwarta w trybie wyłączności. (Błąd 3767)

Zamknij każde wystąpienie tabeli, którą próbujesz przekształcić do postaci replikowalnej, i spróbuj ponownie.


Nie można powtórzyć nazwy tabeli <nazwa> w klauzuli FROM. (Błąd 3074)

Nie można podawać nazwy tabeli więcej niż jeden raz. Usuń dodatkowe wystąpienia nazwy tabeli lub zastosuj alias. Jeśli jest to próba sprzężenia tabeli z nią samą, zastosuj alias, aby zmienić drugie odwołanie się do tej samej tabeli.


Zbyt wiele zadań klienta. (Błąd 3053)

Uruchomiono zbyt wiele kopii systemu Visual Basic® lub aplikacji Visual Basic w tym samym czasie. Zamknij jedną lub więcej sesji.


Błąd dyskowej operacji wejścia/wyjścia przy próbie czytania lub pisania do katalogu TEMP. (Błąd 3572)

Wystąpił problem przy próbie dostępu do katalogu TEMP komputera. Sprawdź, czy ścieżka do katalogu TEMP jest ustawiona prawidłowo.


Brak miejsca na dysku tymczasowym. (Błąd 3183)

Usiłowano dokonać operacji, która wymaga więcej miejsca niż jest dostępne na dysku tymczasowym. Lokalizacja dysku tymczasowego zależy od DOS-owej zmiennej środowiska TEMP, ustawianej podczas uruchamiania systemu.

Na przykład podczas tworzenia kwerendy mogą powstawać pliki tymczasowe o rozmiarach większych niż dysk tymczasowy. Należy wówczas zmniejszyć wielkość plików tymczasowych przez dostęp do mniejszych porcji danych, lub też zwiększyć rozmiar pliku tymczasowego.

Wielkość dostępnego obszaru na dysku tymczasowym można zwiększyć na kilka sposobów:

  • Wybieraj mniej rekordów. Obiekty Recordset typu zestaw dynamiczny, utrwalony i progresywny zapisują klucze i dane na dysku tymczasowym.
  • Umieść dysk tymczasowy na innej stacji.
  • Jeśli tymczasowy dysk jest dyskiem RAM, zwiększ ilość dostępnej pamięci typu RAM oraz obszar przeznaczony na dysk RAM, lub też przenieś go na dysk twardy.
  • Zwolnij miejsce w bazie danych przez usunięcie z niej danych lub też nie używanych tabel, kwerend, formularzy, makr i modułów.
  • Zwolnij miejsce przez defragmentację bazy danych.
  • Jeśli nadal brakuje miejsca, rozważ możliwość usunięcia z dysku nie używanych plików.


Bufor odczytu okazał się zbyt mały w stosunku do wielkości żądanych danych. (Błąd 3640)

Podczas wykonywania metod GetRows lub GetRowsEx bufor odczytu okazał się zbyt mały, aby pomieścić podane wiersze.


Strona kodowa specyficzna dla języka nie jest określona lub nie może zostać znaleziona. (Błąd 3649)

Nastąpiła próba otwarcia bazy danych utworzonej w języku, który nie został zainstalowany na danym komputerze. Należy ustalić, jaki to był język, a następnie upewnić się, że jest on zainstalowany w systemie. Jeśli baza danych powstała przy użyciu DAO, język został określony wraz z argumentem ustawień regionalnych metody CreateDatabase. Jeśli baza danych powstała za pomocą programu Microsoft® Access, język został określony z opcją "Kolejność sortowania nowej bazy danych" na karcie Ogólne okna dialogowego Opcje, które jest osiągalne poprzez kliknięcie polecenia Opcje w menu Narzędzia.

Języki są dodawane do systemu poprzez “Ustawienia regionalne” Panelu sterowania.


Obiekt Recordset zawiera mniej rekordów niż zażądano. (Błąd 3641)

Osiągnięto koniec obiektu Recordset.


Podana długość wiersza jest mniejsza niż suma długości kolumn. (Błąd 3646)

Parametr długości wiersza nie określił wystarczającej długości dla łączenia kolumn.


Aparat bazy danych nie rozpoznaje pola <nazwa> w wyrażeniu kontroli poprawności lub wartości domyślnej w tabeli <nazwa>. (Błąd

Aparat bazy danych nie rozpoznaje pola <nazwa> w wyrażeniu kontroli poprawności lub wartości domyślnej w tabeli <nazwa>. (Błąd 3344)

Podane wyrażenie odwołuje się do pola w niepoprawny sposób, lub odwołuje się do nieistniejącego pola. Sprawdź, czy pole istnieje i czy nazwa jest podana prawidłowo.


Wyrażenie, które próbowano zastosować dla właściwości DefaultValue jest nieprawidłowe, ponieważ <komunikat błędu>. Do

Wyrażenie, które próbowano zastosować dla właściwości DefaultValue jest nieprawidłowe, ponieważ <komunikat błędu>. Do ustawienia tej właściwości należy użyć poprawnego wyrażenia. (Błąd 3406)

Wyrażenie, którego próbujesz użyć dla właściwości DefaultValue jest nieprawidłowe. Zastosuj poprawne wyrażenie.


Błąd <objaśnienie błędu> w regule poprawności. (Błąd 3405)

Nie można poprawnie obliczyć wyrażenia z powodu podanego w objaśnieniu błędu. Na przykład, jeżeli komunikat brzmi "Niezgodność typu", to znaczy, że ustawienie właściwości jest niezgodne ze zdefiniowanym typem danych pola.


<Błąd> w wyrażeniu kontroli poprawności na poziomie tabeli. (Błąd 3320)

Wystąpił błąd w wyrażeniu reguły poprawności na poziomie tabeli lub w wyrażeniu na jej wartość domyślną. Mógł to być błąd składniowy lub jakiś inny rodzaj błędu.


Nieznana funkcja <nazwa> w wyrażeniu kontroli poprawności lub wartości domyślnej dla <nazwa>. (Błąd 3388)

Funkcja, do której nastąpiło odesłanie, jest nieznana (ponieważ jej nazwa jest nieprawidłowa lub niepoprawnie napisana) lub jest funkcją o typie, który nie jest dopuszczalny przez właściwość ValidationRule lub DefaultValue. Do niedopuszczalnych typów funkcji zalicza się funkcje zdefiniowane przez użytkownika oraz funkcje agregujące SQL.


Nie można umieścić wyrażenia kontroli poprawności w tym polu. (Błąd 3313)

Nastąpiła próba ustawienia właściwości poprawności dla pola (takiego jak pole typu Autonumer lub obiekt OLE) nie akceptującego tego typu właściwości. Użyj innego pola do kontroli poprawności danych lub, jeżeli do tabeli nie dodano danych, ponownie zdefiniuj typ danych dla tego pola.


Reguły poprawności i wartości domyślne nie mogą być umieszczone w tabelach systemowych lub tabelach połączonych. (Błąd 3312)

Usiłowano ustawić właściwość DefaultValue, ValidationRule, ValidationText lub Required w tabeli, polu lub innym obiekcie zabronionym przez aplikację. Na przykład próbujesz ustawić właściwość dla obiektu systemowego.


Pole <nazwa> nie może być ciągiem znaków o zerowej długości. (Błąd 3315)

Właściwość AllowZeroLength dla tego pola ma wartość False, zabraniając wprowadzenia do pola ciągu znaków o zerowej długości. Wpisz inną wartość w to pole.


Pole <nazwa> nie może zawierać wartości Null, ponieważ właściwość Required tego pola została ustawiona na True. Wprowadź

Pole <nazwa> nie może zawierać wartości Null, ponieważ właściwość Required tego pola została ustawiona na True. Wprowadź wartość w to pole. (Błąd 3314)

Właściwość Required dla tego pola posiada wartość True, zabraniając nadania polu wartości Null. Wpisz w pole wartość inną niż Null.


<Tekst komunikatu reguły poprawności na poziomie tabeli>. (Błąd 3316)

Reguła poprawności na poziomie tabeli została naruszona.


Reguła poprawności <reguła> ustalona dla pola <nazwa> wprowadza ograniczenia na niektóre wartości. Wprowadź wartość akceptowaną

Reguła poprawności <reguła> ustalona dla pola <nazwa> wprowadza ograniczenia na niektóre wartości. Wprowadź wartość akceptowaną przez wyrażenie określone dla tego pola. (Błąd 3317)

Właściwość ValidationRule tego pola zawiera wyrażenie ograniczające wartości, które można wpisać w to pole. Musisz wpisać wartość, która nie jest zabroniona przez wyrażenie.


Naruszenie TLV. (Błąd 3716)

Ten rekord zawiera pole, którego wartość nie spełnia wymagań ograniczeń na poziomie tabeli. Zaktualizuj pole naruszające regułę poprawności i prześlij ponownie rekord powodujący konflikt, lub usuń ten rekord.


Zbyt wielu aktywnych użytkowników. (Błąd 3239)

W środowisku wielodostępnym bazy danych aparatu Microsoft Jet pozwalają na jednoczesną pracę do 255 użytkowników. Trzeba poczekać, aż jeden lub więcej użytkowników przestanie korzystać z systemu i ponowić operację.


Nie można zainicjować Synchronizatora z powodu zbyt wielu uruchomionych aplikacji. (Błąd 3538)

Brak jest zasobów systemowych wystarczających do uruchomienia Synchronizatora i jednoczesnej obsługi wszystkich aktywnych aplikacji. W tej sytuacji należy zamknąć jedną lub więcej aplikacji, a następnie spróbować ponownie uruchomić Synchronizator.


Zbyt wiele zdefiniowanych pól. (Błąd 3190)

Usiłowano wykonać operację angażującą więcej niż 255 pól. Należy zmniejszyć liczbę pól, a następnie powtórzyć operację.


Zbyt wiele wywołanych sesji szybkiego wyszukiwania (FastFind). (Błąd 3408)

Metoda DAO FIND może być wykonana jeden raz dla tabeli lub zestawu rekordów.


Nie można utworzyć indeksu; zbyt wiele już zdefiniowanych indeksów. (Błąd 3039)

Nie można utworzyć jeszcze jednego indeksu dla tej tabeli. Aby zrobić miejsce na nowy indeks, należy usunąć istniejący indeks. Limitem są 32 indeksy na tabelę.


Operacja nieudana. Zbyt dużo indeksów dla tabeli <nazwa>. Usuń niektóre indeksy tabeli i spróbuj wykonać operację ponownie.

Operacja nieudana. Zbyt dużo indeksów dla tabeli <nazwa>. Usuń niektóre indeksy tabeli i spróbuj wykonać operację ponownie. (Błąd 3626)

Tabela w bazie danych aparatu Microsoft Jet nie może mieć więcej niż 32 indeksy. Nie można utworzyć dodatkowych indeksów dla tabeli o tak dużej liczbie indeksów. Ponadto, nie można przeprowadzić kompaktowania bazy danych zawierającej tabelę o tak dużej liczbie indeksów, ponieważ operacja kompaktowania bazy danych wiąże się z tworzeniem pewnej liczby nowych indeksów.

Usuń jeden lub więcej indeksów tabeli o podanej nazwie i spróbuj wykonać operację ponownie.


Indeks nie może zawierać więcej niż 10 pól. (Błąd 3277)

Zdefiniowano indeks zawierający więcej niż dziesięć pól. Należy zmniejszyć liczbę pól do dziesięciu lub mniej.


Zbyt wiele pól typu Memo, OLE, lub obiekt Hyperlink. (Błąd 3054)

Nastąpiła próba wykonania operacji Btrieve, która używa zbyt wielu pól typu Memo lub typu obiekt OLE. Zmniejsz liczbę pól typu Memo i typu obiekt OLE i powtórz operację.


Nie można otworzyć więcej baz danych. (Błąd 3048)

Limit baz danych, które mogą być otwarte jednocześnie został wyczerpany. Zamknij jedną lub więcej baz danych i powtórz operację.


Nie można znaleźć więcej plików. (Błąd 3025)

Limit otwartych jednocześnie plików został wyczerpany. Zamknij jeden lub więcej plików, a następnie powtórz operację.


Nie można otworzyć więcej tabel. (Błąd 3014)

Limit tabel, które mogą być jednocześnie otwarte, został wyczerpany. Zamknij jedną lub więcej tabel i powtórz operację.


Nie można rozpocząć sesji. Zbyt wiele sesji jest już aktywnych. (Błąd 3198)

Usiłowano wykonać operację, która rozpoczęłaby nową sesję, lecz zbyt wiele sesji jest już aktywnych. Należy poczekać, dopóki jedna lub więcej sesji nie zakończy się, a następnie powtórzyć operację.


Błąd podczas ładowania DLL. (Błąd 3462)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator już jest aktywny. (Błąd 3544)

W danym momencie może być aktywna tylko jedna kopia Synchronizatora. Zamiast uruchamiać nową kopię Synchronizatora, należy skorzystać z już pracującej.


Synchronizator nie mógł usunąć pliku. (Błąd 3568)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie może otworzyć dziennika Synchronizatora. (Błąd 3506)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie znalazł zdarzenia systemowego, które mógłby przesłać do klienta. (Błąd 3534)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Synchronizator nie może zostać zainicjowany. (Błąd 3532)

Nie można uruchomić Synchronizatora. Należy wówczas zamknąć system i uruchomić ponownie komputer. Jeżeli błąd występuje nadal, trzeba ponownie skonfigurować Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. Z menu Narzędzia (Tools) wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.


Synchronizator nie jest zainstalowany. (Błąd 3543)

Na komputerze nie został zainstalowany Synchronizator.

Aby skonfigurować Synchronizator

  1. Uruchom program Menedżer replikacji.
  2. Z menu Narzędzia (Tools) wybierz polecenie konfiguracji Menedżera replikacji.
  3. Postępuj według instrukcji kreatora.

Jeżeli używana aplikacja pochodzi z innej firmy niż Microsoft, należy zwrócić się do tej firmy o dostarczenie dyskietki instalacyjnej Synchronizatora.


Synchronizator już obsługuje jednego klienta. (Błąd 3530)

Użytkownik próbował uruchomić drugiego klienta Synchronizatora, który może obsługiwać tylko jednego klienta naraz. W tej sytuacji należy zidentyfikować aplikację, która korzysta z Synchronizatora, i zamknąć ją.


Synchronizator nie mógł zostać poprawnie zamknięty i jest wciąż aktywny. (Błąd 3541)

Programowe żądanie zakończenia pracy Synchronizatora nie zostało poprawnie zrealizowane i Synchronizator nadal pracuje w tle.

Aby zakończyć pracę Synchronizatora

  1. Naciśnij klawisze CTRL+ALT+DELETE, aby wywołać okno dialogowe Zamknij program.
  2. Kliknij opcję Synchronizator.
  3. Kliknij przycisk Zakończ zadanie.


Błąd podczas wysyłania komunikatu. (Błąd 3519)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Nie można rozpocząć transakcji; zbyt wiele zagnieżdżonych transakcji. (Błąd 3003)

Nastąpiła próba zagnieżdżenia transakcji powyżej piątego poziomu zagłębienia. Zastosuj metodę CommitTrans lub Rollback, aby zapisać lub wycofać się z bieżącej transakcji przed rozpoczęciem następnej.


Nieodpowiedni typ danych w wyrażeniu kryterium. (Błąd 3464)

Wyrażenie kryterium w metodzie Find próbuje porównać pole z wartością, której typ danych nie odpowiada typowi danych pola.


Nie można ustawić planu dla Synchronizatora. (Błąd 3497)

Wystąpił wewnętrzny problem podczas ustawiania planu. Należy ponowić próbę.


Nie można sprząc więcej niż jednej tabeli o takiej samej nazwie <nazwa>. (Błąd 3081)

Nastąpiła próba sprzężenia dwóch lub więcej tabel o takiej samej nazwie. Wybierz różne tabele, zmień nazwę jednej z tabel lub zastosuj alias i powtórz operację. Jeśli jest to próba sprzężenia tabeli z sobą samą, zastosuj alias tabeli, aby zmienić drugie odesłanie do tej samej tabeli.


Nieoczekiwany błąd <numer błędu> w sterowniku zewnętrznej bazy danych. (Błąd 3275)

Sterownik zewnętrznej bazy danych zwrócił błąd. Błąd mógł zostać spowodowany przez wykonanie operacji niedopuszczalnych dla tego typu zewnętrznej bazy danych.


Naruszenie klucza unikatowego. (Błąd 3715)

Ten rekord posiada taką samą wartość klucza jak inny rekord, podczas gdy wartości unikatowe są jedynymi dozwolonymi. Zmień wartość klucza w rekordzie powodującym konflikt, lub kluczu wygrywającym konflikt i prześlij rekord ponownie, bądź go usuń.


Nieznana nazwa. (Błąd 2424)

Wprowadzone wyrażenie zawiera nazwę pola lub właściwości, która nie została rozpoznana. Upewnij się, że obiekt istnieje lub sprawdź, czy wyrażenie zostało wprowadzone poprawnie.


Wyrażenie filtru częściowego zawiera nieznaną funkcję. (Błąd 3589)

Sprawdź, czy zastosowana funkcja ma właściwą nazwę. Warto przy tym pamiętać, że nie wszystkie funkcje są dozwolone w wyrażeniach filtru.


We właściwości ReplicaFilter wystąpiło niepoprawne wyrażenie. (Błąd 3587)

Ciąg ReplicaFilter zawiera niedopuszczalne słowo. Sprawdź składnię ciągu pod kątem błędów literowych i pominiętych słów.


Nieznana nazwa funkcji. (Błąd 2425)

Wprowadzone wyrażenie zawiera nazwę funkcji, która nie została rozpoznana. Upewnij się, że funkcja istnieje lub sprawdź, czy wyrażenie zostało wprowadzone poprawnie.


Błąd składniowy. (Błąd 2433)

Sformułowanie lub interpunkcja polecenia jest niepoprawna. Możliwe, że brakuje operatora lub określono operator, który nie istnieje.


Nazwy pól z pierwszego wiersza importowanej tabeli nie mogą zostać rozdzielone. (Błąd 3245)

Pierwszy wiersz danych zawiera niewłaściwe nazwy pól. Na przykład, w nazwie pola występują jednocześnie ciągi znaków z cudzysłowem i bez cudzysłowu. W poniższym przykładzie pola trzecie i czwarte nie mogą być rozpoznane.

"Nazwa", Data, "ID " Numer, "Numer "telefonu

Pierwsze dwa pola są prawidłowe, ale trzecie i czwarte są błędne, gdyż zawierają znaki nie będące spacjami na zewnątrz pary znaków cudzysłowu.

W tej sytuacji należy zweryfikować importowaną tabelę pod kątem właściwego położenia znaków cudzysłowu i ponowić próbę importu.


Konflikt uaktualnienie/uaktualnienie. Inna replika także uaktualniła dany rekord. Ten rekord przegrał w konflikcie. Ponów próbę

Konflikt uaktualnienie/uaktualnienie. Inna replika także uaktualniła dany rekord. Ten rekord przegrał w konflikcie. Ponów próbę uaktualnienia lub usuń rekord powodujący konflikt. (Błąd 3713)

Ten rekord zawiera wartość pola, która przegrała w konflikcie z inną repliką. Ponów próbę uaktualnienia lub usuń rekord powodujący konflikt.


Konflikt uaktualnienie/usunięcie. Uaktualniony rekord został usunięty w innej replice. Dodaj ponownie rekord powodujący

Konflikt uaktualnienie/usunięcie. Uaktualniony rekord został usunięty w innej replice. Dodaj ponownie rekord powodujący konflikt lub usuń go. (Błąd 3736)

Kiedy rekord jest usunięty w jednej replice, ale uaktualniony w innej, usunięty rekord zawsze wygrywa w konflikcie podczas synchronizacji. Uaktualniony rekord jest rejestrowany w tabeli konfliktów. Aby odwrócić domyślne rozwiązanie problemu, dodaj ponownie rekord powodujący konflikt. Aby zatwierdzić domyślne rozwiązanie problemu, usuń rekord powodujący konflikt.


Aktualizacja danych w połączonych tabelach nie jest obsługiwana przez tę wersję ISAM. (Błąd 3616)

Używany instalowalny sterownik ISAM nie pozwala na aktualizowanie rekordów w tabelach zewnętrznych. Można tylko dodawać nowe rekordy.


Konflikt uaktualnienie/integralność referencyjna. (Błąd 3718)

Rekord zawierający klucz podstawowy został uaktualniony przez inną replikę, więc odwołujący się do niego rekord został odrzucony. Utwórz nowy rekord zawierający klucz podstawowy spełniający wymagania ograniczeń integralności referencyjnej i prześlij ponownie uaktualnienie, zmodyfikuj wartość klucza obcego w tym rekordzie aby odpowiadał poprawnej wartości klucza podstawowego i prześlij ponownie uaktualnienie, lub usuń rekord powodujący konflikt.


Dostępne tylko w wersji 1.0. (Błąd 3334)

Usiłowano skorzystać z własności, która nie jest obsługiwana przez bieżącą wersję aplikacji.


Aparat bazy danych Microsoft Jet nie może znaleźć rekordu w tabeli <nazwa> o kluczu pasującym do pola (pól) <nazwa>. (Błąd

Aparat bazy danych Microsoft Jet nie może znaleźć rekordu w tabeli <nazwa> o kluczu pasującym do pola (pól) <nazwa>. (Błąd 3101)

Po stronie "wielu" w relacji jeden-do-wielu wprowadzono dane, dla których brak odpowiadającego rekordu po stronie "jeden". Na przykład, błąd ten pojawia się, gdy tabele Klienci i Zamówienia zostaną sprzężone za pomocą pola KodKlienta, po czym nastąpi dodanie zamówienia z wartością pola KodKlienta nie odpowiadającą żadnemu rekordowi w tabeli Klienci.


WIDOK nie może zawierać parametru. (Błąd 3730)

Ten błąd występuje podczas próby utworzenia widoku przy użyciu DDL języka SQL. Jeśli część SELECT instrukcji widoku CREATE zawiera jakiekolwiek parametry, zwrócony zostanie niniejszy błąd. Aby obejść problem, należy użyć instrukcji CREATE PROCEDURE zamiast powyższej.


Próba zmiany wartości kolumny w replice częściowej naruszyła zasadę obowiązującą w replikach częściowych. (Błąd 3571)

W replice częściowej nie można zmienić klucza podstawowego tabeli, chyba że nie ma nigdzie odwołań do tej tabeli.


Narusza reguły dla replik częściowych. (Błąd 3590)

Nie można uaktualnić kolumny w tabeli repliki częściowej, kiedy inna tabela odwołuje się do tej kolumny. Najprawdopodobniej jest to przypadek, gdzie informacja dotycząca tabeli nie istnieje w replice częściowej. Upewnij się, że uwzględniasz wszystkie związki do powiązanych tabel podczas definiowania filtrów częściowych.


Nie można usunąć właściwości wbudowanej. (Błąd 3384)

Próbowano usunąć obiekt Property zdefiniowany przez aparat baz danych Microsoft Jet.

Można usuwać tylko właściwości zdefiniowane przez użytkownika (łącznie ze zdefiniowanymi przez aplikację), na modyfikację których użytkownik posiada zezwolenie albo właściwości, dla których takie zezwolenie nie jest potrzebne.


Nie można dołączyć obiektu Field będącego już elementem kolekcji Fields. (Błąd 3266)

Obiekt Field został określony jako argument operacji Append, podczas gdy należy on już do istniejącej kolekcji Fields. Należy użyć instrukcji Dim oraz metody CreateField w celu zadeklarowania nowego obiektu typu Field oraz określenia jego właściwości, a następnie powtórzyć operację z nowym obiektem typu Field.


Nieprawidłowa wartość właściwości. (Błąd 3271)

Prawdopodobne przyczyny:

  • Ustawienie właściwości Value obiektu typu Parameter jest zbyt długie lub też z innego powodu nieprawidłowe.
  • Nazwa obiektu Index jest ciągiem znaków o zerowej długości (" "). Podczas dołączania obiektu do kolekcji typu Indexes należy wprowadzić nazwę obiektu typu Index.
  • Nazwa obiektu typu Workspace jest ciągiem znaków o długości zerowej. Podczas dołączania obiektu do kolekcji typu Workspaces należy wprowadzić nazwę obiektu typu Workspace.


Nie można dołączyć obiektu Index będącego już elementem kolekcji Indexes. (Błąd 3269)

Obiekt Index został określony jako argument operacji Append, podczas gdy należy on już do istniejącej kolekcji Indexes. Należy użyć instrukcji Dim oraz metody CreateIndex w celu zadeklarowania nowego obiektu typu Index oraz określenia jego właściwości, a następnie powtórzyć operację z nowym obiektem typu Index.


Wartość właściwości nie jest poprawna dla obiektów REMOTE. (Błąd 3365)

Ta właściwość nie jest dostępna dla obiektów skojarzonych z bazami danych ODBC.


Przed zastosowaniem tej metody właściwość <nazwa> musi być ustawiona. (Błąd 3386)

Próbowano dołączyć do kolekcji nowy obiekt Property bez ustawienia wszystkich jego nowych właściwości: Value, Type i Name.


Pole nie jest zdefiniowane i nie można dołączyć obiektu TableDef lub Index. (Błąd 3264)

Dołączenie obiektu TableDef nie jest możliwe, dopóki nie zdefiniowano jednego lub więcej pól. Do utworzenia pól należy użyć metody CreateField, dołączyć je do kolekcji Fields obiektu TableDef, a następnie dołączyć obiekt TableDef do kolekcji TableDefs.


Nie można dołączyć relacji, dla której nie zdefiniowano pól. (Błąd 3366)

Próbowano dołączyć obiekt Relation do kolekcji Relations, ale obiekt Relation nie ma żadnych pól.

Aby prawidłowo dołączyć obiekt Relation

  1. Zastosuj metodę CreateRelation do utworzenia obiektu Relation.

    Ustaw właściwości Table, ForeignTable i Attributes obiektu Relation, jeżeli nie zostały one określone jako argumenty metody CreateRelation.

    Użyj metody CreateField, aby utworzyć nowy obiekt Field dla każdego pola w kluczach podstawowym i obcym dołączanej relacji.

  2. Ustaw właściwości Name (jeżeli nie została określona wcześniej jako argument metody CreateField) i ForeignName obiektu lub obiektów Field zgodnie z odpowiadającymi ustawieniami właściwości Name obiektów Field klucza podstawowego i klucza obcego każdego pola w związku.
  3. Zastosuj metodę Append do dołączenia obiektu lub obiektów Field do kolekcji Fields obiektu Relation.
  4. Zastosuj metodę Append do dołączenia obiektu Relation do kolekcji Relations bazy danych.


Nie można ustawić właściwości obiektu będącego już elementem kolekcji. (Błąd 3268)

Usiłowano zmienić wartość właściwości obiektu (typu TableDef, Field itd.), który został już dołączony do kolekcji.


Do tego obiektu nie można zastosować tej metody. (Błąd 3273)

Nastąpiła próba użycia metody dla obiektu nie odsługującego tej metody. Listę dopuszczalnych metod dla obiektu można znaleźć w haśle Podsumowanie w opisie tego obiektu.


Właściwość można ustawić wyłącznie wtedy, gdy obiekt Field stanowi część kolekcji Fields obiektu Recordset. (Błąd 3267)

Ta właściwość jest dopuszczalna wyłącznie dla obiektów typu Field będących częścią kolekcji Fields obiektu Recordset. Listę właściwości dostępnych dla różnych kolekcji typu Fields można znaleźć pod hasłem Podsumowanie informacji.


Obiekt nie jest kolekcją. (Błąd 3272)

Nastąpiło odwołanie do obiektu jakby był on kolekcją. Na przykład, taki błąd może być spowodowany instrukcją qrySprzedaż.Refresh lub qrySprzedaż(2).


Nie można dołączyć obiektu. Obiekt o tej nazwie już istnieje w kolekcji. (Błąd 3367)

Próbowano dołączyć obiekt do kolekcji, która zawiera już obiekt o takiej samej nazwie. Użyj metody Refresh do sprawdzenia, czy obiekt, który ma być dołączony, już istnieje w kolekcji lub spróbuj zmienić wartość właściwości Name obiektu.


Nie odnaleziono właściwości. (Błąd 3270)

Podana właściwość nie została znaleziona.

Prawdopodobne przyczyny:

  • Właściwość nie istnieje. Należy sprawdzić w kodzie poprawność pisowni nazwy właściwości.
  • Jeśli właściwość jest zdefiniowana przez użytkownika, to mogła zostać usunięta z kolekcji.


Właściwości zdefiniowane przez użytkownika nie akceptują wartości Null. (Błąd 3385)

Zdefiniowane przez użytkownika obiekty Property nie mogą przyjąć wartości Null. Można natomiast za pomocą metody Delete usunąć właściwość z jej kolekcją.


Błąd konwersji typu danych. (Błąd 3421)

Aparat bazy danych Microsoft Jet nie zdołał dokonać konwersji danych do typu wymaganego przez metodę lub właściwość. Problem ten pojawia się zwykle wtedy, gdy użytkownik stosuje argument innego typu niż oczekiwany przez metodę lub właściwość.


Brakuje pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych). Spróbuj ponownie

Brakuje pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych). Spróbuj ponownie zainstalować aplikację, która zwróciła błąd. (Błąd 3446)

Nie można znaleźć pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych). Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.


Obiekt jest nieprawidłowy lub nie ma już wartości. (Błąd 3420)

Próbowano zrealizować odwołanie do obiektu, który nie jest już poprawny lub nie ma wartości.

Prawdopodobne przyczyny:

  • Obiekt został zamknięty.
  • Obiekt został osierocony (obiekt macierzysty został zamknięty lub usunięty).
  • Obiekt znajduje się poza zasięgiem.
  • Biblioteka obiektów nie jest odnotowana w Rejestrze Microsoft® Windows®.
  • Nastąpiła próba wskazania metody lub właściwości kolekcji, ale nie została ona najpierw przypisana do zmiennej. Na przykład odwołanie do właściwości Name należy zrealizować w następujący sposób:

    Dim dbsPublikacje As Database

    Set dbsPublikacje = OpenDatabase("BIBLIO.mdb")

    dbname = dbsPublikacje.Name


Nieudane wywołanie funkcji systemowej OLE. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd. (Błąd 3448)

Nieudane wywołanie funkcji automatyzacji OLE. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.


Nieudana próba zainicjowania pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych) przy

Nieudana próba zainicjowania pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych) przy próbie użycia go. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd. (Błąd 3447)

Podczas próby użycia pliku Jet VBA (VBAJET.dll dla wersji 16-bitowych lub VBAJET32.dll dla wersji 32-bitowych) nie udało się zainicjować tego pliku. Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.


Znaleziono niepoprawną wersję pliku DLL <nazwa>. (Błąd 3445)

Dla bazy danych Microsoft Jet zainstalowana musi być biblioteka DLL Jet (msajt200.dll dla wersji 16-bitowych lub msjt2032 dla wersji 32-bitowych) w wersji 2.5 lub nowszej.

Dla baz danych ODBCDirect, zainstalowana biblioteka DLL Remote Data Objects (RDO) (msrdo32.dll) musi być w wersji 1.0 lub późniejszej.

Spróbuj ponownie zainstalować aplikację, która zwróciła błąd.


W specyfikacji <nazwa> ustalonej szerokości kolumna <kolumna> nie określa szerokości. (Błąd 3444)

W specyfikacji pliku tekstowego instalowalnego sterownika ISAM brak parametru określającego szerokość kolumny. Specyfikację można ustawiać różnymi sposobami:

  • Z programu Microsoft Access wartości te są ustawiane w kreatorze połączonego tekstu (można z niego skorzystać wybierając z menu Plik opcję Pobierz dane zewnętrzne, a następnie polecenie Połącz tabele). Wartości można także zobaczyć w tabelach systemowych MSysIMEXSpecs i MSysIMEXColumns.
  • Z innych aplikacji hosta Microsoft Jet wartości te są zapisywane w pliku Schema.ini.


Nie można dokonać aktualizacji; strona aktualnie zablokowana przez użytkownika <nazwa> na komputerze <nazwa>. (Błąd 3260)

Nastąpiła próba aktualizacji danych znajdujących się na obecnie zablokowanej stronie.

Prawdopodobne przyczyny:

  • Usiłowano zapisać kwerendę używaną przez innego użytkownika. Aby zapisać kwerendę, trzeba poczekać, aż zostanie ona zwolniona przez innego użytkownika.
  • Można też zapisać ją pod inną nazwą. Próbowano zastosować metodę Edit na stronie danych zawierającej otwarty lub zablokowany rekord.


Klient Synchronizatora nie jest już obecny i nie może zostać powiadomiony. (Błąd 3537)

Ten błąd jest nieoczekiwany. Aby uzyskać dodatkowe informacje, należy skontaktować się z biurem pomocy technicznej Microsoft.


Niewłaściwa liczba argumentów funkcji. (Błąd 2439)

Wprowadzono wyrażenie ze złą ilością argumentówfunkcji. Sprawdź, ile argumentów powinna mieć ta funkcja, lub upewnij się, że wyrażenie zostało wprowadzone poprawnie.


Niewłaściwa kolejność sortowania. (Błąd 3220)

Nastąpiła próba połączenia tabeli Paradox utworzonej z międzynarodową kolejnością sortowania, która nie jest obecnie używana.


Format pliku memo nie jest zgodny z podanym formatem zewnętrznej bazy danych. (Błąd 3286)

Aplikacja nie może odczytać pliku memo skojarzonego z bazą danych, którą próbujesz importować lub łączyć i w związku z tym nie może importować lub połączyć pliku. Plik memo może mieć nieprawidłowy format; na przykład wybrano system dBASE IV jako źródło danych, a plik memo jest w formacie FoxPro®.


Nieprawidłowe użycie nawiasów. (Błąd 2442)

Wprowadzone wyrażenie zawiera niepoprawnie użyte nawiasy. Na przykład, nastąpiła próba użycia składni z nawiasami dla identyfikatora w kwerendzie. W kwerendzie można używać tylko identyfikatory standardowej składni.


ADD USER - instrukcja (Microsoft Jet SQL)

ADD USER - instrukcja

Dodaje jednego lub więcej istniejących użytkowników do istniejącej grupy.

Składnia

ADD USER użytkownik[, użytkownik, …] TO grupa

Składnia instrukcji ADD USER zawiera następujące elementy:

Element | Opis
użytkownik | Nazwa użytkownika, która ma być dodana do pliku informacyjnego grupy roboczej.
grupa | Nazwa grupy, która ma być dodana do pliku informacyjnego grupy roboczej.

Uwagi

Po dodaniu użytkownika do grupy, użytkownik otrzymuje wszystkie uprawnienia udzielone grupie.

Zobacz też
ALTER USER lub DATABASE - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP - instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | GRANT - instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja


ALL, DISTINCT, DISTINCTROW, TOP - predykaty (Microsoft Jet SQL)

ALL, DISTINCT, DISTINCTROW, TOP - predykaty

Określają rekordy wybrane z kwerend SQL.

Składnia

SELECT [ALL | DISTINCT | DISTINCTROW | [TOP n [PERCENT]]]
FROM tabela

Składnia instrukcji SELECT z tymi predykatami zawiera następujące elementy:

Element | Opis
ALL Przyjmowane jest, że nie stosuje się żadnych predykatów. Aparat bazy danych Microsoft Jet wybiera wszystkie rekordy spełniające warunki instrukcji SQL. Obie podane niżej instrukcje są równoważne: zwracają wszystkie rekordy tabeli Pracownicy:

SELECT ALL *
FROM Pracownicy
ORDER BY NrPracownika;

SELECT *
FROM Pracownicy
ORDER BY NrPracownika;
DISTINCT Pomijane są te rekordy, które zawierają powtarzające się wartości we wszystkich wybieranych polach. Aby pojawić się w wyniku kwerendy, wartości każdego z pól wymienionych w instrukcji SELECT muszą być niepowtarzalne. Na przykład wielu pracowników wymienionych w tabeli Pracownicy może mieć to samo nazwisko. Jeśli dwa rekordy zawierają w polu Nazwisko wartość Kowalski, wówczas zwrócony będzie tylko jeden z nich:

SELECT DISTINCT
Nazwisko
FROM Pracownicy;

Jeśli predykat DISTINCT nie wystąpi, kwerenda zwróci wszystkie rekordy z nazwiskiem Kowalski.

Jeśli klauzula SELECT obejmuje kilka pól, wówczas jedynie nie powtarzające się kombinacje wartości wszystkich tych pól zostaną uwzględnione w wyniku.

Wyniku kwerendy opartej na DISTINCT nie można aktualizować i nie odzwierciedla on następujących zmian dokonanych przez innych użytkowników.
DISTINCTROW Pomija powtarzające się dane na podstawie wartości całych rekordów, a nie jedynie wybranych pól. Załóżmy na przykład, że tworzymy kwerendę, która sprzęga tabele Klienci i Zamówienia według wartości pola KodKlienta. Tabela Klienci nie zawiera powtarzających się wartości w polu KodKlienta, w przeciwieństwie do tabeli Zamówienia, gdzie może znajdować się wiele zamówień od jednego klienta. Poniższa instrukcja SQL wykorzystuje predykat DISTINCTROW do uzyskania wykazu tych firm, które złożyły choć jedno zamówienie, ale bez ujawniania szczegółów tych zamówień:

SELECT DISTINCTROW NazwaFirmy
FROM Klienci INNER JOIN Zamówienia
ON Klienci.KodKlienta = Zamówienia.KodKlienta
ORDER BY NazwaFirmy;

Bez predykatu DISTINCTROW ta kwerenda da w wyniku powtarzające się rekordy dla tych firm, które złożyły wiele zamówień.

Predykat DISTINCTROW działa tylko w takich kwerendach, które wybierają dane z niektórych (nie wszystkich) tabel wykorzystanych w tej kwerendzie. Predykat DISTINCTROW jest ignorowany, jeśli kwerenda dotyczy tylko jednej tabeli lub jeśli wybierane są pola ze wszystkich tabel.
TOP n [PERCENT] Zwraca tylko te rekordy, które mieszczą się (od góry lub od dołu) w podanym zakresie rekordów uporządkowanych klauzulą ORDER BY. Załóżmy, że interesują nas dane o 25 najlepszych studentach, którzy ukończyli studia w 1994 roku:

SELECT TOP 25
Imię, Nazwisko
FROM Studenci
WHERE RokUkończenia = 1994
ORDER BY ŚredniaOcenKońcowych DESC;

Bez klauzuli ORDER BY ta kwerenda zwróci zestaw 25 przypadkowych rekordów z tabeli Studenci spełniających warunek podany w klauzuli WHERE.

Predykat TOP nie wybiera pomiędzy równymi wartościami. Jeśli na przykład student dwudziesty piąty i dwudziesty szósty na liście mają tę samą średnią, kwerenda zwróci 26 rekordów.

Słowo zastrzeżone PERCENT wskazuje, że zwrócona ma być określona część rekordów (od góry lub od dołu) z listy utworzonej klauzulą ORDER BY, a nie ich konkretna liczba. Załóżmy, że interesują nas dane nie o 25 najlepszych studentach, ale o grupie 10 procent najsłabszych studentów:

SELECT TOP 10 PERCENT
Imię, Nazwisko
FROM Studenci
WHERE RokUkończenia = 1994
ORDER BY ŚredniaOcenKońcowych ASC;

Dzięki użyciu słowa zastrzeżonego ASC wybierane są rekordy z dołu, a nie z góry zakresu. Wartość podana po słowie TOP musi być liczbą typu Integer bez znaku.

TOP nie ma wpływu na to, czy kwerenda może być aktualizowana czy nie.
tabela | Nazwa tabeli, z której pobierane są rekordy.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) SELECT – instrukcja (Microsoft Jet SQL)

Przykład

ALL, DISTINCT, DISTINCTROW, TOP – przykład predykatu


ALL, DISTINCT, DISTINCTROW, TOP - przykład predykatów i (DAO)

ALL, DISTINCT, DISTINCTROW, TOP – przykład predykatów

W tym przykładzie tworzona jest kwerenda sprzęgająca tabele Klienci i Zamówienia według pola KodKlienta. Tabela Klienci nie zawiera powtarzających się wartości w polu KodKlienta, w przeciwieństwie do tabeli Zamówienia, gdzie może znajdować się wiele zamówień od jednego klienta. Użycie słowa kluczowego DISTINCTROW powoduje utworzenie listy firm, które złożyły co najmniej jedno zamówienie. Lista nie zawiera szczegółów dotyczących tych zamówień.

Sub AllDistinctX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dokonaj sprzężenia tabel Klienci i Zamówienia

    ' składający się z pola KodKlienta. Wybierz listę firm

    ' posiadających co najmniej jedno zamówienie.

    Set rst = dbs.OpenRecordset("SELECT DISTINCTROW " _

        & "NazwaFirmy FROM Klienci " _

        & "INNER JOIN Zamówienia " _

        & "ON Klienci.KodKlienta = " _

        & "Zamówienia.KodKlienta " _

        & "ORDER BY NazwaFirmy;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub


ALTER TABLE - instrukcja (Microsoft Jet SQL)

ALTER TABLE - instrukcja

Modyfikuje tabelę uprzednio utworzoną za pomocą instrukcji CREATE TABLE.

Uwaga Aparat baz danych Microsoft Jet nie obsługuje instrukcji ALTER TABLE, ani żadnej z instrukcji języka definicji danych (DDL), używanych w odniesieniu do baz danych nie używających aparatu Microsoft Jet. W przypadku takich baz należy użyć metody DAO Create..

Składnia

ALTER TABLE tabela {ADD {COLUMN typ[(rozmiar)] [NOT NULL] [CONSTRAINT indeks] |
ALTER COLUMN typ[(rozmiar)] |
CONSTRAINT indeks_wielopolowy} |
DROP {COLUMN pole I CONSTRAINT nazwa_indeksu} }

Składnia instrukcji ALTER TABLE zawiera następujące elementy:

Element | Opis
tabela | Nazwa tabeli mającej ulec zmianie.
pole | Nazwa pola, które ma zostać dodane lub usunięte z tabeli, lub nazwa pola które ma być zmienione w tabeli.
typ | Typ danych pola.
rozmiar | Rozmiar pola w znakach (tylko dla pól typu Text i Binary).
indeks | Indeks pola. Aby znaleźć więcej informacji na temat konstruowania tego indeksu zobacz temat CONSTRAINT – klauzula.
indeks wielopolowy | Definicja indeksu wielopolowego, który ma zostać dodany do tabeli. Aby znaleźć więcej informacji na temat konstruowania tego indeksu zobacz temat CONSTRAINT – klauzula.
nazwa indeksu | Nazwa indeksu wielopolowego, który ma zostać usunięty.

Uwagi

Za pomocą instrukcji ALTER TABLE można zmienić istniejącą tabelę na kilka sposobów: Na przykład:

  • Użyj instrukcji ADD COLUMN, aby dodać nowe pole do tabeli. Należy określić nazwę pola, typ danych oraz opcjonalnie rozmiar (dla pól tekstowych i binarnych). Na przykład, następująca instrukcja dodaje pole tekstowe o długości 25 znaków i nazwie Uwagi do tabeli Pracownicy:

    ALTER TABLE Pracownicy ADD COLUMN Uwagi TEXT(25)

    Dla tego pola można również zdefiniować indeks. Aby znaleźć więcej informacji na temat jednopolowych indeksów, zobacz temat CONSTRAINT - klauzula.

    Jeśli na pole nałożono ograniczenie NOT NULL, to nowe rekordy muszą zawierać w tym polu prawidłowe dane.

  • Użyj instrukcji ALTER COLUMN, aby zmienić typ danych istniejącego pola. Należy określić nazwę pola, nowy typ danych i opcjonalnie rozmiar (dla pól tekstowych i binarnych). Na przykład, następująca instrukcja zmienia typ danych pola o nazwie KodPocztowy (początkowo zdefiniowanego jako typ całkowity) w tabeli Pracownicy na typ tekstowy o długości 10 znaków:

    ALTER TABLE Pracownicy ALTER COLUMN KodPocztowy TEXT(10)

  • Klauzula ADD CONSTRAINT powoduje dodanie indeksu wielopolowego. Aby znaleźć więcej informacji na temat indeksów wielopolowych zobacz temat CONSTRAINT - klauzula.
  • Klauzula DROP COLUMN powoduje usunięcie pola. W tym celu należy określić jedynie nazwę pola.
  • Klauzula DROP CONSTRAINT powoduje usunięcie indeksu wielopolowego. W tym celu należy po słowie zastrzeżonym CONSTRAINT określić jedynie nazwę indeksu.

Uwagi

  • Nie można jednocześnie dodać lub usunąć więcej niż jednego pola lub indeksu.
  • W celu dodania do tabeli indeksu jedno- lub wielopolowego, należy użyć instrukcji CREATE INDEX, zaś w celu usunięcia indeksu utworzonego za pomocą instrukcji ALTER TABLE lub CREATE INDEX należy użyć instrukcji ALTER TABLE lub DROP.
  • Ograniczenie NOT NULL może być nałożone na pojedyncze pole lub też wystąpić w nazwanej klauzuli CONSTRAINT dotyczącej pojedynczego pola lub też wielu pól. Pomimo tego ograniczenie NOT NULL można zastosować tylko raz dla pola. Próba zastosowania tego ograniczenia więcej niż jeden raz powoduje wygenerowanie błędu czasu wykonania.
Zobacz też
ADD USER – instrukcja | CREATE USER lub GROUP – instrukcja
ALTER USER lub DATABASE – instrukcja | CREATE VIEW – instrukcja
CONSTRAINT – klauzula | DROP – instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP – instrukcja
CREATE PROCEDURE – instrukcja | GRANT – instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja

Przykład

ALTER TABLE – przykład instrukcji


ALTER USER lub DATABASE - instrukcja (Microsoft Jet SQL)

ALTER USER lub DATABASE - instrukcja

Zmienia hasło istniejącego użytkownika lub dla bazy danych.

Składnia

ALTER DATABASE PASSWORD nowe_hasło stare_hasło

ALTER USER użytkownik PASSWORD nowe_hasło stare_hasło

Składnia instrukcji ALTER USER lub DATABASE zawiera następujące elementy:

Element | Opis
użytkownik | Nazwa użytkownika, która ma być dodana do pliku informacyjnego grupy roboczej.
nowe_hasło | Nowe hasło skojarzone z określonym użytkownikiem lub nazwą bazy danych.
stare_hasło | Obecne hasło skojarzone z określonym użytkownikiem lub nazwą bazy danych.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP - instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | GRANT - instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja


ALTER TABLE - przykład instrukcji (DAO)

ALTER TABLE – przykład instrukcji

Poniższy przykład dodaje pole Zarobki typu Money do tabeli Pracownicy.

Sub AlterTableX1()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dodaj pole Zarobki typu Money do tabeli

    ' Pracownicy.

    dbs.Execute "ALTER TABLE Pracownicy " _

        & "ADD COLUMN Zarobki MONEY;"

    dbs.Close

End Sub

Poniższy przykład zmienia typ danych pola Zarobki z typu Money na typ danych Char.

Sub AlterTableX2()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dodaj pole Zarobki typu Money do tabeli

    ' Pracownicy.

    dbs.Execute "ALTER TABLE Pracownicy " _

        & "ALTER COLUMN Zarobki CHAR(20);"

    dbs.Close

End Sub

W tym przykładzie pole Wynagrodzenie jest usuwane z tabeli Pracownicy.

Sub AlterTableX3()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Usuń pole Wynagrodzenie z tabeli Pracownicy.

    dbs.Execute "ALTER TABLE Pracownicy " _

        & "DROP COLUMN Wynagrodzenie;"

    dbs.Close

End Sub

W tym przykładzie klucz obcy jest dodawany do tabeli Zamówienia. Klucz obcy bazuje na polu NrPracownika i wskazuje na pole NrPracownika tabeli Pracownicy. W tym przykładzie nie jest konieczne wymienianie pola NrPracownika w klauzuli REFERENCES po tabeli Pracownicy, gdyż pole NrPracownika jest kluczem podstawowym w tabeli Pracownicy.

Sub AlterTableX4()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dodaj klucz obcy do tabeli Zamówienia.

    dbs.Execute "ALTER TABLE Zamówienia " _

        & "ADD CONSTRAINT ZwiązekZamówień " _

        & "FOREIGN KEY (NrPracownika) " _

        & "REFERENCES Pracownicy (NrPracownika);"

    dbs.Close

End Sub

W tym przykładzie klucz obcy jest usuwany z tabeli Zamówienia.

Sub AlterTableX5()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Usuń klucz obcy ZwiązekZamówień

    ' z tabeli Zamówienia.

    dbs.Execute "ALTER TABLE Zamówienia " _

        & "DROP CONSTRAINT ZwiązekZamówień;"

    dbs.Close

End Sub


Avg - funkcja (Microsoft Jet SQL)

Avg - funkcja

Oblicza średnią arytmetyczną zbioru wartości zawartych w polu określonym przez kwerendę.

Składnia

Avg(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których średnią chcemy obliczyć, lub wyrażenie, które wykonuje obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Średnia obliczona za pomocą funkcji Avg jest średnią arytmetyczną (sumą wartości podzieloną przez ich liczbę). Funkcji Avg można użyć na przykład w celu obliczenia średniego kosztu frachtu.

Funkcja Avg nie uwzględnia pól o wartości Null podczas obliczeń.

Funkcji Avg można użyć w wyrażeniu kwerendy i we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Zobacz też
SQL - obliczanie pól w funkcjach Funkcje agregujące SQL (SQL)

Przykład

Avg – przykład funkcji


Avg - przykład funkcjii (DAO)

Avg – przykład funkcji

W tym przykładzie tabela Zamówienia jest wykorzystywana do obliczenia przeciętnego kosztu frachtu dla tych zamówień, dla których koszty te przekroczyły 100 dolarów.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub AvgX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Oblicz przeciętny koszt frachtu dla tych

    ' zamówień, dla których ten koszt przekroczył

' 100 dolarów.

Set rst = dbs.OpenRecordset("SELECT Avg(Fracht)" _

        & " AS [Przeciętny fracht]" _

        & " FROM Zamówienia WHERE Fracht > 100;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub


Between...And - operator (Microsoft Jet SQL)

Between...And - operator

Sprawdza, czy wartość wyrażenia wypada w określonym przedziale wartości. Można użyć tego operatora w instrukcjach języka SQL.

Składnia

wyrażenie [Not] Between wartość1 And wartość2

Składnia operatora Between...And zawiera następujące elementy:

Element | Opis
wyrażenie | Wyrażenie identyfikujące pole, które zawiera dane do sprawdzenia.
wartość_1, wartość_2 | Wyrażenia, do których porównywane jest obliczane wyrażenie.

Uwagi

Jeśli wartość wyrażenia mieści się w przedziale między wartość1 a wartość2 (włącznie), operator Between...And zwraca wartość True; w przeciwnym razie, zwraca wartość False. Można także użyć operatora logicznego Not, aby sprawdzić warunek przeciwny (czy wyrażenie leży poza zakresem wyznaczonym przez wartość1 i wartość2).

Operator Between...And można stosować do określania, czy wartość pola mieści się w podanym zakresie liczb. Poniższy przykład określa, czy zamówienie zostało wysłane do miejscowości o kodzie pocztowym z podanego zakresu. Jeśli kod pocztowy pochodzi z zakresu między 98101 a 98199, funkcja IIf zwraca "Lokalny". W przeciwnym razie zwracana jest wartość "Zamiejscowy".

SELECT IIf(KodPocztowy Between 98101 And 98199, "Lokalny", "Zamiejscowy")

FROM Wydawcy

Jeśli wyrażenie, wartość1 lub wartość2 ma wartość Null, operator Between...And zwraca wartość Null.

W związku z tym, że symbole wieloznaczne, np *, są traktowane jak literały, nie można ich używać z operatorem Between...And. Na przykład, nie można zapisać 980* i 989* w celu znalezienia wszystkich kodów pocztowych zaczynających się od 980 do 989. Zamiast tego, istnieją dwa inne sposoby wykonania takiej operacji. Można dodać do kwerendy wyrażenie, które z pola tekstowego wybiera trzy znaki od lewej strony i stosuje Between...And do tych znaków. Drugim sposobem jest rozszerzenie górnego i dolnego zakresu za pomocą dodatkowych znaków — w tym przypadku, od 98000 do 98999 lub 98000 do 98999 – 9999, jeżeli wykorzystywane są rozszerzone kody pocztowe. (Dla dolnego ograniczenia należy pominąć – 0000, gdyż w przeciwnym razie kod pocztowy 98000 będzie odrzucony, jeśli niektóre kody zawierają sekcje rozszerzone, a inne nie.)

Zobacz też
IN – klauzula (Microsoft Jet SQL) | Wyrażenia SQL
WHERE – klauzula (Microsoft Jet SQL) |

Przykład

Podkwerendy SQL - przykład


!SQL - obliczanie pól w funkcjach

Można użyć argumentu wyrażenia znakowego w funkcji agregującej SQL aby wykonać obliczenia na wartościach pola. Na przykład, można obliczać procenty różnych wielkości (na przykład podatki) przez pomnożenie wartości pola przez ułamek.

W poniższej tabeli podane są przykłady działań na polach z tabel Zamówienia i Opisy zamówień w bazie danych Northwind.mdb.

Działanie | Przykład
Dodanie liczby do pola | Fracht + 5
Odjęcie liczby od pola | Fracht – 5
Pomnożenie pola przez liczbę | CenaJednostkowa * 2
Podzielenie pola przez liczbę | Fracht / 2
Dodanie jednego pola do drugiego | StanMagazynu + IlośćZamówiona
Odjęcie jednego pola od drugiego | StanMinimum - StanMagazynu

Poniższy przykład oblicza średnią sumę rabatu wszystkich zamówień w bazie danych Northwind.mdb. Wartości pól CenaJednostkowa i Rabat są mnożone przez siebie aby otrzymać kwotę rabatu dla każdego zamówienia, a później obliczyć średnią. Poniższe wyrażenie może wystąpić w instrukcji SQL w kodzie napisanym w języku Visual Basic:

SELECT Avg(CenaJednostkowa * Rabat) AS [Średni rabat] FROM [Opisy zamówień];

Zobacz też
Funkcje agregujące SQL (SQL) Wyrażenia SQL


CONSTRAINT - klauzula (Microsoft Jet SQL)

CONSTRAINT - klauzula

Ograniczenie jest podobne do indeksu, chociaż może być również użyte do ustanowienia relacji z inną tabelą.

Można użyć klauzuli CONSTRAINT w instrukcjach ALTER TABLE i CREATE TABLE ,aby dodać lub usunąć ograniczenia. Istnieją dwa typy klauzul CONSTRAINT: służąca do narzucania ograniczeń na pojedyncze pole oraz służąca do narzucania ograniczeń na więcej niż jedno pole.

Uwaga Aparat bazy danych Microsoft Jet nie obsługuje klauzuli CONSTRAINT, ani też żadnej z instrukcji języka definicji danych (DDL) używanych w odniesieniu do baz danych nie używających aparatu Microsoft Jet. W przypadku takich baz należy użyć metody DAO Create.

Składnia

Ograniczenie dla pojedynczego pola:

CONSTRAINT nazwa {PRIMARY KEY | UNIQUE | NOT NULL |
REFERENCES tabela_obca [(pole_obce_1, pole_obce_2)]
[ON UPDATE CASCADE | SET NULL]
[ON DELETE CASCADE | SET NULL]}

Ograniczenie dla wielu pól:

CONSTRAINT nazwa
{PRIMARY KEY (podstawowe_1[, podstawowe_2 [, ...]]) |
UNIQUE (unikatowe_1[, unikatowe_2 [, ...]]) |
NOT NULL (niepuste_1[, niepuste_2 [, ...]]) |
FOREIGN KEY [NO INDEX] (odwołanie_1[, odwołanie_2 [, ...]]) REFERENCES tabela_obca [(pole_obce_1[, pole_obce_2 [, ...]])]}
[ON UPDATE CASCADE | SET NULL]
[ON DELETE CASCADE | SET NULL]}

Składnia klauzuli CONSTRAINT zawiera następujące elementy:

Element | Opis
nazwa | Nazwa tworzonego ograniczenia.
podstawowe_1, podstawowe_2 | Nazwa pola lub pól, które mają składać się na klucz podstawowy.
unikatowe_1, unikatowe_2 | Nazwa pola lub pól, które mają składać się na klucz unikatowy.
niepuste_1, niepuste_2 | Nazwa pola lub pól, których wartości muszą być różne od Null.
odesłanie_1, odesłanie_2 | Nazwa pola lub pól klucza obcego, czyli wskazujących na pola w innej tabeli.
tabela_obca | Nazwa tabeli obcej zawierającej pole lub pola określone przez argumenty pole_obce.
pole_obce_1, pole_obce_2 | Nazwa pola lub pól w tabeli_obcej określonych przez odwołanie_1, odwołanie_2. Możesz pominąć ową klauzulę, jeżeli pola lub pole, do którego nastąpiło odwołanie jest kluczem podstawowym tabeli_obcej.

Uwagi

Składnia ograniczenia dla pojedynczego pola w klauzuli definiującej pole w instrukcji ALTER TABLE lub CREATE TABLE, występuje zaraz po określeniu typu danych pola.

Składnia ograniczenia dla wielu pól jest używana wtedy, gdy słowo zastrzeżone CONSTRAINT występuje poza klauzulą definicji pola w instrukcji ALTER TABLE lub CREATE TABLE.

Za pomocą klauzuli CONSTRAINT można określić dla pola następujące typy ograniczenia:

  • Za pomocą słowa zastrzeżonego UNIQUE można określić pole jako klucz unikatowy. Oznacza to, że żadne dwa rekordy w tabeli nie mogą mieć w tym polu takiej samej wartości. Jako unikatowe można określić dowolne pole lub listę pól. Jeśli w jednym ograniczeniu wiele pól jest określonych jako klucz unikatowy, unikatowe muszą być wartości tych pól traktowane jako całość, natomiast w pojedynczych polach wartości mogą się powtarzać.
  • Za pomocą zastrzeżonego słowa PRIMARY KEY można określić pojedyncze pole lub zbiór pól w tabeli jako klucz podstawowy. Wszystkie wartości klucza podstawowego muszą być unikatowe i mieć wartości różne od Null, a tabela może zawierać tylko jeden klucz podstawowy.

    Uwaga Nie wolno ustawiać ograniczenia PRIMARY KEY dla tabeli, która już ma klucz podstawowy, gdyż spowoduje to wystąpienie błędu.

  • Za pomocą słów zastrzeżonych FOREIGN KEY można określić pola jako klucz obcy. Jeśli klucz podstawowy tabeli obcej składa się z więcej niż jednego pola, należy użyć definicji ograniczenia dla wielu pól, wymieniając wszystkie wskazujące pola, nazwę tabeli obcej oraz nazwy wskazywanych pól w tabeli obcej w tej samej kolejności, co pola wskazujące. Jeżeli pola lub pole do którego nastąpiło odwołanie jest kluczem podstawowym tabeli obcej, nie musisz określać pól do których następuje odwołanie. Domyślnie aparat bazy danych zachowuje się jakby klucz podstawowy tabeli obcej był polem, do którego następuje odwołanie.

    Ograniczenia klucza obcego definiują określone czynności, które są wykonywane gdy wartość odpowiedniego klucza podstawowego została zmieniona:

  • Możesz określić czynności wykonywane na tabeli obcej w oparciu o odpowiednią czynność wykonywaną na kluczu podstawowym tabeli, dla której klauzula CONSTRAINT jest zdefiniowana. Na przykład, rozważmy następującą definicję dla tabeli Klienci:

    CREATE TABLE Klienci (KlientId INTEGER PRIMARY KEY, CLstNm NCHAR VARYING (50))

    Rozważmy następującą definicję tabeli Zamówienia, która definiuje relację klucza obcego odwołując się do klucza podstawowego tabeli Klienci:

    CREATE TABLE Zamówienia (ZamId INTEGER PRIMARY KEY, KlientId INTEGER, ZamUwagi NCHAR VARYING (255), CONSTRAINT FKZamKlientId FOREIGN KEY (KlientId) REFERENCES Klienci ON UPDATE CASCADE ON DELETE CASCADE

    Obie klauzule ON UPDATE CASCADE i ON DELETE CASCADE są zdefiniowane jako klucze obce. Klauzula ON UPDATE CASCADE oznacza, że jeśli identyfikator klienta (KlientId) jest aktualizowany w tabeli Klienci, aktualizacja ta będzie również przekazana tabeli Zamówienia. Każde zamówienie zawierające odpowiednią wartość identyfikatora klienta będzie automatycznie aktualizowane. Klauzula ON DELETE CASCADE oznacza, że jeśli klient jest usuwany z tabeli Klienci, wszystkie wiersze w tabeli Zamówienia zawierające ten sam identyfikator klienta też będą usunięte.

    Rozważmy inną definicję tabeli Zamówienia, używając czynności SET NULL zamiast CASCADE:

    CREATE TABLE Zamówienia (ZamId INTEGER PRIMARY KEY, KlientId INTEGER, ZamUwagi NCHAR VARYING (255), CONSTRAINT FKZamKlientId FOREIGN KEY (KlientId) REFERENCES Klienci ON UPDATE SET NULL ON DELETE SET NULL

    Klauzula ON UPDATE SET NULL oznacza, że jeśli identyfikator klienta (KlientId) jest aktualizowany w tabeli Klienci, odpowiednie wartości klucza obcego w tabeli Zamówienia będą automatycznie ustawione na NULL. Podobnie, klauzula ON DELETE SET NULL oznacza, że jeśli klient jest usunięty z tabeli Klienci, wszystkie odpowiadające mu klucze obce w tabeli Zamówienia będą automatycznie ustawione na NULL.

Aby zapobiec automatycznemu tworzeniu się indeksów dla kluczy obcych, można użyć modyfikatora NO INDEX. Ta forma definicji klucza obcego powinna być użyta tylko w wypadku, gdy wartości indeksu wynikowego byłyby często duplikowane. W wypadku, gdy wartości w indeksie klucza obcego są często duplikowane, użycie indeksu może być mniej wydajne niż zwykłe przeglądanie tabeli. Obsługiwanie indeksu tego typu, z wierszami dodawanymi i usuwanymi z tabeli, obniża wydajność i nie przynosi żadnej korzyści.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE VIEW - instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | GRANT - instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja

Przykład

CREATE TABLE - instrukcja, CONSRAINT - klauzula - przykład


Count - funkcja (Microsoft Jet SQL)

Count - funkcja

Oblicza liczbę rekordów zwracanych przez kwerendę.

Składnia

Count(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których liczbę chcemy znaleźć, lub wyrażenie, które wykonuje obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL). Funkcja ta może zliczać dane dowolnego typu, w tym również tekstowego.

Uwagi

Funkcji Count można używać do obliczania liczby rekordów w wyniku kwerendy. Na przykład funkcji Count można użyć do obliczenia liczby zamówień przesłanych do danego kraju.

Pomimo, że wyrażenie może zawierać działania na wartościach znajdujących się w polu, funkcja Count po prostu oblicza liczbę rekordów. Nie ma znaczenia, jakie wartości przechowywane są w rekordach.

Funkcja Count nie uwzględnia rekordów, których pola zawierają wartość Null, za wyjątkiem sytuacji, gdy wyrażenie jest znakiem gwiazdki (*) - symbolem wieloznacznym. Jeżeli użyty zostanie znak gwiazdki, to funkcja Count obliczy całkowitą liczbę rekordów, łącznie z rekordami zawierającymi wartości Null. Funkcja Count(*) jest znacznie szybsza niż funkcja Count([nazwa_kolumny]). Nie należy używać znaku gwiazdki w cudzysłowie (' '). W poniższym przykładzie obliczana jest liczba rekordów w tabeli Zamówienia:

SELECT Count(*)

AS ZamówieniaRazem FROM Zamówienia;

Jeśli wyrażenie zawiera wiele pól, funkcja Count bierze pod uwagę rekord tylko w przypadku, gdy przynajmniej jedno z pól nie jest równe Null. Jeśli wszystkie z określonych pól mają wartość Null, rekord nie jest uwzględniany. Nazwy pól należy oddzielać znakiem &. W poniższym przykładzie pokazano, jak można ograniczyć liczenie do rekordów, w których jedno z pól DataWysyłki lub Fracht nie jest równe Null:

SELECT

Count('DataWysyłki & Fracht')

AS [Not Null] FROM Zamówienia;

Funkcji Count można użyć w wyrażeniu kwerendy. Można użyć również tego wyrażenia we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Zobacz też
SELECT – instrukcja (Microsoft Jet SQL) | Sum – funkcja (Microsoft Jet SQL)
Funkcje agregujące SQL (SQL) |

Przykład

Count – przykład funkcji


Count - przykład funkcjii (DAO)

Count – przykład funkcji

W tym przykładzie tabela Zamówienia jest używana do obliczenia liczby zamówień wysłanych do Wielkiej Brytanii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub CountX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Znajdź liczbę zamówień wysłanych

    ' do Wielkiej Brytanii.

    Set rst = dbs.OpenRecordset("SELECT" _

        & " Count (KrajOdbiorcy)" _

        & " AS [Zamówienia z W.Brytanii]" _

        & " FROM Zamówienia" _

        & " WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub


CREATE INDEX - instrukcja (Microsoft Jet SQL)

CREATE INDEX - instrukcja

Tworzy nowy indeks w istniejącej tabeli.

Uwaga Dla baz danych nie opartych na aparacie Microsoft Jet, aparat bazy danych Microsoft Jet nie obsługuje instrukcji CREATE INDEX (za wyjątkiem tworzenia pseudoindeksu dla tabeli połączonej ODBC) ani żadnej instrukcji języka definicji danych (DDL). W przypadku takich baz należy użyć metody DAO Create. Dodatkowe informacje znaleźć można w punkcie "Użycie".

Składnia

CREATE [ UNIQUE ] INDEX indeks
ON tabela (pole [ASC|DESC][, pole [ASC|DESC], ...])
[WITH { PRIMARY | DISALLOW NULL | IGNORE NULL }]

Składnia instrukcji CREATE INDEX zawiera następujące elementy:

Element | Opis
indeks | Nazwa tworzonego indeksu.
tabela | Nazwa istniejącej tabeli, która będzie zawierać indeks.
pole | Nazwa pola lub pól, które mają być indeksowane. Aby utworzyć indeks dla pojedynczego pola, należy za nazwą tabeli umieścić w nawiasach nazwę pola. Aby utworzyć indeks dla wielu pól, należy podać nazwę każdego pola, które ma być włączone do indeksu. Aby utworzyć indeksy malejące, należy użyć słowa zastrzeżonego DESC; w przeciwnym przypadku indeksy będą uporządkowane rosnąco.

Uwagi

Aby zapobiec występowaniu powtarzających się wartości w polu lub polach indeksowanych, należy użyć słowa zastrzeżonego UNIQUE.

Posługując się opcjonalną klauzulą WITH, można określić reguły poprawności danych. Na przykład:

  • Stosując opcję DISALLOW NULL, można zapobiec występowaniu wartości Null w polu lub polach indeksowanych nowych rekordów.
  • Stosując opcję IGNORE NULL, można zapobiec dołączaniu do indeksu rekordów zawierających w polu lub polach indeksowanych wartości Null.
  • Dodając słowo zastrzeżone PRIMARY, można określić indeksowane pole lub pola jako klucz podstawowy. Pociąga to za sobą unikatowość, tak więc można wówczas pominąć słowo zastrzeżone UNIQUE.

Można użyć instrukcji CREATE INDEX aby utworzyć pseudoindeks dla tabeli połączonej źródła danych ODBC, takiego jak program Microsoft® SQL Server™, która nie posiada jeszcze indeksu. Do utworzenia pseudoindeksu nie są potrzebne uprawnienia ani dostęp do zdalnego serwera, zaś sam fakt istnienia pseudoindeksu nie jest znany zdalnej bazie danych i nie wpływa na nią w żaden sposób. Taką samą składnię można stosować zarówno do tabel połączonych, jak i macierzystych. Tworzenie pseudoindeksu dla tabeli, która w normalnych okolicznościach będzie tylko-do-odczytu, może być wyjątkowo użyteczne.

Można użyć także instrukcji ALTER TABLE w celu dodania jedno- lub wielopolowego indeksu do tabeli lub użyć instrukcji ALTER TABLE lub instrukcji DROP w celu usunięcia indeksu utworzonego za pomocą instrukcji ALTER TABLE lub instrukcji CREATE INDEX.

Uwaga Nie należy używać słowa zastrzeżonego PRIMARY podczas tworzenia nowego indeksu dla tabeli, która już posiada klucz podstawowy; jeśli zostanie ono użyte, wystąpi błąd.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE VIEW - instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | GRANT - instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja

Przykład

CREATE INDEX – przykład instrukcji


CREATE INDEX - przykład instrukcjii (DAO)

CREATE INDEX – przykład instrukcji

W tym przykładzie tworzony jest indeks składający się z pól TelDomowy i TelWewnętrzny tabeli Pracownicy.

Sub CreateIndexX1()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz indeks NowyIndeks w tabeli Pracownicy.

    dbs.Execute _ "CREATE INDEX NowyIndeks ON Pracownicy " & _

        "(TelDomowy, TelWewnętrzny);"

    dbs.Close

End Sub

W tym przykładzie tworzony jest indeks w tabeli Klienci składający się z pola KodKlienta. Wszystkie rekordy muszą zawierać różne dane w polu KodKlienta, niedozwolone są również wartości Null.

Sub CreateIndexX2()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz unikatowy indeks, KodKln,

    ' składający się z pola KodKlienta.

    dbs.Execute "CREATE UNIQUE INDEX KodKln " _

        & "ON Klienci (KodKlienta) " _

        & "WITH DISALLOW NULL;"

    dbs.Close

End Sub


CREATE PROCEDURE - instrukcja (Microsoft Jet SQL)

CREATE PROCEDURE - instrukcja

Tworzy przechowywaną na serwerze SQL procedurę.

Uwaga Aparat bazy danych Microsoft Jet nie obsługuje instrukcji CREATE PROCEDURE, ani żadnej instrukcji DDL, w odniesieniu do baz danych nie opartych o aparat Microsoft Jet.

Składnia

CREATE PROCEDURE procedura
[parametr1 typ_danych[, parametr2 typ_danych[, ...]] AS instrukcja_sql

Składnia instrukcji CREATE PROCEDURE zawiera następujące elementy:

Element | Opis
procedura | Nazwa procedury. Musi ona spełniać wymagania standardowej konwencji nazewnictwa.
parametr_1, parametr_2 | Od jednego do 255 nazw pól lub parametrów. Na przykład: CREATE PROCEDURE Sprzedaż_Według Kraju [Data Początkowa] DateTime, [Data Końcowa] DateTime; Więcej informacji o parametrach można znaleźć pod hasłem PARAMETERS.
typ_danych | Jeden z podstawowych typów danych jezyka SQL aparatu bazy danych Microsoft Jet lub ich synonimów.
instrukcja_sql | Instrukcja SQL taka jak SELECT, UPDATE, DELETE, INSERT, CREATE TABLE, DROP TABLE, i tak dalej.

Uwagi

Procedura SQL składa się z klauzuli PROCEDURE (określającej nazwę procedury), nieobowiązkowej listy definicji parametrów oraz pojedynczej instrukcji SQL.

Nazwa procedury nie może być taka sama jak nazwa istniejącej tabeli.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE VIEW - instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE TABLE – instrukcja | REVOKE - instrukcja

Przykład

CREATE PROCEDURE - instrukcja, PROCEDURE - klauzula -przykład


CREATE TABLE - instrukcja (Microsoft Jet SQL)

CREATE TABLE - instrukcja

Tworzy nową tabelę.

Uwaga Aparat bazy danych Microsoft Jet nie obsługuje instrukcji CREATE TABLE, ani żadnej z instrukcji DDL, w odniesieniu do baz danych nie opartych na aparacie Microsoft Jet. W przypadku takich baz należy użyć metody DAO Create.

Składnia

CREATE [TEMPORARY] TABLE tabela (pole1 typ [(rozmiar)] [NOT NULL] [WITH COMPRESSION | WITH COMP] [indeks1] [, pole2 typ [(rozmiar)] [NOT NULL] [indeks2] [, ...]] [, CONSTRAINT indeks_wielopolowy [, ...]])

Składnia instrukcji CREATE TABLE zawiera następujące elementy:

Element | Opis
tabela | Nazwa tworzonej tabeli.
pole_1, pole_2 | Nazwa pola lub pól, które mają być utworzone w nowej tabeli. Należy utworzyć co najmniej jedno pole.
typ | Typ danych pola w nowej tabeli.
rozmiar | Rozmiar pola w znakach (tylko dla pól typu Text i Binary).
indeks_1, indeks_2 | Klauzula CONSTRAINT definiująca indeks dla pojedynczego pola. Więcej informacji na temat jak utworzyć ten indeks można znaleźć pod hasłem CONSTRAINT – klauzula.
indeks wielopolowy | Klauzula CONSTRAINT definiująca indeks dla wielu pól. Więcej informacji na temat jak utworzyć ten indeks można znaleźć pod hasłem CONSTRAINT – klauzula.

Uwagi

Instrukcja CREATE TABLE jest używana do definiowana nowej tabeli wraz z polami i ograniczeniami nakładanymi na te pola. Jeżeli dla pola określono ograniczenie NOT NULL, to nowe rekordy muszą zawierać w tych polach poprawne wartości.

Klauzula CONSTRAINT nakłada rozmaite ograniczenia na pole i może być użyta do ustalenia klucza podstawowego. Do utworzenia klucza podstawowego lub dodatkowych indeksów w istniejących tabelach można również użyć instrukcji CREATE INDEX.

Ograniczenie NOT NULL może być nałożone na pojedyncze pole lub też wystąpić w nazwanej klauzuli CONSTRAINT dotyczącej pojedynczego pola lub też wielu pól. Pomimo tego ograniczenie NOT NULL można zastosować tylko raz dla pola. Próba zastosowania tego ograniczenia więcej niż jeden raz powoduje wygenerowanie błędu czasu wykonania.

Podczas tworzenia tabeli TEMPORARY jest ona widoczna jedynie w sesji w której była stworzona. Jest ona automatycznie usuwana kiedy sesja zostaje zakończona. Tabele tymczasowe mogą być dostępne dla więcej niż jednego użytkownika.

Atrybut WITH COMPRESSION moży być używany tylko z typami danych CHARACTER oraz MEMO (także znanym jako TEXT) i ich synonimami.

Atrybut WITH COMPRESSION został dodany do kolumn CHARACTER z powodu zmiany przedstawienia znaku do formatu Unicode. Znaki w reprezentacji Unicode niezmiennie wymagają dwóch bajtów dla każdego znaku. Dla istniejących baz danych aparatu Microsoft® Jet które zawierają głównie dane znakowe mogłoby to oznaczać, że rozmiar bazy danych niemalże podwoiłby się po konwersji do formatu Microsoft Jet w wersji 4.0. Jednakże reprezentacja Unicode wielu zestawów znaków poprzednio jednobajtowych (SBCS), może łatwo być skompresowana do jednego bajtu. Jeśli kolumna typu CHARACTER zostanie zdefiniowana z tym atrybutem, dane automatycznie będą skompresowane jako że są one zapisywane i dekompresowane w momencie pobrania z kolumny.

Kolumny typu MEMO także mogą być definiowane tak by przechowywać dane w skompresowanej postaci. Istnieje jednak ograniczenie. Tylko wystąpienia kolumn typu MEMO, które po kompresji nie przekroczą rozmiaru 4096 bajtów, będą skompresowane. Wszystkie inne wystąpienia kolumn typu MEMO pozostaną nieskompresowane. Oznacza to, że dla określonej tabeli, dla określonej kolumny typu MEMO, niektóre dane mogą być skompresowane, a niektóre nieskompresowane.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE VIEW - instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja

Przykład

CREATE TABLE - instrukcja, CONSTRAINT - klauzula - przykład


CREATE TABLE - instrukcja i CONSTRAINT - przykład klauzulii (DAO)

CREATE TABLE – instrukcja i CONSTRAINT – przykład klauzuli

W tym przykładzie tworzona jest nowa tabela o nazwie TaTabela zawierająca dwa pola typu Text.

Sub CreateTableX1()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

' Utwórz tabelę zawierającą dwa pola typu Text.

    dbs.Execute "CREATE TABLE TaTabela " _

        & "(FirstName CHAR, LastName CHAR);"

    dbs.Close

End Sub

W tym przykładzie tworzona jest nowa tabela o nazwie MojaTabela zawierająca dwa pola typu Text, pole typu Date/Time oraz unikatowy indeks składający się ze wszystkich trzech pól.

Sub CreateTableX2()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz tabelę zawierającą trzy pola oraz

    ' unikatowy indeks składający się ' ze wszystkich tych pól.

    dbs.Execute "CREATE TABLE MojaTabela " _

        & "(FirstName CHAR, LastName CHAR, " _

        & "DataUrodzenia DATETIME, " _

        & "CONSTRAINT MojeOgraniczenie UNIQUE " _

        & "(Imię, Nazwisko, DataUrodzenia));"

    dbs.Close

End Sub

W tym przykładzie tworzona jest nowa tabela zawierająca dwa pola typu Text oraz pole typu Integer. Pole SSN jest kluczem podstawowym.

Sub CreateTableX3()

     Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz tabelę zawierającą trzy pola

    ' oraz klucz podstawowy.

    dbs.Execute "CREATE TABLE NowaTabela " _

        & "(FirstName CHAR, LastName CHAR, " _

        & "SSN INTEGER CONSTRAINT MojeOgrPola" _

        & "PRIMARY KEY);"

    dbs.Close

End Sub


CREATE USER lub GROUP - instrukcja (Microsoft Jet SQL)

CREATE USER lub GROUP - instrukcja

Tworzy jednego lub kilku użytkowników lub grup.

Składnia

Tworzenie użytkownika:

CREATE USER użytkownik hasło pid [, użytkownik hasło pid, …]

Tworzenie grupy:

CREATE GROUP grupa pid[, grupa pid, …]

Składnia instrukcji CREATE USER lub GROUP zawiera następujące elementy:

Element | Opis
użytkownik | Nazwa użytkownika, która ma być dodana do pliku informacyjnego grupy roboczej.
grupa | Nazwa grupy, która ma zostać dodana do pliku informacyjnego grupy roboczej.
hasło | Hasło, które ma zostać skojarzone z podanym użytkownikiem.
pid | Identyfikator osobisty.

Uwagi

Użytkownik i grupa nie mogą posiadać takiej samej nazwy.

Hasło wymagane jest dla każdego tworzonego użytkownika lub grupy.

Zobacz też
ADD USER - instrukcja | CREATE TABLE – instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE VIEW - instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja


CREATE VIEW - instrukcja (Microsoft Jet SQL)

CREATE VIEW - instrukcja

Tworzy nowy widok.

Uwaga Aparat bazy danych Microsoft Jet nie obsługuje instrukcji CREATE VIEW, ani żadnej z instrukcji DDL, w odniesieniu do baz danych nie używających aparatu Microsoft Jet.

Składnia

CREATE VIEW widok [(pole1[, pole2[, ...]])] AS instrukcja_select

Składnia instrukcji CREATE VIEW zawiera następujące elementy:

Element | Opis
widok | Nazwa widoku który ma zostać stworzony.
pole_1, pole_2 | Nazwa pola lub pól dla odpowiednich pól określonych w instrukcji_select.
instrukcja select | Instrukcja SQL SELECT. Więcej informacji znajdziesz pod hasłem SELECT – instrukcja.

Uwagi

Instrukcja SELECT, która definiuje widok, nie może być instrukcją SELECT INTO.

Instrukcja SELECT, która definiuje widok nie może zawierać żadnych parametrów.

Nazwa widoku nie może być taka sama jak nazwa istniejącej tabeli.

Jeśli kwerenda zdefiniowana za pomocą instrukcji SELECT jest aktualizowalna, wtedy widok też jest aktualizowalny. W przeciwnym wypadku widok jest tylko-do-odczytu.

Jeżeli jakiekolwiek dla pola w kwerendzie zdefiniowanej przez instrukcję SELECT mają taką samą nazwę, definicja widoku musi zawierać listę pól określającą unikatowe nazwy dla każdego z pól w kwerendzie.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE TABLE – instrukcja
ALTER TABLE - instrukcja | DROP - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja


DELETE - instrukcja (Microsoft Jet SQL)

DELETE - instrukcja

Tworzy kwerendę usuwającą, która usuwa rekordy z jednej lub wielu tabeli wymienionych w klauzuli FROM spełniające warunki klauzuli WHERE.

Składnia

DELETE [tabela.*]
FROM tabela
WHERE kryteria

Składnia instrukcji DELETE zawiera następujące elementy:

Element | Opis
tabela | Nieobowiązkowa nazwa tabeli, z której usuwane są rekordy.
tabela | Nazwa tabeli, z której usuwane są rekordy.
kryteria | Wyrażenie określające rekordy do usunięcia.

Uwagi

Instrukcja DELETE jest szczególnie przydatna przy usuwaniu wielu rekordów.

Aby usunąć całą tabelę z bazy danych, można użyć metody Execute z instrukcją DROP. Wtedy jednak zniszczeniu ulega struktura tabeli. W przeciwieństwie do tego, użycie instrukcji DELETE powoduje jedynie usunięcie danych; struktura tabeli i wszystkie jej właściwości, takie jak atrybuty pól i indeksy, pozostają nienaruszone.

Instrukcja DELETE może być użyta do usunięcia rekordów z tabel w relacji jeden-do-wielu z innymi tabelami. Operacje usuwania kaskadowego powodują, że rekordy w tabelach odpowiadających stronie "wielu" relacji zostaną usunięte, gdy w wyniku kwerendy zostanie usunięty odpowiadający im rekord po stronie "jeden" tej relacji. Na przykład w relacji między tabelami Klienci i Zamówienia, tabela Klienci znajduje się po stronie "jeden", zaś Zamówienia po stronie "wielu" relacji. Usunięcie rekordu z tabeli Klienci powoduje usunięcie odpowiednich rekordów z tabeli Zamówienia, jeśli włączono opcję usuwania kaskadowego.

Kwerenda DELETE usuwa całe rekordy, a nie tylko dane z określonych pól. Jeśli chcemy usunąć wartości z określonych pól, należy utworzyć kwerendę aktualizującą, która zmienia wartości pól na Null.

Ważne

  • Po usunięciu rekordów za pomocą kwerendy usuwającej nie można cofnąć tej operacji. Aby dowiedzieć się, które rekordy zostaną usunięte, należy najpierw sprawdzić wyniki kwerendą wybierającą, używającej tych samych kryteriów, a następnie uruchomić kwerendę usuwającą.
  • Warto przez cały czas przechowywać kopie zapasowe danych. Po pomyłkowym usunięciu rekordów można odzyskać je z kopii zapasowych.
Zobacz też
DROP – instrukcja (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | UPDATE – instrukcja (Microsoft Jet SQL)
IN – klauzula (Microsoft Jet SQL) | WHERE – instrukcja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) |

Przykład

DELETE – przykład instrukcji


DELETE - przykład instrukcji

DELETE – przykład instrukcji

W tym przykładzie usuwane są wszystkie rekordy pracowników posiadających tytuł Stażysta. Nie jest konieczne wymienianie nazwy tabeli w instrukcji DELETE, gdyż klauzula FROM zawiera tylko jedną tabelę.

Sub DeleteX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Usuń rekordy pracowników, posiadających tytuł

    ' Stażysta.

dbs.Execute "DELETE * FROM " _

        & "Pracownicy WHERE Tytuł = 'Stażysta';"

    dbs.Close

End Sub


DROP - instrukcja (Microsoft Jet SQL)

DROP - instrukcja

Usuwa istniejącą tabelę, procedurę, widok z bazy danych, lub usuwa istniejący indeks z tabeli.

Uwaga Aparat bazy danych Microsoft Jet nie obsługuje instrukcji DROP, ani żadnej z instrukcji DDL, w odniesieniu do baz danych nie używających aparatu Microsoft Jet. W przypadku takich baz należy użyć metody Delete DAO.

Składnia

DROP {TABLE tabela | INDEX indeks ON tabela | PROCEDURE procedura | VIEW widok}

Składnia funkcji DROP zawiera następujące elementy:

Element | Opis
tabela | Nazwa tabeli, która ma być usunięta, lub też tabeli, z której ma być usunięty indeks.
procedura | Nazwa procedury, która ma zostać usunięta z tabeli.
widok | Nazwa widoku, który ma zostać usunięty z tabeli.
indeks | Nazwa indeksu, który ma być usunięty z tabeli.

Uwagi

Przed usunięciem tabeli lub też usunięciem z niej indeksu należy tabelę zamknąć.

Aby usunąć indeks z tabeli, można również użyć instrukcji ALTER TABLE.

Można użyć instrukcji CREATE TABLE aby utworzyć tabelę i CREATE INDEX lub ALTER TABLE aby utworzyć indeks. W celu modyfikacji tabeli należy użyć instrukcji ALTER TABLE.

Zobacz też
ADD USER - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE TABLE – instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP USER lub GROUP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja

Przykład

DROP – przykład instrukcji


DROP USER lub GROUP - instrukcja (Microsoft Jet SQL)

DROP USER lub GROUP - instrukcja

Usuwa jednego lub kilku istniejących użytkowników lub grup, bądź usuwa jednego lub kilku użytkowników z istniejącej grupy.

Składnia

Usuwa jednego lub kilku użytkowników lub usuwa jednego lub kilku użytkowników z grupy:

DROP USER użytkownik[, użytkownik, …] [FROM grupa]

Usuwa jedną lub więcej grup:

DROP GROUP grupa[, grupa, …]

Składnia instrukcji DROP USER lub GROUP zawiera następujące elementy:

Element | Opis
użytkownik | Nazwa użytkownika, która ma być usunięta z pliku informacyjnego grupy roboczej.
grupa | Nazwa grupy, która ma być usunięta z pliku informacyjnego grupy roboczej.

Uwagi

Jeśli słowo kluczowe FROM zostało użyte w instrukcji DROP USER, wtedy każdy z użytkowników wymienionych w instrukcji zostanie usunięty z grupy określonej za słowem kluczowym FROM. Sami użytkownicy jednak nie będą usunięci.

Instrukcja DROP GROUP usunie określoną grupę (grupy). Nie wpłynie to na użytkowników, którzy należą do grupy (grup), lecz nie będą oni dłużej członkami usuniętej grupy (grup).

Zobacz też
ADD USER - instrukcja | CREATE TABLE – instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP - instrukcja
CREATE INDEX – instrukcja | GRANT - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja


DROP - przykład instrukcjii (DAO)

DROP – przykład instrukcji

W poniższym przykładzie przyjęto, że w tabeli Pracownicy znajdującej się w bazie danych Northwind istnieje hipotetyczny indeks NowyIndeks.

W tym przykładzie indeks NowyIndeks jest usuwany z tabeli Pracownicy.

Sub DropX1()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Usuń indeks NowyIndeks z tabeli Pracownicy.

    dbs.Execute "DROP INDEX NowyIndeks ON Pracownicy;"

    dbs.Close

End Sub

W tym przykładzie tabela Pracownicy zostaje usunięta z bazy danych.

Sub DropX2()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Usuń tabelę Pracownicy.

    dbs.Execute "DROP TABLE Pracownicy;"

    dbs.Close

End Sub


Równoważne typy danych ANSI SQLRównoważne typy danych ANSI SQL

Poniższa tabela wymienia typy danych ANSI SQL, odpowiadające im typy danych SQL aparatu bazy danych Microsoft Jet, i ich odpowiednie synonimy. Tabela wymienia również odpowiednie typy danych programu Microsoft® SQL Server™.

Typ danych ANSI SQL | Typ danych Microsoft Jet SQL | Synonim | Typ danych Microsoft SQL Server
BIT, BIT VARYING | BINARY (Zob. "Uwagi") | VARBINARY, BINARY VARYING BIT VARYING | BINARY, VARBINARY
Brak | BIT (Zob. "Uwagi") | BOOLEAN, LOGICAL, LOGICAL1, YESNO | BIT
Brak | TINYINT | INTEGER1, BYTE | TINYINT
Brak | COUNTER (Zob. "Uwagi") | AUTOINCREMENT | ( Zob. "Uwagi")
Brak | MONEY | CURRENCY | MONEY
DATE, TIME, TIMESTAMP | DATETIME | DATE, TIME (Zob. "Uwagi") | DATETIME
Brak | UNIQUEIDENTIFIER | GUID | UNIQUEIDENTIFIER
DECIMAL | DECIMAL | NUMERIC, DEC | DECIMAL
REAL | REAL | SINGLE, FLOAT4, IEEESINGLE | REAL
DOUBLE PRECISION, FLOAT | FLOAT | DOUBLE, FLOAT8, IEEEDOUBLE, NUMBER (Zob. "Uwagi") | FLOAT
SMALLINT | SMALLINT | SHORT, INTEGER2 | SMALLINT
INTEGER | INTEGER | LONG, INT, INTEGER4 | INTEGER
INTERVAL | Brak |  | Brak
Brak | IMAGE | LONGBINARY, GENERAL, OLEOBJECT | IMAGE
Brak | TEXT (Zob. "Uwagi") | LONGTEXT, LONGCHAR, MEMO, NOTE, NTEXT (Zob. "Uwagi") | TEXT
CHARACTER, CHARACTER VARYING, NATIONAL CHARACTER, NATIONAL CHARACTER VARYING | CHAR (Zob. "Uwagi") | TEXT(n), ALPHANUMERIC, CHARACTER, STRING, VARCHAR, CHARACTER VARYING, NCHAR, NATIONAL CHARACTER, NATIONAL CHAR, NATIONAL CHARACTER VARYING, NATIONAL CHAR VARYING (Zob. "Uwagi") | CHAR, VARCHAR, NCHAR, NVARCHAR

Uwagi

  • Typ danych ANSI SQL BIT nie odpowiada typowi danych Microsoft Jet SQL BIT. Zamiast tego odpowiada typowi BINARY. Nie istnieje typ ANSI SQL odpowiadający typowi BIT języka Microsoft Jet SQL.
  • TIMESTAMP nie jest już obsługiwany jako synonim DATETIME.
  • NUMERIC nie jest już obsługiwany jako synonim dla FLOAT lub DOUBLE. NUMERIC jest teraz używany jako synonim DECIMAL.
  • Pole typu LONGTEXT jest zawsze zapisywane w formacie reprezentacji Unicode .
  • Jeśli nazwa typu danych TEXT jest używana bez określenia opcjonalnego rozmiaru, na przykład TEXT(25), tworzone jest pole typu LONGTEXT. To pozwala instrukcji CREATE TABLE zapisywać dane w formacie spójnym z typem danych programu Microsoft SQL Server.
  • Pole typu CHAR jest zawsze zapisywane w formacie reprezentacji Unicode, które jest odpowiednikiem typu danych NATIONAL CHAR języka ANSI SQL.
  • Jeśli nazwa typu danych TEXT jest używana wraz z podanym opcjonalnym rozmiarem, na przykład TEXT(25), typ danych odpowiada typowi danych CHAR. To zachowuje wsteczną zgodność z większością aplikacji aparatu Microsoft Jet, podczas współpracy typu danych TEXT (bez określania rozmiaru) z programem Microsoft SQL Server.
Zobacz też

Typy danych języka SQL aparatu baz danych Microsoft Jet


EXECUTE - instrukcja (Microsoft Jet SQL)

EXECUTE - instrukcja

Używana do wywołania wykonania procedury.

Składnia

EXECUTE procedura [parametr_1[, parametr_2[, ...]]

Składnia instrukcji EXECUTE zawiera następujące elementy:

Element | Opis
procedura | Nazwa procedury do wykonania.
parametr_1, parametr_2 | Wartości parametrów zdefiniowanych przez procedurę.

Zobacz też
PARAMETERS – deklaracja (Microsoft Jet SQL) PROCEDURE – klauzula (Microsoft Jet SQL)

Przykład

CREATE PROCEDURE - instrukcja, PROCEDURE - przykład klauzuli


Wyrażenia SQLWyrażenia SQL

Wyrażenia SQL

Wyrażeniem SQL jest ciąg znaków, który tworzy część lub całość instrukcji SQL. Na przykład metoda FindFirst obiektu Recordset używa wyrażenia SQL składającego się z kryteriów wyboru określonych w klauzuli WHERE.

Aparat bazy danych Microsoft Jet do prostych obliczeń arytmetycznych i funkcyjnych stosuje obsługę wyrażeń systemu Visual Basic for Applications (lub VBA). Wszystkie operatory użyte w wyrażeniach języka SQL aparatu Microsoft Jet (z wyjątkiem Between, In i Like) są zdefiniowane przez aparat obsługi wyrażeń VBA. Ponadto obsługa wyrażeń VBA dostarcza ponad 100 funkcji VBA, które można wykorzystywać w wyrażeniach SQL. Na przykład można użyć funkcji VBA do zredagowania kwerendy SQL w widoku projektu kwerendy programu Microsoft Access, oraz w kwerendzie SQL w metodzie DAO OpenRecordset w kodach programów Microsoft Visual C++®, Microsoft Visual Basic i Microsoft Excel.


First, Last - funkcje (Microsoft Jet SQL)

First, Last - funkcje

Zwracają wartość pola pierwszego lub ostatniego rekordu z zestawu wyników zwróconego przez kwerendę.

Składnia

First(wyrażenie)

Last(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których chcemy użyć, lub wyrażenie wykonujące obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Funkcje First i Last są analogiczne do metod DAO MoveFirst i MoveLast obiektu Recordset. Zwracają one wartość określonego pola odpowiednio pierwszego lub ostatniego rekordu z zestawu wyników zwróconego przez kwerendę. Ponieważ zwykle rekordy nie są zwracane w żadnej określonej kolejności (chyba, że kwerenda zawiera klauzulę ORDER BY), to rekordy będą przez te funkcje zwracane losowo.

Zobacz też
SQL - obliczanie pól w funkcjach Funkcje agregujące SQL (SQL)

Przykład

First, Last – funkcje - przykład


First i Last - funkcje - przykładi (DAO)

First i Last – funkcje - przykład

W tym przykładzie zwracane są wartości pola Nazwisko z pierwszego i ostatniego rekordu pobranego z tabeli Pracownicy.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub FirstLastX1()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Zwróć wartość pola Nazwisko z pierwszego

    ' i ostatniego rekordu pobranego z tabeli.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "First(Nazwisko) as Pierwszy, " _

        & "Last(Nazwisko) as Ostatni FROM Pracownicy;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    dbs.Close

End Sub

W następnym przykładzie porównywane jest użycie funkcji First i Last oraz funkcji Min i Max do znalezienia w tabeli Pracownicy najwcześniejszej i najpóźniejszej daty urodzin.

Sub FirstLastX2()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' W tabeli Pracownicy znajdź najwcześniejszą

    ' i najpóźniejszą datę urodzenia.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "First(DataUrodzenia) as PierwszaDU, " _

        & "Last(DataUrodzenia) as OstatniaDU " _

        & "FROM Pracownicy;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    Debug.Print

    ' W tabeli Pracownicy znajdź najwcześniejszą

    ' i najpóźniejszą datę urodzenia.

    Set rst = dbs.OpenRecordset("SELECT " _
        & "Min(DataUrodzenia) as MinDU," _

        & "Max(DataUrodzenia) as MaxDU " _

        & "FROM Pracownicy;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    dbs.Close

End Sub


FROM - klauzula (Microsoft Jet SQL)

FROM - klauzula

Określa tabele lub kwerendy zawierające pola podane na liście instrukcji SELECT.

Składnia

SELECT lista_pól
FROM wyrażenie_tabelowe [IN zewnętrzna_baza_danych]

Składnia instrukcji SELECT z klauzulą FROM zawiera następujące elementy:

Element | Opis
lista_pól | Nazwy pobieranych pól, którym mogą towarzyszyć aliasy nazw pól, funkcje agregujące SQL, predykaty wyboru (ALL, DISTINCT, DISTINCTROW, lub TOP) albo inne opcje instrukcji SELECT.
wyrażenie_tabelowe | Nazwa tabeli lub tabel, z których mają być pobrane dane. Wyrażenie może być nazwą pojedynczej tabeli, zapisanej kweredy, bądź wynikiem operacji INNER JOIN, LEFT JOIN, lub RIGHT JOIN.
zewnętrzna_baza_danych | Pełna ścieżka do zewnętrznej bazy danych zawierającej wszystkie tabele wymienione w wyrażeniu_tabelowym.

Uwagi

Klauzula FROM jest obowiązkowa i następuje bezpośrednio po instrukcji SELECT.

Kolejność nazw tabel w wyrażeniu_tabelowym nie jest istotna.

Aby zwiększyć wydajność i prostotę użycia, wskazane jest użycie tabel połączonych zamiast klauzuli IN do pobierania rekordów z zewnętrznej bazy danych.

Poniższy przykład ilustruje pobieranie danych z tabeli Pracownicy:

SELECT Nazwisko, Imię

FROM Pracownicy;

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT – instrukcja (Microsoft Jet SQL)
IN – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) |

Przykład

SELECT - instrukcja, FROM – przykład klauzuli


GRANT - instrukcja (Microsoft Jet SQL)

GRANT - instrukcja

Udziela określonych przywilejów istniejącemu użytkownikowi lub grupie.

Składnia

GRANT {przywilej[, przywilej, …]} ON
{TABLE tabela |
OBJECT obiekt|

CONTAINER kontener } TO {nazwa_autoryzowanego [, nazwa_autoryzowanego, …]}

Składnia instrukcji GRANT zawiera następujące elementy:

Element | Opis
przywilej | Przywilej lub przywileje, które mają zostać nadane. Przywileje określone są przy pomocy następujących słów kluczowych: SELECT, DELETE, INSERT, UPDATE, DROP, SELECTSECURITY, UPDATESECURITY, DBPASSWORD, UPDATEIDENTITY, CREATE, SELECTSCHEMA, SCHEMA i UPDATEOWNER.
tabela | Jakakolwiek poprawna nazwa tabeli.
obiekt | Nie musi być to obiekt typu tabela. Przechowywana na serwerze SQL kwerenda (widok lub procedura) może posłużyć za przykład.
kontener | Nazwa prawidłowego kontenera.
nazwa_autoryzowanego | Nazwa użytkownika lub grupy.

Zobacz też
ADD USER - instrukcja | CREATE TABLE – instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP - instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | REVOKE - instrukcja


GROUP BY - klauzula (Microsoft Jet SQL)

GROUP BY - klauzula

Scala w jeden rekord rekordy o identycznych wartościach wskazanych na liście pól. Wartość sumy tworzona jest dla każdego rekordu, jeśli w instrukcji SELECT stosowane są funkcje agregujące SQL, takie jak Sum lub Count.

Składnia

SELECT lista_pól
FROM tabela
WHERE kryteria
[GROUP BY lista_pól_grupowania]

Składnia instrukcji SELECT z klauzulą GROUP BY zawiera następujące elementy:

Element | Opis
lista_pól | Nazwy pobieranych pól, którym mogą towarzyszyć aliasy nazw pól, funkcje agregujące SQL, predykaty wyboru (ALL, DISTINCT, DISTINCTROW lub TOP) albo inne opcje instrukcji SELECT.
tabela | Nazwa tabeli, z której pobierane są rekordy. Więcej informacji można znaleźć w opisie klauzuli FROM.
kryteria | Kryteria wyboru. Jeśli instrukcja zawiera klauzulę WHERE, aparat bazy danych Microsoft Jet dokona zgrupowania wartości po zastosowaniu do rekordów warunków podanych w klauzuli WHERE.
lista_pól_grupowania | Nazwy pól (maks. 10) użytych do zgrupowania rekordów. Kolejność nazw pól na liście_pól_grupowania określa poziomy grupowania, od poziomu najwyższego (najbardziej znaczącego) do najniższego (najmniej znaczącego).

Uwagi

Klauzula GROUP BY jest nieobowiązkowa.

Jeśli instrukcja SELECT nie zawiera żadnych funkcji agregujących, wartości zagregowane nie są obliczane.

Wartości Null w polach GROUP BY nie są pomijane i są grupowane. Jednakże wartości Null nie są uwzględniane przez żadną z funkcji agregujących SQL.

Użyj klauzuli WHERE aby wyłączyć rekordy, które nie powinny być grupowane, oraz klauzuli HAVING, aby filtrować rekordy po ich zgrupowaniu.

Pole na liście pól klauzuli GROUP BY może odnosić się do dowolnego pola dowolnej tabeli wymienionej na liście klauzuli FROM, z wyjątkiem pól zawierających dane typu Memo lub obiekt OLE Pole grupowania nie musi być umieszczone na liście pól instrukcji SELECT, o ile tylko instrukcja SELECT zawiera choć jedną funkcję agregacji SQL. Aparat baz danych Microsoft® Jet nie ma możliwości grupowania według pól typu Memo lub typu obiekt OLE.

Wszystkie pola na liście instrukcji SELECT muszą albo być wymienione na liście pól grupowania w klauzuli GROUP BY, albo być argumentami funkcji agregacji SQL.

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
ORDER BY – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)

Przykład

GROUP BY – przykład klauzuli


GROUP BY - przykład klauzulii (DAO)

GROUP BY – przykład klauzuli

W tym przykładzie tworzona jest lista unikatowych nazw tytułów i liczba pracowników posiadających dany tytuł.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub GroupByX1()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dla każdego tytułu znajdź liczbę

    ' pracowników posiadających ten tytuł.

    Set rst = dbs.OpenRecordset("SELECT Tytuł, " _

        & "Count([Tytuł]) AS Licznik " _

        & "FROM Pracownicy GROUP BY Tytuł;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub

W tym przykładzie dla każdego tytułu znajdowana jest liczba pracowników w stanie Waszyngton posiadających ten tytuł.

Sub GroupByX2()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Dla każdego tytułu znajdź liczbę

    ' pracowników posiadających ten tytuł.

' Bierz pod uwagę tylko tych pracowników, którzy

    ' pracują w Waszyngtonie.

    Set rst = dbs.OpenRecordset("SELECT Tytuł, " _

        & "Count(Tytuł) AS Licznik " _

        & "FROM Pracownicy WHERE Region = 'WA' " _

        & "GROUP BY Tytuł;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub


HAVING - klauzula (Microsoft Jet SQL)

HAVING - klauzula

Określa, które ze zgrupowanych rekordów pokazuje instrukcja SELECT z klauzulą GROUP BY. Po zgrupowaniu rekordów przez klauzulę GROUP BY klauzula HAVING wyświetla te rekordy spośród zgrupowanych, które spełniają warunki wymienione w klauzuli HAVING.

Składnia

SELECT lista_pól
FROM tabela
WHERE kryteria_wyboru
GROUP BY lista_pól_grupowania
[HAVING kryteria_grupowania]

Składnia instrukcji SELECT z klauzulą HAVING zawiera następujące elementy:

Element | Opis
lista_pól | Nazwy pobieranych pól, którym mogą towarzyszyć aliasy nazw pól, funkcje agregujące SQL, predykaty wyboru (ALL, DISTINCT, DISTINCTROW, lub TOP) albo inne opcje instrukcji SELECT.
tabela | Nazwa tabeli, z której pobierane są rekordy. Więcej informacji można znaleźć w opisie klauzuli FROM.
kryteria_wyboru | Kryteria wyboru. Jeśli instrukcja zawiera klauzulę WHERE, aparat bazy danych Microsoft Jet dokona zgrupowania wartości po zastosowaniu do rekordów warunków podanych w klauzuli WHERE.
lista_pól_grupowania | Nazwy pól (maks. 10) użytych do zgrupowania rekordów. Kolejność nazw pól na liście_pól_grupowania określa poziomy grupowania, od poziomu najwyższego (najbardziej znaczącego) do najniższego (najmniej znaczącego).
kryteria_grupowania | Wyrażenie określające, które spośród zgrupowanych rekordów będą pokazane.

Uwagi

Klauzula HAVING jest nieobowiązkowa.

Klauzula HAVING jest podobna w działaniu do klauzuli WHERE określającej warunki, jakie muszą spełniać rekordy, aby być pobrane. Po zgrupowaniu wybranych rekordów klauzulą GROUP BY klauzula HAVING określa, które ze zgrupowanych rekordów będą wyświetlone:

SELECT NrKategorii,

Sum(StanMagazynu)

FROM Produkty

GROUP BY NrKategorii

HAVING Sum(StanMagazynu) > 100 And Like "BOS*";

Klauzula HAVING może zawierać do 40 wyrażeń powiązanych ze sobą operatorami logicznymi And i Or.

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
ORDER BY – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)

Przykład

HAVING – przykład klauzuli


HAVING - przykład klauzulii (DAO)

HAVING – przykład klauzuli

W tym przykładzie są wybierane tytuły posiadane przez więcej niż jednego pracownika pracującego w regionie waszyngtońskim.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub HavingX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz tytuł posiadany przez więcej niż jednego

    ' pracownika pracującego w regionie waszyngtońskim.

    Set rst = dbs.OpenRecordset("SELECT Tytuł, " _

        & "Count(Tytuł) as Total FROM Pracownicy " _

        & "WHERE Region = 'WA' " _

        & "GROUP BY Tytuł HAVING Count(Tytuł) > 1;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu wydrukowania

' zawartości obiektu Recordset.

    WyliczPola rst, 25

    dbs.Close

End Sub


IN - klauzula (Microsoft Jet SQL)

IN - klauzula

Określa tabele w zewnętrznej bazie danych, z którą może połączyć się aparat baz danych Microsoft Jet, na przykład w bazie danych dBASE, Paradox lub w zewnętrznej bazie danych Microsoft® Jet.

Składnia

Określenie tabeli wyjściowej (przeznaczenia):

[SELECT | INSERT] INTO przeznaczenie IN
{ ścieżka | ["ścieżka " "typ"] | ["" [typ; DATABASE = ścieżka]]}

Określenie tabeli wejściowej (źródła):

FROM wyrażenie_tabelowe IN
{ ścieżka | ["ścieżka " "typ"] | ["" [typ; DATABASE = ścieżka]]}

Składnia instrukcji SELECT z klauzulą IN zawiera następujące elementy:

Element | Opis
przeznaczenie | Nazwa tabeli zewnętrznej, do której mają być wstawione dane.
wyrażenie_tabelowe | Nazwa tabeli lub tabel, z których mają być pobrane dane. Ten argument może być nazwą pojedynczej tabeli, zapisanej kwerendy, bądź wynikiem użycia operacji INNER JOIN, LEFT JOIN, lub RIGHT JOIN.
ścieżka | Pełna ścieżka katalogu lub pliku zawierającego tabelę.
typ | Nazwa typu bazy danych użytej do utworzenia tabeli, o ile jest to baza danych inna niż Microsoft Jet (na przykład dBASE III, dBASE IV, Paradox 3.x lub Paradox 4.x).

Uwagi

Klauzula IN pozwala na jednoczesne połączenie się tylko z jedną zewnętrzną bazą danych.

W niektórych przypadkach argument ścieżka odnosi się do katalogu zawierającego pliki bazy danych. Na przykład przy pracy z tabelami baz danych dBASE, FoxPro® lub Paradox argument ścieżka określa katalog z plikami .dbf lub .db. Nazwa pliku jest wnioskowana na podstawie argumentów przeznaczenie lub wyrażenie_tabelowe.

Określając bazę danych inną niż Microsoft Jet, należy do nazwy bazy dostawić średnik (;) i ująć ją w pojedynczy (' ') lub podwójny (" ") cudzysłów. Na przykład, poprawne są obie formy: 'dBASE IV;' i "dBASE IV;".

Do określenia zewnętrznej bazy danych można też użyć zastrzeżonego słowa DATABASE. Poniższy przykład pokazuje, jak można na różne sposoby określić tę samą tabelę:

... FROM Tabela IN "" [dBASE IV; DATABASE=C:\DBASE\DATA\SALES;];

... FROM Tabela IN "C:\DBASE\DATA\SALES" "dBASE IV;"

Uwagi

Zastosowanie tabeli połączonej zamiast klauzuli IN jest bardziej wydajne.

Słowo zastrzeżone IN może też wystąpić w wyrażeniu jako operator porównania. Więcej informacji można znaleźć w opisie operatora In.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) | SELECT – instrukcja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
INSERT INTO – instrukcja (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) |

Przykład

IN – przykład klauzuli


INNER JOIN - operacja (Microsoft Jet SQL)

INNER JOIN - operacja

Łączy (scala) rekordy z dwóch tabel, jeśli wspólne pole zawiera odpowiadające sobie wartości.

Składnia

FROM tabela_1 INNER JOIN tabela_2 ON tabela_1.pole_1 op_por tabela_2.pole_2

Składnia operacji INNER JOIN zawiera następujące elementy:

Element | Opis
tabela_1, tabela_2 | Nazwy tabel, których rekordy są łączone (scalane).
pole_1, pole_2 | Nazwy pól sprzęgających. Jeśli nie są one typu numerycznego, pola muszą być tego samego typu danych i zawierać ten sam rodzaj danych, ale nie muszą mieć tej samej nazwy.
op_por | Dowolny operator porównania: "=", "<", ">", "<=", ">=" lub "<>".

Uwagi

Operacja INNER JOIN może być użyta w dowolnej klauzuli FROM. Jest to najczęściej występujący typ sprzężenia. Sprzężenia wewnętrzne łączą rekordy z dwóch tabel, jeśli w polu wspólnym dla obu tabel znajdują się odpowiadające sobie wartości.

Operacja INNER JOIN zastosowana do tabel Działy i Pracownicy może zostać użyta do wyboru wszystkich pracowników zatrudnionych w każdym dziale. Jeśli jednak chcemy wybrać wszystkie działy (nawet jeśli w niektórych z nich nie ma pracowników) lub wszystkich pracowników (nawet jeśli niektórzy z nich nie pracują w żadnym dziale), to musimy użyć operacji LEFT JOIN lub RIGHT JOIN do utworzenia sprzężenia zewnętrznego.

Podczas próby sprzęgania pól zawierających dane typu Memo lub obiekt OLE występuje błąd.

Można sprząc dwa pola numeryczne podobnych typów. Na przykład, można sprząc pola Autonumer i Long, ponieważ są one podobnych typów. Nie można natomiast sprząc pól typu Single i Double.

Przykład przedstawiony poniżej pokazuje, w jaki sposób można sprząc tabele Kategorie i Produkty według pola NrKategorii.

SELECT NazwaKategorii, NazwaProduktu

FROM Kategorie INNER JOIN Produkty

ON Kategorie.NrKategorii = Produkty.NrKategorii;

W poprzednim przykładzie NrKategorii jest polem sprzężonym, ale nie jest ono uwzględnione w wyniku kwerendy, ponieważ nie jest zawarte w instrukcji SELECT. Aby dołączyć pole sprzęgające, należy dodać nazwę pola do instrukcji SELECT — w tym przypadku Kategorie.NrKategorii.

W jednej instrukcji JOIN można umieścić wiele klauzul ON, używając następującej składni:

SELECT pola
FROM tabela_1 INNER JOIN tabela_2
ON tabela_1.pole_1 op_por tabela_2.pole_1 AND
ON tabela_1.pole_2 op_por tabela_2.pole_2) OR
ON tabela_1.pole_3 op_por tabela_2.pole_3)];

Można również zagnieżdżać instrukcje JOIN, używając następującej składni:

SELECT pola
FROM tabela_1 INNER JOIN
(tabela_2 INNER JOIN [( ] tabela_3
[INNER JOIN [( ] tabela_x [INNER JOIN ...)]
ON tabela_3.pole_3 op_por tabela_x.pole_x)]
ON tabela_2. pole_2 op_por tabela_3.pole_3)
ON tabela_1. pole_1 op_por tabela_2.pole_2;

Operacje LEFT JOIN i RIGHT JOIN mogą być zagnieżdżone wewnątrz operacji INNER JOIN, lecz operacja INNER JOIN nie może być zagnieżdżona wewnątrz operacji LEFT JOIN lub RIGHT JOIN.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) | TRANSFORM – instrukcja (Microsoft Jet SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) | UNION – operacja (Microsoft Jet SQL)
SELECT - instrukcja (Microsoft Jet SQL) |

Przykład

INNER JOIN – przykład operacji


INNER JOIN - przykład operacjii (DAO)

INNER JOIN – przykład operacji

Niniejszy przykład tworzy dwa sprzężenia: jedno między tabelami OpisyZamówień i Zamówienia oraz drugie między tabelami Zamówienia i Pracownicy. Jest to konieczne, ponieważ tabela Pracownicy nie zawiera danych o sprzedaży, natomiast tabela OpisyZamównień nie zawiera danych o pracownikach. Wynikiem kwerendy jest lista pracowników oraz całkowita wartość zrealizowanych przez nich transakcji sprzedaży.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub InnerJoinX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz jedno sprzężenie między tabelami

    ' OpisyZamówień i Zamówienia oraz drugie między

    ' tabelami Zamówienia i Pracownicy. Utwórz listę

' pracowników oraz łącznych wartości

    ' zrealizowanych przez nich transakcji sprzedaży.

    Set rst = dbs.OpenRecordset("SELECT DISTINCTROW " _

        & "Sum(CenaJednostkowa * Ilość) AS Sprzedaż, " _

        & "(Imię & Chr(32) & Nazwisko) " _

        & "AS PełneNazwisko " _

        & "FROM Pracownicy INNER JOIN(Zamówienia " _

        & "INNER JOIN [Opisy zamówień] " _

        & "ON [Opisy zamowień].NrZamówienia = " _

        & "Zamówienia.NrZamówienia ) " _

        & "ON Zamówienia.NrPracownika = " _

        & "Pracownicy.NrPracownika " _

        & "GROUP BY (Imię & Chr(32) & Nazwisko);")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 20

    dbs.Close

End Sub


In - operator (Microsoft Jet SQL)

In - operator

Sprawdza, czy wartość wyrażenia jest równa dowolnej wartości z podanej listy.

Składnia

wyrażenie [Not] In(wartość1, wartość2, . . .)

Uwagi

Składnia operatora In zawiera następujące elementy:

Element | Opis
wyrażenie | Wyrażenie identyfikujące pole, które zawiera dane do sprawdzenia.
wartość_1, wartość_2 | Wyrażenie lub lista wyrażeń, z którymi porównywane jest wyrażenie.

Jeśli na liście wartości znajduje się wartość wyrażenia, operator In zwraca wartość True; w przeciwnym razie zwraca wartość False. Można także użyć operatora logicznego Not, aby sprawdzić warunek przeciwny (czy wyrażenie nie znajduje się na liście wartości).

Na przykład, za pomocą operatora In można określić, które zamówienia zostały dostarczone do dowolnego ze wskazanych regionów:

SELECT *

FROM Zamówienia

WHERE RegionOdbiorcy In ('Avon','Glos','Som')

Zobacz też
Wyrażenia SQL WHERE – klauzula (Microsoft Jet SQL)

Przykład

In - przykład operatora


In - operator - przykładi (DAO)

In – operator - przykład

W poniższym przykładzie użyto tabeli Zamówienia z bazy danych Northwind.mdb do utworzenia kwerendy zawierającej wszystkie zamówienia wysłane do Lancashire i Essex oraz daty wysyłki.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub InX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz te rekordy z tabeli Zamówienia, których

    ' pola RegionOdbiorcy mają wartość Lancashire ' lub Essex.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "KodKlienta, DataWysyłki FROM Zamówienia " _

        & "WHERE RegionOdbiorcy In " _

        & "('Lancashire','Essex');")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu wydrukowania

    ' zawartości obiektu Recordset.

    WyliczPola rst, 12

    dbs.Close

End Sub


INSERT INTO - instrukcja (Microsoft Jet SQL)

INSERT INTO - instrukcja

Dodaje rekord lub rekordy do tabeli. Odwołania do niej następują jako do kwerendy dołączającej.

Składnia

Kwerenda dołączająca wiele rekordów:

INSERT INTO cel [(pole_1[,pole_2[, ...]])] [IN zewnętrzna_baza_danych]
SELECT [źródło.] pole_1[,pole_2[, ...]
FROM wyrażenie_tabelowe

Kwerenda dołączająca pojedynczy rekord:

INSERT INTO cel [(pole_1[,pole_2[, ...]])]
VALUES (wartość_1[,wartość_2[, ...])

Składnia instrukcji INSERT zawiera następujące elementy:

Element | Opis
cel | Nazwa tabeli lub kwerendy, do której mają być dołączone rekordy.
pole_1, pole_2 | Nazwy pól, do których będą dołączane dane, jeśli występują po argumencie cel, lub też nazwy pól, z których będą pobierane dane, jeśli występują po argumencie źródło.
zewnętrzna_baza_danych | Ścieżka do zewnętrznej bazy danych. Opis ścieżki można znaleźć pod hasłem IN.
źródło | Nazwa tabeli lub kwerendy, z której będą kopiowane rekordy.
wyrażenie_tabelowe | Nazwa tabeli lub tabel, z których pobierane są rekordy. Ten argument może być nazwą pojedynczej tabeli, lub wynikiem działania instrukcji INNER JOIN, LEFT JOIN, lub operacji RIGHT JOIN bądź zachowanej kwerendy.
wartość_1, wartość_2 | Wartości, które mają być umieszczone w określonych polach nowego rekordu. Każda wartość jest umieszczana w polu, które odpowiada pozycji wartości na liście: wartość_1 zostaje umieszczona w polu_1 nowego rekordu, wartość_2 w polu_2, i tak dalej. Wartości muszą być oddzielone przecinkami, zaś pola tekstowe muszą być ujęte w cudzysłów (' ').

Uwagi

Aby dodać do tabeli pojedynczy rekord, można skorzystać z instrukcji INSERT INTO, używając przytoczonej wyżej składni kwerendy dołączającej pojedynczy rekord. W takim przypadku nazwa i wartość każdego pola rekordu jest określona w kodzie. Należy określić każde z pól rekordu, którego wartość ma zostać zmieniona, oraz wartość tego pola. W przypadku, gdy nie wszystkie pola są wymienione, wartość domyślna Null jest przyjmowana dla pominiętych kolumn. Rekordy są dodawane na końcu tabeli.

Można też użyć instrukcji INSERT INTO, aby dodać zestaw rekordów z innej tabeli lub kwerendy przez użycie klauzuli SELECT ... FROM jak pokazano powyżej w składni kwerendy dołączającej wiele rekordów. W takim przypadku klauzula SELECT określa pola, które mają zostać dołączone do podanej tabeli cel.

Tabele źródło i cel mogą określać zarówno tabelę, jak i kwerendę. Jeśli określono kwerendę, aparat baz danych Microsoft Jet dołącza rekordy do wszystkich tabel określonych w kwerendzie.

Instrukcja INSERT INTO jest nieobowiązkowa, lecz jeśli występuje, to musi poprzedzać instrukcję SELECT.

Jeśli tabela docelowa zawiera klucz podstawowy, należy zadbać o to, aby dodawać unikatowe wartości, nie będące wartością Null do pola lub pól klucza podstawowego; w przeciwnym wypadku aparat baz danych Microsoft Jet nie doda tych rekordów.

Jeśli dołączasz rekordy do tabeli z polem Autonumer i chcesz przenumerować dołączone rekordy, nie dołączaj pola Autonumer w kwerendzie. Pole Autonumer powinno być włączone do kwerendy, jeśli mają być zachowane oryginalne wartości tego pola.

Klauzula IN służy do dołączania rekordów do tabeli znajdującej się w innej bazie danych.

Aby utworzyć nową tabelę, należy zamiast kwerendy tworzącej tabelę użyć instrukcji SELECT... INTO.

Aby przed uruchomieniem kwerendy dołączającej dowiedzieć się, które rekordy zostaną dołączone, należy najpierw wykonać i obejrzeć wyniki kwerendy wybierającej, używając tych samych kryteriów wyboru.

Kwerenda dołączająca kopiuje rekordy z jednej lub wielu tabel do innej tabeli. Tabele, które zawierają rekordy, nie są zmieniane przez kwerendę dołączającą.

Zamiast dołączać istniejące rekordy z innej tabeli, można określić wartość każdego pola w pojedynczym nowym rekordzie, używając do tego celu klauzuli VALUES. Jeśli pominięto listę pól, to klauzula VALUES musi zawierać wartość dla każdego pola tabeli; w przeciwnym przypadku operacja INSERT nie powiedzie się. Instrukcji INSERT INTO z klauzulą VALUES należy użyć do dołączenia każdego nowego rekordu.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
IN – klauzula (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) |

Przykład

INSERT INTO – przykład instrukcji


INSERT INTO - przykład instrukcjii (DAO)

INSERT INTO – przykład instrukcji

W tym przykładzie wybierane są wszystkie rekordy z hipotetycznej tabeli NowiKlienci, po czym są one dodawane do tabeli Klienci. Ponieważ nie są podane konkretne kolumny, nazwy kolumn tabeli, której dotyczy instrukcja SELECT, muszą dokładnie odpowiadać nazwom kolumn z tabeli, której dotyczy INSERT INTO.

Sub InsertIntoX1()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz wszystkie rekordy z tabeli NowiKlienci

    ' i dodaj je do tabeli Klienci.

    dbs.Execute " INSERT INTO Klienci " _

        & "SELECT * " _

        & "FROM [NowyKlienci];"

    dbs.Close

End Sub

W tym przykładzie tworzony jest nowy rekord w tabeli Pracownicy.

Sub InsertIntoX2()

    Dim dbs As Database

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Utwórz nowy rekord w tabeli Pracownicy.

    ' Imię brzmi Piotr, nazwisko - Czarniecki,

    ' zaś tytuł - Stażysta.

    dbs.Execute " INSERT INTO Pracownicy " _

        & "(Imię,Nazwisko, Tytuł) VALUES " _

        & "('Piotr', 'Czarniecki', 'Stażysta');"

    dbs.Close

End Sub


IN - przykład klauzulii (DAO)

IN – przykład klauzuli

W poniższej tabeli pokazano, jak klauzula IN może być użyta do pobierania danych z zewnętrznej bazy danych. W każdym z przykładów przyjęto, że w zewnętrznej bazie danych jest przechowywana hipotetyczna tabela Klienci.

Zewnętrzna baza danych Instrukcja SQL
baza danych Microsoft® Jet SELECT KodKlienta
FROM Klienci
IN OtherDB.mdb
WHERE KodKlienta Like "A*";
dBASE III lub IV.
Aby pobrać dane z tabeli bazy danych dBASE III, należy zastąpić "dBASE IV;" przez "dBASE III;". 		SELECT KodKlienta
FROM Klienci
IN "C:\DBASE\DATA\SALES" "dBASE IV;"
WHERE KodKlienta Like "A*";
dBASE III lub IV przy użyciu składni z Database. SELECT KodKlienta
FROM Klienci
IN "" [dBASE IV; Database=C:\DBASE\DATA\SALES;]
WHERE KodKlienta Like "A*";
Paradox 3.x lub 4.x.
Aby pobrać dane z tabeli bazy danych Paradox wersja 3.x, należy zastąpić "Paradox 4.x;" przez "Paradox 3.x;". 		SELECT KodClienta
FROM Klienci
IN "C:\PARADOX\DATA\SALES" "Paradox 4.x;"
WHERE KodClienta Like "A*";
Paradox 3.x lub 4.x przy użyciu składni z Database. SELECT KodClienta
FROM Klienci
IN "" [Paradox 4.x;Database=C:\PARADOX\DATA\SALES;]
WHERE KodClienta Like "A*";
Arkusz kalkulacyjny Microsoft Excel SELECT KodKlienta, NazwaFirmy
FROM Klienci
IN "c:\documents\xldata.xls" "EXCEL 5.0;"
WHERE KodKlienta Like "A*"
ORDER BY KodKlienta;
Nazwany zakres arkuszu kalkulacyjnego SELECT KodKlienta, NazwaFirmy
FROM [Klienci$]
IN "c:\documents\xldata.xls" "EXCEL 5.0;"
WHERE KodKlienta Like "A*"
ORDER BY KodKlienta;


SQL - typy danychSQL - typy danych

SQL – typy danych

Typy danych języka SQL aparatu baz danych Microsoft Jet składają się z 13 podstawowych typów danych zdefiniowanych przez aparat baz danych Microsoft Jet oraz kilkunastu dopuszczalnych synonimów tych typów.

Poniższa tabela zawiera podstawowe typy danych. Synonimy podano pod hasłem Słowa zastrzeżone w języku SQL aparatu baz danych Microsoft Jet.

Typ danych | Rozmiar w pamięci | Opis
BINARY | 1 bajt na znak | W polu tego typu może być przechowywany dowolny typ danych. Nie jest wykonywana żadna translacja danych (na przykład na tekst). Sposób wprowadzenia danych w pole binarne narzuca sposób ich wyprowadzania.
BIT | 1 bajt | Wartości Tak i Nie oraz pola zawierające tylko jedną z dwóch wartości.
TINYINT | 1 bajt | Wartość całkowita z przedziału od 0 do 255.
MONEY | 8 bajtów | Skalowana liczba całkowita z przedziału od – 922 337 203 685 477,5808 do 922 337 203 685 477,5807.
DATETIME (Zob. DOUBLE) | 8 bajtów | Wartość oznaczająca datę lub godzinę z przedziału lat od 100 do 9999.
UNIQUEIDENTIFIER | 128 bitów | Unikatowy numer identyfikacyjny stosowany podczas zdalnego wywołania procedur.
REAL | 4 bajtów | Wartość zmiennoprzecinkowa pojedynczej precyzji z zakresu od – 3,402823E38 do – 1,401298E-45 dla wartości ujemnych, od 1,401298E-45 do 3,402823E38 dla wartości dodatnich oraz 0.
FLOAT | 8 bajtów | Wartość zmiennoprzecinkowa podwójnej precyzji z zakresu od – 1,79769313486232E308 do – 4,94065645841247E-324 dla wartości ujemnych, od 4,94065645841247E-324 do 1,79769313486232E308 dla wartości dodatnich oraz 0.
SMALLINT | 2 bajtów | Liczba całkowita pojedynczej precyzji z zakresu od – 32,768 do 32,767. (Zob. "Uwagi")
INTEGER | 4 bajtów | Liczba całkowita podwójnej precyzji z zakresu od – 2,147,483,648 do 2,147,483,647. (Zob. "Uwagi")
DECIMAL | 17 bajtów | Dokładny typ numeryczny, który przyjmuje wartości danych od 1028 - 1 do – 1028 - 1. Można zdefiniować obie precyzje (1 - 28) oraz skalę (0 – definiowana precyzja). Domyślną precyzją i skalą są odpowiednio 18 i 0.
TEXT | 2 bajty na znak (Zob. "Uwagi") | Od zera do maksymalnie 2,14 gigabajta.
IMAGE | Według wymagań | Od zera do maksymalnie 2,14 gigabajta. Stosowany dla obiektów OLE.
CHARACTER | 2 bajty na znak (Zob. "Uwagi") | Od zera do 255 znaków.

Uwagi

  • Obie wartości początkowa oraz przyrost mogą być modyfikowane za pomocą instrukcji ALTER TABLE. Nowe wiersze wstawione do tabeli będą zawierać wartości automatycznie generowane dla kolumny na podstawie wartości początkowej i przyrostu. Jeśli nowa wartość początkowa i przyrost mogą generować wartości, które odpowiadają wartościom generowanym na podstawie poprzedniej wartości początkowej i przyrostu, wtedy będą generowane duplikaty. Jeżeli kolumna jest kluczem podstawowym, to wstawianie nowych wierszy może powodować występowanie błedów, jeśli generowane są duplikaty.
  • Aby znaleźć ostatnią wartość, która została użyta dla kolumny typu Autonumer, należy użyć następującej instrukcji: SELECT @@IDENTITY. Nie można określić nazwy tabeli. Wartość zwrócona pochodzi z ostatniej tabeli, zawierającej kolumnę typu Autonumer, która była uaktualniona.
  • Znaki w polach zdefiniowanych jako TEXT (znanych także jako MEMO) lub CHAR (znanych także jako TEXT(n) o określonej długości) są przechowywane w formacie reprezentacji Unicode. Znaki w reprezentacji Unicode niezmiennie wymagają dwóch bajtów dla każdego znaku. Dla istniejących baz danych aparatu Microsoft® Jet które zawierają głównie dane znakowe mogłoby to oznaczać, że rozmiar bazy danych niemalże podwoiłby się po konwersji do formatu Microsoft Jet w wersji 4.0. Jednakże reprezentacja Unicode wielu zestawów znaków poprzednio jednobajtowych (SBCS), może łatwo być skompresowana do jednego bajtu. Aby uzyskać więcej informacji, zobacz temat CREATE TABLE. Jeśli kolumna CHAR zostanie zdefiniowana z tym atrybutem, dane automatycznie będą skompresowane jako że są one zapisywane i dekompresowane w momencie pobrania z kolumny.
Zobacz też
Odpowiedniki typów danych w ANSI SQL Słowa zastrzeżone w języku SQL aparatu bazy danych Microsoft Jet


SQL - słowa zastrzeżoneSQL - słowa zastrzeżone

SQL – słowa zastrzeżone

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Poniższa lista zawiera wszystkie słowa zastrzeżone stosowane przez aparat bazy danych Microsoft Jet w instrukcji SQL. Słowa na liście, które nie są napisane w całości wielkimi literami są także zastrzeżone w innych aplikacjach. W rezultacie, poszczególne tematy pomocy dla tych słów zawierają ogólny opis, który nie koncentruje się na użyciu ich w języku SQL.

Uwaga Słowa, po których następuje znak gwiazdki (*), są zastrzeżone, ale obecnie nie mają znaczenia w kontekście instrukcji SQL aparatu Microsoft Jet (na przykład Level i TableID). Słowa, które nie są podkreślone, nie mają połączenia z objaśnieniami.

A

ABSOLUTE | ANY
ADD | ARE
ADMINDB | AS
ALL | ASC
Alphanumeric — zob. TEXT | ASSERTION
ALTER | AUTHORIZATION
ALTER TABLE | AUTOINCREMENT — zob. COUNTER
And | Avg
AS |

B-C

BEGIN | COLLATION
Between | COLUMN
BINARY | COMMIT
BIT | COMP, COMPRESSION
BIT_LENGTH | CONNECT
BOOLEAN — zob. BIT | CONNECTION
BOTH | CONSTRAINT, CONSTRAINTS
BY | CONTAINER
BYTE | CONTAINS
CASCADE | CONVERT
CATALOG | Count
CHAR, CHARACTER — zob. TEXT | COUNTER
CHAR_LENGTH | CREATE
CHARACTER_LENGTH | CURRENCY
CHECK | CURRENT_DATE
CLOSE | CURRENT_TIME
CLUSTERED | CURRENT_TIMESTAMP
COALESCE | CURRENT_USER
COLLATE | CURSOR

D

DATABASE | DISALLOW
DATE — zob. DATETIME | DISCONNECT
DATETIME | DISTINCT
DAY | DISTINCTROW
DEC, DECIMAL | DOMAIN
DECLARE | DOUBLE
DELETE | DROP
DESC |

E-H

Eqv | FOREIGN
EXCLUSIVECONNECT | FROM
EXEC, EXECUTE | FROM Clause
EXISTS | GENERAL zob. LONGBINARY
EXTRACT | GRANT
FALSE | GROUP
FETCH | GUID
FIRST | HAVING
FLOAT, FLOAT8 — zob. DOUBLE | HOUR
FLOAT4 — zob. SINGLE |

I

IDENTITY | INPUT
IEEEDOUBLE — zob. DOUBLE | INSENSITIVE
IEEESINGLE — zob. SINGLE | INSERT
IGNORE | INSERT INTO
IMAGE | INT, INTEGER, INTEGER4 — zob. LONG
Imp | INTEGER1 — zob. BYTE
In | INTEGER2 — zob. SHORT
IN | INTERVAL
INDEX | INTO
INDEXCREATEDB | Is
INNER | ISOLATION

J-M

JOIN | LONGTEXT
KEY | LOWER
LANGUAGE | MATCH
LAST | Max
LEFT | MEMO — zob. LONGTEXT
Level* | Min
Like | MINUTE
LOGICAL, LOGICAL1 — zob. BIT | Mod
LONG | MONEY — zob. CURRENCY
LONGBINARY | MONTH
LONGCHAR |

N-P

NATIONAL | Outer*
NCHAR | OUTPUT
NONCLUSTERED | OWNERACCESS
Not | PAD
NTEXT | PARAMETERS
NULL | PARTIAL
NUMBER — zob. DOUBLE | PASSWORD
NUMERIC — See DECIMAL | PERCENT
NVARCHAR | PIVOT
OCTET_LENGTH | POSITION
OLEOBJECT — zob. LONGBINARY | PRECISION
ON | PREPARE
OPEN | PRIMARY
OPTION | PRIVILEGES
Or | PROC, PROCEDURE
ORDER | PUBLIC

Q-S

REAL — zob. SINGLE | SMALLDATETIME
REFERENCES | SMALLINT — zob. SHORT
RESTRICT | SMALLMONEY
REVOKE | SOME
RIGHT | SPACE
ROLLBACK | SQL
SCHEMA | SQLCODE, SQLERROR, SQLSTATE
SECOND | StDev
SELECT | StDevP
SELECTSCHEMA | STRING — zob. TEXT
SELECTSECURITY | SUBSTRING
SET | Sum
SHORT | SYSNAME
SINGLE | SYSTEM_USER
SIZE |

T-Z

TABLE | UPDATEOWNER
TableID* | UPDATESECURITY
TEMPORARY | UPPER
TEXT | USAGE
TIME — zob. DATETIME | USER
TIMESTAMP | USING
TIMEZONE_HOUR | VALUE
TIMEZONE_MINUTE | VALUES
TINYINT | Var
TO | VARBINARY — zob. BINARY
TOP | VARCHAR — zob. TEXT
TRAILING | VarP
TRANSACTION | VARYING
TRANSFORM | VIEW
TRANSLATE | WHEN
TRANSLATION | WHENEVER
TRIM | WHERE
TRUE | WITH
UNION | WORK
UNIQUE | Xor
UNIQUEIDENTIFIER | YEAR
UNKNOWN | YESNO — See BIT
UPDATE | ZONE
UPDATEIDENTITY |


Porównanie języków Microsoft Jet SQL i ANSI SQLPorównanie języków Microsoft Jet SQL i ANSI SQL

Język SQL aparatu baz danych Microsoft Jet jest ogólnie zgodny z standardem ANSI-89 Level 1. Mimo tego, pewne cechy ANSI SQL nie zostały zaimplementowane w języku SQL aparatu Microsoft® Jet. W wersji 4.X aparatu Microsoft Jet, mechanizm Microsoft OLE DB Provider dla aparatu Jet zapewnia więcej możliwości składni ANSI-92 SQL. Na odwrót, Microsoft Jet SQL zawiera słowa zastrzeżone i elementy, które nie występują w ANSI SQL.

Główne różnice
  • Microsoft Jet SQL oraz ANSI SQL mają różne słowa zastrzeżone i typy danych. Aby uzyskać więcej informacji, zobacz temat Słowa zastrzeżone w języku SQL aparatu baz danych Microsoft Jet oraz Równoważne typy danych ANSI SQL. Przy użyciu mechanizmu Microsoft OLE DB Provider dla aparatu Jet z aparatem bazy danych Jet 4.X, pojawiają się dodatkowe słowa zastrzeżone.
  • Odmienne reguły odnoszą się do konstrukcji Between...And, która ma następującą składnię:

    wyrażenie1 [NOT] Between wartość1 And wartość2

    W języku Microsoft Jet SQL wartość1 może być większa od wartości2; w ANSI SQL wartość1 musi być równa lub mniejsza niż wartość2.

  • Język SQL aparatu bazy danych Microsoft Jet obsługuje zarówno symbole wieloznaczne języka ANSI SQL, jak i specyficzne dla aparatu Microsoft Jet symbole wieloznaczne używane z operatorem Like. Użycie symboli wieloznacznych standardu ANSI i aparatu Microsoft Jet jest rozłączne. Należy używać jednego zestawu lub drugiego, lecz nie można ich łączyć. Symbole wieloznaczne języka ANSI SQL są dostępne jedynie przy użyciu aparatu Jet 4.X i mechanizmu Microsoft OLE DB Provider dla aparatu Jet. Jeżeli nastąpi próba użycia symboli wieloznacznych języka ANSI SQL z poziomu programu Microsoft Access lub DAO, wtedy zostaną one zinterpretowane jako literały. Nie stanie się tak przy użyciu mechanizmu Microsoft OLE DB Provider dla aparatu Jet oraz aparatu Jet w wersji 4.X.

    Pasujący znak Microsoft Jet SQL ANSI SQL
    dowolnego pojedynczego znaku ? _ (podkreślenie)
    zera lub kilku znaków * %

  • Microsoft Jet SQL jest na ogół mniej restrykcyjny. Na przykład, pozwala na grupowanie i porządkowanie według wyrażeń.
  • Microsoft Jet SQL umożliwia stosowanie bardziej uniwersalnych wyrażeń.
Dodatkowe cechy języka Microsoft Jet SQL

Microsoft Jet SQL obejmuje następujące cechy dodatkowe:

· Instrukcję TRANSFORM zapewniającą obsługę kwerend krzyżowych

  • Dodatkowe funkcje agregujące, jak StDev i VarP.

· Deklarację PARAMETERS do definiowania kwerend parametycznych

Elementy ANSI SQL nie istniejące w języku Microsoft Jet SQL

Język Microsoft Jet SQL nie obsługuje następujących cech języka ANSI SQL:

  • Słowa DISTINCT w funkcjach agregacji. Na przykład, język Microsoft Jet SQL nie pozwala na wyrażenie SUM(DISTINCT nazwa_kolumny).
  • Klauzuli LIMIT TO nn ROWS stosowanej w celu ograniczenia liczby wierszy zwracanych przez kwerendę. Aby ograniczać zakres kwerendy, można jedynie używać klauzuli WHERE.
Zobacz też
Odpowiedniki typów danych w ANSI SQL | Słowa zastrzeżone w języku SQL aparatu bazy danych Microsoft Jet
Like – operator (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
Typy danych języka SQL aparatu baz danych Microsoft Jet | Użycie symboli wieloznacznych w porównywaniu ciągów znaków


LEFT JOIN, RIGHT JOIN - operacje (Microsoft Jet SQL)

LEFT JOIN, RIGHT JOIN - operacje

Użyte w dowolnej klauzuli FROM, łączą (scalają) rekordy z tabel źródłowych.

Składnia

FROM tabela_1 [ LEFT | RIGHT ] JOIN tabela_2
ON tabela_1.pole_1 op_por tabela_2.pole_2

Składnia operacji LEFT JOIN i RIGHT JOIN zawiera następujące elementy:

Element | Opis
tabela_1, tabela_2 | Nazwy tabel, których rekordy są łączone (scalane).
pole_1, pole_2 | Nazwy pól sprzęgających. Pola muszą być tego samego typu danych i zawierać ten sam rodzaj danych, ale nie muszą mieć tych samych nazw.
op_por | Dowolny operator porównania: "=", "<", ">", "<=", ">=" lub "<>".

Uwagi

Operacja LEFT JOIN służy do tworzenia sprzężenia zewnętrznego lewostronnego. Sprzężenia zewnętrzne lewostronne włączają wszystkie rekordy z pierwszej (lewej) z dwóch tabel, nawet jeśli w rekordach z drugiej (prawej) tabeli nie istnieją odpowiadające im wartości.

Operacja RIGHT JOIN służy do tworzenia sprzężenia zewnętrznego prawostronnego. Sprzężenia zewnętrzne prawostronne włączają wszystkie rekordy z drugiej (prawej) z dwóch tabel, nawet jeśli w rekordach pierwszej (lewej) tabeli nie istnieją odpowiadające im wartości.

Na przykład, do wybrania wszystkich wydziałów, także tych, do których nie są przypisani pracownicy, należy użyć operacji sprzężenia lewostronnego (operator LEFT JOIN) z tabelą Wydziały (lewa) i tabelą Pracownicy (prawa). Aby wybrać wszystkich pracowników, włączając tych nie przydzielonych do wydziałów, należy użyć operacji RIGHT JOIN.

W poniższym przykładzie pokazano, jak można dokonać sprzężenia tabel Kategorie i Produkty według pola NrKategoria. Kwerenda daje w wyniku listę wszystkich kategorii, w tym również nie zawierających żadnego produktu.

SELECT NazwaKategorii,

NazwaProduktu

FROM Kategorie LEFT JOIN Produkty

ON Kategorie.NrKategorii = Produkty.NrKategorii;

W tym przykładzie, NrKategorii jest polem sprzężonym, ale nie jest uwzględnione w wyniku kwerendy, ponieważ nie jest zawarte w instrukcji SELECT. Aby dołączyć pole sprzężone, należy w instrukcji SELECT dodać nazwę pola — w tym przypadku Kategorie.NrKategorii.

Uwagi

Aby utworzyć kwerendę zawierającą wyłącznie rekordy, w których dane w polach sprzężonych są takie same, należy użyć operacji INNER JOIN.

  • Operacje LEFT JOIN i RIGHT JOIN mogą być zagnieżdżane wewnątrz operacji INNER JOIN, lecz operacja INNER JOIN nie może być zagnieżdżana wewnątrz operacji LEFT JOIN lub RIGHT JOIN. Pod hasłem INNER JOIN można znaleźć rozważania dotyczące zagnieżdżeń sprzężeń.
  • Można łączyć wiele klauzul ON. Pod hasłem INNER JOIN można znaleźć rozważania dotyczące łączenia klauzul. Wyjaśniono tam, jak należy dokonywać tej operacji.

Podczas próby sprzęgania pól zawierających dane typu Memo lub obiekt OLE występuje błąd.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) | UNION – operacja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) |

Przykład

LEFT JOIN, RIGHT JOIN – przykład operacji


LEFT JOIN, RIGHT JOIN - przykład operacjii (DAO)

LEFT JOIN, RIGHT JOIN – przykład operacji

W tym przykładzie przyjęto, że w tabeli Pracownicy istnieją hipotetyczne pola Nazwa wydziału i Nr wydziału. Należy zauważyć, że w tabeli Pracownicy znajdującej się w bazie danych Northwind nie ma takich pól.

W tym przykładzie wybierane są wszystkie wydziały, w tym również te, w których nikt nie pracuje.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub LeftRightJoinX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz wszystkie wydziały, również te,

    ' w których nikt nie pracuje.

    Set rst = dbs.OpenRecordset _

        ("SELECT [Nazwa wydziału], " _

        & "Imię & Chr(32)& Nazwisko AS PełneNazwisko " _

        & "FROM Wydziały LEFT JOIN Pracownicy " _

        & "ON Wydziały.[Nr wydziału] = " _

        & "Pracownicy.[Nr wydziału] " _

        & "ORDER BY [Nazwa wydziału];")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 20

    dbs.Close

End Sub


Like - operator (Microsoft Jet SQL)

Like - operator

Porównuje wyrażenie znakowe do wzorca w wyrażeniu SQL.

Składnia

wyrażenie Like "wzorzec"

Składnia operatora Like zawiera następujące elementy:

Element | Opis
wyrażenie | Wyrażenie SQL stosowane w klauzuli WHERE.
wzorzec | Ciąg znaków lub literał znakowy, z którym porównywane jest wyrażenie.

Uwagi

Operator Like może być wykorzystywany do wyszukiwania wartości pola, które pasują do określonego wzorca. Definiując wzorzec, można wskazać pełną wartość (na przykład, Like "Kowalski") lub zastosować symbole wieloznaczne, aby znaleźć zakres wartości (na przykład, Like "Kow*").

W wyrażeniu operator Like może służyć do porównywania wartości pola z wyrażeniem znakowym. Na przykład, użycie Like "C*" w kwerendzie SQL powoduje zwrócenie wszystkich wartości pól zaczynających się na literę C. W kwerendzie parametrycznej można zażądać, aby użytkownik podał wzorzec dla poszukiwań.

Następujący przykład zwraca dane zaczynające się na literę P, po której następuje dowolna litera z przedziału od A do F i trzy cyfry:

Like "P[A-F]###"

Poniższa tabela prezentuje sposób użycia operatora Like do sprawdzania zgodności wyrażeń z różnymi wzorcami.

Rodzaj dopasowania | Wzorzec | Pasuje (zwraca True) | Nie pasuje (zwraca False)
Wiele znaków | a*a | aa, aBa, aBBBa | aBC
 | *ab* | abc, AABB, Xab | aZb, bac
Znak specjalny | a[*]a | a*a | aaa
Wiele znaków | ab* | abcdefg, abc | cab, aab
Pojedynczy znak | a?a | aaa, a3a, aBa | aBBBa
Pojedyncza cyfra | a#a | a0a, a1a, a2a | aaa, a10a
Zakres znaków | [a-z] | f, p, j | 2, &
Poza zakresem | [!a-z] | 9, &, % | b, a
Nie cyfra | [!0-9] | A, a, &, ~ | 0, 1, 9
Kombinacja | a[!b-m]# | An9, az0, a99 | abc, aj0

Zobacz też
Wyrażenia SQL | Stosowanie symboli wieloznacznych przy porównywaniu ciągów znaków
WHERE – klauzula (Microsoft Jet SQL) |

Przykład

Like - przykład operatora


Like - operator - przykładi (DAO)

Like – operator - przykład

W tym przykładzie zwracana jest lista pracowników o nazwiskach zaczynających się na literę od A do D.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub LikeX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Zwróć listę pracowników o nazwiskach

    ' zaczynających się na literę od A do D.

    Set rst = dbs.OpenRecordset("SELECT Nazwisko," _

        & " Imię FROM Pracownicy" _

        & " WHERE Nazwisko Like '[A-D]*';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 20

    dbs.Close

End Sub


Min, Max - funkcje (Microsoft Jet SQL)

Min, Max - funkcje

Zwracają wartość minimalną lub maksymalną zbioru wartości zawartych w określonym kwerendą polu.

Składnia

Min(wyrażenie)

Max(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których chcemy użyć, lub wyrażenie wykonujące obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Funkcji Min i Max można użyć do określenia najmniejszej i największej wartości pola z określonej grupy rekordów. Na przykład, można użyć tych funkcji do obliczenia najniższego i najwyższego kosztu frachtu. Jeżeli nie jest określone grupowanie, to brana jest pod uwagę cała tabela.

Funkcji Min i Max można użyć w wyrażeniu kwerendy i we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Zobacz też

Funkcje agregujące SQL (SQL)

Przykład

Min, Max – funkcje - przykład


Min i Max - funkcje - przykładi (DAO)

Min i Max – funkcje - przykład

W tym przykładzie tabela Zamówienia jest używana do znalezienia najniższych i najwyższych kosztów frachtu zamówień wysłanych do Wielkiej Brytanii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub MinMaxX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Zwróć wartości najniższej i najwyższej opłaty

    ' za fracht za zamówienia wysłane do Wielkiej

    Set rst = dbs.OpenRecordset("SELECT " _

        & "Min(Fracht) AS [Najniższy fracht], " _

        & "Max(Fracht)AS [Najwyższy fracht] " _

        & "FROM Zamówienia WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    dbs.Close

End Sub


Funkcje skalarne ODBCFunkcje skalarne ODBC

Funkcje skalarne ODBC

Język SQL aparatu Microsoft® Jet obsługuje składnię zdefiniowaną w ODBC dla funkcji skalaranych. Na przykład, kwerenda:

SELECT DAILYCLOSE, DAILYCHANGE FROM DAILYQUOTE
WHERE {fn ABS(DAILYCHANGE)} > 5

zwróci wszystkie wiersze, w których wartość bezwzględna zmiany ceny akcji jest większa niż pięć.

Obsługiwany jest podzbiór funkcji skalarnych zdefiniowanych w ODBC. Poniższa tabela wymienia obsługiwane funkcje.

Dalsze informacje o opisie argumentów i pełne objaśnienie składni włączania funkcji w instrukcje SQL można znaleźć w dokumentacji ODBC.

Funkcje obsługi ciągów
ASCII | LENGTH | RTRIM
CHAR | LOCATE | SPACE
CONCAT | LTRIM | SUBSTRING
LCASE | RIGHT | UCASE
LEFT |  |

Funkcje numeryczne
ABS | FLOOR | SIN
ATAN | LOG | SQRT
CEILING | POWER | TAN
COS | RAND | MOD
EXP | SIGN |

Funkcje czasu i daty
CURDATE | DAYOFYEAR | MONTH
CURTIME | YEAR | WEEK
NOW | HOUR | QUARTER
DAYOFMONTH | MINUTE | MONTHNAME
DAYOFWEEK | SECOND | DAYNAME

Konwersja typów danych
CONVERT Literały ciągów mogą być konwertowane do następujących typów danych: SQL_FLOAT, SQL_DOUBLE, SQL_NUMERIC, SQL_INTEGER, SQL_REAL, SQL_SMALLINT, SQL_VARCHAR oraz SQL_DATETIME.

Zobacz też

Konfigurowanie aparatu baz danych Microsoft Jet do współpracy z ODBC


ORDER BY - klauzula (Microsoft Jet SQL)

ORDER BY - klauzula

Sortuje rekordy będące wynikiem kwerendy rosnąco lub malejąco według wartości określonego pola lub pól.

Składnia

SELECT lista_pól
FROM tabela
WHERE kryteria_wyboru
[ORDER BY pole1 [ASC | DESC ][, pole2 [ASC | DESC ]][, ...]]]

Składnia instrukcji SELECT z klauzulą ORDER BY zawiera następujące elementy:

Element | Opis
lista_pól | Nazwy pobieranych pól, którym mogą towarzyszyć aliasy nazw pól, funkcje agregujące SQL, predykaty wyboru (ALL, DISTINCT, DISTINCTROW, lub TOP) albo inne opcje instrukcji SELECT.
tabela | Nazwa tabeli, z której pobierane są rekordy. Więcej informacji można znaleźć w opisie klauzuli FROM.
kryteria_wyboru | Kryteria wyboru. Jeśli instrukcja zawiera klauzulę WHERE, aparat bazy danych Microsoft Jet porządkuje wartości dopiero po zastosowaniu do rekordów warunków wymienionych w klauzuli WHERE.
pole_1, pole_2 | Nazwy pól, względem których sortowane są rekordy.

Uwagi

Klauzula ORDER BY jest nieobowiązkowa. Jednak trzeba użyć, aby pobierane dane były prezentowane w określonej kolejności.

Domyślną kolejnością sortowania jest kolejność rosnąca (A do Ż, 0 do 9). W obu poniższych przykładach dane o pracownikach (nazwisko i imię) wyświetlane są alfabetycznie według nazwisk:

SELECT Nazwisko, Imię

FROM Pracownicy

ORDER BY Nazwisko;

SELECT Nazwisko, Imię

FROM Pracownicy

ORDER BY Nazwisko ASC;

Aby zmienić kolejność sortowania na malejącą (Ż do A, 9 to 0), należy za każdym z pól, któremu ma odpowiadać kolejność malejąca, umieścić zastrzeżone słowo DESC. W kolejnym przykładzie pobierane są wynagrodzenia pracowników i sortowane są w kolejności malejącej:

SELECT Nazwisko, Wynagrodzenie

FROM Pracownicy

ORDER BY Wynagrodzenie DESC, Nazwisko;

W przypadku umieszczenia na liście klauzuli ORDER BY pól zawierających dane typu Memo lub obiekt OLE wystąpi błąd. Aparat bazy danych Microsoft Jet nie sortuje pól tych typów.

Klauzula ORDER BY jest zazwyczaj ostatnim elementem instrukcji SQL.

Klauzula ORDER BY może zawierać nazwy kilku pól. Rekordy są sortowane najpierw według wartości pola zajmującego pierwsze miejsce na liście klauzuli ORDER BY. Rekordy o identycznych wartościach w tych polach są następnie sortowane według wartości drugiego pola, i tak dalej.

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
HAVING – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)

Przykład

ORDER BY – przykład klauzuli


ORDER BY - przykład klauzuli i (DAO)

ORDER BY – przykład klauzuli

Występująca w poniższym przykładzie instrukcja SQL używa klauzuli ORDER BY do sortowania nazwisk w porządku malejącym (od Ż do A).

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub OrderByX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz nazwiska i imiona zawarte

    ' w tabeli Pracownicy i następnie posortuj je

    ' według nazwisk w porządku malejącym.

Set rst = dbs.OpenRecordset("SELECT Nazwisko, " _

        & "Imię FROM Pracownicy " _

        & "ORDER BY Nazwisko DESC;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

' Wywołaj procedurę WyliczPola w celu wydrukowania

' zawartości obiektu Recordset.

    WyliczPola rst, 12

    dbs.Close

End Sub


PARAMETERS - deklaracja (Microsoft Jet SQL)

PARAMETERS - deklaracja

Deklaruje nazwę i typ danych każdego parametru w kwerendzie parametrycznej.

Składnia

PARAMETERS nazwa typ_danych [,nazwa typ_danych [, ...]]

Składnia deklaracji PARAMETERS zawiera następujące elementy:

Element | Opis
nazwa | Nazwa parametru. Przypisana do właściwości Name obiektu Parameter jest używana do identyfikacji tego parametru w kolekcji Parameters. Można użyć nazwy jako ciągu znaków wyświetlanego w oknie dialogowym przy uruchomieniu kwerendy przez aplikację. Tekst zawierający odstępy lub znaki przestankowe musi być ujęty w nawiasy kwadratowe ([]). Na przykład, [Niska cena] i [Od którego miesiąca rozpocząć raport?] są poprawnymi nazwami.
typ_danych | Jeden z podstawowych typów danych języka SQL aparatu bazy danych Microsoft Jet lub ich synonimów.

Uwagi

Dla wielokrotnie uruchamianych kwerend można użyć deklaracji PARAMETERS w celu utworzenia kwerendy parametrycznej. Kwerenda parametryczna ułatwia automatyzację procesu zmiany kryteriów kwerendy. Podczas każdego uruchomienia kwerendy kod będzie musiał przekazać do niej parametry.

Deklaracja PARAMETERS jest nieobowiązkowa, lecz jeśli występuje, musi poprzedzać wszelkie inne instrukcje, w tym instrukcje SELECT.

Jeśli deklaracja zawiera kilka parametrów, to należy oddzielić je przecinkami. Następujący przykład zawiera dwa parametry:

PARAMETERS [Niska cena] Currency, [Data rozpoczęcia] DateTime;

Można użyć nazwy ale nie typu danych w klauzuli WHERE lub HAVING. W poniższym przykładzie oczekiwane są dwa parametry, a następnie kryteria stosowane są do rekordów w tabeli Zamówienia:

PARAMETERS [Niska cena] Currency,

[Data rozpoczęcia] DateTime;

SELECT NrZamówienia, IlośćZamówiona

FROM Zamówienia

WHERE IlośćZamówiona > [Niska cena]

AND DataZamówienia >= [Data rozpoczęcia];

Zobacz też
EXECUTE – instrukcja (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
Typy danych języka SQL aparatu baz danych Microsoft Jet |

Przykład

PARAMETERS – przykład deklaracji


PARAMETERS - przykład deklaracjii (DAO)

PARAMETERS – przykład deklaracji

W tym przykładzie użytkownik powinien podać nazwę stanowiska, które będzie elementem kryterium kwerendy.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub ParametersX()

    Dim dbs As Database, qdf As QueryDef

    Dim rst As Recordset

    Dim strSql As String, strParam As String

    Dim strKomunikat As String

    Dim intPolecenie As Integer

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("NorthWind.mdb")

    ' Zdefiniuj klauzulę parametrów.

    strParm = "PARAMETERS [Tytuł pracownika] CHAR; "

    ' Zdefiniuj instrukcję SQL z klauzulą parametrów.

    strSql = strParm & "SELECT Nazwisko, Imię, " _

        & "NrPracownika " _

        & "FROM Pracownicy " _

        & "WHERE Tytuł = [Tytuł pracownika];"

    ' Utwórz obiekt typu QueryDef bazujący

    ' na instrukcji SQL.

    Set qdf = dbs.CreateQueryDef _

        ("Znajdź pracowników", strSql)

    Do While True

        strKomunikat = _

            "Znajdź pracowników wg stanowiska " _ & Chr(13) _

            & "  Wybierz stanowisko:" & Chr(13) _

            & "   1 - Szef sprzedaży" & Chr(13)  _

            & "   2 - Przedstawiciel handlowy" _

            & Chr(13) _ & "   3 - Koordynator sprzedaży

        intPolecenie = Val(InputBox(strKomunikat))

        Select Case intPolecenie

            Case 1

                qdf("Tytuł pracownika") = _

                    "Szef sprzedaży "

            Case 2

                qdf("Tytuł pracownika") = _

                    "Przedstawiciel handlowy"

            Case 3

                qdf("Tytuł pracownika") = _

                    "Koordynator sprzedaży"

            Case Else

                Exit Do

        End Select

        ' Utwórz tymczasowy obiekt Recordset ' typu utrwalonego.

        Set rst = qdf.OpenRecordset(dbOpenSnapshot)

        ' Zapełnij obiekt Recordset.

        rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

        WyliczPola rst, 12

    Loop

' Ponieważ jest to przykład,

' Usuń obiekt typu QueryDef.

    dbs.QueryDefs.Delete "Znajdź pracowników"

    dbs.Close

End Sub


PROCEDURE - klauzula (Microsoft Jet SQL)

PROCEDURE - klauzula

Definiuje nazwę i nieobowiązkowe parametry kwerendy.

Uwaga Klauzula PROCEDURE została zastąpiona przez instrukcję PROCEDURE. Chociaż klauzula PROCEDURE ciągle jest obsługiwana, instrukcja PROCEDURE zapewnia więcej możliwości niż klauzula PROCEDURE i jest zalecaną składnią.

Składnia

PROCEDURE nazwa [parametr_1 typ_danych[,parametr_2 typ_danych[, ...]]

Składnia klauzuli PROCEDURE zawiera następujące elementy:

Element | Opis
nazwa | Nazwa procedury. Musi ona spełniać wymagania standardowej konwencji nazewnictwa.
parametr_1, parametr_2 | Jedna lub więcej nazw pól lub parametrów. Na przykład: PROCEDURE Sprzedaż_w_krajach [Data rozpoczęcia] DateTime, [Data zakończenia] DateTime; Więcej informacji o parametrach można znaleźć pod hasłem PARAMETERS.
typ_danych | Jeden z podstawowych typów danych języka SQL aparatu bazy danych Microsoft Jet lub ich synonimów.

Uwagi

Procedura SQL składa się z klauzuli PROCEDURE (określającej nazwę procedury), nieobowiązkowej listy definicji parametrów oraz pojedynczej instrukcji SQL. Na przykład, procedura Pobierz_numer_elementu może uruchomić kwerendę pobierającą numer określonego artykułu.

Uwagi

  • Jeśli klauzula zawiera wiele definicji pól (czyli par parametr-typ_danych), to należy je oddzielić przecinkami.
  • Po klauzuli PROCEDURE musi wystąpić instrukcja SQL (na przykład, instrukcja SELECT lub UPDATE).
Zobacz też
DELETE – instrukcja (Microsoft Jet SQL) | PARAMETERS – deklaracja (Microsoft Jet SQL)
EXECUTE – instrukcja (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
Typy danych języka SQL aparatu baz danych Microsoft Jet | UPDATE – instrukcja (Microsoft Jet SQL)

Przykład

CREATE PROCEDURE - instrukcja, PROCEDURE - przykład klauzuli


CREATE PROCEDURE - instrukcja, PROCEDURE - przykład klauzulii (DAO)

CREATE PROCEDURE - instrukcja, PROCEDURE - przykład klauzuli

W tym przykładzie kwerendzie zostaje nadana nazwa ListaKategorii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub ProcedureX()

    Dim dbs As Database, rst As Recordset

    Dim qdf As QueryDef, strSql As String

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    strSql = "PROCEDURE ListaKategorii; " _

        & "SELECT DISTINCTROW NazwaKategorii, " _

        & "NrKategorii FROM Kategorie " _

        & "ORDER BY NazwaKategorii;"

    ' Utwórz nazwany obiekt typu QueryDef

' bazujący na instrukcji SQL.

Set qdf = dbs.CreateQueryDef("NowaKwerenda ", strSql)

' Utwórz tymczasowy obiekt Recordset

' typu utrwalonego.

    Set rst = qdf.OpenRecordset(dbOpenSnapshot)

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

' Ponieważ jest to przykład,

' Usuń obiekt typu QueryDef.

    dbs.QueryDefs.Delete "NowaKwerenda"

    dbs.Close

End Sub


REVOKE - instrukcja (Microsoft Jet SQL)

REVOKE - instrukcja

Odwołuje określone przywileje dla istniejącego użytkownika lub grupy.

Składnia

REVOKE {przywilej[, przywilej, …]} ON
{TABLE tabela |
OBJECT obiekt|

CONTAINTER kontener}
FROM {nazwa_autoryzowanego [, nazwa_autoryzowanego, …]}

Składnia instrukcja REVOKE zawiera następujące elementy:

Element | Opis
przywilej | Przywilej lub przywileje, które mają zostać odwołane. Przywileje określone są przy pomocy następujących słów kluczowych: SELECT, DELETE, INSERT, UPDATE, DROP, SELECTSECURITY, UPDATESECURITY, DBPASSWORD, UPDATEIDENTITY, CREATE, SELECTSCHEMA, SCHEMA i UPDATEOWNER.
tabela | Jakakolwiek poprawna nazwa tabeli.
obiekt | Nie musi być to obiekt typu tabela. Przechowywana na serwerze SQL kwerenda (widok lub procedura) może posłużyć za przykład.
kontener | Nazwa prawidłowego kontenera.
nazwa_autoryzowanego | Nazwa użytkownika lub grupy.

Zobacz też
ADD USER - instrukcja | CREATE TABLE – instrukcja
ALTER USER lub DATABASE - instrukcja | CREATE USER lub GROUP - instrukcja
ALTER TABLE - instrukcja | CREATE VIEW - instrukcja
CONSTRAINT - klauzula | DROP - instrukcja
CREATE INDEX – instrukcja | DROP USER lub GROUP - instrukcja
CREATE PROCEDURE - instrukcja | GRANT - instrukcja


SELECT - instrukcja (Microsoft Jet SQL)

SELECT - instrukcja

Powoduje pobranie z bazy danych przez aparat baz danych Microsoft Jet informacji w postaci zestawu rekordów.

Składnia

SELECT [predykat] { * | tabela.* | [tabela.]pole1 [AS alias1] [, [tabela.]pole2 [AS alias2] [, ...]]}
FROM wyrażenie_tabelowe [, ...] [IN zewnętrzna_baza_danych]
[WHERE... ]
]
[GROUP BY... ]
]
[HAVING... ]
]
[ORDER BY... ]
WITH OWNERACCESS OPTION;

Składnia instrukcji SELECT zawiera następujące elementy:

Element | Opis
predykat | Jeden z następujących predykatów: ALL, DISTINCT, DISTINCTROW lub TOP. Predykat służy do ograniczenia liczby zwracanych rekordów. Jeśli nie podano żadnego predykatu, domyślnie przyjmuje się predykat ALL.
* | Wskazuje, że wybrane mają być wszystkie pola z podanej tabeli lub tabel.
tabela | Nazwa tabeli zawierającej pola, które składają się na rekordy będące wynikiem instrukcji.
pole_1, pole_2 | Nazwy pól zawierających dane, które mają być pobrane. Jeśli podano kilka pól, są one pobierane w kolejności podanej na liście.
alias1, alias2 | Nazwy, które zostaną użyte jako nagłówki kolumn w miejsce nazw kolumn z tabeli.
wyrażenie_tabelowe | Nazwa tabeli lub tabel z których mają być pobrane dane.
zewnętrzna_baza_danych | Nazwa bazy danych zawierającej tabele wymienione w wyrażeniu_tabelowym, o ile nie znajdują się one w bieżącej bazie danych.

Uwagi

Realizując tę operację, aparat bazy danych Microsoft® Jet przeszukuje wskazaną tabelę lub tabele, pobiera określone kolumny, wybiera wiersze spełniające podane kryterium wyboru, po czym sortuje lub grupuje te wiersze zgodnie z określonym w instrukcji porządkiem.

Instrukcje SELECT nie zmieniają danych w bazie danych.

Słowo SELECT jest zazwyczaj pierwszym słowem instrukcji SQL. Większość instrukcji SQL to albo instrukcje SELECT, albo instrukcje SELECT...INTO.

Minimalna postać składni instrukcji SELECT jest następująca:

SELECT pola FROM tabela

Aby wybrać wszystkie pola z tabeli, należy użyć znaku gwiazdki (*). W poniższym przykładzie wybierane są wszystkie pola z tabeli Pracownicy:

SELECT * FROM Pracownicy;

Jeśli dana nazwa pola występuje w kilku tabelach wymienionych w klauzuli FROM, należy tę nazwę pola poprzedzić nazwą tabeli i operatorem . (kropka). W kolejnym przykładzie pole Dział występuje zarówno w tabeli Pracownicy, jak i w tabeli Kierownicy. Instrukcja SQL pobiera działy z tabeli Pracownicy i nazwiska kierowników działów z tabeli Kierownicy:

SELECT Pracownicy.Dział, Kierownicy.NazwiskoKierownika

FROM Pracownicy INNER JOIN Kierownicy

WHERE Pracownicy.Dział = Kierownicy.Dział;

Przy tworzeniu obiektu Recordset, aparat bazy danych Microsoft Jet używa nazwy pola tabeli jako nazwy obiektu Field w obiekcie Recordset. Jeżeli chcesz nadać inną nazwę polu, lub gdy nazwa nie jest zasugerowana przez wyrażenie użyte do utworzenia pola, użyj słowa zastrzeżonego AS. W poniższym przykładzie słowem Urodz nazwano obiekt typu Field w wynikowym obiekcie Recordset:

SELECT DataUrodzenia

AS Urodz FROM Pracownicy;

W każdym przypadku użycia funkcji agregujących lub kwerend dających w wyniku niejednoznaczne lub powtarzające się nazwy obiektów Field, należy za pomocą klauzuli AS podać inną nazwę obiektu Field. W poniższym przykładzie słowo Licznik służy do nadania nazwy zwracanemu przez kwerendę obiektowi Field w wynikowym obiekcie Recordset:

SELECT COUNT(NrPracownika)

AS Licznik FROM Pracownicy;

Pozostałe klauzule instrukcji SELECT służą do ograniczania i organizowania danych zwracanych przez kwerendę. Więcej informacji znajduje się w temacie pomocy klauzuli, której używasz.

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | ORDER BY – klauzula (Microsoft Jet SQL)
DELETE – instrukcja (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | UNION – operacja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | UPDATE – instrukcja (Microsoft Jet SQL)
IN – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
INSERT INTO – instrukcja (Microsoft Jet SQL) | WITH OWNERACCESS OPTION – deklaracja (Microsoft Jet SQL)

Przykład

SELECT - instrukcja, FROM – przykład klauzuli


SELECT...INTO - instrukcja (Microsoft Jet SQL)

SELECT...INTO - instrukcja

Tworzy kwerendę tworzącą tabelę.

Składnia

SELECT pole_1[,pole_2[, ...]] INTO nowa_tabela [IN zewnętrzna_baza_danych]
FROM źródło

Składnia instrukcji SELECT...INTO zawiera następujące elementy:

Element | Opis
pole_1, pole_2 | Nazwy pól, które mają być skopiowane do nowej tabeli.
nowa_tabela | Nazwa tworzonej tabeli. Musi ona spełniać wymagania standardowej konwencji nazewnictwa. Jeśli nowa_tabela ma taką samą nazwę jak tabela już istniejąca, to wystąpi błąd przechwytywalny.
zewnętrzna_baza_danych | Ścieżka do zewnętrznej bazy danych. Opis ścieżki można znaleźć pod hasłem IN.
źródło | Nazwa istniejącej tabeli, z której wybierane są rekordy. Może to być pojedyncza tabela, wiele tabel lub kwerenda.

Uwagi

Kwerend tworzących tabele można używać do archiwizowania rekordów, tworzenia zapasowych kopii tabel lub do tworzenia kopii eksportowanych do innych baz danych lub używanych jako materiał do raportów wyświetlających dane za wybrane okresy. Na przykład, można utworzyć raport sprzedaży miesięcznej w rejonach, uruchamiając co miesiąc tę samą kwerendę tworzącą tabelę.

Uwagi

  • Może zaistnieć potrzeba zdefiniowania dla nowej tabeli klucza podstawowego. Po utworzeniu tabeli jej pola dziedziczą typ danych i rozmiar pola dla każdego pola z tabel będących przedmiotem kwerendy, lecz żadne inne właściwości pól lub tabel nie są przenoszone.
  • Aby dodać dane do istniejącej tabeli, należy zamiast tworzenia kwerendy dołączającej użyć instrukcji INSERT INTO.
  • Aby przed uruchomieniem kwerendy tworzącej tabelę dowiedzieć się, które rekordy zostaną wybrane, należy najpierw obejrzeć wyniki instrukcji SELECT z takimi samymi kryteriami wyboru.
Zobacz też
ALL, DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | UNION – operacja (Microsoft Jet SQL)
IN – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
INSERT INTO – instrukcja (Microsoft Jet SQL) |

Przykład

SELECT...INTO – przykład instrukcji


SELECT...INTO - przykład instrukcjii (DAO)

SELECT...INTO – przykład instrukcji

W tym przykładzie wybierane są wszystkie rekordy tabeli Pracownicy, po czym są one kopiowane do nowej tabeli o nazwie Kopia prac.

Sub SelectIntoX()

    Dim dbs As Database

    Dim qdf As QueryDef

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz wszystkie rekordy tabeli Pracownicy

    ' i skopiuj je do nowej tabeli Kopia prac.

    dbs.Execute "SELECT Pracownicy.* INTO " _

        & "[Kopia prac] FROM Pracownicy;"

    ' Ponieważ jest to przykład, Usuń tabelę.

    dbs.Execute "DROP TABLE [Kopia prac];"

    dbs.Close

End Sub


SELECT - instrukcja i FROM - przykład klauzulii (DAO)

SELECT – instrukcja i FROM – przykład klauzuli

W niektórych z poniższych przykładów przyjęto, że w tabeli Pracownicy znajduje się pole Zarobki. Należy zauważyć, że w tabeli Pracownicy znajdującej się w bazie danych Northwind nie ma takiego pola.

W tym przykładzie tworzony jest obiekt Recordset typu zestaw dynamiczny bazujący na instrukcji SQL, który wybiera pola Nazwisko i Imię ze wszystkich rekordów tabeli Pracownicy. Wywoływana jest procedura WyliczPola drukująca zawartość obiektu Recordset w oknie.

Sub SelectX1()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz nazwiska i imiona ze wszystkich

    ' rekordów tabeli Pracownicy.

Set rst = dbs.OpenRecordset("SELECT Nazwisko, "

        & "Imię FROM Pracownicy;")

    ' Zapełnij obiekt Recordset.

rst.MoveLast

' Wywołaj procedurę WyliczPola w celu

' wydrukowania zawartości obiektu Recordset.

WyliczPola rst,12

dbs.Close

End Sub

W tym przykładzie znajdowana jest liczba rekordów zawierających wartość w polu KodPocztowy, a zwracane pole otrzymuje nazwę Licznik.

Sub SelectX2()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Policz rekordy zawierające wartość KodPocztowy

    ' i zwróć w polu Licznik znalezioną liczbę

    ' rekordów.

Set rst = dbs.OpenRecordset("SELECT Count " _

        & "(KodPocztowy) AS Licznik FROM Klienci;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu wydrukowania

    ' zawartości obiektu Recordset. ' Określ szerokość pola = 12.

    WyliczPola rst, 12

    dbs.Close

End Sub

W tym przykładzie zostaje znaleziona i wyświetlona liczba pracowników oraz ich przeciętne i maksymalne wynagrodzenie.

Sub SelectX3()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

Set dbs = OpenDatabase("Northwind.mdb")

    ' Policz pracowników, oblicz przeciętne

    ' wynagrodzenie i zwróć maksymalne wynagrodzenie.

    Set rst = dbs.OpenRecordset("SELECT Count (*) " _

        & "AS RazemPracowników, Avg(Wynagrodzenie) " _

        & "AS PrzeciętneWynagr, Max(Wynagrodzenie) " _

        & "AS MaksymalneWynagr FROM Pracownicy;")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu wydrukowania

    ' zawartości obiektu Recordset. Przekaż obiekt ' Recordset i

    ' wymaganą szerokość pola.

    WyliczPola rst, 17

    dbs.Close

End Sub

Obiekt Recordset jest przekazywany do procedury Sub o nazwie WyliczPola. Następnie procedura ta formatuje i drukuje pola obiektu Recordset w oknie Debug. Zmienna intDłPola zawiera wymaganą szerokość drukowanego pola. Niektóre pola mogą zostać obcięte.

Sub WyliczPola(rst As Recordset, intDłPola As Integer)

    Dim lngRekordy As Long, lngPola As Long

    Dim lngLiczRek As Long, lngLiczPol As Long

    Dim strTytuł As String, strTymcz As String

    ' W zmiennej lngRekordy umieść liczbę

    ' rekordów obiektu Recordset.

    lngRekordy = rst.RecordCount

    ' W zmiennej lngPola umieść liczbę

    ' pól obiektu Recordset.

    lngPola = rst.Fields.Count

    Debug.Print "Liczba rekordów: " & lngRekordy _

        & " Liczba pól w rekordzie: " & lngPola

    Debug.Print

' Utwórz ciąg znaków służący do drukowania nagłówka

' kolumny.

    strTytuł = "Rekord  "

    For lngLiczPol = 0 To lngPola - 1

        strTytuł = strTytuł _

        & Left(rst.Fields(lngLiczPol).Name _

        & Space(intDłPola), intDłPola)

    Next lngLiczPol

    ' Drukuj nagłówek kolumny.

    Debug.Print strTytuł

    Debug.Print

    ' Przejdź w pętli przez wszystkie elementy ' obiektu Recordset;

    ' wydrukuj liczbę rekordów i wartości pol.

    rst.MoveFirst

    For lngLiczRek = 0 To lngRecordy - 1

        Debug.Print Right(Space(6) & _

            Str(lngLiczRek), 6) & "  ";

        For lngLiczPol = 0 To lngPola - 1

            ' Sprawdź, czy wartość jest równa Null.

            If IsNull(rst.Fields(lngLiczPol)) Then

                strTymcz = "<puste>"

            Else

                ' Wpisz w strTymcz zawartość pola.

                Select Case _

                    rst.Fields(lngLiczPol).Type

                    Case 11

                        strTymcz = ""

                    Case dbText, dbMemo

                        strTymcz = _

                            rst.Fields(lngLiczPol)

                    Case Else

                        strTymcz = _

                            str(rst.Fields(lngLiczPol))

                End Select

            End If

            Debug.Print Left(strTymcz _

                & Space(intDłPola), intDłPola);

        Next lngLiczPol

        Debug.Print

        rst.MoveNext

    Next lngLiczRek

End Sub


StDev, StDevP - funkcje (Microsoft Jet SQL)

StDev, StDevP - funkcje

Zwracają oszacowanie odchylenia standardowego populacji lub próbki populacji w postaci zbioru wartości zawartych w polu określonym kwerendą.

Składnia

StDev(wyrażenie)

StDevP(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których chcemy użyć do obliczeń, lub wyrażenie wykonujące obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Funkcja StDevP przeprowadza obliczenia na populacji, a funkcja StDev na próbce populacji.

Jeżeli kwerenda zawiera mniej niż dwa rekordy (lub nie zawiera żadnego rekordu, w przypadku funkcji StDevP), funkcje te zwracają wartość Null (która wskazuje, że odchylenie standardowe nie może zostać obliczone).

Funkcji StDev i StDevP można użyć w wyrażeniu kwerendy. Można użyć również tego wyrażenia we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Zobacz też
Avg – funkcja (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
SELECT - instrukcja (Microsoft Jet SQL) | SUM - funkcja (Microsoft Jet SQL)

Przykład

StDev, StDevP – funkcje - przykład


StDev, StDevP - funkcje - przykładi (DAO)

StDev, StDevP – funkcje - przykład

W tym przykładzie tabela Zamówienia jest wykorzystywana do oszacowania odchylenia standardowego opłat za fracht za zamówienia wysłane do Wielkiej Brytanii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub StDevX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Oblicz odchylenie standardowe opłat za fracht

    ' za zamówienia wysłane do Wielkiej Brytanii.

    Set rst = dbs.OpenRecordset("SELECT " _

        & "StDev(Fracht) " _

        & "AS [Odch. stand. frachtu] FROM Zamówienia " _

        & "WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    Debug.Print

    Set rst = dbs.OpenRecordset("SELECT " _

        & "StDevP(Fracht) " _

        & "AS [Odch. stand. frachtu (popul.)] " _

        & "FROM Zamówienia " _

        & "WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 15

    dbs.Close

End Sub


Podkwerendy SQL

Podkwerendą jest instrukcja SELECT zagnieżdżona wewnątrz instrukcji SELECT, SELECT...INTO, INSERT...INTO, DELETE, lub UPDATE albo we wnętrzu innej podkwerendy.

Składnia

W celu utworzenia podkwerendy można użyć następujących trzech postaci składni:

porównanie [ANY | ALL | SOME] (instrukcja_sql)

wyrażenie [NOT] IN (instrukcja_sql)

[NOT] EXISTS (instrukcja_sql)

Podkwerenda składa się z następujących elementów:

Element | Opis
porównanie | Wyrażenie i operator porównania porównujący wyrażenie z wynikiem podkwerendy.
wyrażenie | Wyrażenie, którego wartość jest poszukiwana w zbiorze wyników podkwerendy.
instrukcja_sql | Instrukcja SELECT o takim samym formacie i spełniająca te same reguły, co każda instrukcja SQL. Musi być ujęta w nawiasy.

Uwagi

Można użyć podkwerendy zamiast wyrażenia w liście pól instrukcji SELECT lub klauzuli WHERE czy HAVING. W podkwerendzie instrukcja SELECT służy to dostarczenia jednej lub więcej wartości, które biorą udział w obliczaniu wyrażeń klauzul WHERE lub HAVING.

Predykaty ANY oraz SOME, będące synonimami, służą do pobierania rekordów w głównej kwerendzie, spełniających porównanie z dowolnym rekordem pobranym przez podkwerendę. Poniższy przykład zwraca wszystkie wyroby, których cena jednostkowa jest większa niż cena dowolnego innego wyrobu sprzedawanego z rabatem 25 procent lub wyższym:

SELECT * FROM Produkty

WHERE CenaJednostkowa > ANY

(SELECT CenaJednostkowa FROM OpisyZamówień

WHERE Rabat >= .25);

Predykat ALL jest używany do pobierania tylko tych wartości z wyniku głównej kwerendy, które spełniają porównanie ze wszystkimi rekordami pobranymi przez podkwerendę. Jeśli w poprzednim przykładzie zamienimy ANY na ALL, to kwerenda zwróci tylko te produkty, których cena jednostkowa jest większa niż cena wszystkich produktów sprzedawanych z rabatem 25 procent lub wyższym. Jest to o wiele ostrzejsze ograniczenie.

Predykat IN służy do pobierania w głównej kwerendzie tylko tych rekordów, dla których w podkwerendzie istnieją rekordy zawierające takie same wartości. Poniższy przykład zwraca wszystkie produkty sprzedawane z rabatem 25 procent lub wyższym:

SELECT * FROM Produkty

WHERE NrProduktu IN

(SELECT NrProduktu_FROM OpisyZamówień

WHERE Rabat >= .25);

I odwrotnie, można użyć predykatu NOT IN do pobrania w głównej kwerendzie tylko tych rekordów, dla których w podkwerendzie nie istnieją rekordy zawierające takie same wartości.

Predykat EXISTS (z nieobowiązkowym słowem zastrzeżonym NOT) jest używany w porównaniach logicznych do określenia, czy podkwerenda zwróciła jakiekolwiek rekordy.

Można także użyć aliasów nazw tabel w podkwerendzie, aby odwołać się do tabel wymienionych w klauzuli FROM na zewnątrz podkwerendy. Poniższy przykład zwraca nazwiska pracowników, których zarobki są równe lub wyższe od przeciętnych zarobków wszystkich pracowników na tym samym stanowisku. Tabela Pracownicy ma alias "T1".

SELECT Nazwisko,

Imię, Stanowisko, Wynagrodzenie

FROM Pracownicy AS T1

WHERE Wynagrodzenie >=

(SELECT Avg(Wynagrodzenie)

FROM Pracownicy

WHERE T1.Stanowisko = Pracownicy.Stanowisko) Order by Stanowisko;

W powyższym przykładzie słowo zastrzeżone AS jest nieobowiązkowe.

Niektóre podkwerendy są dopuszczalne w kwerendzie krzyżowej — zwłaszcza jako predykaty (w klauzuli WHERE). Podkwerendy jako wynik (czyli te znajdujące się na liście SELECT) nie są dozwolone w kwerendach krzyżowych.

Zobacz też
ALL, DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
DELETE – instrukcja (Microsoft Jet SQL) | SELECT INTO – instrukcja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | UNION – operacja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) | UPDATE – instrukcja (Microsoft Jet SQL)
INSERT INTO – instrukcja (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) |

Przykład

Podkwerendy SQL - przykład


Podkwerenda SQL - przykładi (DAO)

Podkwerenda SQL - przykład

W tym przykładzie drukowana jest lista nazw i adresów wszystkich klientów, którzy złożyli zamówienie w drugim kwartale 1995 roku.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub SubQueryX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wymień nazwę i kontakt do wszystkich

' klientów, którzy złożyli zamówienie w drugim

' kwartale 1995 roku

    Set rst = _ dbs.OpenRecordset("SELECT Przedstawiciel," _

        & " NazwaFirmy, TytułPrzedstawiciela, Telefon" _

        & " FROM Klienci" _

        & " WHERE KodKlienta" _

        & " IN (SELECT KodKlienta FROM Zamówienia" _

        & " WHERE DataZamówienia Between #04/1/95#" _

        & " And #07/1/95#);")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 25

    dbs.Close

End Sub


Sum - funkcja (Microsoft Jet SQL)

Sum - funkcja

Zwraca sumę zbioru wartości zawartych w polu określonym przez kwerendę.

Składnia

Sum(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, które chcemy zsumować, lub wyrażenie wykonujące obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Funkcja Sum sumuje wartości pola. Na przykład, można użyć funkcji Sum do określenia całkowitej wysokości opłat związanych z frachtem.

Funkcja Sum ignoruje rekordy zawierające pola o wartości Null. Następujący przykład pokazuje, w jaki sposób można obliczyć sumę wartości produktów na podstawie pól CenaJednostkowa i Ilość:

SELECT

Sum(CenaJednostkowa * Ilość)

AS [Wartość razem] FROM [Opisy zamówień];

Funkcji Sum można użyć w wyrażeniu kwerendy. Można użyć także tego wyrażenia we właściwości SQL obiektu QueryDef lub przy tworzeniu obiektu Recordset na podstawie kwerendy SQL.

Zobacz też
Count – funkcja (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
SELECT - instrukcja (Microsoft Jet SQL) |

Przykład

Sum – przykład funkcji


Sum - przykład funkcjii (DAO)

Sum – przykład funkcji

W tym przykładzie tabela Zamówienia jest używana do obliczenia łącznej wartości zrealizowanych zamówień wysłanych do Wielkiej Brytanii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub SumX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Oblicz łączną wartość zrealizowanych zamówień

    ' wysłanych do Wielkiej Brytanii.

    Set rst = dbs.OpenRecordset("SELECT" _

        & " Sum(CenaJednostkowa*Ilość)" _

        & " AS [Łączna sprzedaż w W. Brytanii]" _

        & " FROM Zamówienia" _

        & " INNER JOIN [Opisy zamówien] ON" _

        & " Zamówienia.NrZamówienia = " _

        & "[Opisy Zamówień].NrZamówienia" _

        & " WHERE (KrajOdbiorcy = 'UK');")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

WyliczPola rst, 12

    dbs.Close

End Sub


TRANSACTION - instrukcja (Microsoft Jet SQL)

TRANSACTION - instrukcja

Używana do inicjowania i przeprowadzania jawnych transakcji.

Składnia

Inicjowanie nowej transakcji.

BEGIN TRANSACTION

Zakończenie transakcji przez zatwierdzenie pracy wykonanej podczas transakcji.

COMMIT [TRANSACTION | WORK]

Zakończenie transakcji przez wycofanie pracy wykonanej podczas transakcji.

ROLLBACK [TRANSACTION | WORK]

Uwagi

Transakcje nie są uruchamiane automatycznie. Aby rozpocząć transakcję, należy uczynić to jawnie przy użyciu instrukcji BEGIN TRANSACTION.

Transakcje mogą być zagnieżdżane do pięciu poziomów. Aby rozpocząć zagnieżdżoną transakcję, należy użyć instrukcji BEGIN TRANSACTION w kontekście istniejącej transakcji.

Transakcje nie są obsługiwane dla tabel połączonych.


TRANSFORM - instrukcja (Microsoft Jet SQL)

TRANSFORM - instrukcja

Tworzy kwerendę krzyżową.

Składnia

TRANSFORM funkcja_agregacji
instrukcja select
PIVOT pole_główne [IN (wartość_1[, wartość_2[, ...]])]

Instrukcja TRANSFORM składa się z następujących elementów:

Element | Opis
funkcja agregacji | Funkcja agregacji SQL działająca na wybranych danych.
instrukcja select | Instrukcja SELECT.
pole_główne | Pole lub wyrażenie, które ma być wykorzystane do utworzenia nagłówków kolumn w zbiorze wyników kwerendy.
wartość_1, wartość_2 | Stałe wartości służące do tworzenia nagłówków kolumn.

Uwagi

Podczas podsumowywania danych za pomocą kwerendy krzyżowej wybrane wartości z określonych pól lub wyrażeń są używane jako nagłówki kolumn, co pozwala na przedstawienie danych w bardziej zwartej formie, niż jest to możliwe przy użyciu kwerendy wybierającej.

Instrukcja TRANSFORM jest nieobowiązkowa, lecz jeśli występuje, to musi być pierwszą instrukcją SQL. Poprzedza ona instrukcję SELECT określającą pola używane jako nagłówki wierszy oraz klauzulę GROUP BY określającą grupowanie wierszy. Dodatkowo można dołączyć inne klauzule, takie jak WHERE, które określają dodatkowe kryteria wyboru lub sortowania. W roli predykatów w kwerendzie krzyżowej można również wykorzystać podkwerendy — w szczególności występujące w klauzuli WHERE.

Wartości zwrócone w polu pole_główne są wykorzystywane jako nagłówki kolumn w zbiorze wyników kwerendy. Na przykład, w kwerendzie krzyżowej pogrupowanie danych o sprzedaży według miesiąca sprzedaży utworzy 12 kolumn. Można ograniczyć zakres elementu pole_główne do tworzenia nagłówków z ustalonych wartości (wartość_1, wartość_2) wymienionych w nieobowiązkowej klauzuli IN. W celu utworzenia dodatkowych kolumn można również podać wartości stałe, dla których nie istnieją odpowiadające im dane.

Zobacz też
FROM – klauzula (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
INNER JOIN – operacja (Microsoft Jet SQL) | Podkwerendy SQL
ORDER BY – klauzula (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)

Przykład

TRANSFORM - przykład instrukcji


TRANSFORM - przykład instrukcjii (DAO)

TRANSFORM – przykład instrukcji

W tym przykładzie klauzula TRANSFORM języka SQL jest użyta do utworzenia kwerendy krzyżowej pokazującej liczbę zamówień zebranych przez każdego pracownika w każdym kwartale 1994 roku. Do uruchomienia tej procedury potrzebna jest funkcja SQLTRANSFORMOutput.

Sub TransformX1()

    Dim dbs As Database

    Dim strSQL As String

    Dim qdfTRANSFORM As QueryDef

    strSQL = "PARAMETERS prmRok SHORT; TRANSFORM " _

        & "Count(NrZamówienia) " _

        & "SELECT Imię & "" "" & Nazwisko AS " _

        & "PełneNazwisko FROM Pracownicy " _

        & "INNER JOIN Zamówienia " _

        & "ON Pracownicy.NrPracownika = " _

        & "Zamówienia.NrPracownika WHERE DatePart " _

        & "(""yyyy"", DataZamówienia) = [prmRok] "

       strSQL = strSQL & "GROUP BY Imię & " _

        & """ "" & Nazwisko " _

        & "ORDER BY Imię & "" "" & Nazwisko " _

        & "PIVOT DatePart(""q"", DataZamówienia)"

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    Set qdfTRANSFORM = dbs.CreateQueryDef _

        ("", strSQL)

    SQLTRANSFORMOutput qdfTRANSFORM, 1994

    dbs.Close

End Sub

W tym przykładzie klauzula TRANSFORM języka SQL służy do utworzenia nieco bardziej skomplikowanej kwerendy krzyżowej pokazującej całkowitą wartość zamówień zebranych przez każdego pracownika w każdym kwartale 1994 roku. Do uruchomienia procedury potrzebna jest funkcja SQLTRANSFORMOutput.

Sub TransformX2()

    Dim dbs As Database

    Dim strSQL As String

    Dim qdfTRANSFORM As QueryDef

    strSQL = "PARAMETERS prmYear SMALLINT; TRANSFORM " _

        & "Sum(Subtotal) SELECT Imię & "" """ _

        & "& Nazwisko AS PełneNazwisko " _

        & "FROM Pracownicy INNER JOIN " _

        & "(Zamówienia INNER JOIN " _

        & "[Częściowe zamówienia] " _

        & "ON Zamówienia.NrZamówienia = " _

        & "[Częściowe zamówienia].NrZamówienia) " _

        & "ON Pracownicy.NrPracownika = " _

        & "Zamówienia.NrPracownika WHERE DatePart" _

        & "(""yyyy"", DataZamówienia) = [prmRok] "

       strSQL = strSQL & "GROUP BY Imię & "" """ _

        & "& Nazwisko " _

        & "ORDER BY Imię & "" "" & Nazwisko " _

        & "PIVOT DatePart(""q"",DataZamowienia)"

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    Set qdfTRANSFORM = dbs.CreateQueryDef _

        ("", strSQL)

    SQLTRANSFORMOutput qdfTRANSFORM, 1994

    dbs.Close

End Sub

Function SQLTRANSFORMOutput(qdfTymcz As QueryDef, _

    intRok As Integer)

    Dim rstTRANSFORM As Recordset

    Dim fldPętla As Field

    Dim booPierwsze As Boolean

    qdfTymcz.PARAMETERS!prmRok = intRok

    Set rstTRANSFORM = qdfTymcz.OpenRecordset()

    Debug.Print qdfTymcz.SQL

    Debug.Print

    Debug.Print , , "Kwartał"

    With rstTRANSFORM

        booPierwsze = True

        For Each fldPętla In .Fields

            If booPierwsze = True Then

                Debug.Print fldPętla.Name

                Debug.Print , ;

                booPierwsze = False

            Else

                Debug.Print , fldPętla.Name;

            End If

        Next fldPętla

        Debug.Print

        Do While Not .EOF

            booPierwsze = True

            For Each fldPętla In .Fields

                If booPierwsze = True Then

                    Debug.Print fldPętla

                    Debug.Print , ;

                    booPierwsze = False

                Else

                    Debug.Print , fldPętla;

                End If

            Next fldPętla

            Debug.Print

            .MoveNext

        Loop

    End With

End Function


UNION - operacja (Microsoft Jet SQL)

UNION - operacja

Tworzy kwerendę składającą, scalającą wyniki dwóch lub więcej niezależnych kwerend lub tabel.

Składnia

[TABLE] kwerenda_1 UNION [ALL] [TABLE] kwerenda_2 [UNION [ALL] [TABLE] kwerenda_n [ ... ]]

Składnia operacji UNION zawiera następujące elementy:

Element | Opis
kwerenda_1-n | Instrukcja SELECT, nazwa zapamiętanej kwerendy lub nazwa przechowywanej w bazie danych tabeli poprzedzona słowem kluczowym TABLE.

Uwagi

Za pomocą operacji UNION można scalić wyniki dwóch lub więcej kwerend, tabel i instrukcji SELECT, w dowolnej kombinacji. Poniższy przykład scala istniejącą tabelę o nazwie "Nowe rachunki" oraz instrukcję SELECT:

TABLE [Nowe rachunki] UNION ALL

SELECT *

FROM Klienci

WHERE WartośćZamówienia > 1000;

Domyślnie, po wykonaniu operacji UNION nie są zwracane powtarzające się rekordy. Aby zwracane były wszystkie rekordy, należy dodać predykat ALL. W takim przypadku kwerenda wykonuje się szybciej.

Wszystkie kwerendy w operacji UNION muszą zwracać żądać tą samą liczbę pól; jednakże pola nie muszą być tego samego rozmiaru czy typu danych.

Aliasy powinny występować tylko w pierwszej instrukcji SELECT, gdyż w pozostałych instrukcjach są ignorowane. W klauzuli ORDER BY należy się odwoływać do pól tak, jak są one nazwane w pierwszej instrukcji SELECT.

Uwagi

  • Można używać klauzuli GROUP BY lub HAVING w każdym argumencie kwerendy, aby zgrupować zwrócone dane.
  • W celu wyświetlenia danych w określonym porządku można na końcu ostatniej kwerendy użyć klauzuli ORDER BY.
Zobacz też
ALL, DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | ORDER BY – klauzula (Microsoft Jet SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | Podkwerendy SQL
INNER JOIN – operacja (Microsoft Jet SQL) | WHERE – klauzula (Microsoft Jet SQL)
LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL) |

Przykład

UNION – przykład operacji


UNION - przykład operacjii (DAO)

UNION – przykład operacji

W tym przykładzie pobierane są nazwy i siedziby dostawców i klientów z Brazylii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub UnionX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Pobierz nazwy i siedziby wszystkich

    ' dostawców i klientów z Brazylii.

    Set rst = dbs.OpenRecordset("SELECT NazwaFirmy," _

        & " Miasto FROM Dostawcy" _

        & " WHERE Kraj = 'Brazylia' UNION" _

        & " SELECT NazwaFirmy, Miasto FROM Klienci" _

        & " WHERE Kraj = 'Brazylia';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 12

    dbs.Close

End Sub


UPDATE - instrukcja (Microsoft Jet SQL)

UPDATE - instrukcja

Tworzy kwerendę aktualizującą, która zmienia wartości w polach określonej tabeli zgodnie z podanymi kryteriami.

Składnia

UPDATE tabela
SET nowa_wartość
WHERE kryteria;

Składnia instrukcji UPDATE zawiera następujące elementy:

Element | Opis
tabela | Nazwa tabeli zawierającej dane, które mają zostać zmodyfikowane.
nowa_wartość | Wyrażenie określające wartość, która ma być wstawiona w określonym polu uaktualnianych rekordów.
kryteria | Wyrażenie określające, które rekordy zostaną uaktualnione. Uaktualniane są wyłącznie rekordy spełniające to wyrażenie.

Uwagi

Instrukcja UPDATE jest szczególnie przydatna, gdy chcemy zmienić wiele rekordów lub gdy zmieniane rekordy znajdują się w wielu tabelach.

Można zmienić jednocześnie wiele pól. Poniższy przykład zwiększa wartość pola WartośćZamówienia o 10 procent oraz wartość pola Fracht o 3 procent dla odbiorców w Wielkiej Brytanii.

UPDATE Zamówienia

SET WartośćZamówienia = WartośćZamówienia * 1.1,

Fracht = Fracht * 1.03

WHERE KrajOdbiorcy = 'UK';

Ważne

  • Instrukcja UPDATE nie generuje zestawu wyników. Po zaktualizowaniu rekordów za pomocą kwerendy aktualizującej nie można cofnąć tej operacji. Jeśli chcemy wiedzieć, które rekordy zostały uaktualnione, należy najpierw przejrzeć wyniki kwerendy wybierającej stosującej te same kryteria, a następnie uruchomić kwerendę aktualizującą.
  • Warto przez cały czas przechowywać kopie zapasowe danych. Po pomyłkowej aktualizacji rekordów można odzyskać je kopii zapasowych.
Zobacz też
SELECT - instrukcja (Microsoft Jet SQL) WHERE – klauzula (Microsoft Jet SQL)

Przykład

UPDATE - przykład instrukcji


UPDATE - przykład instrukcjii (DAO)

UPDATE – przykład instrukcji

W tym przykładzie wartość pola Przełożeni jest zmieniana na 5 w tych wszystkich rekordach pracowników, w których wynosiła 2.

Sub UpdateX()

    Dim dbs As Database

    Dim qdf As QueryDef

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Zmień wartość pola Przełożeni na 5 we wszystkich

    ' rekordach pracowników, w których wynosiła ona 2

    dbs.Execute "UPDATE Pracownicy " _

        & "SET Przełożeni = 5 " _

        & "WHERE Przełożeni = 2;"

    dbs.Close

End Sub


Stosowanie symboli wieloznacznych przy porównywaniu ciągów znaków

Funkcja dopasowania do wzorca dostarcza uniwersalne narzędzie do porównywania ciągów znaków. Poniższa tabela zawiera symbole wieloznaczne, które można stosować z operatorem Like, oraz liczbę znaków, do których one pasują.

Znak(i) we wzorcu | Pasuje w wyrażeniach do
? lub _ (podkreślenie) | dowolnego pojedynczego znaku
* lub % | zera lub kilku znaków
# | dowolnej pojedynczej cyfry (0 – 9)
[lista_znaków] | dowolnego pojedynczego znaku na liście_znaków
[!lista_znaków] | dowolnego pojedynczego znaku spoza listy_znaków

Do dopasowania pojedynczego znaku w wyrażeniu można stosować grupy jedno- lub wieloznakowe (lista_znaków) zawarte w nawiasach kwadratowych ([ ]), przy czym lista_znaków może zawierać niemal dowolne znaki z zestawu znaków ANSI, włącznie z cyframi. Można używać znaków specjalnych, takich jak nawias otwierający ([ ), znak zapytania (?), znak numeru (#) oraz gwiazdka (*); ale do bezpośrednich porównań należy otoczyć je nawiasami. Nie można jednak w tym celu użyć znaku nawiasu kwadratowego zamykającego ( ]) wewnątrz grupy, można jednak umieścić go poza grupą indywidualnie jako zwykły znak.

Jako dodatek do prostej listy znaków zawartej w nawiasach kwadratowych, lista_znaków może określać zakres znaków przy użyciu myślnika (-) oddzielającego górne i dolne ograniczenie zakresu. Na przykład, użycie [A-Z] we wzorcu daje w wyniku dopasowania pozytywny wynik, jeśli znak na odpowiadającej pozycji w wyrażeniu zawiera dowolną wielką literę od A do Z. Wewnątrz nawiasów kwadratowych można umieszczać wiele zakresów bez ich oddzielania. Na przykład [a-zA-Z0-9] pasuje do dowolnego znaku alfanumerycznego.

Ważne jest aby zwrócić uwagę na fakt, że symbole wieloznaczne (%) i (_) języka ANSI SQL dostępne są jedynie z aparatem Microsoft® Jet w wersji 4.X oraz z mechanizmem Microsoft OLE DB Provider dla aparatu Jet. Będą one traktowane jak literały przy użyciu z poziomu programu Microsoft Access lub DAO.

Pozostałe ważne zasady dopasowywania do wzorców:

  • Wykrzyknik (!) na początku listy_znaków oznacza, że dopasowanie występuje, jeśli w wyrażeniu znajduje się dowolny znak z wyjątkiem umieszczonych na liście_znaków. Wykrzyknik umieszczony poza nawiasami oznacza sam siebie.
  • Myślnik (-) musi być użyty albo na początku (po wykrzykniku, jeśli występuje), albo na końcu listy_znaków, i wówczas oznacza sam siebie. W każdym innym miejscu myślnik służy do wskazania zakresu znaków ANSI.
  • Przy określaniu zakresu znaków granice zakresu muszą być umieszczone w kolejności rosnącej (A-Z lub 0-100). [A-Z] jest poprawnym przykładem, ale nie [Z-A].
  • Sekwencja znaków [ ] jest ignorowana; jest ona uważana za ciąg znakowy długości zerowej (“”).
Zobacz też
Like - operator Wyrażenia SQL


Var, VarP - funkcje (Microsoft Jet SQL)

Var, VarP - funkcje

Zwracają oszacowanie wariancji populacji lub próbki populacji w postaci zbioru wartości zawartych w polu określonym kwerendą.

Składnia

Var(wyrażenie)

VarP(wyrażenie)

Wyrażenie reprezentuje wyrażenie znakowe identyfikujące pole zawierające dane, których chcemy użyć do obliczeń, lub wyrażenie wykonujące obliczenia na podstawie danych z tego pola. Operandy w wyrażeniu mogą być nazwą pola tabeli, stałą lub funkcją (która może być albo wewnętrzna, albo zdefiniowana przez użytkownika, ale nie może być jedną z innych funkcji agregujących języka SQL).

Uwagi

Funkcja VarP przeprowadza obliczenia na populacji, a funkcja Var na próbce populacji.

Jeżeli kwerenda zawiera mniej niż dwa rekordy, funkcje Var i VarP zwracają wartość Null, która wskazuje, że wariancja nie może zostać obliczona.

Funkcji Var i VarP można używać w wyrażeniu kwerendy lub w instrukcji SQL.

Zobacz też

Funkcje agregujące SQL (SQL)

Przykład

VAR, VARP – przykład funkcji


Var, VarP - przykład funkcjii (DAO)

Var, VarP – przykład funkcji

W tym przykładzie tabela Zamówienia jest wykorzystywana do oszacowania wariancji kosztów frachtu zamówień wysłanych do Wielkiej Brytanii.

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub VarX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Oblicz wariancję kosztów frachtu do Wielkiej

    ' za fracht za zamówienia wysłane do Wielkiej

    Set rst = dbs.OpenRecordset("SELECT " _

        & "Var(Fracht) " _

        & "AS [Wariancja frachtu do W. Brytanii] " _

        & "FROM Zamówienia WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 20

    Debug.Print

    Set rst = dbs.OpenRecordset("SELECT " _

        & "VarP(Fracht) " _

        & "AS [Wariancja frachtu do W. Brytanii " _

        & "FROM Zamówienia WHERE KrajOdbiorcy = 'UK';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset. Przekaż obiekt

    ' Recordset i wymaganą szerokość pola.

    WyliczPola rst, 20

    dbs.Close

End Sub


WHERE - klauzula (Microsoft Jet SQL)

WHERE - klauzula

Określa, które rekordy z tabel wymienionych w klauzuli FROM są uwzględniane przez instrukcje SELECT, UPDATE, lub DELETE.

Składnia

SELECT lista_pól
FROM wyrażenie_tabelowe
WHERE kryteria

Składnia instrukcji SELECT z klauzulą WHERE zawiera następujące elementy:

Element | Opis
lista_pól | Nazwy pobieranych pól, którym mogą towarzyszyć aliasy nazw pól, predykaty wyboru (ALL, DISTINCT, DISTINCTROW lub TOP) albo inne opcje instrukcji SELECT.
wyrażenie_tabelowe | Nazwa tabeli lub tabel, z których mają być pobrane dane.
kryteria | Wyrażenie, które spełniają rekordy włączane do wyniku kwerendy.

Uwagi

Aparat bazy danych Microsoft Jet wybiera z tabel te rekordy, które spełniają warunki wymienione w klauzuli WHERE. Jeśli nie określisz klauzuli WHERE, kwerenda zwróci wszystkie rekordy z tabeli. Jeśli w klauzuli FROM kwerendy podano kilka tabel, a nie zamieszczono klauzuli WHERE lub JOIN, wówczas kwerenda utworzy iloczyn kartezjański tabel.

Klauzula WHERE nie jest obowiązkowa, jednak jeśli występuje, musi być umieszczona po klauzuli FROM. Można na przykład wybrać wszystkich pracowników działu sprzedaży (WHERE Dział = 'Sprzedaż') lub wszystkich klientów w wieku od 18 do 30 lat (WHERE Wiek Between 18 And 30).

Jeśli nie używasz klauzuli JOIN, aby wykonać operację sprzęgania SQL wielu tabel, wynikowy obiekt Recordset nie będzie mógł być aktualizowany.

Klauzula WHERE jest podobna w działaniu do klauzuli HAVING. WHERE określa, które rekordy są wybrane. Podobnie, jeśli rekordy są grupowane przy użyciu klauzuli GROUP BY, HAVING określa, które rekordy są wyświetlane.

Użyj klauzuli WHERE aby wyeliminować rekordy, które nie mają być grupowane przy użyciu klauzuli GROUP BY.

Do określania rekordów zwracanych przez instrukcję SQL można stosować różne wyrażenia. Poniższa instrukcja SQL wybiera tych pracowników, których wynagrodzenie przekracza 2 100:

SELECT Nazwisko, Wynagrodzenie

FROM Pracownicy

WHERE Wynagrodzenie > 2100;

Klauzula WHERE może zawierać do 40 wyrażeń połączonych operatorami logicznymi And i Or.

Nazwa pola, w której występuje spacja lub znak przestankowy, musi być umieszczona w nawiasach kwadratowych ([ ]). Tabela z danymi o klientach może zawierać różne rodzaje informacji:

SELECT [Ulubiona restauracja klienta]

Kiedy określasz argument kryteria, literał daty musi być w formacie amerykańskim, nawet jeśli nie używasz amerykańskiej wersji aparatu baz danych Microsoft® Jet. I tak, data 10 maja 1996 roku, pisana w Polsce jako 96-05-10, w formacie amerykańskim wygląda następująco: 5/10/96 (miesiąc/dzień/rok). Pamiętaj też, że literał daty musi być otoczony dwoma znakami numeru (#), tak jak to ilustrują dalsze przykłady.

Poniższa instrukcja SQL wyszukuje w tabeli rekordy datowane dnia 10 maja 1996 (bez względu na wersję językową bazy danych):

SELECT *

FROM Zamówienia

WHERE DataWysyłki = #5/10/96#;

Inną możliwością jest użycie funkcji DateValue, która rozpoznaje międzynarodowe ustawienia definiowane w systemie Microsoft Windows. Poniższy przykład kodu pasuje do warunków amerykańskich:

SELECT *

FROM Zamówienia

WHERE DataWysyłki = DateValue('5/10/96');

A ten jest odpowiedni do warunków polskich:

SELECT *

FROM Zamówienia

WHERE DataWysyłki = DateValue('96-05-10');

Uwaga Jeśli kolumna wymieniona w kryteriach jest typu GUID, składnia kryteriów jest nieco inna:

WHERE ReplicaID = {GUID {12345678-90AB-CDEF-1234-567890ABCDEF}}

Nawiasy klamrowe i łączniki muszą być umieszczone w sposób pokazany w tym przykładzie.

Zobacz też
ALL DISTINCT, DISTINCTROW, TOP – predykaty (Microsoft Jet SQL) | LEFT JOIN, RIGHT JOIN – operacje (Microsoft Jet SQL)
DELETE – instrukcja (Microsoft Jet SQL) | ORDER BY – klauzula (Microsoft Jet SQL)
FROM – klauzula (Microsoft Jet SQL) | SELECT - instrukcja (Microsoft Jet SQL)
GROUP BY – klauzula (Microsoft Jet SQL) | SELECT...INTO – instrukcja (Microsoft Jet SQL)
HAVING – klauzula (Microsoft Jet SQL) | Funkcje agregujące SQL (SQL)
IN – klauzula (Microsoft Jet SQL) | UPDATE – instrukcja (Microsoft Jet SQL)
INNER JOIN – operacja (Microsoft Jet SQL) |

Przykład

WHERE – przykład klauzuli


WHERE - przykład klauzulii (DAO)

WHERE – przykład klauzuli

W poniższym przykładzie założono, że w tabeli Pracownicy istnieje pole Zarobki. Należy zauważyć, że w tabeli Pracownicy znajdującej się w bazie danych Northwind nie ma takiego pola.

W tym przykładzie wybierane są pola Nazwisko i Imię z każdego rekordu, w którym wartość pierwszego z tych pól równa jest "Kowalski".

W tym przykładzie wywoływana jest procedura WyliczPola, którą można znaleźć w przykładzie dotyczącym instrukcji SELECT.

Sub WhereX()

    Dim dbs As Database, rst As Recordset

    ' Zmodyfikuj ten wiersz tak, by ścieżka wskazywała

    ' na rzeczywistą bazę danych Northwind.

    Set dbs = OpenDatabase("Northwind.mdb")

    ' Wybierz te rekordy z tabeli Pracownicy,

    ' dla których wartość pola Nazwisko

    ' równa jest "Kowalski".

Set rst = dbs.OpenRecordset("SELECT Nazwisko, " _

        & "Imię FROM Pracownicy " _

        & "WHERE Nazwisko = 'Kowalski';")

    ' Zapełnij obiekt Recordset.

    rst.MoveLast

    ' Wywołaj procedurę WyliczPola w celu

    ' wydrukowania zawartości obiektu Recordset.

    WyliczPola rst, 12

    dbs.Close

End Sub


WITH OWNERACCESS OPTION - deklaracja (Microsoft Jet SQL)

WITH OWNERACCESS OPTION - deklaracja

W środowisku wielodostępnym z chronioną grupą roboczą deklaracja ta jest używana w kwerendzie do nadania użytkownikowi uruchamiającemu kwerendę tych samych uprawnienień co posiadane przez właściciela kwerendy.

Składnia

instrukcja_sql
WITH OWNERACCESS OPTION;

Uwagi

Deklaracja WITH OWNERACCESS OPTION jest nieobowiązkowa.

Poniższy przykład umożliwia użytkownikowi obejrzenie informacji o zarobkach (nawet jeśli nie posiada on uprawnień do przeglądania tabeli Płace), przy założeniu, iż właściciel kwerendy posiada takie uprawnienia:

SELECT Nazwisko,

Imię, Wynagrodzenie

FROM Pracownicy

ORDER BY Nazwisko

WITH OWNERACCESS OPTION;

Jeśli za pomocą innych środków uniemożliwiono użytkownikowi tworzenie lub dodawanie danych do tabeli, to użycie opcji WITH OWNERACCESS OPTION pozwala użytkownikowi na uruchomienie kwerendy tworzącej tabelę lub kwerendy dołączającej.

Jeżeli chcesz wymusić ustawienia bezpieczeństwa w grupie roboczej i prawa użytkowników, nie używaj deklaracji WITH OWNERACCESS OPTION.

Stosowanie tej opcji wymaga prawa dostępu do pliku System.mdw związanego z bazą danych. Jest to użyteczne jedynie w przypadku bezpiecznej implementacji w środowisku wielodostępnym.

Zobacz też

SELECT - instrukcja (Microsoft Jet SQL)


Co nowego w języku definicji danych (DDL)

Aparat bazy danych Microsoft® Jet w wersji 4.x posiada nowe i rozszerzone instrukcje języka definicji danych (DDL).

Szczegółowe informacje o nowych funkcjach można znaleźć w następujących tematach:

ALTER TABLE - instrukcja | CREATE USER lub GROUP - instrukcja
CONSTRAINT - klauzula | ADD USER - instrukcja
CREATE PROCEDURE - instrukcja | DROP USER lub GROUP - instrukcja
CREATE TABLE – instrukcja | ALTER USER lub DATABASE - instrukcja
CREATE VIEW - instrukcja | GRANT - instrukcja
DROP - instrukcja | REVOKE - instrukcja

Zobacz też
Przegląd nowości | Co nowego w ustawieniach Rejestru systemowego Windows
Co nowego w języku manipulacji danymi (DML) |


Co nowego w języku manipulacji danymi (DML)

Aparat bazy danych Microsoft® Jet w wersji 4.x posiada nowe i rozszerzone instrukcje języka manipulacji danymi (DML).

Szczegółowe informacje o nowych funkcjach można znaleźć w następujących tematach:

EXECUTE – instrukcja | TRANSACTION – instrukcja
PROCEDURE – klauzula |

Zobacz też
Przegląd nowości | Co nowego w ustawieniach Rejestru systemowego Windows
Co nowego w języku definicji danych (DDL) |


Przegląd nowości (Microsoft Jet SQL)

Przegląd nowości

Aparat bazy danych Microsoft® Jet w wersji 4.x charakteryzuje się wieloma nowymi właściwościami, włączając dodatkowe słowa zastrzeżone SQL, typy danych SQL, oraz funkcje skalarne ODBC. Dostępnych jest teraz więcej informacji porównawczych SQL z ANSI SQL i więcej informacji o odpowiednikach typów danych w ANSI SQL. Symbole wieloznaczne ANSI SQL, znak procent (%) i znak podkreślenia (_), są dostępne w wersji 4.x aparatu Jet i mechanizmie Microsoft OLE DB Provider dla aparatu Jet.

Szczegółowe informacje o nowych funkcjach można znaleźć w następujących tematach:

SQL – słowa zastrzeżone | Porównanie Microsoft Jet SQL i ANSI SQL
SQL – typy danych | Odpowiedniki typów danych w ANSI SQL
ODBC – funkcje skalarne | Użycie symboli wieloznacznych w porównywaniu ciągów znaków

Aparat bazy danych Microsoft Jet w wersji 4.x posiada nowe instrukcje języka definicji danych (DDL), nowe instrukcje języka manipulacji danymi (DML), dodatkowe metody służące do dostosowywania wpisów Rejestru systemowego Windows® oraz dodatkowe ustawienia używane przy inicjowaniu sterownika aparatu bazy danych.

Szczegółowe informacje o nowych funkcjach można znaleźć w następujących tematach:

Co nowego w języku definicji danych (DDL) | Co nowego w ustawieniach Rejestru systemowego Windows
Co nowego w języku manipulacji danymi (DML) |


Co nowego w ustawieniach Rejestru systemowego Windows

Aparat bazy danych Microsoft® Jet w wersji 4.x oferuje teraz cztery metody do modyfikacji wpisów Rejestru systemowego Microsoft Windows®. Oprócz użycia programu Regedit.exe w celu zastąpienia wartości domyślnych lub tworzenia części w drzewie rejestru Twojej aplikacji do zarządzania ustawieniami, możesz również użyć metody DAO SetOption lub właściwości połączeń w mechanizmie Microsoft OLE DB Provider dla aparatu Jet.

Podane są szczegółowe informacje i przykłady dotyczące ustawień inicjujących dla aparatu bazy danych Jet. Ustawienia te używane są przy dostępie do baz danych programu Microsoft Access. Zapewniona jest również informacja o ustawieniach mechanizmu replikacji aparatu bazy danych Microsoft Jet.

Szczegółowe informacje o nowych funkcjach można znaleźć w następujących tematach:

Dostosowywanie ustawień Rejestru Windows dla aparatu baz danych Microsoft Jet Inicjowanie sterownika aparatu baz danych Microsoft Jet 4.0

Zobacz też
Przegląd nowości | Co nowego w języku manipulacji danymi (DML)
Co nowego w języku definicji danych (DDL) |


komputer bazowy <definicja Jet>

komputer bazowy

Komputer używany w topologii gwiazdy. Replika jest kopiowana z serwera centralnego i umieszczana na komputerze bazowym. Taka replika ta może być użyta do wykonania dodatkowych replik dla innych komputerów.

Zobacz też
serwer centralny topologia gwiazdy


tabela konfliktów <definicja Jet>

tabela konfliktów

Tabela generowana po wykryciu konfliktu synchronizacji pomiędzy dwoma replikami. Tabela konfliktów pojawia się tylko w replice zawierającej odrzucone zmiany.


replikacja bazy danych <definicja Jet>

replikacja bazy danych

Proces kopiowania bazy danych w taki sposób, że dwie lub więcej kopii (replik) tej samej bazy danych mogą pozostawać zsynchronizowane. Zmiany danych w replikowanej tabeli jednej repliki są wysyłane i stosowane do innych replik w zestawie replik. Zmiany wprowadzone do projektu bazy danych w replice pełniącej rolę wzorca są wysyłane i stosowane do wszystkich replik w zestawie.


domyślny partner w synchronizacji <definicja Jet>

domyślny partner w synchronizacji

Synchronizator używany do automatycznej synchronizacji repliki z innymi replikami w zestawie. Podczas tworzenia repliki, Synchronizator zarządzający repliką źródłową staje się domyślnym partnerem w synchronizacji dla nowej repliki.


domyślny plan synchronizacji <definicja Jet>

domyślny plan synchronizacji

Szablon używany przez Synchronizator do zdefiniowania planu pomiędzy nowo zarządzaną repliką a jej domyślnym partnerem w synchronizacji w sytuacji, gdy nie istnieje plan synchronizacji dla nowo zarządzanej repliki. Po zdefiniowaniu planu można go zmienić.


wzorzec <definicja Jet>

wzorzec

Baza danych, do której dodane zostały tabele systemowe, pola systemowe oraz właściwości replikacji. Wzorzec jest pierwszą repliką w zestawie replik. Zmiany w strukturze bazy danych można wykonać tylko za pomocą wzorca. Repliki w tym samym zestawie mogą kolejno przybierać rolę wzorca, ale w tym samym czasie, w każdym zestawie replik może być tylko jeden wzorzec.


folder skrzynki <definicja Jet>

folder skrzynki

Współużytkowane miejsce w sieci, gdzie Synchronizator może zostawić lub skąd może pobrać zmiany dokonane w projekcie.


GUID (globally unique identifier, unikatowy identyfikator globalny) <definicja Jet>

GUID (globally unique identifier, unikatowy identyfikator globalny)

16-bitowe pole używane do określania unikatowego identyfikatora replikacji. Identyfikatory GUID są szeroko używane do identyfikacji replik, zestawów replik, tabel, rekordów i innych obiektów.

Uwaga W programie Microsoft® Access, identyfikatory GUID są nazywane identyfikatorami replikacji (Replication ID).


serwer centralny <definicja Jet>

serwer centralny

Komputer używany w topologii gwiazdy. Replika znajdująca się na tym komputerze może być użyta jako partner w synchronizacji z innymi replikami.

Zobacz też
komputer bazowy | topologia gwiazdy
komputer satelitarny |


obiekt lokalny <definicja Jet>

obiekt lokalny

Tabela lub kwerenda, która pozostaje w replice, w której została utworzona. Ani obiekt, ani dokonywane w nim zmiany nie są rozpowszechniane na inne elementy zestawu replik.


replika zarządzana <definicja Jet>

replika zarządzana

Replika z przypisanym jej Synchronizatorem. Synchronizator przekazuje zmiany do innych replik zestawu i odbiera od nich zmiany.

Uwaga Jeżeli do repliki nie jest przypisany Synchronizator, to mimo to można ją zsynchronizować w kodzie aplikacji lub przy użyciu innego Synchronizatora. Jednak, dopóki do repliki nie zostanie przypisany Synchronizator, nie można z tej repliki ustalać planów synchronizacji.


replikacja obiektu <definicja Jet>

replikacja obiektu

Proces reprodukcji obiektu (tabeli lub kwerendy), w którym synchronizowane są co najmniej dwie kopie tego samego obiektu. Zmiany wprowadzone do projektu obiektu we wzorcu są wysyłane i stosowane do wszystkich replik w zestawie.


synchronizacja na żądanie <definicja Jet>

synchronizacja na żądanie

Wymiana danych pomiędzy dwoma replikami zachodząca na jawne żądanie użytkownika.


replika <definicja Jet>

replika

Kopia bazy danych zawierająca jej tabele, kwerendy, formularze, raporty, makra i moduły. Replika jest elementem zestawu replik i może być synchronizowana z innymi replikami w zestawie. Zmiany danych w replikowanej tabeli jednej repliki są wysyłane i stosowane do innych elementów zestawu replik.

Uwaga Wzorzec jest także repliką.


replikowana baza danych <definicja Jet>

replikowana baza danych

Baza danych, do której dodano dodatkowe tabele, pola i właściwości w celu zapisania informacji opisujących zmiany danych oraz projektu replikowanych obiektów w bazie danych.


obiekt replikowany <definicja Jet>

obiekt replikowany

Tabela lub kwerenda występująca we wszystkich replikach w zestawie replik. Obiekt zreplikowany można zmienić jedynie na poziomie wzorca. Zmiany te są przekazywane do innych replik w zestawie replik podczas synchronizacji.


zestaw replik <definicja Jet>

zestaw replik

Repliki, które dzielą wspólny projekt bazy danych oraz unikatowy identyfikator zestawu replik. Elementy zestawu replik są synchronizowane.


element zestawu replik <definicja Jet>

element zestawu replik

Replika należąca do zestawu replik. Elementy zestawu replik dzielą ten sam projekt bazy danych i mogą być synchronizowane.


replikować <definicja Jet>

replikować

Tworzyć replikę lub kopię czegoś 3 na przykład bazy danych.


replikacja <definicja Jet>

replikacja

Proces tworzenia i synchronizacji replik w różnych położeniach. Replikacja dodaje pola systemowe, tabele systemowe i właściwości replikacji do bazy danych w taki sposób, że zmiany danych w tej bazie lub w jej projekcie są wysyłane i stosowane do wszystkich elementów zestawu replik.


Replication Manager firmy Microsoft <definicja Jet>

Replication Manager firmy Microsoft

Aplikacja dostarczająca graficzny interfejs użytkownika do zarządzania położeniem, planem synchronizacji oraz związkami jednej lub wielu replik z innymi replikami w zestawie. Program Replication Manager zarządza tymi ustawieniami Synchronizatora, które sterują replikacją, natomiast Synchronizator przeprowadza faktyczny proces synchronizacji. Replication Manager jest częścią pakietu Microsoft® Office 97, Developer Edition.


okres zatrzymania <definicja Jet>

okres zatrzymania

Liczba dni, przez które system będzie przechowywał dla repliki pewne informacje dotyczące systemu replikacji. Jeżeli okres zatrzymania upłynie przed synchronizacją repliki, synchronizacja nie powiedzie się.


komputer satelitarny <definicja Jet>

komputer satelitarny

W topologii gwiazdy jest to komputer, na którym znajduje się replika. Replika ta jest kopiowana z komputera bazowego i domyślnie synchronizowana z repliką na serwerze centralnym.

Zobacz też
komputer bazowy | topologia gwiazdy
serwer centralnyr |


plan <definicja Jet>

plan

Momenty czasu, w których Synchronizator będzie inicjował synchronizację z innymi replikami. Minimalna różnica czasu pomiędzy planowanymi synchronizacjami wynosi 15 minut. Dla różnych Synchronizatorów można ustawić różne plany.


synchronizacja planowana <definicja Jet>

synchronizacja planowana

Wymiana danych pomiędzy replikami zachodząca w określonym wcześniej momencie czasu.


współużytkowany folder sieciowy <definicja Jet>

współużytkowany folder sieciowy

Zobacz folder skrzynki.


topologia gwiazdy <definicja Jet>

topologia gwiazdy

Typ schematu organizacyjnego komputerów połączonych siecią. W przypadku replikacji pojęcie to odnosi się do serwera centralnego, komputera bazowego i rozmieszczenia elementów zestawu replik na innych komputerach satelitarnych. Topologia jest ważna dla określenia planów synchronizacji.

Zobacz też
komputer bazowy | komputer satelitarny
serwer centralny |


konflikt synchronizacji <definicja Jet>

konflikt synchronizacji

Sytuacja, w której użytkownicy dwóch replik zmienili ten sam rekord. Jeden ze zmienionych rekordów zostaje wybrany jako "zwycięzca" i zgodnie z nim aktualizowany jest rekord w replice "przegrywającej". Rekord, który "przegrał", zapisywany jest (w postaci po aktualizacji) w tabeli konfliktów swojej repliki.


błąd synchronizacji <definicja Jet>

błąd synchronizacji

Problem pojawiający się podczas synchronizacji, nie pozwalający na pomyślne zastosowanie zmian do rekordu. Błąd synchronizacji jest poważniejszy niż konflikt i powinien być rozwiązany tak szybko jak to możliwe.


synchronizacja <definicja Jet>

synchronizacja

Proces aktualizacji dwóch replik, w których wymieniane są wszystkie zmienione rekordy i obiekty. Wymiana danych pomiędzy replikami może być jedno- lub dwukierunkowa i może być kierowana przez Synchronizator.


topologia zestawu replik <definicja Jet>

topologia zestawu replik

Kolejność propagacji zmian od jednej repliki do drugiej. Topologia jest ważna, ponieważ określa, jak szybko zmiany wykonane w innej replice pojawią się w replice, z której korzysta użytkownik.


Synchronizator <definicja Jet>

Synchronizator

Program nadzorujący zmiany dokonywane w replice i zajmujący się faktyczną wymianą danych pomiędzy replikami. Synchronizator działa w tle i pokazuje się na pasku zadań. Synchronizatory dla danego zestawu replik można obejrzeć w oknie Synchronization programu Replication Manager.

Uwaga W poprzedniej wersji programu Replication Manager Synchronizatory były nazywane Transporterami.


okno Synchronization <definicja Jet>

okno Synchronization

Obszar programu Replication Manager, w którym pojawiają się Synchronizatory. Można je w tym oknie przesuwać, a samo okno powiększać lub pomniejszać, w celu wyświetlenia większej lub mniejszej liczby Synchronizatorów. Można także kliknąć linię pomiędzy dwoma Synchronizatorami, aby poddać edycji ich plany synchronizacji. Aby zrozumieć różne ikony w oknie Synchronization, należy kliknąć opcję Legenda z menu Widok.